]> git.pld-linux.org Git - packages/deluge.git/blob - deluge.spec
- new
[packages/deluge.git] / deluge.spec
1 Summary:        A Python BitTorrent client with support for UPnP and DHT
2 Summary(pl.UTF-8):      Klient BitTorrenta napisany w pythonie ze wspraciem dla UPnP i DHT
3 Name:           deluge
4 Version:        0.4.99.2
5 Release:        0.1
6 License:        GPL
7 Group:          X11/Applications/Networking
8 URL:            http://deluge-torrent.org/
9 Source0:        http://deluge-torrent.org/downloads/%{name}-%{version}.tar.gz
10 # Source0-md5:  e4f9b3a39dfecf793dfcd62f2ccb1286
11 #Source1:       %{name}-fixed-setup.py
12 BuildRequires:  boost-program_options-devel
13 BuildRequires:  boost-regex-devel
14 BuildRequires:  desktop-file-utils
15 BuildRequires:  libtool
16 BuildRequires:  python-devel
17 BuildRequires:  rb_libtorrent-devel
18 Requires:       /bin/sh
19 Requires:       python-dbus
20 Requires:       python-pygtk-glade
21 Requires:       python-pyxdg
22 Requires:       rb_libtorrent
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Deluge is a new BitTorrent client, created using Python and GTK+. It
27 is intended to bring a native, full-featured client to Linux GTK+
28 desktop environments such as GNOME and XFCE. It supports features such
29 as DHT (Distributed Hash Tables) and UPnP (Universal Plug-n-Play) that
30 allow one to more easily share BitTorrent data even from behind a
31 router with virtually zero configuration of port-forwarding.
32
33 %description -l pl.UTF-8
34
35 %prep
36 %setup -q
37 #install -m 0755 %{SOURCE1} ./setup.py
38
39
40 %build
41 ## We forcibly don't store the installation directory during the build, so
42 ## we need to ensure that it is properly inserted into the code as required.
43 %{__sed} -i -e "s:INSTALL_PREFIX = '@datadir@':INSTALL_PREFIX = '%{_usr}':" \
44         src/dcommon.py
45 %ifarch x86_64 ppc64 sparc64
46         CFLAGS="%{optflags} -DAMD64" %{__python} setup.py build
47 %else
48         CFLAGS="%{optflags}" %{__python} setup.py build
49 %endif
50
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
55
56 ## ...then strip the unneeded shebang lines from some of the plugins...
57 for FILE in $RPM_BUILD_ROOT%{py_sitedir}/%{name}/{delugegtk.py,delugeplugins.py}; do
58         sed -i 1d ${FILE};
59 done
60
61 %find_lang %{name}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files -f %{name}.lang
67 %defattr(644,root,root,755)
68 %doc LICENSE
69 %attr(755,root,root) %{_bindir}/%{name}
70 %dir %{py_sitedir}/%{name}/
71 %{py_sitedir}/%{name}/*.py[co]
72 %{py_sitedir}/%{name}/*.so
73 %{py_sitedir}/%{name}-%{version}-py2.5.egg-info
74 %{_desktopdir}/%{name}.desktop
75 %dir %{_datadir}/%{name}
76 %{_datadir}/%{name}/*
77 %{_pixmapsdir}/%{name}.xpm
This page took 0.08636 seconds and 3 git commands to generate.