]> git.pld-linux.org Git - packages/delo.git/blame - delo.spec
- initial revision
[packages/delo.git] / delo.spec
CommitLineData
61b48602
JR
1%define debver 0.8-2
2%define ver %(echo %{debver} | sed 's/-.*//')
3Summary: The DECstation boot loader
4Name: delo
5Version: %{ver}
6Release: 0.1
7License: GPL
8Group: Applications/System
9# debian? can't find original
10Source0: ftp://ftp.pl.debian.org/debian/pool/main/d/delo/%{name}_%{debver}.tar.gz
11# Source0-md5: c230e2c175a6488c7145b9a7118cc5ba
12#URL:
13Provides: bootloader
14#ExclusiveArch: mipsel
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%define _sbindir /sbin
18
19%description
20This is DELO, the DECstation boot loader, which you need to boot Linux
21on DECstations from storage media. It can also create bootable media
22for DECstations on other machines.
23
24%prep
25%setup -q
26
27%build
28%{__make} \
29 CC="%{__cc}" \
30 CFLAGS="%{rpmcflags}" \
31 LDFLAGS="%{rpmldflags}"
32
33%install
34rm -rf $RPM_BUILD_ROOT
35install -d $RPM_BUILD_ROOT{/etc/sysconfig/rc-boot,%{_mandir}/man{5,8}}
36
37install delo/delo /sbin
38install loader/delo.2nd /boot
39
40install man/delo8 %{_mandir}/man8
41install man/delo.conf.5 %{_mandir}/man5
42install man/t-rex.1 %{_mandir}/man1
43
44install t-rex/t-rex %{_bindir}
45install t-rex-loader/t-rex-loader %{_libdir}/%{name}
46
47install delo.conf /etc
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%files
53%defattr(644,root,root,755)
54%doc README TODO kernel-patch/ramdisk_kernel_parameters.patch
55%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
56%attr(755,root,root) /boot/delo.2nd
57%attr(755,root,root) %{_sbindir}/delo
58%attr(755,root,root) %{_bindir}/t-rex
59%dir %attr(755,root,root) %{_libdir}/%{name}
60%attr(755,root,root) %{_libdir}/%{name}/*
61%{_mandir}/man[158]/*
This page took 0.342901 seconds and 4 git commands to generate.