]> git.pld-linux.org Git - packages/dehydrated.git/blob - letsencrypt.sh.spec
lighttpd: keep privkey as last
[packages/dehydrated.git] / letsencrypt.sh.spec
1 Summary:        letsencrypt/acme client implemented as a shell-script
2 Name:           letsencrypt.sh
3 Version:        0.2.0
4 Release:        2
5 License:        MIT
6 Group:          Applications/Networking
7 Source0:        https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  74974ab79d6879b92ba353bbf3d1257e
9 Source1:        apache.conf
10 Source2:        lighttpd.conf
11 Source3:        config.sh
12 Source4:        domains.txt
13 Source5:        hook.sh
14 Source6:        crontab
15 Patch0:         pld.patch
16 URL:            https://github.com/lukas2511/letsencrypt.sh
17 BuildRequires:  rpmbuild(macros) >= 1.713
18 Requires:       crondaemon
19 Requires:       curl
20 Requires:       grep
21 Requires:       mktemp
22 Requires:       openssl-tools
23 Requires:       sed
24 Requires:       webapps
25 Requires:       webserver(access)
26 Requires:       webserver(alias)
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _webapps        /etc/webapps
31 %define         _webapp         %{name}
32 %define         _sysconfdir     %{_webapps}/%{_webapp}
33 %define         _appdir         %{_datadir}/%{_webapp}
34
35 %description
36 This is a client for signing certificates with an ACME-server
37 (currently only provided by letsencrypt) implemented as a relatively
38 simple bash-script.
39
40 Current features:
41 - Signing of a list of domains
42 - Signing of a CSR
43 - Renewal if a certificate is about to expire or SAN (subdomains)
44   changed
45 - Certificate revocation
46
47 %prep
48 %setup -q
49 %patch0 -p1
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{acme-challenges,certs},/etc/cron.d}
54
55 install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
56 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
57 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
58 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
59 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
60 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/letsencrypt
61 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
62 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %triggerin -- apache1 < 1.3.37-3, apache1-base
68 %webapp_register apache %{_webapp}
69
70 %triggerun -- apache1 < 1.3.37-3, apache1-base
71 %webapp_unregister apache %{_webapp}
72
73 %triggerin -- apache < 2.2.0, apache-base
74 %webapp_register httpd %{_webapp}
75
76 %triggerun -- apache < 2.2.0, apache-base
77 %webapp_unregister httpd %{_webapp}
78
79 %triggerin -- lighttpd
80 %webapp_register lighttpd %{_webapp}
81
82 %triggerun -- lighttpd
83 %webapp_unregister lighttpd %{_webapp}
84
85 %files
86 %defattr(644,root,root,755)
87 %doc README.md CHANGELOG LICENSE
88 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/letsencrypt
89 %dir %attr(750,root,http) %{_sysconfdir}
90 %dir %attr(700,root,root) %{_sysconfdir}/certs
91 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
92 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
93 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
94 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
95 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
96 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
97 # challenges written here from letsencrypt.sh, need to be readable by webserver
98 %dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
99
100 %attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.098368 seconds and 3 git commands to generate.