]> git.pld-linux.org Git - packages/dehydrated.git/blob - dehydrated.spec
c8ef827a6901ef6a79ba15c47458b96e5bcc7802
[packages/dehydrated.git] / dehydrated.spec
1 Summary:        letsencrypt/acme client implemented as a shell-script
2 Name:           dehydrated
3 Version:        0.3.1
4 Release:        1
5 License:        MIT
6 Group:          Applications/Networking
7 Source0:        https://github.com/lukas2511/dehydrated/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  7a3b92b963da6469c4a53f051d6efa24
9 Source1:        apache.conf
10 Source2:        lighttpd.conf
11 Source3:        nginx.conf
12 Source4:        domains.txt
13 Source5:        hook.sh
14 Source6:        crontab
15 Patch0:         pld.patch
16 URL:            https://github.com/lukas2511/dehydrated
17 BuildRequires:  rpmbuild(macros) >= 1.713
18 Requires:       crondaemon
19 Requires:       curl
20 Requires:       grep
21 Requires:       mktemp
22 Requires:       openssl-tools
23 Requires:       sed
24 Requires:       webapps
25 Suggests:       webserver(access)
26 Suggests:       webserver(alias)
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _webapps        /etc/webapps
31 %define         _webapp         %{name}
32 %define         _sysconfdir     %{_webapps}/%{_webapp}
33 %define         _appdir         %{_datadir}/%{_webapp}
34
35 %description
36 This is a client for signing certificates with an ACME-server
37 (currently only provided by letsencrypt) implemented as a relatively
38 simple bash-script.
39
40 Current features:
41 - Signing of a list of domains
42 - Signing of a CSR
43 - Renewal if a certificate is about to expire or SAN (subdomains)
44   changed
45 - Certificate revocation
46
47 %prep
48 %setup -q
49 %patch0 -p1
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/certs,/etc/cron.d} \
54         $RPM_BUILD_ROOT/var/lib/%{name}/{accounts,acme-challenge,certs}
55
56 install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
57 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
58 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
59 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
60 cp -p docs/examples/config $RPM_BUILD_ROOT%{_sysconfdir}
61 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
62 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/%{name}
63 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
64 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %triggerin -- apache1 < 1.3.37-3, apache1-base
70 %webapp_register apache %{_webapp}
71
72 %triggerun -- apache1 < 1.3.37-3, apache1-base
73 %webapp_unregister apache %{_webapp}
74
75 %triggerin -- apache < 2.2.0, apache-base
76 %webapp_register httpd %{_webapp}
77
78 %triggerun -- apache < 2.2.0, apache-base
79 %webapp_unregister httpd %{_webapp}
80
81 %triggerin -- lighttpd
82 %webapp_register lighttpd %{_webapp}
83
84 %triggerun -- lighttpd
85 %webapp_unregister lighttpd %{_webapp}
86
87 %triggerin -- nginx
88 %webapp_register nginx %{_webapp}
89
90 %triggerun -- nginx
91 %webapp_unregister nginx %{_webapp}
92
93 %files
94 %defattr(644,root,root,755)
95 %doc README.md CHANGELOG LICENSE
96 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
97 %dir %attr(750,root,http) %{_sysconfdir}
98 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
99 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
100 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
101 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
102 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
103 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
104 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
105 %attr(755,root,root) %{_sbindir}/%{name}
106 %dir %attr(751,root,root) /var/lib/%{name}
107 %dir %attr(700,root,root) /var/lib/%{name}/accounts
108 %dir %attr(700,root,root) /var/lib/%{name}/certs
109 # challenges written here, need to be readable by webserver
110 %dir %attr(751,root,root) /var/lib/%{name}/acme-challenge
This page took 0.064414 seconds and 2 git commands to generate.