]> git.pld-linux.org Git - packages/dee.git/blob - dee.spec
a18774b66e8fab8b8090cc10bdb157d566bcf023
[packages/dee.git] / dee.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library build
4
5 Summary:        Model to synchronize multiple instances over DBus
6 Summary(pl.UTF-8):      Model synchronizacji wielu instancji poprzez DBus
7 Name:           dee
8 Version:        1.2.7
9 Release:        4
10 # GPLv3-licensed tests and examples are in the tarball, but not installed
11 License:        LGPL v3
12 Group:          Libraries
13 Source0:        http://launchpad.net/dee/1.0/%{version}/+download/%{name}-%{version}.tar.gz
14 # Source0-md5:  b92f27f0a99cac24c2128880601bb7d7
15 URL:            https://launchpad.net/dee
16 BuildRequires:  glib2-devel >= 1:2.32
17 BuildRequires:  gobject-introspection-devel >= 0.10.2
18 BuildRequires:  gtk-doc >= 1.8
19 BuildRequires:  libicu-devel >= 4.6
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.219
22 # not needed for releases
23 #BuildRequires: vala
24 Requires:       glib2 >= 1:2.32
25 Requires:       libicu >= 4.6
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Libdee is a library that uses DBus to provide objects allowing you to
30 create Model-View-Controller type programs across DBus. It also
31 consists of utility objects which extend DBus allowing for
32 peer-to-peer discoverability of known objects without needing a
33 central registrar.
34
35 %description -l pl.UTF-8
36 Libdee to biblioteka wykorzystująca DBus w celu zapewnienia obiektów
37 pozwalających na tworzenie programów typu model-widok-kontroler
38 poprzez DBus. Składa się z obiektów narzędziowych rozszerzających DBus
39 o możliwość widzenia znanych obiektów w komunikacji peer-to-peer bez
40 potrzeby centralnego rejestru.
41
42 %package devel
43 Summary:        Development files for libdee
44 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libdee
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       glib2-devel >= 1:2.32
48 Requires:       libicu-devel >= 4.6
49
50 %description devel
51 This package contains the header files for developing applications
52 that use libdee library.
53
54 %description devel -l pl.UTF-8
55 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia aplikacji
56 wykorzystujących bibliotekę libdee.
57
58 %package static
59 Summary:        Static libdee library
60 Summary(pl.UTF-8):      Biblioteka statyczna libdee
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static libdee library.
66
67 %description static -l pl.UTF-8
68 Biblioteka statyczna libdee.
69
70 %package apidocs
71 Summary:        Libdee API documentation
72 Summary(pl.UTF-8):      Dokumentacja API biblioteki libdee
73 Group:          Documentation
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 API documentation for libdee library.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki libdee.
83
84 %package -n python-dee
85 Summary:        Python bindings for libdee
86 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libdee
87 Group:          Development/Languages/Python
88 Requires:       python-pygobject3
89
90 %description -n python-dee
91 Python bindings for libdee.
92
93 %description -n python-dee -l pl.UTF-8
94 Wiązania Pythona do biblioteki libdee.
95
96 %package -n vala-dee
97 Summary:        Libdee API for Vala language
98 Summary(pl.UTF-8):      API libdee dla języka Vala
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 Requires:       vala
102 %if "%{_rpmversion}" >= "5"
103 BuildArch:      noarch
104 %endif
105
106 %description -n vala-dee
107 Libdee API for Vala language.
108
109 %description -n vala-dee -l pl.UTF-8
110 API libdee dla języka Vala.
111
112 %prep
113 %setup -q
114
115 %build
116 %configure \
117         --disable-silent-rules \
118         %{?with_static_libs:--enable-static} \
119         --with-html-dir=%{_gtkdocdir}
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %py_postclean
131
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdee*.la
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS
143 %attr(755,root,root) %{_bindir}/dee-tool
144 %attr(755,root,root) %{_libdir}/libdee-1.0.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libdee-1.0.so.4
146 %{_libdir}/girepository-1.0/Dee-1.0.typelib
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libdee-1.0.so
151 %{_includedir}/dee-1.0
152 %{_pkgconfigdir}/dee-1.0.pc
153 %{_pkgconfigdir}/dee-icu-1.0.pc
154 %{_datadir}/gir-1.0/Dee-1.0.gir
155
156 %if %{with static_libs}
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libdee-1.0.a
160 %endif
161
162 %files apidocs
163 %defattr(644,root,root,755)
164 %{_gtkdocdir}/dee-1.0
165
166 %files -n python-dee
167 %defattr(644,root,root,755)
168 %{py_sitedir}/gi/overrides/Dee.py[co]
169
170 %files -n vala-dee
171 %defattr(644,root,root,755)
172 %{_datadir}/vala/vapi/dee-1.0.vapi
173 %{_datadir}/vala/vapi/dee-1.0.deps
This page took 0.028373 seconds and 2 git commands to generate.