]> git.pld-linux.org Git - packages/decopter.git/commitdiff
- 0.2.11, updated paths patch, added c++ patch
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 17 May 2003 09:11:29 +0000 (09:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    decopter-c++.patch -> 1.1
    decopter-paths.patch -> 1.2
    decopter.spec -> 1.4

decopter-c++.patch [new file with mode: 0644]
decopter-paths.patch
decopter.spec

diff --git a/decopter-c++.patch b/decopter-c++.patch
new file mode 100644 (file)
index 0000000..145030e
--- /dev/null
@@ -0,0 +1,19 @@
+--- decopter-0.2.11/point3d.cc.orig    2003-03-12 16:18:34.000000000 +0100
++++ decopter-0.2.11/point3d.cc 2003-05-17 00:36:31.000000000 +0200
+@@ -1,5 +1,6 @@
+ #include "point3d.h"
+ #include <GL/gl.h>
++#include <iostream>
+ Point3D::Point3D (const Vector3D &pos, float _u, float _v)
+ {
+--- decopter-0.2.11/patch.cc.orig      2003-03-12 16:18:34.000000000 +0100
++++ decopter-0.2.11/patch.cc   2003-05-17 10:42:28.000000000 +0200
+@@ -1,6 +1,7 @@
+ #include "patch.h"
+ #include <iostream>
+ #include <cmath>
++#include <assert.h>
+ Patch::Patch(double _x1, double _z1, double _x2, double _z2, int PatchLevel, HeightMap *_hm, BTTPool *bttpool, int TextureSize, IndicesTree *lit, IndicesTree *rit, GLuint *_indices)
+ {
index e979965abe2761abd6764771997ffa2b1d891979..318793eb230e4f7eb2d81531115ac6e762d511c0 100644 (file)
@@ -1,37 +1,47 @@
-diff -urN aaa/decopter-0.2.9/fly.cc decopter-0.2.9/fly.cc
---- aaa/decopter-0.2.9/fly.cc  Thu Jan  9 13:32:26 2003
-+++ decopter-0.2.9/fly.cc      Sat Feb  1 22:34:57 2003
+diff -Nur decopter-0.2.11.orig/common.cc decopter-0.2.11/common.cc
+--- decopter-0.2.11.orig/common.cc     2003-03-12 16:18:34.000000000 +0100
++++ decopter-0.2.11/common.cc  2003-05-17 00:21:28.000000000 +0200
+@@ -41,7 +41,7 @@
+ string GetTexturesDirectory()
+ {
+         string TexturesDirectory;
+-        TexturesDirectory="/usr/local/games/decopter/textures/";
++        TexturesDirectory="/usr/share/decopter/textures/";
+         cout <<"TexturesDirectory: "<<TexturesDirectory<<"\n";
+         return TexturesDirectory;
+ }
+diff -Nur decopter-0.2.11.orig/fly.cc decopter-0.2.11/fly.cc
+--- decopter-0.2.11.orig/fly.cc        2003-03-12 16:18:34.000000000 +0100
++++ decopter-0.2.11/fly.cc     2003-05-17 00:21:55.000000000 +0200
 @@ -24,9 +24,9 @@
  
 @@ -24,9 +24,9 @@
  
-     gm=new GameManager(InitialScreenWidth,InitialScreenHeight,InitialScreenBPP);
+         gm=new GameManager(InitialScreenWidth,InitialScreenHeight,InitialScreenBPP);
  
  
--    gm->LoadLandscape("maps/default.land",ViewDistance,40000,MainPatchLevel);
-+    gm->LoadLandscape("/usr/share/decopter/maps/default.land",ViewDistance,40000,MainPatchLevel);
+-        gm->LoadLandscape("maps/default.land",ViewDistance,40000,MainPatchLevel);
++        gm->LoadLandscape("/usr/share/decopter/maps/default.land",ViewDistance,40000,MainPatchLevel);
  
  
--    gm->InitCopter("3D/copter.metamesh");
-+    gm->InitCopter("/usr/share/decopter/3D/copter.metamesh");
+-        gm->InitCopter("3D/copter.metamesh");
++        gm->InitCopter("/usr/share/decopter/3D/copter.metamesh");
  
  
-     while (!done)
-     {
-diff -urN aaa/decopter-0.2.9/gamemanager.cc decopter-0.2.9/gamemanager.cc
---- aaa/decopter-0.2.9/gamemanager.cc  Thu Jan  9 13:32:26 2003
-+++ decopter-0.2.9/gamemanager.cc      Sat Feb  1 22:35:11 2003
-@@ -273,8 +273,8 @@
- {
-     MetaMeshes["copter"]=MetaMesh(filename);
-     MetaMeshes["copter"].GenerateLists();
--    copter=new Copter(&(MetaMeshes["copter"]),"desc/copter",Vector3D(5000,1200,-15000),landscape);
--    copter->SetTextures("maps/default.copter");
-+    copter=new Copter(&(MetaMeshes["copter"]),"/usr/share/decopter/desc/copter",Vector3D(5000,1200,-15000),landscape);
-+    copter->SetTextures("/usr/share/decopter/maps/default.copter");
+         while (!done)
+         {
+diff -Nur decopter-0.2.11.orig/gamemanager.cc decopter-0.2.11/gamemanager.cc
+--- decopter-0.2.11.orig/gamemanager.cc        2003-03-12 16:18:34.000000000 +0100
++++ decopter-0.2.11/gamemanager.cc     2003-05-17 00:23:12.000000000 +0200
+@@ -243,7 +243,7 @@
+         MetaMeshes["copter"]=MetaMesh(filename);
+         MetaMeshes["copter"].GenerateLists();
+         copter=new Copter(&(MetaMeshes["copter"]),Vector3D(5000,1200,-15000),landscape);
+-        copter->SetTextures("maps/default.copter");
++        copter->SetTextures("/usr/share/decopter/maps/default.copter");
  }
  
  void GameManager::DrawCopter()
  }
  
  void GameManager::DrawCopter()
-diff -urN aaa/decopter-0.2.9/generate_textures.cc decopter-0.2.9/generate_textures.cc
---- aaa/decopter-0.2.9/generate_textures.cc    Thu Jan  9 13:32:26 2003
-+++ decopter-0.2.9/generate_textures.cc        Sat Feb  1 22:35:33 2003
-@@ -4,8 +4,8 @@
- #include "utils.h"
+diff -Nur decopter-0.2.11.orig/generate_textures.cc decopter-0.2.11/generate_textures.cc
+--- decopter-0.2.11.orig/generate_textures.cc  2003-03-12 16:18:34.000000000 +0100
++++ decopter-0.2.11/generate_textures.cc       2003-05-17 00:22:09.000000000 +0200
+@@ -3,8 +3,8 @@
+ #include "common.h"
  #include <iostream>
  
 -#define LandscapeFilename "maps/default.land"
  #include <iostream>
  
 -#define LandscapeFilename "maps/default.land"
@@ -41,30 +51,18 @@ diff -urN aaa/decopter-0.2.9/generate_textures.cc decopter-0.2.9/generate_textur
  
  #define LightX 0.5
  #define LightZ 0.5
  
  #define LightX 0.5
  #define LightZ 0.5
-diff -urN aaa/decopter-0.2.9/landscape_texture_browser.cc decopter-0.2.9/landscape_texture_browser.cc
---- aaa/decopter-0.2.9/landscape_texture_browser.cc    Thu Jan  9 13:32:26 2003
-+++ decopter-0.2.9/landscape_texture_browser.cc        Sat Feb  1 22:35:49 2003
-@@ -19,7 +19,7 @@
-     gm=new GameManager(InitialScreenWidth,InitialScreenHeight,InitialScreenBPP);
-     gm->Set2DMode();
--    gm->LoadLandscape("maps/default.land",1,10000,10);
-+    gm->LoadLandscape("/usr/share/decopter/maps/default.land",1,10000,10);
-     while (!done)
-     {
-diff -urN aaa/decopter-0.2.9/maps/default.land decopter-0.2.9/maps/default.land
---- aaa/decopter-0.2.9/maps/default.land       Thu Jan  9 13:32:26 2003
-+++ decopter-0.2.9/maps/default.land   Sat Feb  1 22:40:51 2003
+diff -Nur decopter-0.2.11.orig/maps/default.land decopter-0.2.11/maps/default.land
+--- decopter-0.2.11.orig/maps/default.land     2003-03-12 16:18:34.000000000 +0100
++++ decopter-0.2.11/maps/default.land  2003-05-17 00:24:48.000000000 +0200
 @@ -1,4 +1,4 @@
 -map maps/landscape.png
 +map /usr/share/decopter/maps/landscape.png
  LandscapeScaleXZ 100.0
  LandscapeScaleY 5000.0
  Light 100000 50000 100000 
 @@ -1,4 +1,4 @@
 -map maps/landscape.png
 +map /usr/share/decopter/maps/landscape.png
  LandscapeScaleXZ 100.0
  LandscapeScaleY 5000.0
  Light 100000 50000 100000 
-diff -urN aaa/decopter-0.2.9/maps/default.trees decopter-0.2.9/maps/default.trees
---- aaa/decopter-0.2.9/maps/default.trees      Thu Jan  9 13:32:26 2003
-+++ decopter-0.2.9/maps/default.trees  Sat Feb  1 22:41:18 2003
+diff -Nur decopter-0.2.11.orig/maps/default.trees decopter-0.2.11/maps/default.trees
+--- decopter-0.2.11.orig/maps/default.trees    2003-03-12 16:18:34.000000000 +0100
++++ decopter-0.2.11/maps/default.trees 2003-05-17 00:25:11.000000000 +0200
 @@ -1,6 +1,6 @@
 -textures/tree1.png tree1
 -textures/tree2.png tree2
 @@ -1,6 +1,6 @@
 -textures/tree1.png tree1
 -textures/tree2.png tree2
@@ -78,15 +76,3 @@ diff -urN aaa/decopter-0.2.9/maps/default.trees decopter-0.2.9/maps/default.tree
 +/usr/share/decopter/textures/tree4.png tree4
 +/usr/share/decopter/textures/tree5.png tree5
 +/usr/share/decopter/textures/tree6.png tree6
 +/usr/share/decopter/textures/tree4.png tree4
 +/usr/share/decopter/textures/tree5.png tree5
 +/usr/share/decopter/textures/tree6.png tree6
-diff -urN aaa/decopter-0.2.9/utils.cc decopter-0.2.9/utils.cc
---- aaa/decopter-0.2.9/utils.cc        Thu Jan  9 13:32:26 2003
-+++ decopter-0.2.9/utils.cc    Sat Feb  1 22:41:49 2003
-@@ -41,7 +41,7 @@
- string GetTexturesDirectory()
- {
-     string TexturesDirectory;
--    TexturesDirectory="/usr/local/games/decopter/textures/";
-+    TexturesDirectory="/usr/share/decopter/textures/";
-     cout <<"TexturesDirectory: "<<TexturesDirectory<<"\n";
-     return TexturesDirectory;
- }
index f3149034b7998212ade3d32d2ec46cd562673617..b7121386e50fa4d26d551601e8a3c576cce29a04 100644 (file)
@@ -2,7 +2,7 @@
 Summary:       Unrealistic helicopter simulator
 Summary(pl):   Nierealistyczny symulator helikoptera
 Name:          decopter
 Summary:       Unrealistic helicopter simulator
 Summary(pl):   Nierealistyczny symulator helikoptera
 Name:          decopter
-Version:       0.2.9
+Version:       0.2.11
 Release:       1
 License:       GPL
 Group:         X11/Applications/Games
 Release:       1
 License:       GPL
 Group:         X11/Applications/Games
@@ -11,6 +11,7 @@ Source1:      http://dl.sourceforge.net/%{name}/%{name}-textures-%{_textures_ver}.tar
 Source2:       %{name}.desktop
 Source3:       %{name}.png
 Patch0:                %{name}-paths.patch
 Source2:       %{name}.desktop
 Source3:       %{name}.png
 Patch0:                %{name}-paths.patch
+Patch1:                %{name}-c++.patch
 URL:           http://decopter.sourceforge.net/
 Buildrequires: OpenGL-devel
 BuildRequires: SDL-devel
 URL:           http://decopter.sourceforge.net/
 Buildrequires: OpenGL-devel
 BuildRequires: SDL-devel
@@ -28,11 +29,14 @@ decopter jest nierealistycznym symulatorem helikoptera. Nie jest on
 grywalny, mo¿na tylko lataæ w ko³o.
 
 %prep
 grywalny, mo¿na tylko lataæ w ko³o.
 
 %prep
-%setup -q -a 1
+%setup -q -a1
 %patch0 -p1
 %patch0 -p1
+%patch1 -p1
 
 %build
 
 %build
-%{__make}
+%{__make} \
+       CXX="%{__cxx}" \
+       CXXFLAGS="`sdl-config --cflags` -I/usr/X11R6/include -Wall %{rpmcflags} %{!?debug:-fomit-frame-pointer}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -41,7 +45,6 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_applnkdir}/Games,%{_pixmapsdir}} \
 
 install fly $RPM_BUILD_ROOT%{_bindir}/decopter
 install generate_textures $RPM_BUILD_ROOT%{_bindir}
 
 install fly $RPM_BUILD_ROOT%{_bindir}/decopter
 install generate_textures $RPM_BUILD_ROOT%{_bindir}
-install landscape_texture_browser $RPM_BUILD_ROOT%{_bindir}
 
 install 3D/* $RPM_BUILD_ROOT%{_datadir}/%{name}/3D
 install desc/* $RPM_BUILD_ROOT%{_datadir}/%{name}/desc
 
 install 3D/* $RPM_BUILD_ROOT%{_datadir}/%{name}/3D
 install desc/* $RPM_BUILD_ROOT%{_datadir}/%{name}/desc
This page took 0.100551 seconds and 4 git commands to generate.