]> git.pld-linux.org Git - packages/debhelper.git/blob - debhelper.spec
4e282b31e4410e8331c4839ab2de07c05545a254
[packages/debhelper.git] / debhelper.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 Summary:        Helper programs for debian/rules
6 Summary(pl.UTF-8):      Programy pomocnicze dla debian/rules
7 Name:           debhelper
8 Version:        8.9.6
9 Release:        1
10 License:        GPL v2
11 Group:          Applications
12 Source0:        ftp://ftp.debian.org/debian/pool/main/d/debhelper/%{name}_%{version}.tar.gz
13 # Source0-md5:  8056654d4cd671cbb24ff0d2c1cfbd97
14 URL:            http://kitenet.net/~joey/code/debhelper/
15 BuildRequires:  dpkg
16 BuildRequires:  fakeroot
17 BuildRequires:  perl-tools-pod
18 BuildRequires:  po4a
19 # uses man-db specific --recode option in dh_installman
20 BuildRequires:  man-db
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A collection of programs that can be used in a debian/rules file to
26 automate common tasks related to building Debian packages. Programs
27 are included to install various files into your package, compress
28 files, fix file permissions, integrate your package with the Debian
29 menu system, debconf, doc-base, etc.
30
31 Most Debian packages use debhelper as part of their build process.
32
33 %description -l pl.UTF-8
34 Zestaw programów, których można używać w pliku debian/rules do
35 automatyzacji często wykonywanych zadań związanych z budowaniem
36 pakietów Debiana. Zawiera programy do instalowania różnych plików
37 pakietu, kompresji plików, poprawiania uprawnień plików, integracji
38 pakietu z systemem menu Debiana, debconfem, doc-base itp.
39
40 %prep
41 %setup -q -n %{name}
42
43 %build
44 %{!?with_tests:DEB_BUILD_OPTIONS=nocheck} \
45 fakeroot debian/rules binary
46 mv debian/debhelper%{_docdir}/debhelper doc
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT
51 cp -a debian/debhelper/* $RPM_BUILD_ROOT
52
53 %{__rm} -r $RPM_BUILD_ROOT/DEBIAN
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc doc/* examples debian/changelog
61 %attr(755,root,root) %{_bindir}/dh
62 %attr(755,root,root) %{_bindir}/dh_*
63 %{_datadir}/%{name}
64
65 %dir %{perl_vendorlib}/Debian
66 %dir %{perl_vendorlib}/Debian/Debhelper
67 %{perl_vendorlib}/Debian/Debhelper/Dh_Buildsystems.pm
68 %{perl_vendorlib}/Debian/Debhelper/Dh_Getopt.pm
69 %{perl_vendorlib}/Debian/Debhelper/Dh_Lib.pm
70 %{perl_vendorlib}/Debian/Debhelper/Dh_Version.pm
71 %{perl_vendorlib}/Debian/Debhelper/Sequence
72 %{perl_vendorlib}/Debian/Debhelper/Buildsystem
73 %{perl_vendorlib}/Debian/Debhelper/Buildsystem.pm
74
75 %{_mandir}/man1/dh.1*
76 %{_mandir}/man1/dh_*.1*
77 %lang(es) %{_mandir}/es/man1/dh.1*
78 %lang(es) %{_mandir}/es/man1/dh_*.1*
79 %lang(fr) %{_mandir}/fr/man1/dh.1*
80 %lang(fr) %{_mandir}/fr/man1/dh_*.1*
81 %{_mandir}/man7/debhelper.7*
82 %lang(es) %{_mandir}/es/man7/debhelper.7*
83 %lang(fr) %{_mandir}/fr/man7/debhelper.7*
This page took 0.129931 seconds and 2 git commands to generate.