]> git.pld-linux.org Git - packages/deadbeef.git/commitdiff
- update to 0.5.6
authorKacper Kornet <draenog@pld-linux.org>
Tue, 4 Jun 2013 23:35:50 +0000 (00:35 +0100)
committerKacper Kornet <draenog@pld-linux.org>
Tue, 4 Jun 2013 23:52:05 +0000 (00:52 +0100)
- remove ffmpeg-plugin (ffmpeg >= 0.11 is not supported)
- remove unused ffmpeg-0.8 patch
- add missing BRs
- use patch, not sed, to fix missing libraries

deadbeef-ffmpeg-0.8.patch [deleted file]
deadbeef.spec
lm-missing-symbols.patch

diff --git a/deadbeef-ffmpeg-0.8.patch b/deadbeef-ffmpeg-0.8.patch
deleted file mode 100644 (file)
index a77e295..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
---- deadbeef-0.5.1/plugins/ffmpeg/ffmpeg.c~    2011-05-22 15:58:53.000000000 +0200
-+++ deadbeef-0.5.1/plugins/ffmpeg/ffmpeg.c     2011-06-30 10:24:44.386376024 +0200
-@@ -140,7 +140,7 @@
-     for (i = 0; i < info->fctx->nb_streams; i++)
-     {
-         info->ctx = info->fctx->streams[i]->codec;
--        if (info->ctx->codec_type == CODEC_TYPE_AUDIO)
-+        if (info->ctx->codec_type == AVMEDIA_TYPE_AUDIO)
-         {
-             info->codec = avcodec_find_decoder (info->ctx->codec_id);
-             if (info->codec != NULL) {
-@@ -490,7 +490,7 @@
-     for (i = 0; i < fctx->nb_streams; i++)
-     {
-         ctx = fctx->streams[i]->codec;
--        if (ctx->codec_type == CODEC_TYPE_AUDIO)
-+        if (ctx->codec_type == AVMEDIA_TYPE_AUDIO)
-         {
-             codec = avcodec_find_decoder(ctx->codec_id);
-             if (codec != NULL && !strcasecmp (codec->name, "alac")) { // only open alac streams
-@@ -704,7 +704,7 @@
-     ffmpeg_init_exts ();
-     avcodec_init ();
-     av_register_all ();
--    av_register_protocol (&vfswrapper);
-+    av_register_protocol2 (&vfswrapper, sizeof(vfswrapper));
-     return 0;
- }
-@@ -745,7 +745,7 @@
-     for (i = 0; i < fctx->nb_streams; i++)
-     {
-         ctx = fctx->streams[i]->codec;
--        if (ctx->codec_type == CODEC_TYPE_AUDIO)
-+        if (ctx->codec_type == AVMEDIA_TYPE_AUDIO)
-         {
-             codec = avcodec_find_decoder(ctx->codec_id);
-             if (codec != NULL)
index 642d704f47052c8fcd91fba60275858e9e2f7fbc..4ee4bf2d245bbf3b08d13bce3c96a10156206153 100644 (file)
@@ -1,19 +1,18 @@
 Summary:       Ultimate Music Player
 Name:          deadbeef
 Summary:       Ultimate Music Player
 Name:          deadbeef
-Version:       0.5.2
-Release:       1
+Version:       0.5.6
+Release:       0.1
 License:       GPL v2 and LGPL v2.1
 Group:         X11/Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/deadbeef/%{name}-%{version}.tar.bz2
 License:       GPL v2 and LGPL v2.1
 Group:         X11/Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/deadbeef/%{name}-%{version}.tar.bz2
-# Source0-md5: 0810c1b609b6c1ca43578ebf321fdec4
+# Source0-md5: 26b6036ca7e59c88267d3de4f42c4d01
 Patch0:                lm-missing-symbols.patch
 Patch0:                lm-missing-symbols.patch
-Patch1:                %{name}-ffmpeg-0.8.patch
 URL:           http://deadbeef.sourceforge.net/
 BuildRequires: alsa-lib-devel
 BuildRequires: automake >= 1.11
 BuildRequires: curl-devel
 BuildRequires: dbus-devel
 URL:           http://deadbeef.sourceforge.net/
 BuildRequires: alsa-lib-devel
 BuildRequires: automake >= 1.11
 BuildRequires: curl-devel
 BuildRequires: dbus-devel
-BuildRequires: ffmpeg-devel >= 0.7.1
+BuildRequires: faad2-devel
 BuildRequires: gettext-devel
 BuildRequires: gtk+2-devel >= 2.12
 BuildRequires: imlib2-devel
 BuildRequires: gettext-devel
 BuildRequires: gtk+2-devel >= 2.12
 BuildRequires: imlib2-devel
@@ -24,10 +23,12 @@ BuildRequires:      libmad-devel
 BuildRequires: libsamplerate-devel
 BuildRequires: libsndfile-devel
 BuildRequires: libvorbis-devel
 BuildRequires: libsamplerate-devel
 BuildRequires: libsndfile-devel
 BuildRequires: libvorbis-devel
+BuildRequires: libzip-devel
 BuildRequires: pakchois-devel
 BuildRequires: pkgconfig
 BuildRequires: pulseaudio-devel
 BuildRequires: wavpack-devel
 BuildRequires: pakchois-devel
 BuildRequires: pkgconfig
 BuildRequires: pulseaudio-devel
 BuildRequires: wavpack-devel
+BuildRequires: yasm
 Requires(post,postun): desktop-file-utils
 Requires(post,postun): gtk-update-icon-cache
 Requires:      hicolor-icon-theme
 Requires(post,postun): desktop-file-utils
 Requires(post,postun): gtk-update-icon-cache
 Requires:      hicolor-icon-theme
@@ -66,13 +67,6 @@ Group:               X11/Applications/Multimedia
 %description plugin-cdda
 Audio CD player.
 
 %description plugin-cdda
 Audio CD player.
 
-%package plugin-ffmpeg
-Summary:       FFMPEG plugin
-Group:         X11/Applications/Multimedia
-
-%description plugin-ffmpeg
-FFMPEG audio player.
-
 %package plugin-flac
 Summary:       FLAC plugin
 Group:         X11/Applications/Multimedia
 %package plugin-flac
 Summary:       FLAC plugin
 Group:         X11/Applications/Multimedia
@@ -159,7 +153,7 @@ WavPack decoder.
 
 %prep
 %setup -q
 
 %prep
 %setup -q
-%{__sed} -i -r "s@^(ffmpeg_la_LIBADD.*)@\1 -lm@" plugins/ffmpeg/Makefile.am
+%patch0 -p1
 
 %build
 %{__aclocal}
 
 %build
 %{__aclocal}
@@ -181,6 +175,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %find_lang %{name}
 
 
 %find_lang %{name}
 
+# work around automatic docs installation
+%{__rm} -rf %{name}-%{version}-doc
+cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -194,7 +193,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README about.txt help.txt
+%doc %{name}-%{version}-doc/{about.txt,ChangeLog,help.txt,README,translators.txt}
+%lang(pt_BR) %doc %{name}-%{version}-doc/help.pt_BR.txt
+%lang(ru) %doc %{name}-%{version}-doc/help.ru.txt
 %attr(755,root,root) %{_bindir}/deadbeef
 %{_desktopdir}/deadbeef.desktop
 %{_iconsdir}/hicolor/*/apps/deadbeef.png
 %attr(755,root,root) %{_bindir}/deadbeef
 %{_desktopdir}/deadbeef.desktop
 %{_iconsdir}/hicolor/*/apps/deadbeef.png
@@ -236,10 +237,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root)%{_libdir}/deadbeef/cdda.so*
 
 %defattr(644,root,root,755)
 %attr(755,root,root)%{_libdir}/deadbeef/cdda.so*
 
-%files plugin-ffmpeg
-%defattr(644,root,root,755)
-%attr(755,root,root)%{_libdir}/deadbeef/ffmpeg.so*
-
 %files plugin-flac
 %defattr(644,root,root,755)
 %attr(755,root,root)%{_libdir}/deadbeef/flac.so*
 %files plugin-flac
 %defattr(644,root,root,755)
 %attr(755,root,root)%{_libdir}/deadbeef/flac.so*
index 7fc951b8bbb92f9355068ee6008b1f7849af96c9..a775c8fac0a1239e33faf83e12c1ac9d148aa628 100644 (file)
@@ -1,13 +1,3 @@
-diff -uNr deadbeef-0.5.1.old/plugins/ffap/Makefile.am deadbeef-0.5.1/plugins/ffap/Makefile.am
---- deadbeef-0.5.1.old/plugins/ffap/Makefile.am        2011-03-03 21:06:15.000000000 +0100
-+++ deadbeef-0.5.1/plugins/ffap/Makefile.am    2011-06-06 21:27:36.783839885 +0200
-@@ -4,5 +4,6 @@
- ffap_la_SOURCES = ffap.c
- ffap_la_LDFLAGS = -module
-+ffap_la_LIBADD = $(LDADD) -lm
- AM_CFLAGS = $(CFLAGS) -std=c99
- endif
 diff -uNr deadbeef-0.5.1.old/plugins/ffmpeg/Makefile.am deadbeef-0.5.1/plugins/ffmpeg/Makefile.am
 --- deadbeef-0.5.1.old/plugins/ffmpeg/Makefile.am      2011-03-03 21:06:15.000000000 +0100
 +++ deadbeef-0.5.1/plugins/ffmpeg/Makefile.am  2011-06-06 21:19:42.009745288 +0200
 diff -uNr deadbeef-0.5.1.old/plugins/ffmpeg/Makefile.am deadbeef-0.5.1/plugins/ffmpeg/Makefile.am
 --- deadbeef-0.5.1.old/plugins/ffmpeg/Makefile.am      2011-03-03 21:06:15.000000000 +0100
 +++ deadbeef-0.5.1/plugins/ffmpeg/Makefile.am  2011-06-06 21:19:42.009745288 +0200
@@ -19,15 +9,16 @@ diff -uNr deadbeef-0.5.1.old/plugins/ffmpeg/Makefile.am deadbeef-0.5.1/plugins/f
 +ffmpeg_la_LIBADD = $(LDADD) $(FFMPEG_DEPS_LIBS) -lm
  AM_CFLAGS = $(CFLAGS) -std=c99 ${FFMPEG_DEPS_CFLAGS}
  endif
 +ffmpeg_la_LIBADD = $(LDADD) $(FFMPEG_DEPS_LIBS) -lm
  AM_CFLAGS = $(CFLAGS) -std=c99 ${FFMPEG_DEPS_CFLAGS}
  endif
-diff -uNr deadbeef-0.5.1.old/plugins/m3u/Makefile.am deadbeef-0.5.1/plugins/m3u/Makefile.am
---- deadbeef-0.5.1.old/plugins/m3u/Makefile.am 2011-05-07 18:42:49.000000000 +0200
-+++ deadbeef-0.5.1/plugins/m3u/Makefile.am     2011-06-06 21:19:24.463173681 +0200
-@@ -5,7 +5,7 @@
+diff --git a/plugins/alac/Makefile.am b/plugins/alac/Makefile.am
+index 0dc48ad..268e3e9 100644
+--- a/plugins/alac/Makefile.am
++++ b/plugins/alac/Makefile.am
+@@ -15,7 +15,7 @@ alac.c decomp.h demux.c demux.h stream.c stream.h\
  
  
m3u_la_LDFLAGS = -module
alac_la_LDFLAGS = -module
  
  
--m3u_la_LIBADD = $(LIBADD)
-+m3u_la_LIBADD = $(LIBADD) -lm
- m3u_la_CFLAGS = $(CFLAGS) -std=c99
+-alac_la_LIBADD = $(LDADD) $(FAAD2_LIBS)
++alac_la_LIBADD = $(LDADD) $(FAAD2_LIBS) -lm
+ AM_CFLAGS = $(CFLAGS) -std=c99 -DUSE_MP4FF -DUSE_TAGGING -I../libmp4ff
  endif
  endif
This page took 0.049071 seconds and 4 git commands to generate.