]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
- added missing translations
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
3 Name:           ddd
4 Version:        3.1.5
5 Release:        1
6 Copyright:      GPL
7 Group:          Development/Debuggers
8 Group(pl):      Programowanie/Odpluskwiacze
9 Source:         ftp://ftp.ips.cs.tu-bs.de/pub/local/softech/ddd/src/%{name}-%{version}.tar.gz
10 Patch:          ddd-pty.patch
11 Icon:           ddd.xpm
12 URL:            http://www.cs.tu-bs.de/softech/ddd/
13 Buildroot:      /tmp/%{name}-%{version}-root
14
15 %define         _prefix /usr/X11R6
16 %define         _mandir /usr/X11R6/man
17
18 %description
19 The Data Display Debugger (DDD) is a common graphical user interface for
20 GDB, DBX, and XDB, the popular UNIX debuggers.  Besides ``classical''
21 front-end features such as viewing source texts, DDD provides a graphical
22 data display, where data structures are displayed as graphs.  A simple mouse
23 click dereferences pointers or views structure contents, updated each time
24 the program stops.  Using DDD, you can reason about your application by
25 viewing its data, not just by viewing it execute lines of source code. 
26 Other DDD features include: debugging of programs written in C, C++, Ada,
27 Fortran, Java, Pascal, Modula-2, or Modula-3; machine-level debugging;
28 hypertext source navigation and lookup; breakpoint, backtrace, and history
29 editors; preferences and settings editors; program execution in terminal
30 emulator window; debugging on remote host; on-line manual; interactive help
31 on the Motif user interface; GDB/DBX/XDB command-line interface with full
32 editing, history, search, and completion capabilities.  DDD has been
33 designed to compete with well-known commercial debuggers
34
35 %description -l pl
36 Data Display Debugger (DDD) jest typowm graficznym interfejsem do
37 GDB, DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
38 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
39 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury wy¶wietlane
40 s± w postaci graficznej. Proste klikniêcie mysz± pozwala na przegl±danie
41 zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy program siê zatrzyma).
42 Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania programów napisanych w C, C++,
43 Ada, Fortran, Java, Pascal, Modula-2, or Modula-2; debugowanie na poziomie
44 maszyny; hypertekstowa nawigacja po ¼ród³ach; brekpoin, backtrace i emulator
45 okna historii; mo¿liwo¶æ ustawiania preferencji; uruchamianie programów w oknie
46 terminala; debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
47 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i wyszukiwaniem.
48
49 %package python
50 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
51 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
52 Group:          Development/Debuggers
53 Group(pl):      Programowanie/Odpluskwiacze
54 Requires:       %{name} = %{version}
55
56 %description python
57 Data Display Debugger - python debugger.
58
59 %description -l pl
60 Data Display Debugger - debugger pythona.
61
62 %prep
63 %setup -q
64 #%patch -p1
65
66 %build
67 %configure --with-motif
68 make CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT/{etc/X11/wmconfig,usr/lib/python-1.5,%{_libdir}/X11/app-defaults}
73
74 make install prefix=$RPM_BUILD_ROOT%{_prefix} \
75         mandir=$RPM_BUILD_ROOT%{_mandir} \
76         bindir=$RPM_BUILD_ROOT%{_bindir} \
77         libdir=$RPM_BUILD_ROOT%{_libdir}
78
79 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}
80 install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT/usr/lib/python-1.5
81
82 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
83
84 cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd <<EOF
85 ddd name "DDD"
86 ddd description "Data Display Debuger"
87 ddd exec "/usr/X11R6/bin/ddd"
88 ddd group "Development"
89 EOF
90
91 cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd-python <<EOF
92 ddd name "DDD for python"
93 ddd description "Data Display Debuger - python"
94 ddd exec "/usr/X11R6/bin/ddd --pydb"
95 ddd group "Development"
96 EOF
97
98 gzip -9nf ANNOUNCE BUGS ChangeLog NEWS* OPENBUGS PROBLEMS README TIPS \
99         TODO $RPM_BUILD_ROOT%{_mandir}/man1/*
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc {ANNOUNCE,BUGS,ChangeLog,NEWS*,OPENBUGS,PROBLEMS,README,TIPS,TODO}.gz
106 %doc doc/sample.dddinit
107 /etc/X11/wmconfig/ddd
108 %attr(755,root,root) %{_bindir}/*
109 %{_libdir}/X11/app-defaults/Ddd
110 %{_mandir}/man1/*
111
112 %files python
113 %defattr(644,root,root,755)
114 /etc/X11/wmconfig/ddd-python
115 %attr(755,root,root) %{_bindir}/pydb.py
116 /usr/lib/python*/*
This page took 1.264336 seconds and 4 git commands to generate.