]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
- release 7
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Summary(ja.UTF-8):      GDB,DBX,Ladebug,JDB,Perl,Pythonのグラフィカルデバッガのフロントエンド
3 Summary(pl.UTF-8):      Interfejs X do debugerów GDB, DBX i XDB
4 Summary(zh_CN.UTF-8):   图形化的程序调试器前端;如GDB,DBX,Ladebug,JDB,Perl,Python
5 Name:           ddd
6 Version:        3.3.11
7 Release:        7
8 Epoch:          1
9 License:        GPL
10 Group:          Development/Debuggers
11 Source0:        http://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
12 # Source0-md5:  f19437ebfdb5f2667d6de30f700dd319
13 Source1:        %{name}.desktop
14 Source2:        http://art.gnome.org/images/icons/other/Debugger.png
15 # Source2-md5:  c046d9b0a04abdbb4a2be08a374ac2cd
16 Patch0:         %{name}-ptrace.patch
17 Patch1:         %{name}-info.patch
18 Patch2:         %{name}-home_etc.patch
19 Patch3:         %{name}-am185.patch
20 URL:            http://www.gnu.org/software/ddd/
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  bison
24 BuildRequires:  elfutils-devel
25 BuildRequires:  flex
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 BuildRequires:  motif-devel
29 BuildRequires:  ncurses-devel >= 5.0
30 BuildRequires:  readline-devel
31 BuildRequires:  xorg-lib-libXmu-devel
32 BuildRequires:  xorg-lib-libXpm-devel
33 BuildRequires:  texinfo
34 Requires:       gdb
35 Requires:       xorg-lib-libXt >= 1.0.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _appdefsdir     %{_datadir}/X11/app-defaults
39
40 %define         specflags       -fno-strict-aliasing
41
42 %description
43 The Data Display Debugger (DDD) is a common graphical user interface
44 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
45 ``classical'' front-end features such as viewing source texts, DDD
46 provides a graphical data display, where data structures are displayed
47 as graphs. A simple mouse click dereferences pointers or views
48 structure contents, updated each time the program stops. Using DDD,
49 you can reason about your application by viewing its data, not just by
50 viewing it execute lines of source code. Other DDD features include:
51 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
52 Modula-2, or Modula-3; machine-level debugging; hypertext source
53 navigation and lookup; breakpoint, backtrace, and history editors;
54 preferences and settings editors; program execution in terminal
55 emulator window; debugging on remote host; on-line manual; interactive
56 help on the Motif user interface; GDB/DBX/XDB command-line interface
57 with full editing, history, search, and completion capabilities. DDD
58 has been designed to compete with well-known commercial debuggers
59
60 %description -l ja.UTF-8
61 DDDは、GDB,DBX,WDB,Ladebug,JDB,XDB,Perlデバッガ、またはPythonデバッガ
62 のようなコマンドライン型デバッガをグラフィカル型のデバッガに変身させる
63 フロントエンドです。ソースコードの参照等のような"通常"のフロントエンド
64 の機能のみならず、DDDはデータ構造をグラフとして表示する、会話式グラフ
65 ィカルデータ表示することで有名になりました。
66
67 %description -l pl.UTF-8
68 Data Display Debugger (DDD) jest typowym graficznym interfejsem do
69 GDB, DBX, i XDB - popularnych UNIXowych debuggerów. Poza
70 ``klasycznymi'' możliwościami interfejsów graficznych takich jak
71 przeglądanie kodów źródłowych DDD dostarcza graficznych narzędzi,
72 gdzie struktury wyświetlane są w postaci graficznej. Proste kliknięcie
73 myszą pozwala na przeglądanie zawartości struktur (aktualizowane za
74 każdym razem gdy program się zatrzyma). Inne możliwości DDD to:
75 możliwość debugowania programów napisanych w C, C++, Ada, Fortran,
76 Java, Pascal, Modula-2, or Modula-2; debugowanie na poziomie maszyny;
77 hypertekstowa nawigacja po źródłach; breakpoint, backtrace i emulator
78 okna historii; możliwość ustawiania preferencji; uruchamianie
79 programów w oknie terminala; debugowanie na zdalnych serwerach;
80 podręcznik on-line; interaktywna pomoc; linia poleceń GDB/DBX/XDB z
81 pełną edycją, historią i wyszukiwaniem.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88 %patch3 -p1
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__automake}
95 %configure \
96         --with-motif \
97         --with-readline \
98         --with-termlib=tinfo
99
100 %{__make} \
101         CXXOPT="-DNDEBUG %{rpmcflags}"
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_appdefsdir},%{_desktopdir},%{_pixmapsdir}}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install ddd/Ddd $RPM_BUILD_ROOT%{_appdefsdir}
111
112 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
113 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/ddd.png
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p      /sbin/postshell
119 -/usr/sbin/fix-info-dir -c %{_infodir}
120
121 %postun -p      /sbin/postshell
122 -/usr/sbin/fix-info-dir -c %{_infodir}
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS NEWS README TIPS TODO doc/*.pdf
127 %attr(755,root,root) %{_bindir}/ddd
128 %{_datadir}/ddd*
129 %{_appdefsdir}/Ddd
130 %{_desktopdir}/ddd.desktop
131 %{_pixmapsdir}/*.png
132 %{_mandir}/man1/*
133 %{_infodir}/ddd*
This page took 0.08408 seconds and 3 git commands to generate.