]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
d61ddd5419ec5083866a85658a34c767cc57e510
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Summary(ja.UTF-8):      GDB,DBX,Ladebug,JDB,Perl,Pythonのグラフィカルデバッガのフロントエンド
3 Summary(pl.UTF-8):      Interfejs X do debugerów GDB, DBX i XDB
4 Summary(zh_CN.UTF-8):   图形化的程序调试器前端;如GDB,DBX,Ladebug,JDB,Perl,Python
5 Name:           ddd
6 Version:        3.4.0
7 Release:        1
8 Epoch:          1
9 License:        GPL v3+
10 Group:          Development/Debuggers
11 Source0:        https://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
12 # Source0-md5:  23fc7448a189908c945fe2ba7fd3a53a
13 Source1:        %{name}.desktop
14 # originally http://art.gnome.org/images/icons/other/Debugger.png
15 Source2:        Debugger.png
16 # Source2-md5:  c046d9b0a04abdbb4a2be08a374ac2cd
17 Patch0:         %{name}-ptrace.patch
18 Patch1:         %{name}-info.patch
19 Patch2:         %{name}-home_etc.patch
20 URL:            http://www.gnu.org/software/ddd/
21 BuildRequires:  autoconf >= 2.71
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  bison >= 1.28
24 BuildRequires:  elfutils-devel
25 BuildRequires:  flex
26 BuildRequires:  gnulib
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool >= 2:2
29 BuildRequires:  motif-devel
30 BuildRequires:  ncurses-devel >= 5.0
31 BuildRequires:  readline-devel
32 BuildRequires:  xorg-lib-libX11-devel
33 BuildRequires:  xorg-lib-libXaw-devel
34 BuildRequires:  xorg-lib-libXext-devel
35 BuildRequires:  xorg-lib-libXmu-devel
36 BuildRequires:  xorg-lib-libXpm-devel
37 BuildRequires:  xorg-lib-libXt-devel
38 BuildRequires:  texinfo
39 Requires:       gdb
40 Requires:       xorg-lib-libXt >= 1.0.0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _appdefsdir     %{_datadir}/X11/app-defaults
44
45 %define         specflags       -fno-strict-aliasing
46
47 %description
48 The Data Display Debugger (DDD) is a common graphical user interface
49 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
50 ``classical'' front-end features such as viewing source texts, DDD
51 provides a graphical data display, where data structures are displayed
52 as graphs. A simple mouse click dereferences pointers or views
53 structure contents, updated each time the program stops. Using DDD,
54 you can reason about your application by viewing its data, not just by
55 viewing it execute lines of source code. Other DDD features include:
56 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
57 Modula-2, or Modula-3; machine-level debugging; hypertext source
58 navigation and lookup; breakpoint, backtrace, and history editors;
59 preferences and settings editors; program execution in terminal
60 emulator window; debugging on remote host; on-line manual; interactive
61 help on the Motif user interface; GDB/DBX/XDB command-line interface
62 with full editing, history, search, and completion capabilities. DDD
63 has been designed to compete with well-known commercial debuggers
64
65 %description -l ja.UTF-8
66 DDDは、GDB,DBX,WDB,Ladebug,JDB,XDB,Perlデバッガ、またはPythonデバッガ
67 のようなコマンドライン型デバッガをグラフィカル型のデバッガに変身させる
68 フロントエンドです。ソースコードの参照等のような"通常"のフロントエンド
69 の機能のみならず、DDDはデータ構造をグラフとして表示する、会話式グラフ
70 ィカルデータ表示することで有名になりました。
71
72 %description -l pl.UTF-8
73 Data Display Debugger (DDD) jest typowym graficznym interfejsem do
74 GDB, DBX, i XDB - popularnych UNIXowych debuggerów. Poza
75 ``klasycznymi'' możliwościami interfejsów graficznych takich jak
76 przeglądanie kodów źródłowych DDD dostarcza graficznych narzędzi,
77 gdzie struktury wyświetlane są w postaci graficznej. Proste kliknięcie
78 myszą pozwala na przeglądanie zawartości struktur (aktualizowane za
79 każdym razem gdy program się zatrzyma). Inne możliwości DDD to:
80 możliwość debugowania programów napisanych w C, C++, Ada, Fortran,
81 Java, Pascal, Modula-2, or Modula-2; debugowanie na poziomie maszyny;
82 hypertekstowa nawigacja po źródłach; breakpoint, backtrace i emulator
83 okna historii; możliwość ustawiania preferencji; uruchamianie
84 programów w oknie terminala; debugowanie na zdalnych serwerach;
85 podręcznik on-line; interaktywna pomoc; linia poleceń GDB/DBX/XDB z
86 pełną edycją, historią i wyszukiwaniem.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93
94 ln -sf %{_datadir}/gnulib/doc/fdl-1.3.texi ddd/fdl-1.3.texi
95
96 %build
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoconf}
100 %{__automake}
101 %configure \
102         --with-motif \
103         --with-readline \
104         --with-termlib=tinfo
105
106 %{__make} \
107         CXXOPT="-DNDEBUG %{rpmcflags}"
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_appdefsdir},%{_desktopdir},%{_pixmapsdir}}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 cp -p ddd/Ddd $RPM_BUILD_ROOT%{_appdefsdir}
117
118 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
119 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/ddd.png
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/postshell
125 -/usr/sbin/fix-info-dir -c %{_infodir}
126
127 %postun -p /sbin/postshell
128 -/usr/sbin/fix-info-dir -c %{_infodir}
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS CREDITS NEWS README TIPS doc/*.pdf
133 %attr(755,root,root) %{_bindir}/ddd
134 %{_datadir}/ddd-%{version}
135 %{_appdefsdir}/Ddd
136 %{_desktopdir}/ddd.desktop
137 %{_pixmapsdir}/ddd.png
138 %{_mandir}/man1/ddd.1*
139 %{_infodir}/ddd.info*
140 %{_infodir}/ddd-themes.info*
This page took 0.074782 seconds and 3 git commands to generate.