]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
- release 7.
[packages/ddd.git] / ddd.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('pydb')"
4 %define python_compile python -c "import compileall; compileall.compile_dir('pydb')"
5
6 Summary:        X interface to the GDB, DBX and XDB debuggers
7 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
8 Name:           ddd
9 Version:        3.3.1
10 Release:        7
11 License:        GPL
12 Group:          Development/Debuggers
13 Group(de):      Entwicklung/Debugger
14 Group(pl):      Programowanie/Odpluskwiacze
15 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
16 Source1:        %{name}.desktop
17 Source2:        %{name}-python.desktop
18 Patch0:         %{name}-DESTDIR.patch
19 Patch1:         %{name}-ptrace.patch
20 Patch2:         %{name}-info.patch
21 Icon:           ddd.xpm
22 URL:            http://www.gnu.org/software/ddd/
23 BuildRequires:  XFree86-devel
24 BuildRequires:  motif-devel
25 BuildRequires:  ncurses-devel >= 5.0
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  python
28 BuildRequires:  texinfo
29 BuildRequires:  automake
30 Requires:       gdb
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _prefix         /usr/X11R6
34 %define         _mandir         %{_prefix}/man
35
36 %description
37 The Data Display Debugger (DDD) is a common graphical user interface
38 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
39 ``classical'' front-end features such as viewing source texts, DDD
40 provides a graphical data display, where data structures are displayed
41 as graphs. A simple mouse click dereferences pointers or views
42 structure contents, updated each time the program stops. Using DDD,
43 you can reason about your application by viewing its data, not just by
44 viewing it execute lines of source code. Other DDD features include:
45 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
46 Modula-2, or Modula-3; machine-level debugging; hypertext source
47 navigation and lookup; breakpoint, backtrace, and history editors;
48 preferences and settings editors; program execution in terminal
49 emulator window; debugging on remote host; on-line manual; interactive
50 help on the Motif user interface; GDB/DBX/XDB command-line interface
51 with full editing, history, search, and completion capabilities. DDD
52 has been designed to compete with well-known commercial debuggers
53
54 %description -l pl
55 Data Display Debugger (DDD) jest typowym graficznym interfejsem do GDB,
56 DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
57 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
58 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury
59 wy¶wietlane s± w postaci graficznej. Proste klikniêcie mysz± pozwala
60 na przegl±danie zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy
61 program siê zatrzyma). Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania
62 programów napisanych w C, C++, Ada, Fortran, Java, Pascal, Modula-2,
63 or Modula-2; debugowanie na poziomie maszyny; hypertekstowa nawigacja
64 po ¼ród³ach; breakpoint, backtrace i emulator okna historii; mo¿liwo¶æ
65 ustawiania preferencji; uruchamianie programów w oknie terminala;
66 debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
67 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i
68 wyszukiwaniem.
69
70 %package python
71 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
72 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debugger pythona
73 Group:          Development/Debuggers
74 Group(de):      Entwicklung/Debugger
75 Group(pl):      Programowanie/Odpluskwiacze
76 Requires:       %{name} = %{version}
77
78 %description python
79 Data Display Debugger - python debugger.
80
81 %description -l pl
82 Data Display Debugger - debugger pythona.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 %build
91 automake -a -c
92 %configure2_13 \
93         --with-motif
94 %{__make} CXXOPT="-DNDEBUG %{rpmcflags}"
95 %python_compile
96 %python_compile_opt 
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{python_sitepkgsdir} \
101         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
102         $RPM_BUILD_ROOT%{_applnkdir}/Development
103
104 %{__make} DESTDIR=$RPM_BUILD_ROOT install 
105
106 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
107 install pydb/{pydbcmd,pydbsupt}.py[co] $RPM_BUILD_ROOT%{python_sitepkgsdir}
108
109 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
110
111 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
112
113 gzip -9nf ANNOUNCE BUGS NEWS* OPENBUGS PROBLEMS README TIPS
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
120
121 %postun
122 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
123
124 %files
125 %defattr(644,root,root,755)
126 %doc {ANNOUNCE,BUGS,NEWS*,OPENBUGS,PROBLEMS,README,TIPS}.gz
127 %doc doc/sample.dddinit
128 %{_applnkdir}/Development/ddd.desktop
129 %attr(755,root,root) %{_bindir}/ddd
130 %{_libdir}/X11/app-defaults/Ddd
131 %{_mandir}/man1/*
132 %{_datadir}/ddd*
133 %{_infodir}/ddd*
134
135 %files python
136 %defattr(644,root,root,755)
137 %{_applnkdir}/Development/ddd-python.desktop
138 %attr(755,root,root) %{_bindir}/pydb
139 %{python_sitepkgsdir}/*
This page took 0.095516 seconds and 3 git commands to generate.