]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
- updated to 3.3.1
[packages/ddd.git] / ddd.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('pydb')"
4 %define python_compile python -c "import compileall; compileall.compile_dir('pydb')"
5
6 Summary:        X interface to the GDB, DBX and XDB debuggers
7 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
8 Name:           ddd
9 Version:        3.3.1
10 Release:        1
11 License:        GPL
12 Group:          Development/Debuggers
13 Group(de):      Entwicklung/Debugger
14 Group(pl):      Programowanie/Odpluskwiacze
15 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
16 Source1:        %{name}.desktop
17 Source2:        %{name}-python.desktop
18 Patch0:         %{name}-DESTDIR.patch
19 Patch1:         %{name}-ptrace.patch
20 Icon:           ddd.xpm
21 URL:            http://www.gnu.org/software/ddd/
22 BuildRequires:  XFree86-devel
23 BuildRequires:  motif-devel
24 BuildRequires:  ncurses-devel >= 5.0
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  python
27 BuildRequires:  texinfo
28 Requires:       gdb
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _prefix         /usr/X11R6
32 %define         _mandir         %{_prefix}/man
33
34 %description
35 The Data Display Debugger (DDD) is a common graphical user interface
36 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
37 ``classical'' front-end features such as viewing source texts, DDD
38 provides a graphical data display, where data structures are displayed
39 as graphs. A simple mouse click dereferences pointers or views
40 structure contents, updated each time the program stops. Using DDD,
41 you can reason about your application by viewing its data, not just by
42 viewing it execute lines of source code. Other DDD features include:
43 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
44 Modula-2, or Modula-3; machine-level debugging; hypertext source
45 navigation and lookup; breakpoint, backtrace, and history editors;
46 preferences and settings editors; program execution in terminal
47 emulator window; debugging on remote host; on-line manual; interactive
48 help on the Motif user interface; GDB/DBX/XDB command-line interface
49 with full editing, history, search, and completion capabilities. DDD
50 has been designed to compete with well-known commercial debuggers
51
52 %description -l pl
53 Data Display Debugger (DDD) jest typowm graficznym interfejsem do GDB,
54 DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
55 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
56 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury
57 wy¶wietlane s± w postaci graficznej. Proste klikniêcie mysz± pozwala
58 na przegl±danie zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy
59 program siê zatrzyma). Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania
60 programów napisanych w C, C++, Ada, Fortran, Java, Pascal, Modula-2,
61 or Modula-2; debugowanie na poziomie maszyny; hypertekstowa nawigacja
62 po ¼ród³ach; breakpoint, backtrace i emulator okna historii; mo¿liwo¶æ
63 ustawiania preferencji; uruchamianie programów w oknie terminala;
64 debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
65 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i
66 wyszukiwaniem.
67
68 %package python
69 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
70 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
71 Group:          Development/Debuggers
72 Group(de):      Entwicklung/Debugger
73 Group(pl):      Programowanie/Odpluskwiacze
74 Requires:       %{name} = %{version}
75
76 %description python
77 Data Display Debugger - python debugger.
78
79 %description -l pl
80 Data Display Debugger - debugger pythona.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86
87 %build
88 automake -a -c
89 %configure \
90         --with-motif
91 %{__make} CXXOPT="-DNDEBUG %{rpmcflags}"
92 %python_compile
93 %python_compile_opt 
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{python_sitepkgsdir} \
98         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
99         $RPM_BUILD_ROOT%{_applnkdir}/Development
100
101 %{__make} DESTDIR=$RPM_BUILD_ROOT install 
102
103 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
104 install pydb/{pydbcmd,pydbsupt}.py[co] $RPM_BUILD_ROOT%{python_sitepkgsdir}
105
106 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
107
108 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
109
110 gzip -9nf ANNOUNCE BUGS NEWS* OPENBUGS PROBLEMS README TIPS
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
117
118 %postun
119 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
120
121 %files
122 %defattr(644,root,root,755)
123 %doc {ANNOUNCE,BUGS,NEWS*,OPENBUGS,PROBLEMS,README,TIPS}.gz
124 %doc doc/sample.dddinit
125 %{_applnkdir}/Development/ddd.desktop
126 %attr(755,root,root) %{_bindir}/ddd
127 %{_libdir}/X11/app-defaults/Ddd
128 %{_mandir}/man1/*
129 %{_datadir}/ddd*
130 %{_infodir}/ddd*
131
132 %files python
133 %defattr(644,root,root,755)
134 %{_applnkdir}/Development/ddd-python.desktop
135 %attr(755,root,root) %{_bindir}/pydb
136 %{python_sitepkgsdir}/*
This page took 0.442706 seconds and 3 git commands to generate.