]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
- xorgs modular deps, release 3.
[packages/ddd.git] / ddd.spec
1 Summary:        X interface to the GDB, DBX and XDB debuggers
2 Summary(ja):    GDB,DBX,Ladebug,JDB,Perl,Python¤Î¥°¥é¥Õ¥£¥«¥ë¥Ç¥Ð¥Ã¥¬¤Î¥Õ¥í¥ó¥È¥¨¥ó¥É
3 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
4 Summary(zh_CN): Í¼Ðλ¯µÄ³ÌÐòµ÷ÊÔÆ÷Ç°¶Ë;ÈçGDB,DBX,Ladebug,JDB,Perl,Python
5 Name:           ddd
6 Version:        3.3.11
7 Release:        3
8 Epoch:          1
9 License:        GPL
10 Group:          Development/Debuggers
11 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
12 # Source0-md5:  f19437ebfdb5f2667d6de30f700dd319
13 Source1:        %{name}.desktop
14 Source2:        http://art.gnome.org/images/icons/other/Debugger.png
15 # Source2-md5:  c046d9b0a04abdbb4a2be08a374ac2cd
16 Patch0:         %{name}-ptrace.patch
17 Patch1:         %{name}-info.patch
18 Patch2:         %{name}-home_etc.patch
19 Patch3:         %{name}-am185.patch
20 URL:            http://www.gnu.org/software/ddd/
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  bison
24 BuildRequires:  elfutils-devel
25 BuildRequires:  flex
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 BuildRequires:  motif-devel
29 BuildRequires:  ncurses-devel >= 5.0
30 BuildRequires:  readline-devel
31 BuildRequires:  xorg-lib-libXmu-devel
32 BuildRequires:  xorg-lib-libXpm-devel
33 BuildRequires:  texinfo
34 Requires:       gdb
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _appdefsdir     /usr/X11R6/lib/X11/app-defaults
38
39 %define         specflags       -fno-strict-aliasing
40
41 %description
42 The Data Display Debugger (DDD) is a common graphical user interface
43 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
44 ``classical'' front-end features such as viewing source texts, DDD
45 provides a graphical data display, where data structures are displayed
46 as graphs. A simple mouse click dereferences pointers or views
47 structure contents, updated each time the program stops. Using DDD,
48 you can reason about your application by viewing its data, not just by
49 viewing it execute lines of source code. Other DDD features include:
50 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
51 Modula-2, or Modula-3; machine-level debugging; hypertext source
52 navigation and lookup; breakpoint, backtrace, and history editors;
53 preferences and settings editors; program execution in terminal
54 emulator window; debugging on remote host; on-line manual; interactive
55 help on the Motif user interface; GDB/DBX/XDB command-line interface
56 with full editing, history, search, and completion capabilities. DDD
57 has been designed to compete with well-known commercial debuggers
58
59 %description -l ja
60 DDD¤Ï¡¢GDB,DBX,WDB,Ladebug,JDB,XDB,Perl¥Ç¥Ð¥Ã¥¬¡¢¤Þ¤¿¤ÏPython¥Ç¥Ð¥Ã¥¬
61 ¤Î¤è¤¦¤Ê¥³¥Þ¥ó¥É¥é¥¤¥ó·¿¥Ç¥Ð¥Ã¥¬¤ò¥°¥é¥Õ¥£¥«¥ë·¿¤Î¥Ç¥Ð¥Ã¥¬¤ËÊѿȤµ¤»¤ë
62 ¥Õ¥í¥ó¥È¥¨¥ó¥É¤Ç¤¹¡£¥½¡¼¥¹¥³¡¼¥É¤Î»²¾ÈÅù¤Î¤è¤¦¤Ê"Ä̾ï"¤Î¥Õ¥í¥ó¥È¥¨¥ó¥É
63 ¤Îµ¡Ç½¤Î¤ß¤Ê¤é¤º¡¢DDD¤Ï¥Ç¡¼¥¿¹½Â¤¤ò¥°¥é¥Õ¤È¤·¤Æɽ¼¨¤¹¤ë¡¢²ñÏü°¥°¥é¥Õ
64 ¥£¥«¥ë¥Ç¡¼¥¿É½¼¨¤¹¤ë¤³¤È¤Çͭ̾¤Ë¤Ê¤ê¤Þ¤·¤¿¡£
65
66 %description -l pl
67 Data Display Debugger (DDD) jest typowym graficznym interfejsem do
68 GDB, DBX, i XDB - popularnych UNIXowych debuggerów. Poza
69 ``klasycznymi'' mo¿liwo¶ciami interfejsów graficznych takich jak
70 przegl±danie kodów ¼ród³owych DDD dostarcza graficznych narzêdzi,
71 gdzie struktury wy¶wietlane s± w postaci graficznej. Proste klikniêcie
72 mysz± pozwala na przegl±danie zawarto¶ci struktur (aktualizowane za
73 ka¿dym razem gdy program siê zatrzyma). Inne mo¿liwo¶ci DDD to:
74 mo¿liwo¶æ debugowania programów napisanych w C, C++, Ada, Fortran,
75 Java, Pascal, Modula-2, or Modula-2; debugowanie na poziomie maszyny;
76 hypertekstowa nawigacja po ¼ród³ach; breakpoint, backtrace i emulator
77 okna historii; mo¿liwo¶æ ustawiania preferencji; uruchamianie
78 programów w oknie terminala; debugowanie na zdalnych serwerach;
79 podrêcznik on-line; interaktywna pomoc; linia poleceñ GDB/DBX/XDB z
80 pe³n± edycj±, histori± i wyszukiwaniem.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         --with-motif \
96         --with-readline \
97         --with-termlib=tinfo
98
99 %{__make} \
100         CXXOPT="-DNDEBUG %{rpmcflags}"
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_appdefsdir},%{_desktopdir},%{_pixmapsdir}}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install ddd/Ddd $RPM_BUILD_ROOT%{_appdefsdir}
110
111 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
112 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/ddd.png
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
119
120 %postun
121 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS NEWS README TIPS TODO doc/*.pdf
126 %attr(755,root,root) %{_bindir}/ddd
127 %{_datadir}/ddd*
128 %{_appdefsdir}/Ddd
129 %{_desktopdir}/ddd.desktop
130 %{_pixmapsdir}/*.png
131 %{_mandir}/man1/*
132 %{_infodir}/ddd*
This page took 0.551888 seconds and 3 git commands to generate.