]> git.pld-linux.org Git - packages/ddd.git/blob - ddd.spec
2b470bee5288cf3be60f8f2e093e15d04761bf78
[packages/ddd.git] / ddd.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('pydb')"
4 %define python_compile python -c "import compileall; compileall.compile_dir('pydb')"
5
6 Summary:        X interface to the GDB, DBX and XDB debuggers
7 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB
8 Name:           ddd
9 Version:        3.2.98
10 Release:        1
11 License:        GPL
12 Group:          Development/Debuggers
13 Group(pl):      Programowanie/Odpluskwiacze
14 Source0:        ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
15 Source1:        ddd.desktop
16 Source2:        ddd-python.desktop
17 Patch0:         ddd-DESTDIR.patch
18 Icon:           ddd.xpm
19 URL:            http://www.gnu.org/software/ddd/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  motif-devel
22 BuildRequires:  ncurses-devel >= 5.0
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  python
25 BuildRequires:  texinfo
26 Requires:       gdb
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _prefix         /usr/X11R6
30 %define         _mandir         %{_prefix}/man
31
32 %description
33 The Data Display Debugger (DDD) is a common graphical user interface
34 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
35 ``classical'' front-end features such as viewing source texts, DDD
36 provides a graphical data display, where data structures are displayed
37 as graphs. A simple mouse click dereferences pointers or views
38 structure contents, updated each time the program stops. Using DDD,
39 you can reason about your application by viewing its data, not just by
40 viewing it execute lines of source code. Other DDD features include:
41 debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
42 Modula-2, or Modula-3; machine-level debugging; hypertext source
43 navigation and lookup; breakpoint, backtrace, and history editors;
44 preferences and settings editors; program execution in terminal
45 emulator window; debugging on remote host; on-line manual; interactive
46 help on the Motif user interface; GDB/DBX/XDB command-line interface
47 with full editing, history, search, and completion capabilities. DDD
48 has been designed to compete with well-known commercial debuggers
49
50 %description -l pl
51 Data Display Debugger (DDD) jest typowm graficznym interfejsem do GDB,
52 DBX, i XDB - popularnych UNIXowych debuggerów. Poza ``klasycznymi''
53 mo¿liwo¶ciami interfejsów graficznych takich jak przegl±danie kodów
54 ¼ród³owych DDD dostarcza graficznych narzêdzi, gdzie struktury
55 wy¶wietlane s± w postaci graficznej. Proste klikniêcie mysz± pozwala
56 na przegl±danie zawarto¶ci struktur (aktualizowane za ka¿dym razem gdy
57 program siê zatrzyma). Inne mo¿liwo¶ci DDD to: mo¿liwo¶æ debugowania
58 programów napisanych w C, C++, Ada, Fortran, Java, Pascal, Modula-2,
59 or Modula-2; debugowanie na poziomie maszyny; hypertekstowa nawigacja
60 po ¼ród³ach; breakpoint, backtrace i emulator okna historii; mo¿liwo¶æ
61 ustawiania preferencji; uruchamianie programów w oknie terminala;
62 debugowanie na zdalnych serwerach; podrêcznik on-line; interaktywna
63 pomoc; linia poleceñ GDB/DBX/XDB z pe³n± edycj±, histori± i
64 wyszukiwaniem.
65
66 %package python
67 Summary:        X interface to the GDB, DBX and XDB debuggers - The python debugger
68 Summary(pl):    Interfejs X do debugerów GDB, DBX i XDB - debuger pythona
69 Group:          Development/Debuggers
70 Group(pl):      Programowanie/Odpluskwiacze
71 Requires:       %{name} = %{version}
72
73 %description python
74 Data Display Debugger - python debugger.
75
76 %description -l pl
77 Data Display Debugger - debugger pythona.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82
83 %build
84 automake -a -c
85 %configure \
86         --with-motif
87 %{__make} CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
88 %python_compile
89 %python_compile_opt 
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{python_sitepkgsdir} \
94         $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
95         $RPM_BUILD_ROOT%{_applnkdir}/Development
96
97 %{__make} DESTDIR=$RPM_BUILD_ROOT install 
98
99 install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
100 install pydb/{pydbcmd,pydbsupt}.py[co] $RPM_BUILD_ROOT%{python_sitepkgsdir}
101
102 install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
103
104 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
105
106 gzip -9nf ANNOUNCE BUGS NEWS* OPENBUGS PROBLEMS README TIPS
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
113
114 %postun
115 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
116
117 %files
118 %defattr(644,root,root,755)
119 %doc {ANNOUNCE,BUGS,NEWS*,OPENBUGS,PROBLEMS,README,TIPS}.gz
120 %doc doc/sample.dddinit
121 %{_applnkdir}/Development/ddd.desktop
122 %attr(755,root,root) %{_bindir}/ddd
123 %{_libdir}/X11/app-defaults/Ddd
124 %{_mandir}/man1/*
125 %{_datadir}/ddd*
126 %{_infodir}/ddd*
127
128 %files python
129 %defattr(644,root,root,755)
130 %{_applnkdir}/Development/ddd-python.desktop
131 %attr(755,root,root) %{_bindir}/pydb
132 %{python_sitepkgsdir}/*
This page took 0.033973 seconds and 2 git commands to generate.