]> git.pld-linux.org Git - packages/ddclient.git/blob - ddclient.spec
send less mail by default, eg. not on every shutdown.
[packages/ddclient.git] / ddclient.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        A dynamic IP address utility
3 Summary(pl.UTF-8):      Narzędzie do dynamicznych adresów IP
4 Summary(pt_BR.UTF-8):   Cliente para atualizar entradas DNS dinâmicas no DynDNS.org
5 Name:           ddclient
6 Version:        3.8.3
7 Release:        1
8 Epoch:          1
9 License:        GPL v2
10 Group:          Networking
11 Source0:        http://downloads.sourceforge.net/ddclient/%{name}-%{version}.tar.bz2
12 # Source0-md5:  3b426ae52d509e463b42eeb08fb89e0b
13 Source1:        %{name}.init
14 Source2:        %{name}.sysconfig
15 Source3:        %{name}.NetworkManager
16 Patch0:         config.patch
17 # https://github.com/wimpunk/ddclient
18 URL:            http://ddclient.sourceforge.net/
19 BuildRequires:  rpm-perlprov
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       rc-scripts
23 # for freedns: Digest::SHA1, IO::Socket::SSL
24 Suggests:       perl-Digest-SHA1
25 Suggests:       perl-IO-Socket-SSL
26 # for cloudflare JSON::Any
27 Suggests:       perl-JSON-Any
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 DDclient is a small full featured client with FULL DynDNS NIC2
33 support, requiring only Perl and no additional modules. It runs under
34 most UNIX OSes and has been tested under Linux and FreeBSD. Supported
35 features include: operating as a daemon, manual and automatic updates,
36 static and dynamic updates, optimized updates for multiple addresses,
37 MX, wildcards, abuse avoidance, retrying failed updates, and sending
38 update status to syslog and through e-mail. This release may now
39 obtain your IP address from any interface, web based IP detection,
40 Watchguard's SOHO router, Netopia's R910 router, SMC's Barricade
41 broadband router, Netgear's RT3xx router, Linksys' broadband routers,
42 MaxGate's UGATE-3x00 routers, ELSA's LANCOM DSL/10 routers and now
43 provides Full support for DynDNS.org's NIC2 protocol. Support is also
44 included for other dynamic DNS services. Comes with sample scripts for
45 use with DHCP, PPP, and cron. See the README for more information.
46
47 %description -l pl.UTF-8
48 DDclient to mały, w pełni funkcjonalny klient z PEŁNĄ obsługą DynDNS
49 NIC2, wymagający tylko Perla bez żadnych dodatkowych modułów. Działa
50 pod większością systemów uniksowych, był testowany pod Linuksem i
51 FreeBSD. Jego możliwości to między innymi: praca jako demon, ręczne i
52 automatyczne uaktualnienia, statyczne i dynamiczne uaktualnienia,
53 uaktualnienia zoptymalizowane dla wielu adresów, MX-y, wildcardy,
54 zapobieganie nadużyciom, ponawianie nieudanych uaktualnień, wysyłanie
55 statusu uaktualnień do sysloga i pocztą. Ta wersja może pobrać adres
56 IP z dowolnego interfejsu, wykrywania przez WWW, routerów: Watchguard
57 SOGO, szerokopasmowych SMC Barricane, Netgear RT3xx, szerokopasmowych
58 Linksys, MaxGate UGATE-3x00, ELSA LANCOM DSL/10, a teraz także ma
59 pełną obsługę protokołu DynDNS NIC2. Ma także wsparcie dla innych
60 usług dynamicznego DNS. Zawiera przykładowe skrypty do używania z
61 DHCP, PPP i cronem. Więcej informacji w README.
62
63 %description -l pt_BR.UTF-8
64 O ddclient é um cliente perl usada para atualizar entradas DNS
65 dinâmicas em contas do serviço de DNS dinâmico gratuito. Veja
66 <http://www.dyndns.org> para obter detalhes sobre como obter uma conta
67 gratuita.
68
69 %prep
70 %setup -q
71 cp -p sample-etc_ddclient.conf %{name}.conf
72 %patch0 -p1
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ddclient,/etc/{rc.d/init.d,sysconfig,NetworkManager/dispatcher.d},%{_sbindir},%{_var}/cache/%{name}}
77 cp -p %{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
78 install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
79 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
80 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
81 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/NetworkManager/dispatcher.d/50-%{name}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 /sbin/chkconfig --add %{name}
88 %service %{name} restart "%{name} daemon"
89
90 %preun
91 if [ "$1" = "0" ]; then
92         %service %{name} stop
93         /sbin/chkconfig --del %{name}
94 fi
95
96 %triggerpostun -- ddclient < 1:3.6.4
97 if [ -f /etc/ddclient.conf.rpmsave ]; then
98         echo "Moving config to new location /etc/ddclient"
99         mv -f /etc/ddclient/ddclient.conf /etc/ddclient/ddclient.conf.rpmnew
100         mv -f /etc/ddclient.conf.rpmsave /etc/ddclient/ddclient.conf
101         mv -f /etc/ddclient.cache /etc/ddclient.cache.rpmsave
102 fi
103
104 %files
105 %defattr(644,root,root,755)
106 %doc ChangeLog Changelog.old README*
107 %attr(755,root,root) %{_sbindir}/ddclient
108 %dir %{_sysconfdir}/%{name}
109 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
110 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ddclient
111 %attr(754,root,root) /etc/rc.d/init.d/%{name}
112 %dir %{_var}/cache/%{name}
113 %attr(755,root,root) /etc/NetworkManager/dispatcher.d/50-%{name}
This page took 0.061418 seconds and 4 git commands to generate.