]> git.pld-linux.org Git - packages/ddccontrol.git/blob - ddccontrol.spec
- added gnome patch and gtk,gnome bconds
[packages/ddccontrol.git] / ddccontrol.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # don't build gnome applet
4 %bcond_without  gtk     # don't build GTK+ GUI
5 #
6 %define dbversion 20060308
7 %define ddcdb   %{name}-db-%{dbversion}
8
9 Summary:        DDCcontrol - control the monitor parameters
10 Summary(pl):    DDCcontrol - narzêdzie do regulacji parametrów monitora
11 Name:           ddccontrol
12 Version:        0.4.1
13 Release:        1
14 License:        GPL v2+
15 Group:          Applications
16 Source0:        http://dl.sourceforge.net/ddccontrol/%{name}-%{version}.tar.bz2
17 # Source0-md5:  bef6825f7dfffbb4fd40eb4a848cd438
18 Source1:        http://dl.sourceforge.net/ddccontrol/%{ddcdb}.tar.bz2
19 # Source1-md5:  973a5db6081054bbb336254331820b0c
20 Patch0:         %{name}-SAM0197.patch
21 Patch1:         %{name}-desktop.patch
22 Patch2:         %{name}-gnome.patch
23 URL:            http://ddccontrol.sourceforge.net/
24 BuildRequires:  autoconf >= 2.50
25 BuildRequires:  automake
26 %{?with_gnome:BuildRequires:    gnome-panel-devel >= 2.10}
27 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2:2.4}
28 BuildRequires:  libtool
29 BuildRequires:  libxml2-devel
30 BuildRequires:  pciutils-devel
31 BuildRequires:  pkgconfig
32 Requires:       %{name}-libs = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 DDCcontrol is a program used to control monitor parameters, like
37 brightness and contrast, by software, i.e. without using the OSD and
38 the buttons in front of the monitor.
39
40 %description -l pl
41 DDCcontrol jest programem s³u¿±cym do regulacji parametrów monitora
42 takich jak jaskrawo¶æ i kontrast, bez u¿ywania OSD i przycisków na
43 obudowie monitora.
44
45 %package gtk
46 Summary:        GTK+ GUI for ddccontrol
47 Summary(pl):    Graficzny interfejs GTK+ dla ddccontrol
48 Group:          X11/Applications
49 Requires:       %{name} = %{version}-%{release}
50
51 %description gtk
52 GTK+ GUI for ddccontrol.
53
54 %description gtk -l pl
55 Graficzny interfejs GTK+ dla ddccontrol.
56
57 %package applet
58 Summary:        GNOME applet for ddccontrol
59 Summary(pl):    Aplet GNOME dla ddccontrol
60 Group:          X11/Applications
61 Requires:       %{name} = %{version}-%{release}
62
63 %description applet
64 GNOME applet for ddccontrol.
65
66 %description applet -l pl
67 Aplet GNOME dla ddccontrol.
68
69 %package libs
70 Summary:        ddccontrol library
71 Summary(pl):    Biblioteka ddccontrol
72 Group:          Libraries
73
74 %description libs
75 DDCcontrol library.
76
77 %description libs -l pl
78 Biblioteka DDCcontrol.
79
80 %package devel
81 Summary:        Development files for ddccontrol library
82 Summary(pl):    Pliki niezbêdne programistom u¿ywaj±cym biblioteki ddccontrol
83 Group:          Development/Libraries
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       libxml2-devel
86 Requires:       pciutils-devel
87
88 %description devel
89 Development files for ddccontrol library.
90
91 %description devel -l pl
92 Pliki niezbêdne programistom u¿ywaj±cym biblioteki ddccontrol.
93
94 %package static
95 Summary:        Static ddccontrol library
96 Summary(pl):    Biblioteka statyczna ddccontrol
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Static ddccontrol library.
102
103 %description static -l pl
104 Biblioteka statyczna ddccontrol.
105
106 %prep
107 %setup -q -a 1
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111
112 %build
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         %{!?with_gtk:--disable-gnome} \
120         %{!?with_gnome:--disable-gnome-applet}
121 %{__make}
122 cd %{ddcdb}
123 %configure
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %{__make} -C %{ddcdb} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %find_lang %{name} --all-name
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog NEWS README TODO doc/html
145 %attr(755,root,root) %{_bindir}/ddccontrol
146 %attr(755,root,root) %{_bindir}/ddcpci
147 %{_datadir}/ddccontrol-db
148
149 %if %{with gtk}
150 %files gtk
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/gddccontrol
153 %{_desktopdir}/gddccontrol.desktop
154 %{_pixmapsdir}/gddccontrol.png
155 %endif
156
157 %if %{with gnome}
158 %files applet
159 %defattr(644,root,root,755)
160 %dir %{_libdir}/ddccontrol
161 %attr(755,root,root) %{_libdir}/ddccontrol/ddcc-applet
162 %{_datadir}/ddccontrol
163 %{_libdir}/bonobo/servers/*
164 %endif
165
166 %files libs
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libddccontrol.so.*.*.*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libddccontrol.so
173 %{_libdir}/libddccontrol.la
174 %{_includedir}/ddccontrol
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libddccontrol.a
This page took 0.24151 seconds and 4 git commands to generate.