]> git.pld-linux.org Git - packages/ddccontrol.git/blob - ddccontrol.spec
- added pl patch (some typo fixes, translation still incomplete)
[packages/ddccontrol.git] / ddccontrol.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # don't build gnome applet
4 %bcond_without  gtk     # don't build GTK+ GUI
5 #
6 %define dbversion 20060308
7 %define ddcdb   %{name}-db-%{dbversion}
8
9 Summary:        DDCcontrol - control the monitor parameters
10 Summary(pl):    DDCcontrol - narzêdzie do regulacji parametrów monitora
11 Name:           ddccontrol
12 Version:        0.4.1
13 Release:        1
14 License:        GPL v2+
15 Group:          Applications
16 Source0:        http://dl.sourceforge.net/ddccontrol/%{name}-%{version}.tar.bz2
17 # Source0-md5:  bef6825f7dfffbb4fd40eb4a848cd438
18 Source1:        http://dl.sourceforge.net/ddccontrol/%{ddcdb}.tar.bz2
19 # Source1-md5:  973a5db6081054bbb336254331820b0c
20 Patch0:         %{name}-SAM0197.patch
21 Patch1:         %{name}-desktop.patch
22 Patch2:         %{name}-gnome.patch
23 Patch3:         %{name}-pl.patch
24 URL:            http://ddccontrol.sourceforge.net/
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake
27 %{?with_gnome:BuildRequires:    gnome-panel-devel >= 2.10}
28 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2:2.4}
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel
31 BuildRequires:  pciutils-devel
32 BuildRequires:  pkgconfig
33 Requires:       %{name}-libs = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 DDCcontrol is a program used to control monitor parameters, like
38 brightness and contrast, by software, i.e. without using the OSD and
39 the buttons in front of the monitor.
40
41 %description -l pl
42 DDCcontrol jest programem s³u¿±cym do regulacji parametrów monitora
43 takich jak jaskrawo¶æ i kontrast, bez u¿ywania OSD i przycisków na
44 obudowie monitora.
45
46 %package gtk
47 Summary:        GTK+ GUI for ddccontrol
48 Summary(pl):    Graficzny interfejs GTK+ dla ddccontrol
49 Group:          X11/Applications
50 Requires:       %{name} = %{version}-%{release}
51
52 %description gtk
53 GTK+ GUI for ddccontrol.
54
55 %description gtk -l pl
56 Graficzny interfejs GTK+ dla ddccontrol.
57
58 %package applet
59 Summary:        GNOME applet for ddccontrol
60 Summary(pl):    Aplet GNOME dla ddccontrol
61 Group:          X11/Applications
62 Requires:       %{name} = %{version}-%{release}
63
64 %description applet
65 GNOME applet for ddccontrol.
66
67 %description applet -l pl
68 Aplet GNOME dla ddccontrol.
69
70 %package libs
71 Summary:        ddccontrol library
72 Summary(pl):    Biblioteka ddccontrol
73 Group:          Libraries
74
75 %description libs
76 DDCcontrol library.
77
78 %description libs -l pl
79 Biblioteka DDCcontrol.
80
81 %package devel
82 Summary:        Development files for ddccontrol library
83 Summary(pl):    Pliki niezbêdne programistom u¿ywaj±cym biblioteki ddccontrol
84 Group:          Development/Libraries
85 Requires:       %{name}-libs = %{version}-%{release}
86 Requires:       libxml2-devel
87 Requires:       pciutils-devel
88
89 %description devel
90 Development files for ddccontrol library.
91
92 %description devel -l pl
93 Pliki niezbêdne programistom u¿ywaj±cym biblioteki ddccontrol.
94
95 %package static
96 Summary:        Static ddccontrol library
97 Summary(pl):    Biblioteka statyczna ddccontrol
98 Group:          Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100
101 %description static
102 Static ddccontrol library.
103
104 %description static -l pl
105 Biblioteka statyczna ddccontrol.
106
107 %prep
108 %setup -q -a 1
109 %patch0 -p1
110 %patch1 -p1
111 %patch2 -p1
112 %patch3 -p1
113
114 %build
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         %{!?with_gtk:--disable-gnome} \
122         %{!?with_gnome:--disable-gnome-applet}
123 %{__make}
124 cd %{ddcdb}
125 %configure
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 %{__make} -C %{ddcdb} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %find_lang %{name} --all-name
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files -f %{name}.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog NEWS README TODO doc/html
147 %attr(755,root,root) %{_bindir}/ddccontrol
148 %attr(755,root,root) %{_bindir}/ddcpci
149 %{_datadir}/ddccontrol-db
150
151 %if %{with gtk}
152 %files gtk
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/gddccontrol
155 %{_desktopdir}/gddccontrol.desktop
156 %{_pixmapsdir}/gddccontrol.png
157 %endif
158
159 %if %{with gnome}
160 %files applet
161 %defattr(644,root,root,755)
162 %dir %{_libdir}/ddccontrol
163 %attr(755,root,root) %{_libdir}/ddccontrol/ddcc-applet
164 %{_datadir}/ddccontrol
165 %{_libdir}/bonobo/servers/*
166 %endif
167
168 %files libs
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libddccontrol.so.*.*.*
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libddccontrol.so
175 %{_libdir}/libddccontrol.la
176 %{_includedir}/ddccontrol
177
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libddccontrol.a
This page took 0.075048 seconds and 3 git commands to generate.