]> git.pld-linux.org Git - packages/dcd.git/blob - dcd.spec
- fixed permisions to configs
[packages/dcd.git] / dcd.spec
1 Summary:        DConnect Daemon - Hub D****ct Connect for Linux
2 Summary(pl):    DConnect Daemon - Hub D****ct Connecta dla Linuksa
3 Name:           dcd
4 Version:        0.1.6
5 Release:        1
6 License:        GPL v2
7 Group:          Networking/Daemons
8 Vendor:         DConnect Team <dc-hub@ds.pg.gda.pl>
9 Source0:        ftp://pollux.ds.pg.gda.pl/pub/Linux/DConnect/sources/devel/%{name}-%{version}.tar.bz2
10 URL:            http://www.dc.ds.pg.gda.pl/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  libwrap-devel
15 BuildRequires:  lwl-devel >= 0.9
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This is Linux D*** Connect Hub implementation for Linux. It works in
20 daemon mode and utilizes threads.
21
22 %description -l pl
23 Pakiet zawiera Linuksow± implementacjê huba D*** Connecta, który
24 pracuje jako demon i u¿ywa w±tków.
25
26 %prep
27 %setup -q
28
29 %build
30 rm -f missing
31 %{__libtoolize}
32 %{__aclocal}
33 %{__autoconf}
34 %{__automake}
35 %configure \
36         --sysconfdir=%{_sysconfdir}/dcd
37
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{sysconfig,rc.d/init.d},/var/log/dcd}
43
44 %{__make} install DESTDIR=$RPM_BUILD_ROOT
45
46 install contrib/PLD/dcd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/dcd
47 install contrib/dcd.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/dcd
48
49 touch $RPM_BUILD_ROOT/var/log/dcd/dcd.log
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /sbin/chkconfig --add dcd
55 if [ -f /var/lock/subsys/dcd ]; then
56         /etc/rc.d/init.d/dcd restart 1>&2
57 else
58         echo "Run \"/etc/rc.d/init.d/dcd start\" to start DConnect Daemon."
59 fi
60
61 %preun
62 if [ "$1" = "0" ]; then
63         if [ -f /var/lock/subsys/dcd ]; then
64                 /etc/rc.d/init.d/dcd stop 1>&2
65         fi
66         /sbin/chkconfig --del dcd
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS BUGS FAQ NEWS README TODO doc/*.txt doc/*.html
72 %attr(751,daemon,root) %dir %{_sysconfdir}/dcd
73 %attr(640,daemon,root) %config(noreplace) %{_sysconfdir}/dcd/passwd
74 %attr(644,daemon,root) %config(noreplace) %{_sysconfdir}/dcd/dcd.conf
75 %attr(644,daemon,root) %config(noreplace) %{_sysconfdir}/dcd/welcome
76 %attr(644,daemon,root) %config(noreplace) %{_sysconfdir}/dcd/motd
77 %config(noreplace) /etc/sysconfig/dcd
78 %attr(755,root,root) %{_sbindir}/dcd
79 %attr(754,root,root) /etc/rc.d/init.d/dcd
80 %attr(644,daemon,root) /var/log/dcd/dcd.log
This page took 0.086412 seconds and 3 git commands to generate.