]> git.pld-linux.org Git - packages/dcd.git/blob - dcd.spec
- 0.2.15 - more mem-leaks removed
[packages/dcd.git] / dcd.spec
1 Summary:        DConnect Daemon - Hub D****ct Connect for Linux
2 Summary(pl):    DConnect Daemon - Hub D****ct Connecta dla Linuksa
3 Name:           dcd
4 Version:        0.2.15
5 Release:        1
6 License:        GPL v2
7 Group:          Networking/Daemons
8 Vendor:         DConnect Team <dc-hub@ds.pg.gda.pl>
9 Source0:        ftp://pollux.ds.pg.gda.pl/pub/Linux/DConnect/sources/devel/%{name}-%{version}.tar.bz2
10 # Source0-md5:  95f6277d60abfde04826bb96e945ae1a
11 URL:            http://www.dc.ds.pg.gda.pl/
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRequires:  libwrap-devel
16 PreReq:         rc-scripts
17 Requires(post,preun):   /sbin/chkconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is Linux D*** Connect Hub implementation for Linux. It works in
22 daemon mode and utilizes threads.
23
24 %description -l pl
25 Pakiet zawiera Linuksow± implementacjê huba D*** Connecta, który
26 pracuje jako demon i u¿ywa w±tków.
27
28 %prep
29 %setup -q
30
31 %build
32 %{__libtoolize}
33 %{__aclocal}
34 %{__autoconf}
35 %{__automake}
36 %configure \
37         --sysconfdir=%{_sysconfdir}/dcd \
38         --with-user=daemon \
39         --with-group=daemon
40
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{sysconfig,rc.d/init.d,logrotate.d},/var/log/archiv/dcd}
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 install contrib/PLD/dcd.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/dcd
51 install contrib/dcd.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dcd
52 install contrib/logrotate.dcd $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/dcd
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 /sbin/chkconfig --add dcd
59 if [ -f /var/lock/subsys/dcd ]; then
60         /etc/rc.d/init.d/dcd restart 1>&2
61 else
62         echo "Run \"/etc/rc.d/init.d/dcd start\" to start DConnect Daemon."
63 fi
64
65 %preun
66 if [ "$1" = "0" ]; then
67         if [ -f /var/lock/subsys/dcd ]; then
68                 /etc/rc.d/init.d/dcd stop 1>&2
69         fi
70         /sbin/chkconfig --del dcd
71 fi
72
73 #%triggerpostun -- dcd < 0.1.1
74 #echo "Upgrading from version < 0.1.1"
75 #echo "Remember to review config - the options were changed!!!"
76 #if [ -e /etc/dcd/dchub.conf.rpmsave ]; then
77 #       cp /etc/dcd/dchub.conf.rpmsave /etc/dcd/dcd.conf
78 #fi
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS BUGS FAQ NEWS README TODO doc/*.html
83 %attr(755,daemon,root) %dir %{_sysconfdir}/dcd
84 %attr(660,root,daemon) %config(noreplace) %{_sysconfdir}/dcd/console.allow
85 %attr(660,root,daemon) %config(noreplace) %{_sysconfdir}/dcd/console.users
86 %attr(660,daemon,daemon) %config(noreplace) %{_sysconfdir}/dcd/dcd.banned
87 %attr(664,root,daemon) %config(noreplace) %{_sysconfdir}/dcd/dcd.conf
88 %attr(664,root,daemon) %config(noreplace) %{_sysconfdir}/dcd/dcd.motd
89 %attr(664,root,daemon) %config(noreplace) %{_sysconfdir}/dcd/dcd.welcome
90 %attr(664,daemon,daemon) %config(noreplace) %{_sysconfdir}/dcd/nicks.allow
91 %config(noreplace) %{_sysconfdir}/sysconfig/dcd
92 %config(noreplace) %{_sysconfdir}/logrotate.d/dcd
93 %attr(755,root,root) %{_sbindir}/dcd
94 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/dcd
95 %attr(751,daemon,root) %dir /var/log/dcd
96 %attr(751,daemon,root) %dir /var/log/archiv/dcd
97 %{_mandir}/man1/*.1*
98 %{_mandir}/man2/*.2*
This page took 0.116018 seconds and 3 git commands to generate.