]> git.pld-linux.org Git - packages/dcc-dccd.git/blob - dcc-dccd.spec
- /home -> /home/services
[packages/dcc-dccd.git] / dcc-dccd.spec
1 Summary:        Distributed Checksum Clearinghouse, anti-spam tool
2 Summary(pl):    Narzêdzie anty-spamowe bazuj±ce na sumach kontrolnych (DCC)
3 Name:           dcc-dccd
4 Version:        1.1.14
5 Release:        1
6 License:        BSD-like
7 Group:          Networking
8 Source0:        http://www.dcc-servers.net/dcc/source/%{name}-%{version}.tar.Z
9 URL:            http://www.dcc-servers.net/
10 Requires(pre):  /usr/sbin/useradd
11 Requires(post,preun):   /sbin/chkconfig
12 Requires(postun):       /usr/sbin/userdel
13 Prereq:         /sbin/chkconfig
14 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         dccdir  /var/lib/dcc
17
18 %description
19 Distributed Checksum Clearinghouse or DCC is a cooperative,
20 distributed system intended to detect "bulk" mail or mail sent to many
21 people. It allows individuals receiving a single mail message to
22 determine that many other people have been sent essentially identical
23 copies of the message and so reject the message. It can identify some
24 unsolicited bulk mail using "spam traps" and other detectors, but that
25 is not its focus.
26
27 The DCC can be viewed as a tool for end users to enforce their right
28 to "opt-in" to streams of bulk mail by refusing all bulk mail except
29 from sources in a "white list." White lists are generally the
30 responsibility of DCC clients, since only they know which bulk mail
31 they solicited.
32
33 NB to use DCC to reject SPAM you need to configure %{dccdir}/dcc_conf
34 and either use procmail or sendmail to feed the messages to DCC.
35
36 %description -l pl
37 DCC (Distributed Checksum Clearinghouse) jest kooperatywnym,
38 rozproszonym systemem maj±cym na celu wykrywanie masowej poczty lub
39 poczty wys³anej do wielu ludzi. Pozwala jednostkom otrzymuj±cym
40 pojedynczy list okre¶liæ, jak wielu innych otrzyma³o dok³adnie
41 identyczne kopie tej wiadomo¶ci i na tej podstawie odrzuciæ j±. Mo¿e
42 zidentyfikowaæ niechcian± masow± pocztê przy u¿yciu "pu³apek
43 antyspamowych" i innych wykrywaczy, ale to nie jest podstawowym celem.
44
45 DCC mo¿na odbieraæ jako narzêdzie dla u¿ytkowników koñcowych,
46 zapewniaj±ce im prawo do przeciwstawienia siê zalewowi masowej poczty
47 przez odrzucenie wszystkich ¶mieci oprócz ¼róde³ z "bia³ej listy".
48 Za bia³e listy odpowiadaj± klienci DCC, jako ¿e tylko oni wiedz±,
49 jak± masow± pocztê zamawiali.
50
51 Aby u¿ywaæ DCC do odrzucania spamu trzeba go skonfigurowaæ poprzez
52 %{dccdir}/dcc_conf i u¿ywaæ procmaila lub sendmaila, by przekazywaæ
53 wszystkie listy do DCC.
54
55 %package cgi
56 Summary:        cgi-scripts for managing mail delivery on a DCC enabled server
57 Summary(pl):    Skrypty cgi do obs³ugi dostarczania poczty na serwerze DCC
58 Group:          Networking
59 Requires:       %{name} >= 1.1.2
60
61 %description cgi
62 Example set of cgi-scripts to allow users to point-and-click manage
63 their own DCC whitelists and thus what is delivered to them. Allows
64 overriding of site level lists. The scripts give controlled access to
65 the whitelists which are otherwise in protected directory space (owned
66 by dcc).
67
68 NB these scripts need configured after installation.
69
70 %description cgi -l pl
71 Przyk³adowy zestaw skryptów pozwalaj±cych u¿ytkownikom na klikane
72 zarz±dzenie ich bia³ymi listami DCC, a wiêc i tym, co dostaj±. Pozwala
73 przykrywaæ listy dotycz±ce serwera. Skrypty daj± dostêp do bia³ych
74 list, które normalnie s± w zabezpieczonym katalogu (którego
75 w³a¶cicielem jest DCC).
76
77 Te skrypty wymagaj± konfiguracji po zainstalowaniu.
78
79 %prep
80 %setup -q
81
82 %build
83 %configure2_13 \
84         --with-uid=99 \
85         --with-cgibin=/home/services/httpd/html/cgi-bin \
86         --with-rundir=%{_var}/run \
87         --with-db-memory=32
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{makeinstall} \
94         MANOWN=$(id -u) \
95         MANGRP=$(id -g) \
96         BINOWN=$(id -u) \
97         BINGRP=$(id -u) \
98         MANDIR=$RPM_BUILD_ROOT%{_mandir} \
99         BINDIR=$RPM_BUILD_ROOT%{_bindir}
100
101 DCC_PROTO_HOMEDIR=$RPM_BUILD%{_var}/lib/dcc
102 DCC_CGIBINDIR=$RPM_BUILD_ROOT%{dccdir}/cgi-bin; export DCC_CGIBINDIR
103 DCC_SUID=$BINOWN DCC_OWN=$BINOWN DCC_GRP=$BINGRP; export DCC_SUID DCC_OWN DCC_GRP
104
105 install -d $RPM_BUILD_ROOT%{_datadir}/sendmail-cf/feature $DCC_CGIBINDIR
106 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{init.d,cron.daily},%{_bindir}} \
107         $RPM_BUILD_ROOT{/var/run/dcc,%{dccdir}/{log,userdirs/{local,esmtp,cyrus,procmail}}}
108
109 %makeinstall
110 cp misc/dcc.m4 misc/dccdnsbl.m4 $RPM_BUILD_ROOT/usr/share/sendmail-cf/feature
111 mv $RPM_BUILD_ROOT/usr/sbin/cron-dccd $RPM_BUILD_ROOT/etc/cron.daily/dccd
112
113 # There already is a logger program which takes the required arguments on Linux
114
115 rm -f $RPM_BUILD_ROOT/usr/sbin/logger
116
117 # We are putting these in the docs directory
118 rm -f $RPM_BUILD_ROOT/usr/sbin/hackmc
119 rm -f $RPM_BUILD_ROOT/usr/sbin/na-spam
120 rm -f $RPM_BUILD_ROOT/usr/sbin/ng-spam
121
122 mv $RPM_BUILD_ROOT/usr/sbin/rcDCC $RPM_BUILD_ROOT/etc/rc.d/init.d/dccd
123 chmod 755 $RPM_BUILD_ROOT/etc/init.d/dccd
124
125 # Set some initial logging, but no rejections
126 perl -p -i -e "s/BRAND=\$/BRAND=RPMDEFAULT/ ; s/DCCM_LOG_AT=\$/\$&10/ ; " \
127         $RPM_BUILD_ROOT%{dccdir}/dcc_conf
128
129 umask 077
130 cat > $RPM_BUILD_ROOT%{dccdir}/flod <<EOF
131 # hostname,port     rem-id [passwd-id] [out-opts] [in-opts]
132
133 # this will not work
134 # nonesuch.example.com,-        32767 100
135 EOF
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %pre
141 /usr/sbin/useradd -d /var/dcc -r dcc >/dev/null 2>&1 || :
142
143 %postun
144 if [ $1 = 0 ]; then
145         /usr/sbin/userdel -r dcc > /dev/null 2>&1 || :
146 fi
147
148 %post
149 /sbin/chkconfig --add dccd || :
150 /sbin/chkconfig --level 016 dccd off || :
151 /usr/bin/cdcc info > %{dccdir}/map.txt || :
152
153 %post cgi
154 echo The scripts need configured and added into your web configuration.
155 echo see %{dccdir}/cgi-bin/README
156
157 %preun
158 if [ $1 = 0 ]; then
159         /sbin/chkconfig --del dccd || :
160         /etc/rc.d/init.d/dccd stop || :
161 fi
162
163 %files
164 %defattr(644,root,root,755)
165 %dir %{dccdir}
166 %dir %{dccdir}/log
167 %dir %{dccdir}/userdirs/local
168 %dir %{dccdir}/userdirs/cyrus
169 %dir %{dccdir}/userdirs/procmail
170 %dir %{dccdir}/userdirs/esmtp
171 %dir /var/run/dcc
172 %doc CHANGES FAQ.html FAQ.txt INSTALL.html INSTALL.txt LICENSE cdcc.html dbclean.html dblist.html dccd.html dcc.html dccm.html dccproc.html dccsight.html homedir/flod homedir/ids homedir/map.txt homedir/README misc/dcc.m4 misc/dccdnsbl.m4 misc/hackmc misc/na-spam misc/ng-spam
173 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_conf
174 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whiteclnt
175 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whitecommon
176 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whitelist
177 %config(noreplace) %verify(not size mtime md5) %{dccdir}/ids
178 %config(noreplace) %verify(not size mtime md5) %{dccdir}/flod
179 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_db
180 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_db.hash
181 %config(noreplace) %verify(not size mtime md5) %{dccdir}/map
182 %{dccdir}/map.txt
183 %attr(754,root,root) /etc/rc.d/init.d/dccd
184 %attr(750,root,root) /etc/cron.daily/dccd
185 %attr(755,root,root) %{_bindir}/cdcc
186 %attr(755,root,root) %{_bindir}/dccproc
187 %attr(755,root,root) %{_sbindir}/dbclean
188 %attr(755,root,root) %{_sbindir}/dblist
189 %attr(755,root,root) %{_sbindir}/dccd
190 %attr(755,root,root) %{_sbindir}/dccm
191 %attr(755,root,root) %{_sbindir}/dccsight
192 %attr(755,root,root) %{_sbindir}/refeed
193 %attr(755,root,root) %{_sbindir}/start-dccd
194 %attr(755,root,root) %{_sbindir}/start-dccm
195 %attr(755,root,root) %{_sbindir}/stop-dccd
196 %attr(755,root,root) %{_sbindir}/wlist
197 %{_datadir}/sendmail-cf/feature/dcc.m4
198 %{_datadir}/sendmail-cf/feature/dccdnsbl.m4
199
200 %{_mandir}/man8/*
201
202 %files cgi
203 %defattr(644,root,root,755)
204 %dir %{dccdir}/cgi-bin
205 %{dccdir}/cgi-bin/chgpasswd
206 %{dccdir}/cgi-bin/common
207 %{dccdir}/cgi-bin/edit-whiteclnt
208 %{dccdir}/cgi-bin/http2https
209 %{dccdir}/cgi-bin/list-log
210 %{dccdir}/cgi-bin/list-msg
211 %{dccdir}/cgi-bin/README
212 %{dccdir}/cgi-bin/webuser-notify
This page took 0.067196 seconds and 3 git commands to generate.