]> git.pld-linux.org Git - packages/dbmail.git/blob - dbmail.spec
- added mailbox2dbmail subpackage
[packages/dbmail.git] / dbmail.spec
1 # TODO: bcond for mysql
2 Summary:        Collection of programs for storing and retrieving mail from a SQL database
3 #Summary(pl):   
4 Name:           dbmail
5 Version:        2.0
6 %define _rc     rc5
7 Release:        0.%{_rc}.2
8 License:        GPL v2
9 Group:          Networking/Daemons
10 Source0:        http://dbmail.org/tgz/%{name}-%{version}%{_rc}.tgz
11 # Source0-md5:  f3cca8eb615af565a388069c1ab68f08
12 URL:            http://www.dbman.org/
13 BuildRequires:  postgresql-devel
14 #Requires(pre,post):    -
15 #Requires(preun):       -
16 #Requires(postun):      -
17 Requires:       postgresql
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 DBMAIL is a collection of programs that enables email to be
22 stored in and retrieved from a database.
23
24 Why is it usefull?
25 ==================
26 Well, for me it's usefull because a number of reasons.
27 - it enables me to create mailboxes without the need of systemusers.
28 - mail is more effeciently stored and therefore it can be inserted
29   an retrieved much faster dan any regular system (DBmail is currently
30   able to retrieve aprox. 250 mail messages per second)
31 - it's more expandable. A database is much easier to access than
32   a flat file or a Maildir. We don't need to parse first.
33 - In my case, i can easily link a mailbox to a certain client
34   which enables me to let the client maintaining his/her own mailboxes
35   without me needing to technically support it.
36 - It's scalable. You can run the dbmail programs on different servers
37   talking to the same database(cluster).
38 - It is more secure. There's no need to maintain system users or write
39   to the filesystem. All this is done through the database.
40
41 # %description -l pl
42 # TODO
43
44 %package mailbox2dbmail
45 Summary:        Copy mail from an mbox file, maildir or mhdir directory to dbmail
46 #Summary(pl):   
47 # FIXME: better group
48 Group:          Applications/Mail
49 Requires:       python-modules >= 2.2
50
51 %description mailbox2dbmail
52 Use this program to copy mail from an mbox file, maildir or mhdir
53 directory to dbmail.  This program uses ./dbmail-smtp for injecting
54 the emails into DBMail.
55
56 # %description mailbox2dbmail -l pl
57 # TODO
58
59 %prep
60 %setup -q -n %{name}-%{version}%{_rc}
61
62 %build
63 # if ac/am/* rebuilding is necessary, do it in this order and add
64 # appropriate BuildRequires
65 #%%{__gettextize}
66 #%%{__aclocal}
67 #%%{__autoconf}
68 #%%{__autoheader}
69 #%%{__automake}
70 %configure2_13 \
71         --with-pgsql
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 install -D dbmail.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbmail/dbmail.conf
81 install -d $RPM_BUILD_ROOT%{_mandir}/man1
82 cp man/*   $RPM_BUILD_ROOT%{_mandir}/man1
83 install contrib/mailbox2dbmail/mailbox2dbmail   $RPM_BUILD_ROOT%{_bindir}
84 install contrib/mailbox2dbmail/mailbox2dbmail.1 $RPM_BUILD_ROOT%{_mandir}/man1
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %pre
90
91 %post
92
93 %preun
94
95 %postun
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS ChangeLog NEWS README THANKS TODO EXTRAS BUGS INSTALL* sql
100 %attr(755,root,root) %{_bindir}/*
101 %{_libdir}/*.a
102 %dir %{_sysconfdir}/dbmail
103 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dbmail/*
104 %{_mandir}/man1/dbmail-*
105
106 %files mailbox2dbmail
107 %defattr(644,root,root,755)
108 %doc contrib/mailbox2dbmail/README
109 %attr(755,root,root) %{_bindir}/*
110 %{_mandir}/man1/mailbox2dbmail*
This page took 0.05728 seconds and 3 git commands to generate.