]> git.pld-linux.org Git - packages/dbh.git/blob - dbh.spec
b609e6755ccb9e516c0171a8de3ac7e51405ab5f
[packages/dbh.git] / dbh.spec
1 %define         ver             1.0
2 %define         rel             14
3
4 Summary:        Disk based hash library
5 Name:           dbh
6 Version:        %{ver}.%{rel}
7 Release:        0.1
8 License:        QPL
9 Group:          Libraries
10 Source0:        http://belnet.dl.sourceforge.net/sourceforge/dbh/%{name}_%{ver}-%{rel}.tgz
11 # Source0-md5:  11352e539a3e40f23d539a52f2153b95
12 URL:            http://dbh.sourceforge.net
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description 
16 Disk based hashes is a method to create multidimensional binary trees on disk.
17 This library permits the extension of database concept to a plethora of 
18 electronic data, such as graphic information. With the multidimensional binary 
19 tree it is possible to mathematically prove that access time to any 
20 particular record is minimized (using the concept of critical points from 
21 calculus), which provides the means to construct optimized databases for 
22 particular applications.  
23
24 %package devel
25 Summary:        Disk based hash library development files
26 Group:          Libraries
27 Requires:       %{name} = %{version}
28
29 %description devel
30 Disk based hash library development files
31
32 %package static
33 Summary:        Disk based hash static libraries
34 Group:          Libraries
35 Requires:       %{name}-devel = %{version}
36
37 %description static
38 Disk based hash static libraries
39
40 %package examples
41 Summary:        Disk based hash library examples
42 Group:          Libraries
43
44 %description examples
45 Disk based hash library examples
46
47 %prep
48 %setup  -q -n %{name}_%{ver}-%{rel}
49
50 %build
51 %{__libtoolize}
52 %{__aclocal}
53 %{__automake}
54 %{__autoconf}
55 %configure 
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT/usr/src/examples/%{name}-%{version}
61 make install DESTDIR=$RPM_BUILD_ROOT 
62
63 cd examples
64 install -m 644 simple_hash.c $RPM_BUILD_ROOT/usr/src/examples/%{name}-%{version}
65 install -m 644 trafico.c $RPM_BUILD_ROOT/usr/src/examples/%{name}-%{version}
66 install -m 644 Makefile $RPM_BUILD_ROOT/usr/src/examples/%{name}-%{version}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files
75 %defattr(644,root,root,755)
76 %doc  AUTHORS COPYING ChangeLog NEWS README TODO doc/*.html
77 %attr(755,root,root) %{_libdir}/*.so.*
78
79 %files devel
80 %defattr(644,root,root,755)
81 %{_includedir}
82 %{_libdir}/*.la
83 %{_libdir}/*.so
84 %{_libdir}/pkgconfig/*.pc
85
86 %files static
87 %defattr(644,root,root,755)
88 %{_libdir}/libdbh.a
89
90 %files examples
91 %defattr(644,root,root,755)
92 %dir /usr/src/examples/%{name}-%{version}
93 /usr/src/examples/%{name}-%{version}/*
This page took 0.047642 seconds and 2 git commands to generate.