]> git.pld-linux.org Git - packages/dbh.git/blob - dbh.spec
1d6019f57152ed4f70b85435285a494198a243fc
[packages/dbh.git] / dbh.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Disk based hash library
6 Summary(pl):    Biblioteka obs³uguj±ca tablice haszuj±ce na dysku
7 Name:           dbh
8 Version:        4.5.0
9 Release:        1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/dbh/%{name}-%{version}.tar.gz
13 # Source0-md5:  52b4b0d5ee0513dc796e989220c11bc6
14 URL:            http://dbh.sourceforge.net/
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Disk based hashes is a method to create multidimensional binary trees
22 on disk. This library permits the extension of database concept to a
23 plethora of electronic data, such as graphic information. With the
24 multidimensional binary tree it is possible to mathematically prove
25 that access time to any particular record is minimized (using the
26 concept of critical points from calculus), which provides the means to
27 construct optimized databases for particular applications.
28
29 %description -l pl
30 Hasze przechowywane na dysku to metoda tworzenia wielowymiarowych
31 drzew binarnych na dysku. Biblioteka pozwala rozszerzaæ pojêcie bazy
32 danych o bogactwo danych elektronicznych, takich jak informacje
33 graficzne. Mo¿na udowodniæ matematycznie, ¿e przy u¿yciu
34 wielowymiarowego drzewa binarnego czas dostêpu do ka¿dego konkretnego
35 rekordu jest minimalny (u¿ywaj±c zasady punktów krytycznych), co
36 daje ¶rodki do tworzenia zoptymalizowanych baz danych dla aplikacji.
37
38 %package devel
39 Summary:        Disk based hash library development files
40 Summary(pl):    Pliki nag³ówkowe biblioteki dbh
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Obsoletes:      dbh-examples
44
45 %description devel
46 Disk based hash library development files.
47
48 %description devel -l pl
49 Pliki nag³ówkowe biblioteki dbh.
50
51 %package static
52 Summary:        Disk based hash static library
53 Summary(pl):    Statyczna biblioteka dbh
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Disk based hash static library.
59
60 %description static -l pl
61 Statyczna biblioteka dbh.
62
63 %prep
64 %setup -q
65
66 %build
67 %{__libtoolize}
68 %{__aclocal} -I m4
69 %{__automake}
70 %{__autoheader}
71 %{__autoconf}
72 %configure \
73         %{!?with_static_libs:--disable-static}
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 cd examples
85 install simple_hash.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86 install trafico.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS ChangeLog
97 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %doc doc/*.html
102 %attr(755,root,root) %{_libdir}/lib*.so
103 %{_libdir}/lib*.la
104 %{_includedir}/*.h
105 %{_pkgconfigdir}/*.pc
106 %{_examplesdir}/%{name}-%{version}
107
108 %if %{with static_libs}
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/lib*.a
112 %endif
This page took 0.034969 seconds and 2 git commands to generate.