]> git.pld-linux.org Git - packages/db5.2.git/blob - db5.2.spec
34f8b35661b028cc8e2b2360229850631144bd08
[packages/db5.2.git] / db5.2.spec
1 #
2 # Conditional build:
3 %bcond_without  java            # don't build Java bindings
4 %bcond_without  tcl             # don't build Tcl bindings
5 %bcond_without  static_libs     # don't build static libraries
6 %bcond_with     sqlite3         # build Sqlite3 API libraries
7 %bcond_with     default_db      # use this db as default system db
8 %bcond_without  rpm_db          # install library to rootfs for /bin/rpm
9
10 %include        /usr/lib/rpm/macros.java
11
12 %define         major           5
13 %define         libver          %{major}.2
14 %define         ver             %{libver}.42
15 %define         patchlevel      0
16 Summary:        Berkeley DB database library for C
17 Summary(pl.UTF-8):      Biblioteka C do obsługi baz Berkeley DB
18 Name:           db5.2
19 Version:        %{ver}.%{patchlevel}
20 Release:        1
21 License:        BSD-like (see LICENSE)
22 Group:          Libraries
23 #Source0Download: http://www.oracle.com/technetwork/database/berkeleydb/downloads/index-082944.html
24 Source0:        http://download.oracle.com/berkeley-db/db-%{ver}.tar.gz
25 # Source0-md5:  28c39545efbeb926d1efef0bf33135b9
26 Patch0:         %{name}-link.patch
27 Patch1:         %{name}-sql-features.patch
28 URL:            http://www.oracle.com/technetwork/database/berkeleydb/downloads/index.html
29 BuildRequires:  automake
30 %if %{with java}
31 BuildRequires:  jdk
32 BuildRequires:  rpm-javaprov
33 %endif
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  rpmbuild(macros) >= 1.426
36 BuildRequires:  sed >= 4.0
37 %{?with_tcl:BuildRequires:      tcl-devel >= 8.4.0}
38 Requires:       uname(release) >= 2.6.0
39 %if %{with default_db}
40 Provides:       db = %{version}-%{release}
41 Provides:       db = %{libver}
42 Obsoletes:      db4
43 %endif
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %if %{without default_db}
47 %define         _includedir     %{_prefix}/include/db%{libver}
48 %endif
49
50 %description
51 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
52 provides embedded database support for both traditional and
53 client/server applications. Berkeley DB is used by many applications,
54 including Python and Perl, so this should be installed on all systems.
55
56 %description -l pl.UTF-8
57 Berkeley Database (Berkeley DB) to zestaw narzędzi programistycznych
58 zapewniających obsługę baz danych w aplikacjach tradycyjnych jak i
59 klient-serwer. Berkeley db jest używana w wielu aplikacjach, w tym w
60 Pythonie i Perlu.
61
62 %package devel
63 Summary:        Header files for Berkeley database library
64 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki Berkeley Database
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 %if %{with default_db}
68 Provides:       db-devel = %{version}-%{release}
69 Obsoletes:      db-devel
70 Obsoletes:      db3-devel
71 Obsoletes:      db4-devel
72 %endif
73
74 %description devel
75 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
76 provides embedded database support for both traditional and
77 client/server applications. Berkeley DB includes B+tree, Extended
78 Linear Hashing, Fixed and Variable-length record access methods,
79 transactions, locking, logging, shared memory caching and database
80 recovery. DB supports C, C++, Java and Perl APIs.
81
82 This package contains the header files, libraries, and documentation
83 for building programs which use Berkeley DB.
84
85 %description devel -l pl.UTF-8
86 Berkeley Database (Berkeley DB) to zestaw narzędzi programistycznych
87 zapewniających obsługę baz danych w aplikacjach tradycyjnych jak i
88 klient-serwer. Berkeley DB obsługuje dostęp do bazy przez B-drzewa i
89 funkcje mieszające ze stałą lub zmienną wielkością rekordu,
90 transakcje, kroniki, pamięć dzieloną i odtwarzanie baz. Ma wsparcie
91 dla C, C++, Javy i Perla.
92
93 Ten pakiet zawiera pliki nagłówkowe i dokumentację do budowania
94 programów używających Berkeley DB.
95
96 %package static
97 Summary:        Static libraries for Berkeley database library
98 Summary(pl.UTF-8):      Statyczne biblioteki Berkeley Database
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 %if %{with default_db}
102 Provides:       db-static = %{version}-%{release}
103 Obsoletes:      db-static
104 Obsoletes:      db3-static
105 Obsoletes:      db4-static
106 %endif
107
108 %description static
109 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
110 provides embedded database support for both traditional and
111 client/server applications. Berkeley DB includes B+tree, Extended
112 Linear Hashing, Fixed and Variable-length record access methods,
113 transactions, locking, logging, shared memory caching and database
114 recovery. DB supports C, C++, Java and Perl APIs.
115
116 This package contains the static libraries for building programs which
117 use Berkeley DB.
118
119 %description static -l pl.UTF-8
120 Berkeley Database (Berkeley DB) to zestaw narzędzi programistycznych
121 zapewniających obsługę baz danych w aplikacjach tradycyjnych jak i
122 klient-serwer. Berkeley DB obsługuje dostęp do bazy przez B-drzewa i
123 funkcje mieszające ze stałą lub zmienną wielkością rekordu,
124 transakcje, kroniki, pamięć dzieloną i odtwarzanie baz. Ma wsparcie
125 dla C, C++, Javy i Perla.
126
127 Ten pakiet zawiera statyczne biblioteki do budowania programów
128 używających Berkeley DB.
129
130 %package cxx
131 Summary:        Berkeley database library for C++
132 Summary(pl.UTF-8):      Biblioteka baz danych Berkeley dla C++
133 Group:          Libraries
134 %if %{with default_db}
135 Provides:       db-cxx = %{version}-%{release}
136 Obsoletes:      db4-cxx
137 %endif
138
139 %description cxx
140 Berkeley database library for C++.
141
142 %description cxx -l pl.UTF-8
143 Biblioteka baz danych Berkeley dla C++.
144
145 %package cxx-devel
146 Summary:        Header files for db-cxx library
147 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki db-cxx
148 Group:          Development/Libraries
149 Requires:       %{name}-cxx = %{version}-%{release}
150 Requires:       %{name}-devel = %{version}-%{release}
151 %if %{with default_db}
152 Provides:       db-cxx-devel = %{version}-%{release}
153 Obsoletes:      db-cxx-devel
154 %endif
155 Conflicts:      db-devel < 4.1.25-3
156
157 %description cxx-devel
158 Header files for db-cxx library.
159
160 %description cxx-devel -l pl.UTF-8
161 Pliki nagłówkowe biblioteki db-cxx.
162
163 %package cxx-static
164 Summary:        Static version of db-cxx library
165 Summary(pl.UTF-8):      Statyczna wersja biblioteki db-cxx
166 Group:          Development/Libraries
167 Requires:       %{name}-cxx-devel = %{version}-%{release}
168 %if %{with default_db}
169 Provides:       db-cxx-static = %{version}-%{release}
170 Obsoletes:      db-cxx-static
171 %endif
172 Conflicts:      db-static < 4.2.50-1
173
174 %description cxx-static
175 Static version of db-cxx library.
176
177 %description cxx-static -l pl.UTF-8
178 Statyczna wersja biblioteki db-cxx.
179
180 %package java
181 Summary:        Berkeley database library for Java
182 Summary(pl.UTF-8):      Biblioteka baz danych Berkeley dla Javy
183 Group:          Libraries
184 Requires:       jpackage-utils
185 %if %{with default_db}
186 Provides:       db-java = %{version}-%{release}
187 Obsoletes:      db-java
188 %endif
189
190 %description java
191 Berkeley database library for Java.
192
193 %description java -l pl.UTF-8
194 Biblioteka baz danych Berkeley dla Javy.
195
196 %package java-devel
197 Summary:        Development files for db-java library
198 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-java
199 Group:          Development/Languages/Java
200 Requires:       %{name}-java = %{version}-%{release}
201 %if %{with default_db}
202 Provides:       db-java-devel = %{version}-%{release}
203 Obsoletes:      db-java-devel
204 %endif
205 Conflicts:      db-devel < 4.1.25-3
206
207 %description java-devel
208 Development files for db-java library.
209
210 %description java-devel -l pl.UTF-8
211 Pliki programistyczne biblioteki db-java.
212
213 %package tcl
214 Summary:        Berkeley database library for Tcl
215 Summary(pl.UTF-8):      Biblioteka baz danych Berkeley dla Tcl
216 Group:          Development/Languages/Tcl
217 Requires:       tcl
218 %if %{with default_db}
219 Provides:       db-tcl = %{version}-%{release}
220 Obsoletes:      db4-tcl
221 %endif
222
223 %description tcl
224 Berkeley database library for Tcl.
225
226 %description tcl -l pl.UTF-8
227 Biblioteka baz danych Berkeley dla Tcl.
228
229 %package tcl-devel
230 Summary:        Development files for db-tcl library
231 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-tcl
232 Group:          Development/Languages/Tcl
233 Requires:       %{name}-tcl = %{version}-%{release}
234 %if %{with default_db}
235 Provides:       db-tcl-devel = %{version}-%{release}
236 Obsoletes:      db-tcl-devel
237 %endif
238 Conflicts:      db-devel < 4.1.25-3
239
240 %description tcl-devel
241 Development files for db-tcl library.
242
243 %description tcl-devel -l pl.UTF-8
244 Pliki programistyczne biblioteki db-tcl.
245
246 %package sql
247 Summary:        SQL layer for Berkeley database library
248 Summary(pl.UTF-8):      Wartstwa SQL dla biblioteki baz danych Berkeley
249 Group:          Libraries
250 %if %{with default_db}
251 Provides:       db-sql = %{version}-%{release}
252 %endif
253
254 %description sql
255 SQL layer for Berkeley database library.
256
257 %description sql -l pl.UTF-8
258 Warstwa SQL dla biblioteki baz danych Berkeley.
259
260 %package sql-devel
261 Summary:        Development files for db-sql library
262 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-sql
263 Group:          Development/Libraries
264 Requires:       %{name}-sql = %{version}-%{release}
265 %if %{with default_db}
266 Provides:       db-sql-devel = %{version}-%{release}
267 Obsoletes:      db-sql-devel
268 %endif
269
270 %description sql-devel
271 Development files for db-sql library.
272
273 %description sql-devel -l pl.UTF-8
274 Pliki programistyczne biblioteki db-sql.
275
276 %package stl
277 Summary:        STL API for Berkeley Database library
278 Summary(pl.UTF-8):      API STL dla biblioteki Berkeley Database
279 Group:          Libraries
280 %if %{with default_db}
281 Provides:       db-stl = %{version}-%{release}
282 %endif
283
284 %description stl
285 STL API for Berkeley database library.
286
287 %description stl -l pl.UTF-8
288 API STL dla biblioteki Berkeley Database.
289
290 %package stl-devel
291 Summary:        Development files for db-stl library
292 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-stl
293 Group:          Development/Libraries
294 Requires:       %{name}-stl = %{version}-%{release}
295 %if %{with default_db}
296 Provides:       db-stl-devel = %{version}-%{release}
297 Obsoletes:      db-stl-devel
298 %endif
299
300 %description stl-devel
301 Development files for db-stl library.
302
303 %description stl-devel -l pl.UTF-8
304 Pliki programistyczne biblioteki db-stl.
305
306 %package sqlite3
307 Summary:        Sqlite3 API for Berkeley Database library
308 Summary(pl.UTF-8):      API Sqlite3 dla biblioteki Berkeley Database
309 Group:          Libraries
310 %if %{with default_db}
311 Provides:       db-sqlite3 = %{version}-%{release}
312 %endif
313
314 %description sqlite3
315 Sqlite3 API for Berkeley database library.
316
317 %description sqlite3 -l pl.UTF-8
318 API Sqlite3 dla biblioteki Berkeley Database.
319
320 %package sqlite3-devel
321 Summary:        Development files for db-sqlite3 library
322 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-sqlite3
323 Group:          Development/Libraries
324 Requires:       %{name}-sqlite3 = %{version}-%{release}
325 %if %{with default_db}
326 Provides:       db-sqlite3-devel = %{version}-%{release}
327 Obsoletes:      db-sqlite3-devel
328 %endif
329
330 %description sqlite3-devel
331 Development files for db-sqlite3 library.
332
333 %description sqlite3-devel -l pl.UTF-8
334 Pliki programistyczne biblioteki db-sqlite3.
335
336 %package utils
337 Summary:        Command line tools for managing Berkeley DB databases
338 Summary(pl.UTF-8):      Narzędzia do obsługi baz Berkeley DB z linii poleceń
339 Group:          Applications/Databases
340 Requires:       %{name} = %{version}-%{release}
341 Requires:       %{name}-sql = %{version}-%{release}
342 %if %{with default_db}
343 Provides:       db-utils = %{version}-%{release}
344 Obsoletes:      db-utils
345 Obsoletes:      db3-utils
346 Obsoletes:      db4-utils
347 %endif
348
349 %description utils
350 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
351 provides embedded database support for both traditional and
352 client/server applications. Berkeley DB includes B+tree, Extended
353 Linear Hashing, Fixed and Variable-length record access methods,
354 transactions, locking, logging, shared memory caching and database
355 recovery. DB supports C, C++, Java and Perl APIs.
356
357 This package contains command line tools for managing Berkeley DB
358 databases.
359
360 %description utils -l pl.UTF-8
361 Berkeley Database (Berkeley DB) to zestaw narzędzi programistycznych
362 zapewniających obsługę baz danych w aplikacjach tradycyjnych jak i
363 klient-serwer. Berkeley DB obsługuje dostęp do bazy przez B-drzewa i
364 funkcje mieszające ze stałą lub zmienną wielkością rekordu,
365 transakcje, kroniki, pamięć dzieloną i odtwarzanie baz. Ma wsparcie
366 dla C, C++, Javy i Perla.
367
368 Ten pakiet zawiera narzędzia do obsługi baz Berkeley DB z linii
369 poleceń.
370
371 %prep
372 %setup -q -n db-%{ver}
373 %patch0 -p1
374 %patch1 -p1
375
376 %build
377 cp -f /usr/share/automake/config.sub dist
378
379 JAVACFLAGS="-source 1.5 -target 1.5"
380 export JAVACFLAGS
381
382 %if %{with static_libs}
383 cp -a build_unix build_unix.static
384
385 cd build_unix.static
386
387 CC="%{__cc}"
388 CXX="%{__cxx}"
389 CFLAGS="%{rpmcflags}"
390 CXXFLAGS="%{rpmcflags} -fno-implicit-templates"
391 LDFLAGS="%{rpmcflags} %{rpmldflags}"
392 export CC CXX CFLAGS CXXFLAGS LDFLAGS
393
394 ../dist/%configure \
395         --disable-shared \
396         --enable-static \
397         --enable-compat185 \
398         --enable-cxx \
399         --enable-dbm \
400         --enable-build_dbm \
401         --enable-posixmutexes
402
403 # (temporarily?) disabled because of compilation errors:
404 #       --enable-dump185 \
405
406 %{__make} library_build
407 cd ..
408 %endif
409
410 cd build_unix
411
412 ../dist/%configure \
413         --prefix=%{_prefix} \
414         --libdir=%{_libdir} \
415         --enable-shared \
416         --disable-static \
417         --enable-compat185 \
418         --enable-cxx \
419         --enable-dbm \
420         --enable-build_dbm \
421         --enable-posixmutexes \
422         --enable-sql \
423         %{?with_sqlite3:--enable-sql_compat} \
424         --enable-sql_codegen \
425         --enable-stl \
426         %{?with_java:--enable-java} \
427         %{?with_tcl:--enable-tcl --with-tcl=/usr/lib}
428
429 %{__make} library_build \
430         TCFLAGS='-I$(builddir) -I%{_includedir}' \
431         LIBSO_LIBS="\$(LIBS)" \
432         LIBTSO_LIBS="\$(LIBS) -ltcl"
433
434 %install
435 rm -rf $RPM_BUILD_ROOT
436 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_bindir}}
437 %if %{with java}
438 install -d $RPM_BUILD_ROOT%{_javadir}
439 %endif
440
441 %if %{with static_libs}
442 %{__make} -C build_unix.static library_install \
443         DESTDIR=$RPM_BUILD_ROOT \
444         docdir=%{_docdir}/db-%{version}-docs \
445         includedir=%{_includedir}
446 %endif
447
448 %{__make} -C build_unix library_install \
449         DESTDIR=$RPM_BUILD_ROOT \
450         LIB_INSTALL_FILE_LIST="" \
451         docdir=%{_docdir}/db-%{version}-docs \
452         includedir=%{_includedir}
453
454 %if %{with rpm_db}
455 install -d $RPM_BUILD_ROOT/%{_lib}
456 mv $RPM_BUILD_ROOT%{_libdir}/libdb-%{libver}.so $RPM_BUILD_ROOT/%{_lib}
457 ln -sf /%{_lib}/libdb-%{libver}.so $RPM_BUILD_ROOT%{_libdir}/libdb-%{libver}.so
458 mv $RPM_BUILD_ROOT%{_libdir}/libdb_sql-%{libver}.so $RPM_BUILD_ROOT/%{_lib}
459 ln -sf /%{_lib}/libdb_sql-%{libver}.so $RPM_BUILD_ROOT%{_libdir}/libdb_sql-%{libver}.so
460 %endif
461
462 cd $RPM_BUILD_ROOT%{_libdir}
463 %if %{with static_libs}
464 mv -f libdb.a libdb-%{libver}.a
465 mv -f libdb_cxx.a libdb_cxx-%{libver}.a
466 %endif
467 %if %{with java}
468 mv -f $RPM_BUILD_ROOT%{_libdir}/db.jar $RPM_BUILD_ROOT%{_javadir}/db-%{libver}.jar
469 %endif
470 %if %{with default_db}
471 ln -sf libdb-%{libver}.so libdb.so
472 ln -sf libdb-%{libver}.so libndbm.so
473 ln -sf libdb-%{libver}.la libdb.la
474 ln -sf libdb-%{libver}.la libndbm.la
475 ln -sf libdb_cxx-%{libver}.so libdb_cxx.so
476 ln -sf libdb_cxx-%{libver}.la libdb_cxx.la
477 %if %{with java}
478 ln -sf libdb_java-%{libver}.la libdb_java.la
479 ln -sf db-%{libver}.jar $RPM_BUILD_ROOT%{_javadir}/db.jar
480 %endif
481 %if %{with tcl}
482 ln -sf libdb_tcl-%{libver}.so libdb_tcl.so
483 ln -sf libdb_tcl-%{libver}.la libdb_tcl.la
484 %endif
485 %if %{with static_libs}
486 ln -sf libdb-%{libver}.a libdb.a
487 ln -sf libdb-%{libver}.a libndbm.a
488 ln -sf libdb_cxx-%{libver}.a libdb_cxx.a
489 %endif
490 %else
491 %{__rm} libdb.so
492 %{__rm} libdb_cxx.so
493 %{__rm} libdb_sql.so
494 %{__rm} libdb_stl.so
495 %{__rm} libdb-%{major}.so
496 %{__rm} libdb_cxx-%{major}.so
497 %{__rm} libdb_sql-%{major}.so
498 %{__rm} libdb_stl-%{major}.so
499 %if %{with java}
500 %{__rm} libdb_java.so
501 %{__rm} libdb_java-%{major}.so
502 %endif
503 %if %{with tcl}
504 %{__rm} libdb_tcl.so
505 %{__rm} libdb_tcl-%{major}.so
506 %endif
507 %endif
508
509 sed -i "s/old_library=''/old_library='libdb-%{libver}.a'/" libdb-%{libver}.la
510 sed -i "s/old_library=''/old_library='libdb_cxx-%{libver}.a'/" libdb_cxx-%{libver}.la
511
512 cd -
513
514 cd $RPM_BUILD_ROOT%{_bindir}
515 mv dbsql dbsql-%{libver}
516 %{?with_default_db:ln -sf dbsql-%{libver} dbsql}
517 for F in db_*; do
518   Fver=$(echo $F|sed 's/db_/db%{libver}_/')
519   mv $F $Fver
520   %{?with_default_db:ln -sf $Fver $F}
521 done
522 cd -
523
524 install -d $RPM_BUILD_ROOT%{_examplesdir}/db-%{version}
525 cp -a examples/c/* $RPM_BUILD_ROOT%{_examplesdir}/db-%{version}
526
527 install -d $RPM_BUILD_ROOT%{_examplesdir}/db-cxx-%{version}
528 cp -a examples/cxx/* $RPM_BUILD_ROOT%{_examplesdir}/db-cxx-%{version}
529
530 %if %{with java}
531 install -d $RPM_BUILD_ROOT%{_examplesdir}/db-java-%{version}
532 cp -a examples/java/* $RPM_BUILD_ROOT%{_examplesdir}/db-java-%{version}
533 %endif
534
535 # in %doc
536 %{__rm} $RPM_BUILD_ROOT%{_docdir}/db-%{version}-docs/{index.html,license/license_db.html}
537
538 # don't have csharp subpackages yet
539 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/db-%{version}-docs/csharp
540
541 %clean
542 rm -rf $RPM_BUILD_ROOT
543
544 %post   -p /sbin/ldconfig
545 %postun -p /sbin/ldconfig
546
547 %post   tcl -p /sbin/ldconfig
548 %postun tcl -p /sbin/ldconfig
549
550 %post   cxx -p /sbin/ldconfig
551 %postun cxx -p /sbin/ldconfig
552
553 %post   sql -p /sbin/ldconfig
554 %postun sql -p /sbin/ldconfig
555
556 %post   stl -p /sbin/ldconfig
557 %postun stl -p /sbin/ldconfig
558
559 %files
560 %defattr(644,root,root,755)
561 %doc LICENSE README docs/index.html docs/license
562 %if %{with rpm_db}
563 %attr(755,root,root) /%{_lib}/libdb-%{libver}.so
564 %else
565 %attr(755,root,root) %{_libdir}/libdb-%{libver}.so
566 %endif
567
568 %files devel
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_bindir}/db%{libver}_sql_codegen
571 %{_libdir}/libdb-%{libver}.la
572 %if %{with rpm_db}
573 %attr(755,root,root) %{_libdir}/libdb-%{libver}.so
574 %endif
575 %if %{with default_db}
576 %attr(755,root,root) %{_bindir}/db_sql_codegen
577 %attr(755,root,root) %{_libdir}/libdb-%{major}.so
578 %attr(755,root,root) %{_libdir}/libdb.so
579 %attr(755,root,root) %{_libdir}/libndbm.so
580 %{_libdir}/libdb.la
581 %{_libdir}/libndbm.la
582 %else
583 %dir %{_includedir}
584 %endif
585 %{_includedir}/db.h
586 %{_includedir}/db_185.h
587 %dir %{_docdir}/db-%{version}-docs
588 %dir %{_docdir}/db-%{version}-docs/api_reference
589 %{_docdir}/db-%{version}-docs/api_reference/C
590 %{_docdir}/db-%{version}-docs/articles
591 %dir %{_docdir}/db-%{version}-docs/gsg
592 %{_docdir}/db-%{version}-docs/gsg/C
593 %dir %{_docdir}/db-%{version}-docs/gsg_txn
594 %{_docdir}/db-%{version}-docs/gsg_txn/C
595 %dir %{_docdir}/db-%{version}-docs/gsg_db_rep
596 %{_docdir}/db-%{version}-docs/gsg_db_rep/C
597 %{_docdir}/db-%{version}-docs/installation
598 %{_docdir}/db-%{version}-docs/porting
599 %{_docdir}/db-%{version}-docs/programmer_reference
600 %{_docdir}/db-%{version}-docs/upgrading
601 %{_examplesdir}/db-%{version}
602
603 %if %{with static_libs}
604 %files static
605 %defattr(644,root,root,755)
606 %{_libdir}/libdb-%{libver}.a
607 %if %{with default_db}
608 %{_libdir}/libdb.a
609 %{_libdir}/libndbm.a
610 %endif
611 %endif
612
613 %files cxx
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/libdb_cxx-%{libver}.so
616
617 %files cxx-devel
618 %defattr(644,root,root,755)
619 %{_libdir}/libdb_cxx-%{libver}.la
620 %if %{with default_db}
621 %attr(755,root,root) %{_libdir}/libdb_cxx-%{major}.so
622 %attr(755,root,root) %{_libdir}/libdb_cxx.so
623 %{_libdir}/libdb_cxx.la
624 %endif
625 %{_includedir}/db_cxx.h
626 %{_docdir}/db-%{version}-docs/api_reference/CXX
627 %{_docdir}/db-%{version}-docs/api_reference/STL
628 %{_docdir}/db-%{version}-docs/gsg/CXX
629 %{_docdir}/db-%{version}-docs/gsg_txn/CXX
630 %{_docdir}/db-%{version}-docs/gsg_db_rep/CXX
631 %{_examplesdir}/db-cxx-%{version}
632
633 %if %{with static_libs}
634 %files cxx-static
635 %defattr(644,root,root,755)
636 %{_libdir}/libdb_cxx-%{libver}.a
637 %if %{with default_db}
638 %{_libdir}/libdb_cxx.a
639 %endif
640 %endif
641
642 %if %{with java}
643 %files java
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/libdb_java-%{libver}.so
646 %attr(755,root,root) %{_libdir}/libdb_java-%{libver}_g.so
647 %{_javadir}/db-%{libver}.jar
648 %if %{with default_db}
649 %{_javadir}/db.jar
650 %endif
651
652 %files java-devel
653 %defattr(644,root,root,755)
654 %{_libdir}/libdb_java-%{libver}.la
655 %if %{with default_db}
656 %attr(755,root,root) %{_libdir}/libdb_java.so
657 %attr(755,root,root) %{_libdir}/libdb_java-%{major}.so
658 %{_libdir}/libdb_java.la
659 %endif
660 %{_docdir}/db-%{version}-docs/collections
661 %{_docdir}/db-%{version}-docs/gsg/JAVA
662 %{_docdir}/db-%{version}-docs/gsg_txn/JAVA
663 %{_docdir}/db-%{version}-docs/gsg_db_rep/JAVA
664 %{_docdir}/db-%{version}-docs/java
665 %{_examplesdir}/db-java-%{version}
666 %endif
667
668 %if %{with tcl}
669 %files tcl
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/libdb_tcl-%{libver}.so
672
673 %files tcl-devel
674 %defattr(644,root,root,755)
675 %{_libdir}/libdb_tcl-%{libver}.la
676 %if %{with default_db}
677 %attr(755,root,root) %{_libdir}/libdb_tcl.so
678 %attr(755,root,root) %{_libdir}/libdb_tcl-%{major}.so
679 %{_libdir}/libdb_tcl.la
680 %endif
681 %{_docdir}/db-%{version}-docs/api_reference/TCL
682 %endif
683
684 %files sql
685 %defattr(644,root,root,755)
686 %if %{with rpm_db}
687 %attr(755,root,root) /%{_lib}/libdb_sql-%{libver}.so
688 %else
689 %attr(755,root,root) %{_libdir}/libdb_sql-%{libver}.so
690 %endif
691
692 %files sql-devel
693 %defattr(644,root,root,755)
694 %{_libdir}/libdb_sql-%{libver}.la
695 %if %{with rpm_db}
696 %attr(755,root,root) %{_libdir}/libdb_sql-%{libver}.so
697 %endif
698 %if %{with default_db}
699 %attr(755,root,root) %{_libdir}/libdb_sql.so
700 %attr(755,root,root) %{_libdir}/libdb_sql-%{major}.so
701 %endif
702 %{_includedir}/dbsql.h
703 %{_docdir}/db-%{version}-docs/bdb-sql
704
705 %files stl
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/libdb_stl-%{libver}.so
708
709 %files stl-devel
710 %defattr(644,root,root,755)
711 %{_libdir}/libdb_stl-%{libver}.la
712 %if %{with default_db}
713 %attr(755,root,root) %{_libdir}/libdb_stl.so
714 %attr(755,root,root) %{_libdir}/libdb_stl-%{major}.so
715 %endif
716 %{_includedir}/dbstl_base_iterator.h
717 %{_includedir}/dbstl_common.h
718 %{_includedir}/dbstl_container.h
719 %{_includedir}/dbstl_dbc.h
720 %{_includedir}/dbstl_dbt.h
721 %{_includedir}/dbstl_element_ref.h
722 %{_includedir}/dbstl_exception.h
723 %{_includedir}/dbstl_inner_utility.h
724 %{_includedir}/dbstl_map.h
725 %{_includedir}/dbstl_resource_manager.h
726 %{_includedir}/dbstl_set.h
727 %{_includedir}/dbstl_utility.h
728 %{_includedir}/dbstl_vector.h
729
730 %if %{with sqlite3}
731 %files sqlite3
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_bindir}/sqlite3
734 %attr(755,root,root) %{_libdir}/libsqlite3.so
735
736 %files sqlite3-devel
737 %defattr(644,root,root,755)
738 %{_libdir}/libsqlite3.la
739 %{_includedir}/sqlite3.h
740 %endif
741
742 %files utils
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_bindir}/db%{libver}_archive
745 %attr(755,root,root) %{_bindir}/db%{libver}_checkpoint
746 %attr(755,root,root) %{_bindir}/db%{libver}_deadlock
747 %attr(755,root,root) %{_bindir}/db%{libver}_dump
748 %attr(755,root,root) %{_bindir}/db%{libver}_hotbackup
749 %attr(755,root,root) %{_bindir}/db%{libver}_load
750 %attr(755,root,root) %{_bindir}/db%{libver}_log_verify
751 %attr(755,root,root) %{_bindir}/db%{libver}_printlog
752 %attr(755,root,root) %{_bindir}/db%{libver}_recover
753 %attr(755,root,root) %{_bindir}/db%{libver}_replicate
754 %attr(755,root,root) %{_bindir}/db%{libver}_stat
755 %attr(755,root,root) %{_bindir}/db%{libver}_tuner
756 %attr(755,root,root) %{_bindir}/db%{libver}_upgrade
757 %attr(755,root,root) %{_bindir}/db%{libver}_verify
758 %attr(755,root,root) %{_bindir}/dbsql-%{libver}
759 %if %{with default_db}
760 %attr(755,root,root) %{_bindir}/db_archive
761 %attr(755,root,root) %{_bindir}/db_checkpoint
762 %attr(755,root,root) %{_bindir}/db_deadlock
763 %attr(755,root,root) %{_bindir}/db_dump
764 %attr(755,root,root) %{_bindir}/db_hotbackup
765 %attr(755,root,root) %{_bindir}/db_load
766 %attr(755,root,root) %{_bindir}/db_log_verify
767 %attr(755,root,root) %{_bindir}/db_printlog
768 %attr(755,root,root) %{_bindir}/db_recover
769 %attr(755,root,root) %{_bindir}/db_replicate
770 %attr(755,root,root) %{_bindir}/db_stat
771 %attr(755,root,root) %{_bindir}/db_tuner
772 %attr(755,root,root) %{_bindir}/db_upgrade
773 %attr(755,root,root) %{_bindir}/db_verify
774 %attr(755,root,root) %{_bindir}/dbsql
775 %endif
This page took 0.133279 seconds and 2 git commands to generate.