]> git.pld-linux.org Git - packages/db4.2.git/blob - db4.2.spec
- updated to 4.1.24
[packages/db4.2.git] / db4.2.spec
1 Summary:        BSD database library for C
2 Summary(pl):    Biblioteka C do obs³ugi baz Berkeley DB
3 Name:           db
4 Version:        4.1.24
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://www.berkeleydb.com/update/snapshot/%{name}-%{version}.tar.gz
9 URL:            http://www.berkeleydb.com/
10 #BuildRequires: glibc-static
11 %{?_with_java:BuildRequires:    java}
12 BuildRequires:  tcl-devel >= 8.3.2
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15
16 %description
17 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
18 provides embedded database support for both traditional and
19 client/server applications. Berkeley DB is used by many applications,
20 including Python and Perl, so this should be installed on all systems.
21
22 %description -l pl
23 Berkeley Database (Berkeley DB) to zestaw narzêdzi programistycznych
24 zapewniaj±cych obs³ugê baz danych w aplikacjach tradycyjnych jak i
25 klient-serwer. Berkeley db jest u¿ywana wielu aplikacjach, w tym w
26 Pythonie i Perlu.
27
28 %package utils
29 Summary:        Command line tools for managing Berkeley DB databases
30 Summary(pl):    Narzêdzia do obs³ugi baz Berkeley DB z linii poleceñ
31 Group:          Applications/Databases
32 Requires:       %{name} = %{version}
33
34 %description utils
35 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
36 provides embedded database support for both traditional and
37 client/server applications. Berkeley DB includes B+tree, Extended
38 Linear Hashing, Fixed and Variable-length record access methods,
39 transactions, locking, logging, shared memory caching and database
40 recovery. DB supports C, C++, Java and Perl APIs.
41
42 This package contains command line tools for managing Berkeley DB
43 databases.
44
45 %description utils -l pl
46 Berkeley Database (Berkeley DB) to zestaw narzêdzi programistycznych
47 zapewniaj±cych obs³ugê baz danych w aplikacjach tradycyjnych jak i
48 klient-serwer. Berkeley DB obs³ugje dostêp do bazy przez B-drzewa i
49 funkcje mieszaj±ce ze sta³± lub zmienn± wielko¶ci± rekordu,
50 transakcje, kroniki, pamiêæ dzielon± i odtwarzanie baz. Ma wsparcie
51 dla C, C++, Javy i Perla.
52
53 Ten pakiet zawiera narzêdzia do obs³ugi baz Berkeley DB z linii
54 poleceñ.
55
56 %package tcl
57 Summary:        Berkeley database library for TCL
58 Summary(pl):    Biblioteka baz danych Berkeley dla TCL
59 Group:          Development/Languages/Tcl
60 Requires:       tcl
61
62 %description tcl
63 Berkeley database library for TCL.
64
65 %description tcl -l pl
66 Biblioteka baz danych Berkeley dla TCL.
67
68 %package cxx
69 Summary:        Berkeley database library for C++
70 Summary(pl):    Biblioteka baz danych Berkeley dla C++
71 Group:          Libraries
72
73 %description cxx
74 Berkeley database library for C++.
75
76 %description cxx -l pl
77 Biblioteka baz danych Berkeley dla C++.
78
79 %package java
80 Summary:        Berkeley database library for Java
81 Summary(pl):    Biblioteka baz danych Berkeley dla Java
82 Group:          Libraries
83
84 %description java
85 Berkeley database library for Java.
86
87 %description java -l pl
88 Biblioteka baz danych Berkeley dla Java.
89
90 %package devel
91 Summary:        Header files for Berkeley database library
92 Summary(pl):    Pliki nag³ówkowe do biblioteki Berkeley Database
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}
95
96 %description devel
97 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
98 provides embedded database support for both traditional and
99 client/server applications. Berkeley DB includes B+tree, Extended
100 Linear Hashing, Fixed and Variable-length record access methods,
101 transactions, locking, logging, shared memory caching and database
102 recovery. DB supports C, C++, Java and Perl APIs.
103
104 This package contains the header files, libraries, and documentation
105 for building programs which use Berkeley DB.
106
107 %description devel -l pl
108 Berkeley Database (Berkeley DB) to zestaw narzêdzi programistycznych
109 zapewniaj±cych obs³ugê baz danych w aplikacjach tradycyjnych jak i
110 klient-serwer. Berkeley DB obs³ugje dostêp do bazy przez B-drzewa i
111 funkcje mieszaj±ce ze sta³± lub zmienn± wielko¶ci± rekordu,
112 transakcje, kroniki, pamiêæ dzielon± i odtwarzanie baz. Ma wsparcie
113 dla C, C++, Javy i Perla.
114
115 Ten pakiet zawiera pliki nag³ówkowe i dokumentacjê do budowania
116 programów u¿ywaj±cych Berkeley DB.
117
118 %package static
119 Summary:        Static libraries for Berkeley database library
120 Summary(pl):    Statyczne biblioteki Berkeley Database
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}
123
124 %description static
125 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
126 provides embedded database support for both traditional and
127 client/server applications. Berkeley DB includes B+tree, Extended
128 Linear Hashing, Fixed and Variable-length record access methods,
129 transactions, locking, logging, shared memory caching and database
130 recovery. DB supports C, C++, Java and Perl APIs.
131
132 This package contains the static libraries for building programs which
133 use Berkeley DB.
134
135 %description static -l pl
136 Berkeley Database (Berkeley DB) to zestaw narzêdzi programistycznych
137 zapewniaj±cych obs³ugê baz danych w aplikacjach tradycyjnych jak i
138 klient-serwer. Berkeley DB obs³ugje dostêp do bazy przez B-drzewa i
139 funkcje mieszaj±ce ze sta³± lub zmienn± wielko¶ci± rekordu,
140 transakcje, kroniki, pamiêæ dzielon± i odtwarzanie baz. Ma wsparcie
141 dla C, C++, Javy i Perla.
142
143 Ten pakiet zawiera statyczne biblioteki do budowania programów
144 u¿ywaj±cych Berkeley DB.
145
146 %prep
147 %setup -q
148
149 %build
150 cp -a build_unix build_unix.static
151
152 cd build_unix.static
153
154 CFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates" \
155 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates" \
156 ../dist/configure \
157         --prefix=%{_prefix} \
158         --enable-compat185 \
159         --disable-shared \
160         --enable-static \
161         --enable-rpc \
162         --enable-cxx
163
164 # (temporarily?) disabled because of compilation errors:
165 #       --enable-dump185 \
166
167 %{__make} library_build
168
169 cd ../build_unix
170
171 CFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates" \
172 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates" \
173
174 %if %{?_with_java:1}%{!?_with_java:0}
175 ../dist/configure \
176         --prefix=%{_prefix} \
177         --enable-compat185 \
178         --enable-shared \
179         --disable-static \
180         --enable-rpc \
181         --enable-cxx \
182         --enable-tcl \
183         --with-tcl=%{_libdir} \
184         --enable-java
185 %else
186 ../dist/configure \
187         --prefix=%{_prefix} \
188         --enable-compat185 \
189         --enable-shared \
190         --disable-static \
191         --enable-rpc \
192         --enable-cxx \
193         --enable-tcl \
194         --with-tcl=/usr/lib
195 %endif
196
197 %{__make} library_build TCFLAGS='-I$(builddir) -I%{_includedir}'
198
199 %install
200 rm -rf $RPM_BUILD_ROOT
201 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_bindir},/lib}
202
203 cd build_unix.static
204
205 %{__make} library_install \
206         prefix=$RPM_BUILD_ROOT%{_prefix}
207
208 cd ../build_unix
209
210 %{__make} library_install \
211         prefix=$RPM_BUILD_ROOT%{_prefix} \
212         includedir=$RPM_BUILD_ROOT%{_includedir} \
213         LIB_INSTALL_FILE_LIST=""
214
215 cd ..
216 #rm -rf examples_java
217 #cp -a java/src/com/sleepycat/examples examples_java
218
219 %clean
220 rm -rf $RPM_BUILD_ROOT
221
222 %post   -p /sbin/ldconfig
223 %postun -p /sbin/ldconfig
224
225 %post   tcl -p /sbin/ldconfig
226 %postun tcl -p /sbin/ldconfig
227
228 %post   cxx -p /sbin/ldconfig
229 %postun cxx -p /sbin/ldconfig
230
231 %files
232 %defattr(644,root,root,755)
233 %doc LICENSE README
234 #%attr(755,root,root) /lib/libdb-*.so
235 %attr(755,root,root) %{_libdir}/libdb-*.so
236
237 %files utils
238 %defattr(644,root,root,755)
239 %doc docs/utility/*
240 %attr(755,root,root) %{_bindir}/berkeley_db_svc
241 %attr(755,root,root) %{_bindir}/db*_archive
242 %attr(755,root,root) %{_bindir}/db*_checkpoint
243 %attr(755,root,root) %{_bindir}/db*_deadlock
244 %attr(755,root,root) %{_bindir}/db*_dump
245 #%attr(755,root,root) %{_bindir}/db*_dump185
246 %attr(755,root,root) %{_bindir}/db*_load
247 %attr(755,root,root) %{_bindir}/db*_printlog
248 %attr(755,root,root) %{_bindir}/db*_recover
249 %attr(755,root,root) %{_bindir}/db*_stat
250 %attr(755,root,root) %{_bindir}/db*_upgrade
251 %attr(755,root,root) %{_bindir}/db*_verify
252
253 %files cxx
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_libdir}/libdb_cxx-*.so
256
257 %if %{?_with_java:1}%{!?_with_java:0}
258 %files java
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_libdir}/libdb_java*.so
261 %attr(644,root,root) %{_libdir}/db.jar
262 %endif
263
264 %files tcl
265 %defattr(644,root,root,755)
266 %attr(755,root,root) %{_libdir}/libdb_tcl-*.so
267
268 %files devel
269 %defattr(644,root,root,755)
270 %doc docs/{api*,ref,index.html,sleepycat,images} examples_c*
271 %attr(755,root,root) %{_libdir}/libdb*.la
272 #%attr(755,root,root) %{_libdir}/libdb.so
273 %attr(755,root,root) %{_libdir}/libdb*.so
274 #%attr(755,root,root) %{_libdir}/libndbm.so
275 #%attr(755,root,root) %{_libdir}/libdb_tcl.so
276 #%attr(755,root,root) %{_libdir}/libdb_cxx.so
277 %{_includedir}/*
278
279 %files static
280 %defattr(644,root,root,755)
281 %{_libdir}/lib*.a
This page took 0.08169 seconds and 3 git commands to generate.