]> git.pld-linux.org Git - packages/db4.2.git/blob - db4.2.spec
- obsolete
[packages/db4.2.git] / db4.2.spec
1 Summary:        BSD database library for C
2 Summary(pl):    Biblioteka C do obs³ugi baz Berkeley DB
3 Name:           db
4 Version:        4.0.14
5 Release:        3.2
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://www.berkeleydb.com/update/snapshot/%{name}-%{version}.tar.gz
9 #Patch0:                %{name}-static.patch
10 #Patch1:                %{name}-linux.patch
11 #Patch2:                %{name}-jbj.patch
12 Patch0:         %{name}-rpm.patch
13 URL:            http://www.berkeleydb.com/
14 #BuildRequires: glibc-static
15 %{?_with_java:BuildRequires:    java}
16 BuildRequires:  tcl-devel >= 8.3.2
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19
20 %description
21 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
22 provides embedded database support for both traditional and
23 client/server applications. Berkeley DB is used by many applications,
24 including Python and Perl, so this should be installed on all systems.
25
26 %description -l pl
27 Berkeley Database (Berkeley DB) to zestaw narzêdzi programistycznych
28 zapewniaj±cych obs³ugê baz danych w aplikacjach tradycyjnych jak i
29 klient-serwer. Berkeley db jest u¿ywana wielu aplikacjach, w tym w
30 Pythonie i Perlu.
31
32 %package utils
33 Summary:        Command line tools for managing Berkeley DB databases
34 Summary(pl):    Narzêdzia do obs³ugi baz Berkeley DB z linii poleceñ
35 Group:          Applications/Databases
36 Requires:       %{name} = %{version}
37
38 %description utils
39 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
40 provides embedded database support for both traditional and
41 client/server applications. Berkeley DB includes B+tree, Extended
42 Linear Hashing, Fixed and Variable-length record access methods,
43 transactions, locking, logging, shared memory caching and database
44 recovery. DB supports C, C++, Java and Perl APIs.
45
46 This package contains command line tools for managing Berkeley DB
47 databases.
48
49 %description utils -l pl
50 Berkeley Database (Berkeley DB) to zestaw narzêdzi programistycznych
51 zapewniaj±cych obs³ugê baz danych w aplikacjach tradycyjnych jak i
52 klient-serwer. Berkeley DB obs³ugje dostêp do bazy przez B-drzewa i
53 funkcje mieszaj±ce ze sta³± lub zmienn± wielko¶ci± rekordu,
54 transakcje, kroniki, pamiêæ dzielon± i odtwarzanie baz. Ma wsparcie
55 dla C, C++, Javy i Perla.
56
57 Ten pakiet zawiera narzêdzia do obs³ugi baz Berkeley DB z linii
58 poleceñ.
59
60 %package tcl
61 Summary:        Berkeley database library for TCL
62 Summary(pl):    Biblioteka baz danych Berkeley dla TCL
63 Group:          Development/Languages/Tcl
64 Requires:       tcl
65
66 %description tcl
67 Berkeley database library for TCL.
68
69 %description tcl -l pl
70 Biblioteka baz danych Berkeley dla TCL.
71
72 %package cxx
73 Summary:        Berkeley database library for C++
74 Summary(pl):    Biblioteka baz danych Berkeley dla C++
75 Group:          Libraries
76
77 %description cxx
78 Berkeley database library for C++.
79
80 %description cxx -l pl
81 Biblioteka baz danych Berkeley dla C++.
82
83 %package java
84 Summary:        Berkeley database library for Java
85 Summary(pl):    Biblioteka baz danych Berkeley dla Java
86 Group:          Libraries
87
88 %description java
89 Berkeley database library for Java.
90
91 %description java -l pl
92 Biblioteka baz danych Berkeley dla Java.
93
94 %package devel
95 Summary:        Header files for Berkeley database library
96 Summary(pl):    Pliki nag³ówkowe do biblioteki Berkeley Database
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}
99
100 %description devel
101 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
102 provides embedded database support for both traditional and
103 client/server applications. Berkeley DB includes B+tree, Extended
104 Linear Hashing, Fixed and Variable-length record access methods,
105 transactions, locking, logging, shared memory caching and database
106 recovery. DB supports C, C++, Java and Perl APIs.
107
108 This package contains the header files, libraries, and documentation
109 for building programs which use Berkeley DB.
110
111 %description devel -l pl
112 Berkeley Database (Berkeley DB) to zestaw narzêdzi programistycznych
113 zapewniaj±cych obs³ugê baz danych w aplikacjach tradycyjnych jak i
114 klient-serwer. Berkeley DB obs³ugje dostêp do bazy przez B-drzewa i
115 funkcje mieszaj±ce ze sta³± lub zmienn± wielko¶ci± rekordu,
116 transakcje, kroniki, pamiêæ dzielon± i odtwarzanie baz. Ma wsparcie
117 dla C, C++, Javy i Perla.
118
119 Ten pakiet zawiera pliki nag³ówkowe i dokumentacjê do budowania
120 programów u¿ywaj±cych Berkeley DB.
121
122 %package static
123 Summary:        Static libraries for Berkeley database library
124 Summary(pl):    Statyczne biblioteki Berkeley Database
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}
127
128 %description static
129 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
130 provides embedded database support for both traditional and
131 client/server applications. Berkeley DB includes B+tree, Extended
132 Linear Hashing, Fixed and Variable-length record access methods,
133 transactions, locking, logging, shared memory caching and database
134 recovery. DB supports C, C++, Java and Perl APIs.
135
136 This package contains the static libraries for building programs which
137 use Berkeley DB.
138
139 %description static -l pl
140 Berkeley Database (Berkeley DB) to zestaw narzêdzi programistycznych
141 zapewniaj±cych obs³ugê baz danych w aplikacjach tradycyjnych jak i
142 klient-serwer. Berkeley DB obs³ugje dostêp do bazy przez B-drzewa i
143 funkcje mieszaj±ce ze sta³± lub zmienn± wielko¶ci± rekordu,
144 transakcje, kroniki, pamiêæ dzielon± i odtwarzanie baz. Ma wsparcie
145 dla C, C++, Javy i Perla.
146
147 Ten pakiet zawiera statyczne biblioteki do budowania programów
148 u¿ywaj±cych Berkeley DB.
149
150 %prep
151 %setup -q
152 %patch0 -p1
153 #%patch1 -p1
154 #%patch2 -p1
155
156 %build
157 cp -a build_unix build_unix.static
158
159 cd build_unix.static
160
161 CFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates" \
162 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates" \
163 ../dist/configure \
164         --prefix=%{_prefix} \
165         --enable-compat185 \
166         --disable-shared \
167         --enable-static \
168         --enable-rpc \
169         --enable-cxx
170
171 # (temporarily?) disabled because of compilation errors:
172 #       --enable-dump185 \
173
174 %{__make} library_build
175
176 cd ../build_unix
177
178 CFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates" \
179 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-implicit-templates" \
180
181 %if %{?_with_java:1}%{!?_with_java:0}
182 ../dist/configure \
183         --prefix=%{_prefix} \
184         --enable-compat185 \
185         --enable-shared \
186         --disable-static \
187         --enable-rpc \
188         --enable-cxx \
189         --enable-tcl \
190         --with-tcl=%{_libdir} \
191         --enable-java
192 %else
193 ../dist/configure \
194         --prefix=%{_prefix} \
195         --enable-compat185 \
196         --enable-shared \
197         --disable-static \
198         --enable-rpc \
199         --enable-cxx \
200         --enable-tcl \
201         --with-tcl=/usr/lib
202 %endif
203
204 %{__make} library_build TCFLAGS='-I$(builddir) -I%{_includedir}'
205
206 %install
207 rm -rf $RPM_BUILD_ROOT
208 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_bindir},/lib}
209
210 cd build_unix.static
211
212 %{__make} library_install \
213         prefix=$RPM_BUILD_ROOT%{_prefix}
214
215 cd ../build_unix
216
217 %{__make} library_install \
218         prefix=$RPM_BUILD_ROOT%{_prefix} \
219         includedir=$RPM_BUILD_ROOT%{_includedir} \
220         LIB_INSTALL_FILE_LIST=""
221
222 #mv -f $RPM_BUILD_ROOT%{_libdir}/libdb-*.so $RPM_BUILD_ROOT/lib
223 #ln -sf ../../lib/libdb-3.1.so $RPM_BUILD_ROOT%{_libdir}/libdb.so
224 #ln -sf ../../lib/libdb-3.1.so $RPM_BUILD_ROOT%{_libdir}/libdb3.so
225 #ln -sf ../../lib/libdb-3.1.so $RPM_BUILD_ROOT%{_libdir}/libdb-3.1.so
226 #ln -sf libdb-3.1.a $RPM_BUILD_ROOT%{_libdir}/libdb.a
227 #ln -sf libdb3.so $RPM_BUILD_ROOT%{_libdir}/libndbm.so
228 #ln -sf libdb3.a $RPM_BUILD_ROOT%{_libdir}/libndbm.a
229
230 cd ..
231 #rm -rf examples_java
232 #cp -a java/src/com/sleepycat/examples examples_java
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %post   -p /sbin/ldconfig
238 %postun -p /sbin/ldconfig
239
240 %post   tcl -p /sbin/ldconfig
241 %postun tcl -p /sbin/ldconfig
242
243 %post   cxx -p /sbin/ldconfig
244 %postun cxx -p /sbin/ldconfig
245
246 %files
247 %defattr(644,root,root,755)
248 %doc LICENSE README
249 #%attr(755,root,root) /lib/libdb-*.so
250 %attr(755,root,root) %{_libdir}/libdb-*.so
251
252 %files utils
253 %defattr(644,root,root,755)
254 %doc docs/utility/*
255 %attr(755,root,root) %{_bindir}/berkeley_db_svc
256 %attr(755,root,root) %{_bindir}/db*_archive
257 %attr(755,root,root) %{_bindir}/db*_checkpoint
258 %attr(755,root,root) %{_bindir}/db*_deadlock
259 %attr(755,root,root) %{_bindir}/db*_dump
260 #%attr(755,root,root) %{_bindir}/db*_dump185
261 %attr(755,root,root) %{_bindir}/db*_load
262 %attr(755,root,root) %{_bindir}/db*_printlog
263 %attr(755,root,root) %{_bindir}/db*_recover
264 %attr(755,root,root) %{_bindir}/db*_stat
265 %attr(755,root,root) %{_bindir}/db*_upgrade
266 %attr(755,root,root) %{_bindir}/db*_verify
267
268 %files cxx
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_libdir}/libdb_cxx-*.so
271
272 %if %{?_with_java:1}%{!?_with_java:0}
273 %files java
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_libdir}/libdb_java*.so
276 %attr(644,root,root) %{_libdir}/db.jar
277 %endif
278
279 %files tcl
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_libdir}/libdb_tcl-*.so
282
283 %files devel
284 %defattr(644,root,root,755)
285 %doc docs/{api*,ref,index.html,sleepycat,images} examples_c*
286 %attr(755,root,root) %{_libdir}/libdb*.la
287 #%attr(755,root,root) %{_libdir}/libdb.so
288 %attr(755,root,root) %{_libdir}/libdb*.so
289 #%attr(755,root,root) %{_libdir}/libndbm.so
290 #%attr(755,root,root) %{_libdir}/libdb_tcl.so
291 #%attr(755,root,root) %{_libdir}/libdb_cxx.so
292 %{_includedir}/*
293
294 %files static
295 %defattr(644,root,root,755)
296 %{_libdir}/lib*.a
This page took 0.145101 seconds and 3 git commands to generate.