]> git.pld-linux.org Git - packages/db3.git/commitdiff
- write from scrach
authorArtur Frysiak <artur@frysiak.net>
Sat, 15 Apr 2000 20:37:58 +0000 (20:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    db3.spec -> 1.1

db3.spec [new file with mode: 0644]

diff --git a/db3.spec b/db3.spec
new file mode 100644 (file)
index 0000000..e3a1a1e
--- /dev/null
+++ b/db3.spec
@@ -0,0 +1,76 @@
+Summary:       Berkeley DB
+Name:          db
+Version:       3.0.55
+Release:       1
+License:       distributable
+Group:         Library
+Source0:       %{name}-%{version}.tar.gz
+Patch0:                db3-DESTDIR.patch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _includedir     %{_prefix}/include/db3
+
+%description
+
+%package devel
+Summary:       Berkeley DB
+Group:         Development/Library
+
+%description devel
+
+#%package static
+#Summary:      Berkeley DB
+#Group:                Development/Library
+#
+#%description static
+
+%prep
+%setup -q
+chmod -R u+w *
+%patch0 -p1 
+
+%build
+cd build_unix
+CFLAGS="$RPM_OPT_FLAGS" \
+LDFLAGS="-s" \
+../dist/configure \
+       --prefix=%{_prefix} \
+       --bindir=%{_bindir} \
+       --includedir=%{_includedir} \
+       --libdir=%{_libdir} \
+       --enable-compat185 \
+       --enable-cxx \
+       --enable-dynamic \
+       --enable-shared \
+       --enable-tcl
+
+make
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+cd build_unix
+make install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       docdir=%{_datadir}/doc/%{name}-%{version}
+
+cd $RPM_BUILD_ROOT%{_bindir}
+for i in `ls`; do
+       mv $i `echo $i|sed -e 's/^db/db3/'`;
+done
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/libdb*-3*.so
+
+%files devel
+%defattr(644,root,root,755)
+%doc %{_datadir}/doc/%{name}-%{version}
+%{_includedir}
+
+#%files static
+#%defattr(644,root,root,755)
This page took 0.100275 seconds and 4 git commands to generate.