]> git.pld-linux.org Git - packages/db3.git/blob - db3.spec
ab607504dad5d9258ba270464fff49cc5f518c0b
[packages/db3.git] / db3.spec
1 Summary:        Berkeley DB
2 Name:           db
3 Version:        3.0.55
4 Release:        1
5 License:        distributable
6 Group:          Libraries
7 Group(fr):      Librairies
8 Group(pl):      Biblioteki
9 Source0:        %{name}-%{version}.tar.gz
10 Patch0:         db3-DESTDIR.patch
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %define         _includedir     %{_prefix}/include/db3
14
15 %description
16
17 %package devel
18 Summary:        Berkeley DB
19 Group:          Development/Libraries
20 Group(fr):      Development/Librairies
21 Group(pl):      Programowanie/Biblioteki
22 Requires:       %{name} = %{version}
23
24 %description devel
25
26 #%package static
27 #Summary:       Berkeley DB
28 #Group:         Development/Libraries
29 #Group(fr):     Development/Librairies
30 #Group(pl):     Programowanie/Biblioteki
31 #Requires:      %{name}-devel = %{version}
32 #
33 #%description static
34
35 %prep
36 %setup -q
37 chmod -R u+w *
38 %patch0 -p1 
39
40 %build
41 LDFLAGS="-s"; export LDFLAGS
42 cd dist
43 %configure \
44         --enable-compat185 \
45         --enable-cxx \
46         --enable-dynamic \
47         --enable-shared \
48         --enable-static \
49         --enable-tcl
50
51 make
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 cd dist
57 make install \
58         DESTDIR=$RPM_BUILD_ROOT \
59         docdir=%{_datadir}/doc/%{name}-%{version}
60
61 cd $RPM_BUILD_ROOT%{_bindir}
62 for i in `ls`; do
63         mv $i `echo $i|sed -e 's/^db/db3/'`;
64 done
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %attr(755,root,root) %{_bindir}/*
72 %attr(755,root,root) %{_libdir}/libdb*-3*.so
73
74 %files devel
75 %defattr(644,root,root,755)
76 %doc %{_datadir}/doc/%{name}-%{version}
77 %{_includedir}
78
79 #%files static
80 #%defattr(644,root,root,755)
This page took 0.057678 seconds and 2 git commands to generate.