]> git.pld-linux.org Git - packages/davfs.git/blob - davfs.spec
- init script for davfsd removed; not needed
[packages/davfs.git] / davfs.spec
1
2 # conditional build
3 # _without_dist_kernel          without kernel from distribution
4
5 %define         _rel    1
6
7 Summary:        Web-based Distributed Authoring and Versioning
8 Summary(pl):    Bazuj±cy na WWW Rozproszone Autoryzowanie i Wersjonowanie
9 Name:           davfs
10 Version:        0.2.4
11 Release:        %{_rel}
12 License:        GPL
13 Group:          Base/Kernel
14 Source0:        http://prdownloads.sourceforge.net/dav/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-path.patch
16 Patch1:         %{name}-is_socket_ready.patch
17 URL:            http://dav.sourceforge.net/
18 %{!?_without_dist_kernel:BuildRequires: kernel-headers}
19 BuildRequires:  autoconf
20 BuildRequires:  %{kgcc_package}
21 BuildRequires:  openssl-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir     /etc
25
26 %description
27 WebDAV is an acronym for Web-based Distributed Authoring and Version-
28 ing. Usually http is a read only protocol, but if you install DAV on
29 your web server, it becomes writable. Furthermore, if you use DAVfs,
30 you can mount your web server onto your filesystem and can use it as a
31 normal disk.
32
33 %description -l pl
34 WebDAV to bazuj±cy na WWW Rozproszone Autoryzowanie i Wersjonowanie.
35 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
36 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
37 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
38 u¿ywaæ tak jak normalnego dysku.
39
40 %package -n kernel-fs-davfs
41 Summary:        DAVfs - Drivers
42 Summary(pl):    DAVfs - Sterowniki
43 Release:        %{_rel}@%{_kernel_ver_str}
44 Group:          Base/Kernel
45 Prereq:         /sbin/depmod
46 %{!?_without_dist_kernel:%requires_releq_kernel_up}
47
48
49 %description -n kernel-fs-davfs
50 WebDAV is an acronym for Web-based Distributed Authoring and Version-
51 ing. Usually http is a read only protocol, but if you install DAV on
52 your web server, it becomes writable. Furthermore, if you use DAVfs,
53 you can mount your web server onto your filesystem and can use it as a
54 normal disk.
55
56 %description -n kernel-fs-davfs -l pl
57 WebDAV to bazuj±cy na WWW Rozproszone Autoryzowanie i Wersjonowanie.
58 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
59 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
60 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
61 u¿ywaæ tak jak normalnego dysku.
62
63 %package -n kernel-smp-fs-davfs
64 Summary:        DAVfs - SMP Drivers
65 Summary(pl):    DAVfs - Sterowniki SMP
66 Release:        %{_rel}@%{_kernel_ver_str}
67 Group:          Base/Kernel
68 Prereq:         /sbin/depmod
69 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
70
71 %description -n kernel-smp-fs-davfs
72 WebDAV is an acronym for Web-based Distributed Authoring and Version-
73 ing. Usually http is a read only protocol, but if you install DAV on
74 your web server, it becomes writable. Furthermore, if you use DAVfs,
75 you can mount your web server onto your filesystem and can use it as a
76 normal disk.
77
78 %description -n kernel-smp-fs-davfs -l pl
79 WebDAV to bazuj±cy na WWW Rozproszone Autoryzowanie i Wersjonowanie.
80 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
81 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
82 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
83 u¿ywaæ tak jak normalnego dysku.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 %configure2_13 \
92         --with-ssl \
93         --with-kernel=%{_kernelsrcdir}
94 %{__make}
95
96 %{__make} -C davfs clean all \
97         CC=%{kgcc} \
98         CFLAGS="-O2 -D__KERNEL__ -DMODULE -D__SMP__ -DCONFIG_X86_LOCAL_APIC \
99         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
100         -fno-strict-aliasing -pipe -fno-strength-reduce"
101 mv davfs/davfs.o davfs-smp.o
102
103 %{__make} -C davfs clean all \
104         CC=%{kgcc} \
105         CFLAGS="-O2 -D__KERNEL__ -DMODULE \
106         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
107         -fno-strict-aliasing -pipe -fno-strength-reduce"
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/rc.d/init.d}
112 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
113
114 echo "all install:" > davfs/Makefile
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install davfs/davfs.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/davfs.o
120 install davfs-smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/davfs.o
121 ln -s %{_sbindir}/mount.davfs $RPM_BUILD_ROOT/sbin/mount.davfs
122
123 gzip -9nf ChangeLog
124
125 %post   -n kernel-fs-davfs
126 /sbin/depmod -a
127
128 %postun -n kernel-fs-davfs
129 /sbin/depmod -a
130
131 %post   -n kernel-smp-fs-davfs
132 /sbin/depmod -a
133
134 %postun -n kernel-smp-fs-davfs
135 /sbin/depmod -a
136
137 %post
138 /sbin/chkconfig --add davfsd
139 if [ -f /var/lock/subsys/davfsd ]; then
140         /etc/rc.d/init.d/davfsd restart 1>&2
141 else
142         echo "Run \"/etc/rc.d/init.d/davfsd start\" to start davfsd daemon."
143 fi
144
145 %preun
146 if [ "$1" = "0" ]; then
147         if [ -f /var/lock/subsys/davfsd ]; then
148                 /etc/rc.d/init.d/davfsd stop 1>&2
149         fi
150         /sbin/chkconfig --del davfsd
151 fi
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %doc *.gz doc/*.html
159 %attr(755,root,root) /sbin/*
160 %attr(755,root,root) %{_sbindir}/*
161
162 %files -n kernel-fs-davfs
163 %defattr(644,root,root,755)
164 %attr(600,root,root) /lib/modules/%{_kernel_ver}/misc/*.o
165
166 %files -n kernel-smp-fs-davfs
167 %defattr(644,root,root,755)
168 %attr(600,root,root) /lib/modules/%{_kernel_ver}smp/misc/*.o
This page took 0.140252 seconds and 3 git commands to generate.