]> git.pld-linux.org Git - packages/darcs.git/blob - darcs.spec
- rel 1
[packages/darcs.git] / darcs.spec
1 Summary:        David's Advanced Revision Control System - yet another replacement for CVS
2 Summary(pl.UTF-8):      David's Advanced Revision Control System - jeszcze jeden zamiennik CVS-a
3 Name:           darcs
4 Version:        2.4
5 Release:        1
6 License:        GPL v2
7 Group:          Development/Version Control
8 Source0:        http://darcs.net/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  169a6d245a33da97b2daa0eda60b28e5
10 Patch0:         %{name}-issue1753.patch
11 URL:            http://darcs.net/
12 BuildRequires:  curl-devel >= 7.19.1
13 BuildRequires:  ghc >= 6.10
14 BuildRequires:  ghc-hashed-storage >= 0.3.8
15 BuildRequires:  ghc-haskeline >= 0.6.1
16 BuildRequires:  ghc-mmap = 1:0.4.1
17 BuildRequires:  ghc-terminfo >= 0.3
18 BuildRequires:  ghc-utf8-string >= 0.3
19 BuildRequires:  ghc-zlib >= 0.5.1.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         libsubdir       ghc-%(/usr/bin/ghc --numeric-version)/%{name}-%{version}
23
24 %description
25 David's Advanced Revision Control System is yet another replacement
26 for CVS. It is written in Haskell, and has been used on Linux, MacOS
27 X, FreeBSD, OpenBSD and Microsoft Windows. Darcs includes a CGI
28 script, which can be used to view the contents of your repository.
29
30 %description -l pl.UTF-8
31 David's Advanced Revision Control System (zaawansowany system kontroli
32 wersji Davida) to jeszcze jeden zamiennik CVS-a. Jest napisany w
33 Haskellu, dotychczas był używany na Linuksie, MacOS-ie X, FreeBSD,
34 OpenBSD i Microsoft Windows. Darcs zawiera skrypt CGI, który może być
35 używany do oglądania zawartości repozytorium.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40
41 %build
42 runhaskell Setup.lhs configure -v2 \
43         --prefix=%{_prefix} \
44         --libdir=%{_libdir} \
45         --libexecdir=%{_libexecdir} \
46         --libsubdir=%{libsubdir} \
47         --docdir=%{_docdir}/%{name}-%{version} \
48         --flags="curl curl-pipelining terminfo color mmap"
49
50 runhaskell Setup.lhs build
51 runhaskell Setup.lhs haddock --executables \
52         --css=doc/darcs.css
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/%{name}
57
58 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
59
60 # work around automatic haddock docs installation
61 rm -rf %{name}-%{version}-doc
62 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
63
64 install -p contrib/darcs_completion $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/%{name}
65
66 # we only want the binary
67 rm -r $RPM_BUILD_ROOT/%{_libdir}/%{libsubdir}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc NEWS README
75 %doc %{name}-%{version}-doc/html
76 %attr(755,root,root) %{_bindir}/*
77 %{_sysconfdir}/bash_completion.d/%{name}
78 %{_mandir}/man1/*
This page took 0.028698 seconds and 3 git commands to generate.