]> git.pld-linux.org Git - packages/darcs.git/blob - darcs.spec
- BR ghc-tar
[packages/darcs.git] / darcs.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 Summary:        David's Advanced Revision Control System - yet another replacement for CVS
6 Summary(pl.UTF-8):      David's Advanced Revision Control System - jeszcze jeden zamiennik CVS-a
7 Name:           darcs
8 Version:        2.5.2
9 Release:        0.1
10 License:        GPL v2
11 Group:          Development/Version Control
12 Source0:        http://darcs.net/releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  491b6ca01dec245a16112ad2c7e07dc1
14 Patch0:         %{name}-ghc72.patch
15 Patch1:         %{name}-relax-regex-libs-deps.patch
16 Patch2:         %{name}-tests-ghc72.patch
17 URL:            http://darcs.net/
18 BuildRequires:  curl-devel >= 7.19.1
19 BuildRequires:  ghc >= 6.12.3
20 BuildRequires:  ghc-hashed-storage >= 0.5
21 BuildRequires:  ghc-haskeline >= 0.6.1
22 BuildRequires:  ghc-mmap >= 1:0.5
23 BuildRequires:  ghc-tar >= 0.3
24 BuildRequires:  ghc-terminfo >= 0.3
25 BuildRequires:  ghc-utf8-string >= 0.3
26 BuildRequires:  ghc-zlib >= 0.5.1.0
27 BuildRequires:  gmp-devel
28 BuildRequires:  pkgconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         ghcdir          ghc-%(/usr/bin/ghc --numeric-version)
32
33 %description
34 David's Advanced Revision Control System is yet another replacement
35 for CVS. It is written in Haskell, and has been used on Linux, MacOS
36 X, FreeBSD, OpenBSD and Microsoft Windows. Darcs includes a CGI
37 script, which can be used to view the contents of your repository.
38
39 %description -l pl.UTF-8
40 David's Advanced Revision Control System (zaawansowany system kontroli
41 wersji Davida) to jeszcze jeden zamiennik CVS-a. Jest napisany w
42 Haskellu, dotychczas był używany na Linuksie, MacOS-ie X, FreeBSD,
43 OpenBSD i Microsoft Windows. Darcs zawiera skrypt CGI, który może być
44 używany do oglądania zawartości repozytorium.
45
46 %package -n bash-completion-darcs
47 Summary:        bash-completion for darcs
48 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla darcsa
49 Group:          Applications/Shells
50 Requires:       bash-completion
51
52 %description -n bash-completion-darcs
53 This package provides bash-completion for darcs.
54
55 %description -n bash-completion-darcs -l pl.UTF-8
56 Pakiet ten dostarcza bashowe uzupełnianie nazw dla darcsa.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63
64 %build
65 runhaskell Setup.lhs configure -v2 \
66         --prefix=%{_prefix} \
67         --libdir=%{_libdir} \
68         --libexecdir=%{_libexecdir} \
69         --docdir=%{_docdir}/%{name}-%{version} \
70         --flags="curl curl-pipelining terminfo color mmap"
71
72 runhaskell Setup.lhs build
73 %{?with_tests:runhaskell Setup.lhs test}
74
75 runhaskell Setup.lhs haddock --executables \
76         --css=doc/darcs.css
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
82
83 # work around automatic haddock docs installation
84 rm -rf %{name}-%{version}-doc
85 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
86
87 # bash completion
88 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
89 install -p contrib/darcs_completion $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/%{name}
90
91 # we only want the binary
92 rm -r $RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc NEWS README
100 %doc %{name}-%{version}-doc/html
101 %attr(755,root,root) %{_bindir}/*
102 %{_mandir}/man1/*
103
104 %files -n bash-completion-darcs
105 %defattr(644,root,root,755)
106 %{_sysconfdir}/bash_completion.d/%{name}
This page took 0.639196 seconds and 3 git commands to generate.