]> git.pld-linux.org Git - packages/darcs.git/blob - darcs.spec
- rel 1
[packages/darcs.git] / darcs.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 Summary:        David's Advanced Revision Control System - yet another replacement for CVS
6 Summary(pl.UTF-8):      David's Advanced Revision Control System - jeszcze jeden zamiennik CVS-a
7 Name:           darcs
8 Version:        2.4.4
9 Release:        1
10 License:        GPL v2
11 Group:          Development/Version Control
12 Source0:        http://darcs.net/releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  1ccd97561e4e0592b44f1989cebeca02
14 Patch0:         %{name}-issue1753.patch
15 URL:            http://darcs.net/
16 BuildRequires:  curl-devel >= 7.19.1
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-hashed-storage >= 0.5
19 BuildRequires:  ghc-haskeline >= 0.6.1
20 BuildRequires:  ghc-mmap >= 1:0.5
21 BuildRequires:  ghc-terminfo >= 0.3
22 BuildRequires:  ghc-utf8-string >= 0.3
23 BuildRequires:  ghc-zlib >= 0.5.1.0
24 BuildRequires:  gmp-devel
25 BuildRequires:  pkgconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         ghcdir          ghc-%(/usr/bin/ghc --numeric-version)
29
30 %description
31 David's Advanced Revision Control System is yet another replacement
32 for CVS. It is written in Haskell, and has been used on Linux, MacOS
33 X, FreeBSD, OpenBSD and Microsoft Windows. Darcs includes a CGI
34 script, which can be used to view the contents of your repository.
35
36 %description -l pl.UTF-8
37 David's Advanced Revision Control System (zaawansowany system kontroli
38 wersji Davida) to jeszcze jeden zamiennik CVS-a. Jest napisany w
39 Haskellu, dotychczas był używany na Linuksie, MacOS-ie X, FreeBSD,
40 OpenBSD i Microsoft Windows. Darcs zawiera skrypt CGI, który może być
41 używany do oglądania zawartości repozytorium.
42
43 %package -n bash-completion-darcs
44 Summary:        bash-completion for darcs
45 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla darcsa
46 Group:          Applications/Shells
47 Requires:       bash-completion
48
49 %description -n bash-completion-darcs
50 This package provides bash-completion for darcs.
51
52 %description -n bash-completion-darcs -l pl.UTF-8
53 Pakiet ten dostarcza bashowe uzupełnianie nazw dla darcsa.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 runhaskell Setup.lhs configure -v2 \
61         --prefix=%{_prefix} \
62         --libdir=%{_libdir} \
63         --libexecdir=%{_libexecdir} \
64         --docdir=%{_docdir}/%{name}-%{version} \
65         --flags="curl curl-pipelining terminfo color mmap"
66
67 runhaskell Setup.lhs build
68 %{?with_tests:runhaskell Setup.lhs test}
69
70 runhaskell Setup.lhs haddock --executables \
71         --css=doc/darcs.css
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
77
78 # work around automatic haddock docs installation
79 rm -rf %{name}-%{version}-doc
80 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
81
82 # bash completion
83 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
84 install -p contrib/darcs_completion $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/%{name}
85
86 # we only want the binary
87 rm -r $RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc NEWS README
95 %doc %{name}-%{version}-doc/html
96 %attr(755,root,root) %{_bindir}/*
97 %{_mandir}/man1/*
98
99 %files -n bash-completion-darcs
100 %defattr(644,root,root,755)
101 %{_sysconfdir}/bash_completion.d/%{name}
This page took 0.068272 seconds and 3 git commands to generate.