]> git.pld-linux.org Git - packages/dar.git/blob - dar.spec
- 2.0.2
[packages/dar.git] / dar.spec
1 #
2 # Conditional build:
3 %bcond_without  static  # build without dar_static
4 #
5 Summary:        dar makes backup of a directory tree and files
6 Summary(pl):    dar - narzêdzie do tworzenia kopii zapasowych drzew katalogów i plików
7 Name:           dar
8 Version:        2.0.2
9 Release:        0.1
10 License:        GPL
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13 # Source0-md5:  061283b4c9e83241483ada90e0379441
14 Patch0:         %{name}-opt.patch
15 URL:            http://dar.linux.free.fr/
16 BuildRequires:  attr-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bzip2-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  zlib-devel
23 %if %{with static}
24 BuildRequires:  attr-static
25 BuildRequires:  bzip2-static
26 BuildRequires:  glibc-static
27 BuildRequires:  libstdc++-static
28 BuildRequires:  zlib-static
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 # workaround for gcc bug optimization/12965 (should be fixed in 3.3.3)
33 %define         specflags_alpha         -O
34
35 %description
36 dar is a shell command, that makes backup of a directory tree and
37 files.
38
39 FILTERS: dar is able to backup from total file system to a single
40 file. Additionally a mechanism of filters permits, based on the
41 filename, to exclude or include some files while backing up or
42 restoring a directory tree. In the other side, a secondary filter
43 mechanism permits to exclude some branches of a directory tree, or to
44 only include some branches.
45
46 DIFFERENTIAL BACKUP: When making a backup with dar, you have the
47 possibility to make a full backup or a differential backup. A full
48 backup, as expected makes backup of all files as specified on the
49 command line (with or without filters). Instead, a differential
50 backup, (over filter mechanism), saves only files that have changed
51 since a given reference backup. Additionally, files that existed in
52 the reference backup and which do no more exist at the time of the
53 differential backup are recorded in the backup. At recovery time,
54 (unless you deactivate it), restoring a differential backup will
55 update changed files and new files, but also remove files that have
56 been recorded as deleted. Note that the reference backup can be a full
57 backup or another differential backup. This way you can make a first
58 full backup, then many differential backup, each taking as reference
59 the last backup made.
60
61 SLICES: Dar stands for Disk ARchive. From the beginning it was
62 designed to be able to split an archive over several removable media
63 whatever their number is and whatever their size is. Thus dar is able
64 to save over old floppy disk, CD-R, DVD-R, CD-RW, DVD-RW, Zip, Jazz,
65 etc... Dar is not concerned by un/mounting a removable medium, instead
66 it is independent of hardware. Given the size, it will split the
67 archive in several files (called SLICES), eventually pausing before
68 creating the next one, allowing this way, the user to un/mount a
69 medium, burn the file on CD-R, send it by email (if your mail system
70 does not allow huge file in emails, dar can help you here also). By
71 default, (no size specified), dar will make one slice whatever its
72 size is. Additionally, the size of the first slice can be specified
73 separately, if for example you want first to fulfil a partially filled
74 disk before starting using empty ones. Last, at restoration time, dar
75 will just pause and prompt the user asking a slice only if it is
76 missing.
77
78 COMPRESSION: last, dar can use compression. By default no compression
79 is used. Actually only gzip algorithm is implemented, but some room
80 has been done for bzip2 and any other compression algorithm. Note
81 that, compression is made before slices, which means that using
82 compression with slices, will not make slices smaller, but will
83 probably make less slices in the backup.
84
85 DIRECT ACCESS: even using compression dar has not to read the whole
86 backup to extract one file. This way if you just want to restore one
87 file from a huge backup, the process will be much faster than using
88 tar. Dar first reads the catalogue (i.e. the contents of the backup),
89 then it goes directly to the location of the saved file(s) you want to
90 restore and proceed to restoration. In particular using slices dar
91 will ask only for the slice(s) containing the file(s) to restore.
92
93 HARD LINK CONSIDERATION: hard links are now properly saved. They are
94 properly restored if possible. If for example restoring across a
95 mounted filesystem, hard linking will fail, but dar will then
96 duplicate the inode and file content, issuing a warning.
97
98 EXTENDED ATTRIBUTES: support for extended attributes have to be
99 activated at compilation time (see INSTALL). Dar is able to save and
100 restore EA, all or just those of a given namespace (system or user).
101 If no EA have been saved and restoration occurs over a file that has
102 EA, they will be preserved. But if they have been saved empty for a
103 given file, any existing EA for that file will be removed at
104 restoration time, unless -u and/or -U is given on command-line.
105
106 ARCHIVE TESTING thanks to CRC (cyclic redundancy checks), dar is able
107 to detect data corruption in the archive. Only the file where data
108 corruption occurred will not be possible to restore, but dar will
109 restore the other even when compression is used.
110
111 USING PIPES dar is now able to produce an archive to its standard
112 output or named pipe. it is also able to read an archive through a
113 pair of pipes, to take a remote archive as reference, or even to
114 restore data from a remote archive. This way it is now possible to
115 store an archive remotely and in total security (if using encrypted
116 means)
117
118 ISOLATION the catalogue (i.e.: the contents of an archive), can be
119 extracted (this operation is called isolation) to a small file, that
120 can in turn be used as reference for differential archive. There is no
121 more need to provide an archive to be able to create a differential
122 backup over it, just its catalogue is necessary.
123
124 RE-SHAPE SLICES OF AN EXISTING ARCHIVE the external program named
125 "dar_xform" is able to change the size of slices of a given archive.
126 The resulting archive is totally identical to archives directly
127 created by dar. Source archive can be taken from a set of slice, from
128 standard input or even a named pipe.
129
130 %description -l pl
131 dar jest poleceniem pow³oki, które tworzy kopie zapasowe drzew
132 katalogów i plików. Mo¿liwo¶ci:
133 - Filtry: dar mo¿e tworzyæ kopiê zapasow± ca³ego systemu plików do
134   pojedynczego pliku; mechanizm filtrów pozwala wy³±czaæ lub do³±czaæ
135   pliki przy tworzeniu kopii lub odtwarzaniu z niej.
136 - Backup ró¿nicowy: dar mo¿e tworzyæ kopie pe³ne lub ró¿nicowe
137   (zawieraj±ce tylko te pliki, które zmieni³y siê od innego backupu)
138 - Czê¶ci (slices): dar oznacza "Disk ARchive". Od pocz±tku ma
139   mo¿liwo¶æ dzielenia archiwów na ró¿ne no¶niki wymienialne,
140   niezale¿nie od ich liczby i rozmiaru (mo¿na tworzyæ kopie na CD-R,
141   DVD-R, CD-RW, Zip, Jazz...).
142 - Kompresja: domy¶lnie dar nie kompresuje danych; ma zaimplementowany
143   algorytm gzip, jest przygotowywany do bzip2 i innych. Kompresja jest
144   wykonywana przed podzia³em na czê¶ci.
145 - Bezpo¶redni dostêp: nawet w przypadku u¿ycia kompresji, dar nie musi
146   czytaæ ca³ej kopii aby odtworzyæ jeden plik. Najpierw odczytuje
147   katalog, nastêpnie skacze od razu do w³a¶ciwego miejsca.
148 - Obs³uga twardych dowi±zañ: dar zachowuje i odtwarza je w miarê
149   mo¿liwo¶ci; w przypadku niemo¿liwo¶ci wykonania dowi±zania, powiela
150   plik i wypisuje ostrze¿enie.
151 - Obs³uga rozszerzonych atrybutów (zale¿nie od opcji kompilacji): dar
152   potrafi zachowywaæ i odtwarzaæ rozszerzone atrubuty - wszystkie lub
153   tylko dotycz±ce danej przestrzeni nazw (systemowej lub u¿ytkownika).
154 - Testowanie archiwów: dziêki u¿yciu CRC dar wykrywa uszkodzone dane;
155   tylko uszkodzone pliki nie zostan± odtworzone, reszta tak - nawet w
156   przypadku u¿ycia kompresji.
157 - U¿ycie rurek - dar mo¿e wyprodukowaæ archiwum na standardowe wyj¶cie
158   lub do nazwanej rurki. Mo¿e tak¿e czytaæ archiwum z pary rurek, a
159   nawet odtwarzaæ ze zdalnego archiwum.
160 - Rozdzielenie: katalog (zawarto¶æ archiwum) mo¿e byæ wyci±gniêty do
161   ma³ego pliku, który mo¿e byæ u¿ywany jako odniesienie dla
162   ró¿nicowego backupu.
163 - Przekszta³canie czê¶ci istniej±cego archiwum: zewnêtrzny program o
164   nazwie dar_xform jest w stanie zmieniaæ rozmiary czê¶ci podanego
165   archiwum. Mo¿e czytaæ z zestawu kata³ków, standardowego wej¶cia lub
166   nazwanej rurki.
167
168 %package static
169 Summary:        Static version of dar backup tool
170 Summary(pl):    Statyczna wersja archiwizatora dar
171 Group:          Applications
172
173 %description static
174 Static version of dar backup tool.
175
176 %description static -l pl
177 Statyczna wersja archiwizatora dar.
178
179 %package devel
180 Summary:        Header files to develop dar software
181 Summary(pl):    Pliki nag³ówkowe biblioteki dar
182 Group:          Development/Libraries
183 Requires:       %{name} = %{version}
184
185 %description devel
186 Header files to develop software which operates on dar.
187
188 %description devel -l pl
189 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania korzystaj±cego z
190 dara.
191
192 %package libs-static
193 Summary:        Static version of dar library
194 Summary(pl):    Statyczna wersja biblioteki dar
195 Group:          Development/Libraries
196 Requires:       %{name}-devel = %{version}
197
198 %description libs-static
199 Static version of dar library.
200
201 %description libs-static -l pl
202 Statyczna wersja biblioteki dar.
203
204 %prep
205 %setup -q
206 %patch -p1
207
208 %build
209 %{__libtoolize}
210 %{__aclocal}
211 %{__autoconf}
212 %{__autoheader}
213 %{__automake}
214 %configure \
215         --enable-ea-support \
216 %{?without_static:--disable-dar-static} \
217         --disable-upx
218 %{__make}
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222 %{?with_static:install -d $RPM_BUILD_ROOT/bin}
223
224 %{__make} install \
225         DESTDIR=$RPM_BUILD_ROOT
226
227 %{?with_static:mv -f $RPM_BUILD_ROOT{%{_bindir},/bin}/dar_static}
228
229 %clean
230 rm -rf $RPM_BUILD_ROOT
231
232 %post   -p /sbin/ldconfig
233 %postun -p /sbin/ldconfig
234
235 %files
236 %defattr(644,root,root,755)
237 %doc BUGS README TODO doc
238 %attr(755,root,root) %{_bindir}/*
239 %attr(755,root,root) %{_libdir}/libdar.so.*.*.*
240 %{_datadir}/%{name}
241 %{_mandir}/man1/*
242
243 %files devel
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_libdir}/libdar.so
246 %{_libdir}/libdar.la
247 %{_includedir}/dar
248
249 %if %{with static}
250 %files static
251 %defattr(644,root,root,755)
252 %attr(755,root,root) /bin/*
253 %endif
254
255 %files libs-static
256 %defattr(644,root,root,755)
257 %{_libdir}/libdar.a
This page took 0.076718 seconds and 3 git commands to generate.