]> git.pld-linux.org Git - packages/dar.git/blob - dar.spec
- spaces -> tabs, other cosmetics
[packages/dar.git] / dar.spec
1 #
2 # Conditional build:
3 %bcond_without  static  # build without dar_static
4 #
5 Summary:        dar makes backup of a directory tree and files
6 Summary(pl):    dar - narzêdzie do tworzenia kopii zapasowych drzew katalogów i plików
7 Name:           dar
8 Version:        2.1.3
9 Release:        1       
10 License:        GPL v2
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13 # Source0-md5:  29d15077cad789396c3ddd41e08c5908
14 Patch0:         %{name}-opt.patch
15 URL:            http://dar.linux.free.fr/
16 BuildRequires:  attr-devel
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  bzip2-devel
20 %ifarch alpha
21 # ICE in 3.3.x up to 3.3.2 - require patched version
22 BuildRequires:  gcc-c++ >= 5:3.3.2-0.3
23 %endif
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.4d
26 BuildRequires:  zlib-devel
27 %if %{with static}
28 BuildRequires:  attr-static
29 BuildRequires:  bzip2-static
30 BuildRequires:  glibc-static
31 BuildRequires:  libstdc++-static
32 BuildRequires:  zlib-static
33 %endif
34 Requires:       %{name}-libs = %{version}-%{release}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 dar is a shell command, that makes backup of a directory tree and
39 files.
40
41 FILTERS: dar is able to backup from total file system to a single
42 file. Additionally a mechanism of filters permits, based on the
43 filename, to exclude or include some files while backing up or
44 restoring a directory tree. In the other side, a secondary filter
45 mechanism permits to exclude some branches of a directory tree, or to
46 only include some branches.
47
48 DIFFERENTIAL BACKUP: When making a backup with dar, you have the
49 possibility to make a full backup or a differential backup. A full
50 backup, as expected makes backup of all files as specified on the
51 command line (with or without filters). Instead, a differential
52 backup, (over filter mechanism), saves only files that have changed
53 since a given reference backup. Additionally, files that existed in
54 the reference backup and which do no more exist at the time of the
55 differential backup are recorded in the backup. At recovery time,
56 (unless you deactivate it), restoring a differential backup will
57 update changed files and new files, but also remove files that have
58 been recorded as deleted. Note that the reference backup can be a full
59 backup or another differential backup. This way you can make a first
60 full backup, then many differential backup, each taking as reference
61 the last backup made.
62
63 SLICES: Dar stands for Disk ARchive. From the beginning it was
64 designed to be able to split an archive over several removable media
65 whatever their number is and whatever their size is. Thus dar is able
66 to save over old floppy disk, CD-R, DVD-R, CD-RW, DVD-RW, Zip, Jazz,
67 etc... Dar is not concerned by un/mounting a removable medium, instead
68 it is independent of hardware. Given the size, it will split the
69 archive in several files (called SLICES), eventually pausing before
70 creating the next one, allowing this way, the user to un/mount a
71 medium, burn the file on CD-R, send it by email (if your mail system
72 does not allow huge file in emails, dar can help you here also). By
73 default, (no size specified), dar will make one slice whatever its
74 size is. Additionally, the size of the first slice can be specified
75 separately, if for example you want first to fulfil a partially filled
76 disk before starting using empty ones. Last, at restoration time, dar
77 will just pause and prompt the user asking a slice only if it is
78 missing.
79
80 COMPRESSION: last, dar can use compression. By default no compression
81 is used. Actually only gzip algorithm is implemented, but some room
82 has been done for bzip2 and any other compression algorithm. Note
83 that, compression is made before slices, which means that using
84 compression with slices, will not make slices smaller, but will
85 probably make less slices in the backup.
86
87 DIRECT ACCESS: even using compression dar has not to read the whole
88 backup to extract one file. This way if you just want to restore one
89 file from a huge backup, the process will be much faster than using
90 tar. Dar first reads the catalogue (i.e. the contents of the backup),
91 then it goes directly to the location of the saved file(s) you want to
92 restore and proceed to restoration. In particular using slices dar
93 will ask only for the slice(s) containing the file(s) to restore.
94
95 HARD LINK CONSIDERATION: hard links are now properly saved. They are
96 properly restored if possible. If for example restoring across a
97 mounted filesystem, hard linking will fail, but dar will then
98 duplicate the inode and file content, issuing a warning.
99
100 EXTENDED ATTRIBUTES: support for extended attributes have to be
101 activated at compilation time (see INSTALL). Dar is able to save and
102 restore EA, all or just those of a given namespace (system or user).
103 If no EA have been saved and restoration occurs over a file that has
104 EA, they will be preserved. But if they have been saved empty for a
105 given file, any existing EA for that file will be removed at
106 restoration time, unless -u and/or -U is given on command-line.
107
108 ARCHIVE TESTING thanks to CRC (cyclic redundancy checks), dar is able
109 to detect data corruption in the archive. Only the file where data
110 corruption occurred will not be possible to restore, but dar will
111 restore the other even when compression is used.
112
113 USING PIPES dar is now able to produce an archive to its standard
114 output or named pipe. it is also able to read an archive through a
115 pair of pipes, to take a remote archive as reference, or even to
116 restore data from a remote archive. This way it is now possible to
117 store an archive remotely and in total security (if using encrypted
118 means)
119
120 ISOLATION the catalogue (i.e.: the contents of an archive), can be
121 extracted (this operation is called isolation) to a small file, that
122 can in turn be used as reference for differential archive. There is no
123 more need to provide an archive to be able to create a differential
124 backup over it, just its catalogue is necessary.
125
126 RE-SHAPE SLICES OF AN EXISTING ARCHIVE the external program named
127 "dar_xform" is able to change the size of slices of a given archive.
128 The resulting archive is totally identical to archives directly
129 created by dar. Source archive can be taken from a set of slice, from
130 standard input or even a named pipe.
131
132 %description -l pl
133 dar jest poleceniem pow³oki, które tworzy kopie zapasowe drzew
134 katalogów i plików. Mo¿liwo¶ci:
135 - Filtry: dar mo¿e tworzyæ kopiê zapasow± ca³ego systemu plików do
136   pojedynczego pliku; mechanizm filtrów pozwala wy³±czaæ lub do³±czaæ
137   pliki przy tworzeniu kopii lub odtwarzaniu z niej.
138 - Backup ró¿nicowy: dar mo¿e tworzyæ kopie pe³ne lub ró¿nicowe
139   (zawieraj±ce tylko te pliki, które zmieni³y siê od innego backupu)
140 - Czê¶ci (slices): dar oznacza "Disk ARchive". Od pocz±tku ma
141   mo¿liwo¶æ dzielenia archiwów na ró¿ne no¶niki wymienialne,
142   niezale¿nie od ich liczby i rozmiaru (mo¿na tworzyæ kopie na CD-R,
143   DVD-R, CD-RW, Zip, Jazz...).
144 - Kompresja: domy¶lnie dar nie kompresuje danych; ma zaimplementowany
145   algorytm gzip, jest przygotowywany do bzip2 i innych. Kompresja jest
146   wykonywana przed podzia³em na czê¶ci.
147 - Bezpo¶redni dostêp: nawet w przypadku u¿ycia kompresji, dar nie musi
148   czytaæ ca³ej kopii aby odtworzyæ jeden plik. Najpierw odczytuje
149   katalog, nastêpnie skacze od razu do w³a¶ciwego miejsca.
150 - Obs³uga twardych dowi±zañ: dar zachowuje i odtwarza je w miarê
151   mo¿liwo¶ci; w przypadku niemo¿liwo¶ci wykonania dowi±zania, powiela
152   plik i wypisuje ostrze¿enie.
153 - Obs³uga rozszerzonych atrybutów (zale¿nie od opcji kompilacji): dar
154   potrafi zachowywaæ i odtwarzaæ rozszerzone atrubuty - wszystkie lub
155   tylko dotycz±ce danej przestrzeni nazw (systemowej lub u¿ytkownika).
156 - Testowanie archiwów: dziêki u¿yciu CRC dar wykrywa uszkodzone dane;
157   tylko uszkodzone pliki nie zostan± odtworzone, reszta tak - nawet w
158   przypadku u¿ycia kompresji.
159 - U¿ycie rurek - dar mo¿e wyprodukowaæ archiwum na standardowe wyj¶cie
160   lub do nazwanej rurki. Mo¿e tak¿e czytaæ archiwum z pary rurek, a
161   nawet odtwarzaæ ze zdalnego archiwum.
162 - Rozdzielenie: katalog (zawarto¶æ archiwum) mo¿e byæ wyci±gniêty do
163   ma³ego pliku, który mo¿e byæ u¿ywany jako odniesienie dla
164   ró¿nicowego backupu.
165 - Przekszta³canie czê¶ci istniej±cego archiwum: zewnêtrzny program o
166   nazwie dar_xform jest w stanie zmieniaæ rozmiary czê¶ci podanego
167   archiwum. Mo¿e czytaæ z zestawu kata³ków, standardowego wej¶cia lub
168   nazwanej rurki.
169
170 %package static
171 Summary:        Static version of dar backup tool
172 Summary(pl):    Statyczna wersja archiwizatora dar
173 Group:          Applications
174
175 %description static
176 Static version of dar backup tool.
177
178 %description static -l pl
179 Statyczna wersja archiwizatora dar.
180
181 %package libs
182 Summary:        Shared version of dar library
183 Summary(pl):    Wspó³dzielona wersja biblioteki dar
184 Group:          Libraries
185
186 %description libs
187 Shared version of dar library.
188
189 %description libs -l pl
190 Wspó³dzielona wersja biblioteki dar.
191
192 %package devel
193 Summary:        Header files to develop dar software
194 Summary(pl):    Pliki nag³ówkowe biblioteki dar
195 Group:          Development/Libraries
196 Requires:       %{name}-libs = %{version}-%{release}
197
198 %description devel
199 Header files to develop software which operates on dar.
200
201 %description devel -l pl
202 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania korzystaj±cego z
203 dara.
204
205 %package libs-static
206 Summary:        Static version of dar library
207 Summary(pl):    Statyczna wersja biblioteki dar
208 Group:          Development/Libraries
209 Requires:       %{name}-devel = %{version}-%{release}
210
211 %description libs-static
212 Static version of dar library.
213
214 %description libs-static -l pl
215 Statyczna wersja biblioteki dar.
216
217 %prep
218 %setup -q
219 %patch -p1
220
221 %build
222 %{__libtoolize}
223 %{__aclocal}
224 %{__autoconf}
225 %{__autoheader}
226 %{__automake}
227 %configure \
228         --enable-ea-support \
229 %{!?with_static:--disable-dar-static} \
230         --disable-upx
231 %{__make}
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235 %{?with_static:install -d $RPM_BUILD_ROOT/bin}
236
237 %{__make} install \
238         DESTDIR=$RPM_BUILD_ROOT
239
240 %{?with_static:mv -f $RPM_BUILD_ROOT{%{_bindir},/bin}/dar_static}
241
242 find $RPM_BUILD_DIR/%{name}-%{version}/doc -name "Makefile*" | xargs rm -fv
243
244 %clean
245 rm -rf $RPM_BUILD_ROOT
246
247 %post   libs -p /sbin/ldconfig
248 %postun libs -p /sbin/ldconfig
249
250 %files
251 %defattr(644,root,root,755)
252 %doc BUGS README TODO doc
253 %attr(755,root,root) %{_bindir}/*
254 %{_datadir}/%{name}
255 %{_mandir}/man1/*
256
257 %files libs
258 %defattr(644,root,root,755)
259 %attr(755,root,root) %{_libdir}/libdar.so.*.*.*
260
261 %files devel
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{_libdir}/libdar.so
264 %{_libdir}/libdar.la
265 %{_includedir}/dar
266
267 %if %{with static}
268 %files static
269 %defattr(644,root,root,755)
270 %attr(755,root,root) /bin/*
271 %endif
272
273 %files libs-static
274 %defattr(644,root,root,755)
275 %{_libdir}/libdar.a
This page took 0.184609 seconds and 3 git commands to generate.