]> git.pld-linux.org Git - packages/dar.git/blob - dar.spec
- BR doxygen
[packages/dar.git] / dar.spec
1 #
2 # Conditional build:
3 %bcond_without  ea              # build without support for linux extented attributes
4 %bcond_without  static          # build without dar_static
5 #
6 Summary:        dar makes backup of a directory tree and files
7 Summary(pl):    dar - narzêdzie do tworzenia kopii zapasowych drzew katalogów i plików
8 Name:           dar
9 Version:        2.2.0
10 Release:        1
11 License:        GPL v2
12 Group:          Applications
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14 # Source0-md5:  d7bdec2b4abd4bdc550f556ace3b9ec8
15 Patch0:         %{name}-opt.patch
16 URL:            http://dar.linux.free.fr/
17 %{?with_ea:BuildRequires:       attr-devel >= 2.4.16-3}
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  bzip2-devel
21 BuildRequires:  doxygen >= 1:1.3
22 %ifarch alpha
23 # ICE in 3.3.x up to 3.3.2 - require patched version
24 BuildRequires:  gcc-c++ >= 5:3.3.2-0.3
25 %endif
26 BuildRequires:  gettext-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool >= 2:1.4d
29 BuildRequires:  openssl-devel
30 BuildRequires:  zlib-devel
31 %if %{with static}
32 %{?with_ea:BuildRequires:       attr-static}
33 BuildRequires:  bzip2-static
34 BuildRequires:  glibc-static
35 BuildRequires:  libstdc++-static
36 BuildRequires:  openssl-static
37 BuildRequires:  zlib-static
38 %endif
39 Requires:       %{name}-libs = %{version}-%{release}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 dar is a shell command, that makes backup of a directory tree and
44 files.
45
46 FILTERS: dar is able to backup from total file system to a single
47 file. Additionally a mechanism of filters permits, based on the
48 filename, to exclude or include some files while backing up or
49 restoring a directory tree. In the other side, a secondary filter
50 mechanism permits to exclude some branches of a directory tree, or to
51 only include some branches.
52
53 DIFFERENTIAL BACKUP: When making a backup with dar, you have the
54 possibility to make a full backup or a differential backup. A full
55 backup, as expected makes backup of all files as specified on the
56 command line (with or without filters). Instead, a differential
57 backup, (over filter mechanism), saves only files that have changed
58 since a given reference backup. Additionally, files that existed in
59 the reference backup and which do no more exist at the time of the
60 differential backup are recorded in the backup. At recovery time,
61 (unless you deactivate it), restoring a differential backup will
62 update changed files and new files, but also remove files that have
63 been recorded as deleted. Note that the reference backup can be a full
64 backup or another differential backup. This way you can make a first
65 full backup, then many differential backup, each taking as reference
66 the last backup made.
67
68 SLICES: Dar stands for Disk ARchive. From the beginning it was
69 designed to be able to split an archive over several removable media
70 whatever their number is and whatever their size is. Thus dar is able
71 to save over old floppy disk, CD-R, DVD-R, CD-RW, DVD-RW, Zip, Jazz,
72 etc... Dar is not concerned by un/mounting a removable medium, instead
73 it is independent of hardware. Given the size, it will split the
74 archive in several files (called SLICES), eventually pausing before
75 creating the next one, allowing this way, the user to un/mount a
76 medium, burn the file on CD-R, send it by email (if your mail system
77 does not allow huge file in emails, dar can help you here also). By
78 default, (no size specified), dar will make one slice whatever its
79 size is. Additionally, the size of the first slice can be specified
80 separately, if for example you want first to fulfil a partially filled
81 disk before starting using empty ones. Last, at restoration time, dar
82 will just pause and prompt the user asking a slice only if it is
83 missing.
84
85 COMPRESSION: last, dar can use compression. By default no compression
86 is used. Actually only gzip algorithm is implemented, but some room
87 has been done for bzip2 and any other compression algorithm. Note
88 that, compression is made before slices, which means that using
89 compression with slices, will not make slices smaller, but will
90 probably make less slices in the backup.
91
92 DIRECT ACCESS: even using compression dar has not to read the whole
93 backup to extract one file. This way if you just want to restore one
94 file from a huge backup, the process will be much faster than using
95 tar. Dar first reads the catalogue (i.e. the contents of the backup),
96 then it goes directly to the location of the saved file(s) you want to
97 restore and proceed to restoration. In particular using slices dar
98 will ask only for the slice(s) containing the file(s) to restore.
99
100 HARD LINK CONSIDERATION: hard links are now properly saved. They are
101 properly restored if possible. If for example restoring across a
102 mounted filesystem, hard linking will fail, but dar will then
103 duplicate the inode and file content, issuing a warning.
104
105 EXTENDED ATTRIBUTES: support for extended attributes have to be
106 activated at compilation time (see INSTALL). Dar is able to save and
107 restore EA, all or just those of a given namespace (system or user).
108 If no EA have been saved and restoration occurs over a file that has
109 EA, they will be preserved. But if they have been saved empty for a
110 given file, any existing EA for that file will be removed at
111 restoration time, unless -u and/or -U is given on command-line.
112
113 ARCHIVE TESTING thanks to CRC (cyclic redundancy checks), dar is able
114 to detect data corruption in the archive. Only the file where data
115 corruption occurred will not be possible to restore, but dar will
116 restore the other even when compression is used.
117
118 USING PIPES dar is now able to produce an archive to its standard
119 output or named pipe. it is also able to read an archive through a
120 pair of pipes, to take a remote archive as reference, or even to
121 restore data from a remote archive. This way it is now possible to
122 store an archive remotely and in total security (if using encrypted
123 means)
124
125 ISOLATION the catalogue (i.e.: the contents of an archive), can be
126 extracted (this operation is called isolation) to a small file, that
127 can in turn be used as reference for differential archive. There is no
128 more need to provide an archive to be able to create a differential
129 backup over it, just its catalogue is necessary.
130
131 RE-SHAPE SLICES OF AN EXISTING ARCHIVE the external program named
132 "dar_xform" is able to change the size of slices of a given archive.
133 The resulting archive is totally identical to archives directly
134 created by dar. Source archive can be taken from a set of slice, from
135 standard input or even a named pipe.
136
137 %description -l pl
138 dar jest poleceniem pow³oki, które tworzy kopie zapasowe drzew
139 katalogów i plików. Mo¿liwo¶ci:
140 - Filtry: dar mo¿e tworzyæ kopiê zapasow± ca³ego systemu plików do
141   pojedynczego pliku; mechanizm filtrów pozwala wy³±czaæ lub do³±czaæ
142   pliki przy tworzeniu kopii lub odtwarzaniu z niej.
143 - Backup ró¿nicowy: dar mo¿e tworzyæ kopie pe³ne lub ró¿nicowe
144   (zawieraj±ce tylko te pliki, które zmieni³y siê od innego backupu)
145 - Czê¶ci (slices): dar oznacza "Disk ARchive". Od pocz±tku ma
146   mo¿liwo¶æ dzielenia archiwów na ró¿ne no¶niki wymienialne,
147   niezale¿nie od ich liczby i rozmiaru (mo¿na tworzyæ kopie na CD-R,
148   DVD-R, CD-RW, Zip, Jazz...).
149 - Kompresja: domy¶lnie dar nie kompresuje danych; ma zaimplementowany
150   algorytm gzip, jest przygotowywany do bzip2 i innych. Kompresja jest
151   wykonywana przed podzia³em na czê¶ci.
152 - Bezpo¶redni dostêp: nawet w przypadku u¿ycia kompresji, dar nie musi
153   czytaæ ca³ej kopii aby odtworzyæ jeden plik. Najpierw odczytuje
154   katalog, nastêpnie skacze od razu do w³a¶ciwego miejsca.
155 - Obs³uga twardych dowi±zañ: dar zachowuje i odtwarza je w miarê
156   mo¿liwo¶ci; w przypadku niemo¿liwo¶ci wykonania dowi±zania, powiela
157   plik i wypisuje ostrze¿enie.
158 - Obs³uga rozszerzonych atrybutów (zale¿nie od opcji kompilacji): dar
159   potrafi zachowywaæ i odtwarzaæ rozszerzone atrybuty - wszystkie lub
160   tylko dotycz±ce danej przestrzeni nazw (systemowej lub u¿ytkownika).
161 - Testowanie archiwów: dziêki u¿yciu CRC dar wykrywa uszkodzone dane;
162   tylko uszkodzone pliki nie zostan± odtworzone, reszta tak - nawet w
163   przypadku u¿ycia kompresji.
164 - U¿ycie rurek - dar mo¿e wyprodukowaæ archiwum na standardowe wyj¶cie
165   lub do nazwanej rurki. Mo¿e tak¿e czytaæ archiwum z pary rurek, a
166   nawet odtwarzaæ ze zdalnego archiwum.
167 - Rozdzielenie: katalog (zawarto¶æ archiwum) mo¿e byæ wyci±gniêty do
168   ma³ego pliku, który mo¿e byæ u¿ywany jako odniesienie dla
169   ró¿nicowego backupu.
170 - Przekszta³canie czê¶ci istniej±cego archiwum: zewnêtrzny program o
171   nazwie dar_xform jest w stanie zmieniaæ rozmiary czê¶ci podanego
172   archiwum. Mo¿e czytaæ z zestawu kawa³ków, standardowego wej¶cia lub
173   nazwanej rurki.
174
175 %package static
176 Summary:        Static version of dar backup tool
177 Summary(pl):    Statyczna wersja archiwizatora dar
178 Group:          Applications
179
180 %description static
181 Static version of dar backup tool.
182
183 %description static -l pl
184 Statyczna wersja archiwizatora dar.
185
186 %package libs
187 Summary:        Shared version of dar library
188 Summary(pl):    Wspó³dzielona wersja biblioteki dar
189 Group:          Libraries
190
191 %description libs
192 Shared version of dar library.
193
194 %description libs -l pl
195 Wspó³dzielona wersja biblioteki dar.
196
197 %package devel
198 Summary:        Header files to develop dar software
199 Summary(pl):    Pliki nag³ówkowe biblioteki dar
200 Group:          Development/Libraries
201 Requires:       %{name}-libs = %{version}-%{release}
202 %{?with_ea:Requires:    attr-devel >= 2.4.16-3}
203 Requires:       bzip2-devel
204 Requires:       libstdc++-devel
205
206 %description devel
207 Header files to develop software which operates on dar.
208
209 %description devel -l pl
210 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania korzystaj±cego z
211 dara.
212
213 %package libs-static
214 Summary:        Static version of dar library
215 Summary(pl):    Statyczna wersja biblioteki dar
216 Group:          Development/Libraries
217 Requires:       %{name}-devel = %{version}-%{release}
218
219 %description libs-static
220 Static version of dar library.
221
222 %description libs-static -l pl
223 Statyczna wersja biblioteki dar.
224
225 %prep
226 %setup -q
227 %patch -p1
228
229 %build
230 %{__libtoolize}
231 %{__aclocal}
232 %{__autoconf}
233 %{__autoheader}
234 %{__automake}
235 %configure \
236         %{!?with_ea:--disable-ea-support} \
237         %{!?with_static:--disable-dar-static} \
238         --enable-mode=64 \
239         --disable-upx
240 %{__make}
241
242 %install
243 rm -rf $RPM_BUILD_ROOT
244 %{?with_static:install -d $RPM_BUILD_ROOT/bin}
245
246 %{__make} install \
247         DESTDIR=$RPM_BUILD_ROOT
248
249 %{?with_static:mv -f $RPM_BUILD_ROOT{%{_bindir},/bin}/dar_static}
250
251 find $RPM_BUILD_DIR/%{name}-%{version}/doc -name "Makefile*" | xargs rm -fv
252
253 %find_lang %{name}
254
255 %clean
256 rm -rf $RPM_BUILD_ROOT
257
258 %post   libs -p /sbin/ldconfig
259 %postun libs -p /sbin/ldconfig
260
261 %files -f %{name}.lang
262 %defattr(644,root,root,755)
263 %doc BUGS README TODO doc
264 %attr(755,root,root) %{_bindir}/*
265 %{_datadir}/%{name}
266 %{_mandir}/man1/*
267
268 %files libs
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_libdir}/libdar64.so.*.*.*
271
272 %files devel
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_libdir}/libdar64.so
275 %{_libdir}/libdar64.la
276 %{_includedir}/dar
277
278 %if %{with static}
279 %files static
280 %defattr(644,root,root,755)
281 %attr(755,root,root) /bin/*
282 %endif
283
284 %files libs-static
285 %defattr(644,root,root,755)
286 %{_libdir}/libdar64.a
This page took 0.083455 seconds and 3 git commands to generate.