]> git.pld-linux.org Git - packages/dante.git/blob - dante.spec
1fffd8accd38b78f9af305b0d7b81421f4566336
[packages/dante.git] / dante.spec
1 # TODO:
2 # - examine ldap and sasl support (deps are pulled into *.la, no direct linking anywhere?)
3 #
4 # Conditional build:
5 %bcond_without  upnp    # UPnP support (via miniupnp)
6 #
7 Summary:        A free Socks v4/v5 client implementation
8 Summary(pl.UTF-8):      Darmowa implementacja klienta Socks v4/5
9 Name:           dante
10 Version:        1.4.1
11 Release:        1
12 License:        BSD-like
13 Group:          Networking/Daemons
14 Source0:        ftp://ftp.inet.no/pub/socks/%{name}-%{version}.tar.gz
15 # Source0-md5:  68c2ce12119e12cea11a90c7a80efa8f
16 Source1:        sockd.init
17 Patch0:         %{name}-am.patch
18 Patch1:         %{name}-build.patch
19 Patch2:         %{name}-miniupnp.patch
20 URL:            http://www.inet.no/dante/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake
23 BuildRequires:  cyrus-sasl-devel
24 BuildRequires:  heimdal-devel
25 BuildRequires:  libtool
26 BuildRequires:  libwrap-devel
27 %{?with_upnp:BuildRequires:     miniupnpc-devel >= 1.6}
28 BuildRequires:  openldap-devel
29 BuildRequires:  pam-devel
30 %{?with_upnp:Requires:  miniupnpc >= 1.6}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Dante is a free implementation of the proxy protocols socks version 4,
35 socks version 5 (rfc1928) and msproxy. It can be used as a firewall
36 between networks. It is being developed by Inferno Nettverk A/S, a
37 Norwegian consulting company. Commercial support is available.
38
39 This package contains the dynamic libraries required to "socksify"
40 existing applications to become socks clients.
41
42 %description -l pl.UTF-8
43 Dante jest darmową implementacją protokołów proxy: socks w wersji 4,
44 socks w wersji 5 (rfc1928) oraz msproxy. Może być używany jako zapora
45 pomiędzy sieciami. Implementacja jest rozwijana przez Inferno Nettverk
46 A/S - Norweską firmę konsultingową. Komercyjne wsparcie jest dostępne.
47
48 Ten pakiet zawiera dynamiczne biblioteki wymagane do "usocksowiania"
49 istniejących aplikacji tak by działały one jako klienci socks.
50
51 %package server
52 Summary:        A free Socks v4/v5 server implementation
53 Summary(pl.UTF-8):      Darmowa implementacja serwera Socks v4/5
54 Group:          Networking/Daemons
55 Requires(post,preun):   /sbin/chkconfig
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       rc-scripts
58
59 %description server
60 This package contains the socks proxy daemon and its documentation.
61 The sockd is the server part of the Dante socks proxy package and
62 allows socks clients to connect through it to the network.
63
64 %description server -l pl.UTF-8
65 Ten pakiet zawiera serwer proxy socks oraz jego dokumentację. Serwer
66 sockd jest częścią pakietu proxy Dante. Za pośrednictwem serwera
67 klienci mogą łączyć się z serwerami w sieci.
68
69 %package devel
70 Summary:        Development files for socks library
71 Summary(pl.UTF-8):      Pliki programistyczne biblioteki socks
72 Group:          Networking/Daemons
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       cyrus-sasl-devel
75 Requires:       heimdal-devel
76 %{?with_upnp:Requires:  miniupnpc-devel >= 1.6}
77 Requires:       openldap-devel
78 Requires:       pam-devel
79
80 %description devel
81 Development files required to compile programs that use socks.
82
83 %description devel -l pl.UTF-8
84 Pliki programistyczne wymagane do rozwoju programów korzystających z
85 socks.
86
87 %package static
88 Summary:        Static socks library
89 Summary(pl.UTF-8):      Statyczna biblioteka socks
90 Group:          Networking/Daemons
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static socks library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka socks.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --disable-silent-rules \
112         --without-glibc-secure \
113         %{!?with_upnp:--without-upnp}
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install example/sock{s,d}.conf $RPM_BUILD_ROOT%{_sysconfdir}
125
126 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/sockd
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %post server
135 /sbin/chkconfig --add sockd
136 if [ -f /var/lock/subsys/sockd ]; then
137         /etc/rc.d/init.d/sockd restart 1>&2
138 else
139         echo "Run \"/etc/rc.d/init.d/sockd start\" to start dante sockd daemon."
140 fi
141
142 %postun server
143 if [ "$1" = "0" ]; then
144         if [ -f /var/lock/subsys/sockd ]; then
145                 /etc/rc.d/init.d/sockd stop 1>&2
146         fi
147         /sbin/chkconfig --del sockd
148 fi
149
150 %files
151 %defattr(644,root,root,755)
152 %doc BUGS CREDITS LICENSE NEWS README SUPPORT UPGRADE
153 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/socks.conf
154 %attr(755,root,root) %{_libdir}/libsocks.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libsocks.so.0
156 %attr(755,root,root) %{_libdir}/libdsocks.so
157 %attr(755,root,root) %{_bindir}/socksify
158 %{_mandir}/man5/socks.conf.5*
159 %{_mandir}/man1/socksify.1*
160
161 %files server
162 %defattr(644,root,root,755)
163 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sockd.conf
164 %attr(754,root,root) /etc/rc.d/init.d/sockd
165 %attr(755,root,root) %{_sbindir}/sockd
166 %{_mandir}/man8/sockd.8*
167 %{_mandir}/man5/sockd.conf.5*
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libsocks.so
172 %{_libdir}/libsocks.la
173 %{_libdir}/libdsocks.la
174 %{_includedir}/socks.h
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libsocks.a
This page took 0.754408 seconds and 2 git commands to generate.