]> git.pld-linux.org Git - packages/dahdi-tools.git/blob - dahdi-tools.spec
61ae722a88a77b70ac1c7e70e457fb8a356d46d3
[packages/dahdi-tools.git] / dahdi-tools.spec
1 # TODO:
2 # warning: Installed (but unpackaged) file(s) found:
3 #    /etc/hotplug/usb/xpp_fxloader
4 #    /etc/hotplug/usb/xpp_fxloader.usermap
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        DAHDI telephony device support
8 Summary(pl.UTF-8):      Obsługa urządzeń telefonicznych DAHDI
9 Name:           dahdi-tools
10 Version:        2.7.0.1
11 Release:        1
12 License:        GPL v2
13 Group:          Base/Kernel
14 Source0:        http://downloads.asterisk.org/pub/telephony/dahdi-tools/%{name}-%{version}.tar.gz
15 # Source0-md5:  a0de4eb4e5f556441a3ded8e88d7d321
16 Source1:        dahdi.init
17 Source2:        dahdi.sysconfig
18 Patch0:         %{name}-as-needed.patch
19 Patch1:         %{name}-perl-path.patch
20 Patch2:         %{name}-includes.patch
21 URL:            http://www.asterisk.org/
22 BuildRequires:  dahdi-linux-devel >= 2.3.0
23 BuildRequires:  libusb-compat-devel >= 0.1
24 BuildRequires:  newt-devel
25 BuildRequires:  perl-base
26 BuildRequires:  perl-tools-pod
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.379
29 Obsoletes:      dahdi-tools-utils
30 Obsoletes:      zaptel
31 Obsoletes:      zaptel-utils
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 DAHDI telephony device driver.
36
37 %description -l pl.UTF-8
38 Sterownik do urządzeń telefonicznych DAHDI.
39
40 %package devel
41 Summary:        DAHDI development headers
42 Summary(pl.UTF-8):      Pliki nagłówkowe DAHDI
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       dahdi-linux-devel
46 Obsoletes:      zaptel-devel
47
48 %description devel
49 DAHDI development headers.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe DAHDI.
53
54 %package static
55 Summary:        DAHDI static library
56 Summary(pl.UTF-8):      Biblioteka statyczna DAHDI
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 DAHDI static library.
62
63 %description static -l pl.UTF-8
64 Biblioteka statyczna DAHDI.
65
66 %package perl
67 Summary:        DAHDI utility programs written in Perl
68 Summary(pl.UTF-8):      Programy narzędziowe DAHDI napisane w Perlu
69 Group:          Applications/Communications
70 Requires:       perl-Dahdi = %{version}-%{release}
71
72 %description perl
73 DAHDI utility programs written in Perl.
74
75 %description perl -l pl.UTF-8
76 Programy narzędziowe DAHDI napisane w Perlu.
77
78 %package init
79 Summary:        DAHDI init scripts
80 Summary(pl.UTF-8):      Skrypty inicjalizujące DAHDI
81 Group:          Applications/Communications
82 Requires(post,preun):   /sbin/chkconfig
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       rc-scripts
85 Obsoletes:      zaptel-init
86
87 %description init
88 DAHDI boot-time initialization.
89
90 %description init -l pl.UTF-8
91 Inicjalizacja DAHDI w czasie startu systemu.
92
93 %package -n perl-Dahdi
94 Summary:        Perl interface to DAHDI
95 Summary(pl.UTF-8):      Perlowy interfejs do DAHDI
96 Group:          Development/Languages/Perl
97 # needs dahdi_scan
98 Requires:       %{name} = %{version}-%{release}
99
100 %description -n perl-Dahdi
101 Perl inferface to DAHDI.
102
103 %description -n perl-Dahdi -l pl.UTF-8
104 Perlowy interfejs do DAHDI.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111
112 cat > download-logger <<'EOF'
113 #!/bin/sh
114 # keep log of files make wanted to download in firmware/ dir
115 echo "$@" >> download.log
116 EOF
117 chmod a+rx download-logger
118
119 %build
120 %configure
121 %{__make} \
122         CC="%{__cc}" \
123         OPTFLAGS="%{rpmcppflags} %{rpmcflags}"
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
129
130 %{__make} -j1 install \
131         DESTDIR=$RPM_BUILD_ROOT
132 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dahdi
133 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/dahdi
134 touch $RPM_BUILD_ROOT%{_sysconfdir}/dahdi.conf
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post init
140 /sbin/chkconfig --add dahdi
141 %service dahdi restart
142
143 %preun init
144 if [ "$1" = "0" ]; then
145         %service dahdi stop
146         /sbin/chkconfig --del dahdi
147 fi
148
149 %files
150 %defattr(644,root,root,755)
151 %doc README
152 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dahdi.conf
153 %dir %{_sysconfdir}/dahdi
154 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dahdi/system.conf
155 #/etc/hotplug/usb/xpp_fxloader
156 #/etc/hotplug/usb/xpp_fxloader.usermap
157 %attr(755,root,root) %{_sbindir}/astribank_*
158 %attr(755,root,root) %{_sbindir}/dahdi_cfg
159 %attr(755,root,root) %{_sbindir}/dahdi_maint
160 %attr(755,root,root) %{_sbindir}/dahdi_monitor
161 %attr(755,root,root) %{_sbindir}/dahdi_scan
162 %attr(755,root,root) %{_sbindir}/dahdi_speed
163 %attr(755,root,root) %{_sbindir}/dahdi_test
164 %attr(755,root,root) %{_sbindir}/dahdi_tool
165 %attr(755,root,root) %{_sbindir}/fxotune
166 %attr(755,root,root) %{_sbindir}/sethdlc
167 %attr(755,root,root) %{_libdir}/libtonezone.so.1.*
168 %attr(755,root,root) %ghost %{_libdir}/libtonezone.so.1
169 %attr(755,root,root) %{_libdir}/libtonezone.so.2.*
170 %attr(755,root,root) %ghost %{_libdir}/libtonezone.so.2
171 %{_datadir}/dahdi
172 %{_mandir}/man8/astribank_*.8*
173 %{_mandir}/man8/dahdi_cfg.8*
174 %{_mandir}/man8/dahdi_maint.8*
175 %{_mandir}/man8/dahdi_monitor.8*
176 %{_mandir}/man8/dahdi_scan.8*
177 %{_mandir}/man8/dahdi_test.8*
178 %{_mandir}/man8/dahdi_tool.8*
179 %{_mandir}/man8/fxotune.8*
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libtonezone.so
184 %{_includedir}/dahdi/tonezone.h
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libtonezone.a
189
190 %files perl
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_sbindir}/dahdi_genconf
193 %attr(755,root,root) %{_sbindir}/dahdi_hardware
194 %attr(755,root,root) %{_sbindir}/dahdi_registration
195 %attr(755,root,root) %{_sbindir}/lsdahdi
196 %attr(755,root,root) %{_sbindir}/twinstar
197 %attr(755,root,root) %{_sbindir}/xpp_blink
198 %attr(755,root,root) %{_sbindir}/xpp_sync
199 %{_mandir}/man8/dahdi_genconf.8*
200 %{_mandir}/man8/dahdi_hardware.8*
201 %{_mandir}/man8/dahdi_registration.8*
202 %{_mandir}/man8/lsdahdi.8*
203 %{_mandir}/man8/twinstar.8*
204 %{_mandir}/man8/xpp_blink.8*
205 %{_mandir}/man8/xpp_sync.8*
206
207 %files init
208 %defattr(644,root,root,755)
209 %attr(754,root,root) /etc/rc.d/init.d/dahdi
210 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dahdi
211
212 %files -n perl-Dahdi
213 %defattr(644,root,root,755)
214 %{perl_vendorlib}/Dahdi
215 %{perl_vendorlib}/Dahdi.pm
This page took 0.077191 seconds and 3 git commands to generate.