]> git.pld-linux.org Git - packages/dahdi-linux.git/blobdiff - dahdi-linux.spec
- fix building kernel modules for 5.18
[packages/dahdi-linux.git] / dahdi-linux.spec
index e8b91a9f960f2e2c01c4defe277a919f6a078eb4..8567e498caa5a75fef2b94913c07c8ce944bb3cf 100644 (file)
 #   unpackaged module: drivers/dahdi/xpp/xpp_usb
 #
 # Conditional build:
-%bcond_without dist_kernel     # without distribution kernel
 %bcond_without  kernel         # don't build kernel modules
 %bcond_with    oslec           # with Open Source Line Echo Canceller
 %bcond_without xpp             # without Astribank
 %bcond_without userspace       # don't build userspace packages
 %bcond_with    verbose
 
-%if "%{_alt_kernel}" != "%{nil}"
-%undefine      with_userspace
-%endif
-
-%ifarch sparc
-%undefine      with_smp
-%endif
 %ifarch alpha
 %undefine      with_xpp
 %endif
-%if %{without kernel}
-%undefine      with_dist_kernel
+
+# The goal here is to have main, userspace, package built once with
+# simple release number, and only rebuild kernel packages with kernel
+# version as part of release number, without the need to bump release
+# with every kernel change.
+%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
+%{error:kernel and userspace cannot be built at the same time on PLD builders}
+exit 1
 %endif
 
-%define                rel     7
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+
+%define                rel     8
 %define                pname   dahdi-linux
 %define                FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
 Summary:       DAHDI telephony device support
 Summary(pl.UTF-8):     Obsługa urządzeń telefonicznych DAHDI
-Name:          %{pname}%{_alt_kernel}
-Version:       2.7.0.1
-Release:       %{rel}
+Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
+Version:       3.1.0
+Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
-# Source0-md5: bd91e46c60b6cdcdee95d7b0fec45e32
+# Source0-md5: 17d7542e613afd6cf860516fe785d56c
 Source3:       %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
 # Source3-md5: 88db9b7a07d8392736171b1b3e6bcc66
 Source4:       %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
@@ -54,12 +55,19 @@ Source6:    %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
 # Source6-md5: 2ea860bb8a9d8ede2858b9557b74ee3c
 Source7:       %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
 # Source7-md5: a7f3886942bb3e9fed349a41b3390c9f
+Patch0:                kernel-4.14.patch
+Patch1:                kernel-5.4.patch
+Patch2:                math64.patch
+Patch3:                kernel-5.6.patch
+Patch4:                kernel-5.9.patch
+Patch5:                kernel-4.9.256.patch
+Patch6:                nostdinc.patch
+Patch7:                kernel-5.17.patch
+Patch8:                kernel-5.18.patch
 URL:           http://www.asterisk.org/
-%if %{with dist_kernel}
-BuildRequires: kernel%{_alt_kernel}-module-build
-%endif
+%{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
 BuildRequires: perl-base
-BuildRequires: rpmbuild(macros) >= 1.379
+BuildRequires: rpmbuild(macros) >= 1.701
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # Rules:
@@ -68,10 +76,11 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # - keep X and X_in in sync
 # - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
 
-%define        modules_1       dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_ethmf.o dahdi_dynamic_loc.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o pciradio.o tor2.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o
-%define        modules_1_in    dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_ethmf,dahdi_dynamic_loc,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,pciradio,tor2,wcfxo,wct1xxp,wctdm,wcte11xp
-%define        modules_2       voicebus/ wct4xxp/ wcte12xp/ %{?with_xpp:xpp/}
-%define        modules_2_in    voicebus/dahdi_voicebus,wct4xxp/wct4xxp,wcte12xp/wcte12xp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_echo,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
+%define        modules_1       dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_ethmf.o dahdi_dynamic_loc.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o wcaxx.o wcte13xp.o wcte43x.o
+%define        modules_1_in    dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_ethmf,dahdi_dynamic_loc,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,wcaxx,wcte13xp,wcte43x
+%define        modules_2       voicebus/ oct612x/ wct4xxp/ %{?with_xpp:xpp/}
+%define        modules_2_in    voicebus/dahdi_voicebus,oct612x/oct612x,wct4xxp/wct4xxp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_echo,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
+
 %ifnarch alpha
 %define        modules_nalpha  wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
 %define        modules_nalpha_in       wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
@@ -96,40 +105,73 @@ Header files for dahdi interface.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe interfejsu dahdi.
 
-%package udev
-Summary:       udev rules for DAHDI kernel modules
-Summary(pl.UTF-8):     Reguły udev dla modułów jądra Linuksa dla DAHDI
-Release:       %{rel}
-Group:         Base/Kernel
-Requires:      dahdi-tools >= 2.2.0
-Requires:      udev-core
-
-%description udev
-udev rules for DAHDI kernel modules.
-
-%description udev -l pl.UTF-8
-Reguły udev dla modułów jądra Linuksa dla DAHDI.
-
-%package -n kernel%{_alt_kernel}-%{pname}
-Summary:       DAHDI Linux kernel driver
-Summary(pl.UTF-8):     Sterownik DAHDI dla jądra Linuksa
-Release:       %{rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-Requires(post,postun): /sbin/depmod
-%if %{with dist_kernel}
-%requires_releq_kernel
-Requires(postun):      %releq_kernel
-%{?with_oslec:Requires:        kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}
-%endif
-
-%description -n kernel%{_alt_kernel}-%{pname}
-DAHDI telephony Linux kernel driver.
-
-%description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8
-Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.
+%define        kernel_pkg()\
+%package -n kernel%{_alt_kernel}-%{pname}\
+Summary:       DAHDI Linux kernel driver\
+Summary(pl.UTF-8):     Sterownik DAHDI dla jądra Linuksa\
+Release:       %{rel}@%{_kernel_ver_str}\
+Group:         Base/Kernel\
+Requires(post,postun): /sbin/depmod\
+%requires_releq_kernel\
+Requires(postun):      %releq_kernel\
+%{?with_oslec:Requires:        kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}\
+\
+%description -n kernel%{_alt_kernel}-%{pname}\
+DAHDI telephony Linux kernel driver.\
+\
+%description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8\
+Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.\
+\
+%if %{with kernel}\
+%files -n kernel%{_alt_kernel}-%{pname}\
+%defattr(644,root,root,755)\
+/lib/modules/%{_kernel_ver}/misc/dahdi*.ko*\
+/lib/modules/%{_kernel_ver}/misc/wcb4xxp.ko*\
+/lib/modules/%{_kernel_ver}/misc/wct4xxp.ko*\
+/lib/modules/%{_kernel_ver}/misc/wctc4xxp.ko*\
+/lib/modules/%{_kernel_ver}/misc/wctdm24xxp.ko*\
+/lib/modules/%{_kernel_ver}/misc/wcte13xp.ko*\
+/lib/modules/%{_kernel_ver}/misc/oct612x.ko*\
+/lib/modules/%{_kernel_ver}/misc/wcaxx.ko*\
+/lib/modules/%{_kernel_ver}/misc/wcte43x.ko*\
+%if %{with xpp}\
+/lib/modules/%{_kernel_ver}/misc/xpd_*.ko*\
+/lib/modules/%{_kernel_ver}/misc/xpp.ko*\
+/lib/modules/%{_kernel_ver}/misc/xpp_usb.ko*\
+%endif\
+%endif\
+\
+%post -n kernel%{_alt_kernel}-%{pname}\
+%depmod %{_kernel_ver}\
+\
+%postun -n kernel%{_alt_kernel}-%{pname}\
+%depmod %{_kernel_ver}\
+%{nil}
+
+%define build_kernel_pkg()\
+%if %{with kernel}\
+%build_kernel_modules V=1 SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include\
+cd drivers/dahdi\
+%install_kernel_modules -D ../../installed -m %{modules_in} -d misc\
+cd ../..\
+%endif\
+%{nil}
+
+%{?with_kernel:%{expand:%create_kernel_packages}}
 
 %prep
 %setup -q -n %{pname}-%{version}
+%patch0 -p1
+%patch1 -p1
+%ifarch %{ix86}
+%patch2 -p1
+%endif
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
        ln -s $a drivers/dahdi/firmware
@@ -146,67 +188,26 @@ chmod a+rx download-logger
 %build
 %{__make} include/dahdi/version.h
 
-%if %{with kernel}
-# hack: build library first (using explicit "lib" target), then modules without cleaning (-c)
-%build_kernel_modules lib SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi/oct612x DAHDI_INCLUDE=$PWD/../../include
-
-%build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include -c
-%endif
+%{?with_kernel:%{expand:%build_kernel_packages}}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-mkdir $RPM_BUILD_ROOT%{_includedir}/dahdi -p
-%if %{with kernel}
-cd drivers/dahdi
-%install_kernel_modules -m %{modules_in} -d misc
-cd ../..
-%endif
+install -d $RPM_BUILD_ROOT%{_includedir}/dahdi
 
 %if %{with userspace}
-install -d $RPM_BUILD_ROOT/etc/udev/rules.d
-
-%{__make} install-devices install-include \
+%{__make} install-include \
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
+%if %{with kernel}
+cp -a installed/* $RPM_BUILD_ROOT
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -n kernel%{_alt_kernel}-%{pname}
-%depmod %{_kernel_ver}
-
-%postun -n kernel%{_alt_kernel}-%{pname}
-%depmod %{_kernel_ver}
-
 %if %{with userspace}
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/dahdi
-
-%files udev
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/dahdi.rules
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xpp.rules
-%endif
-
-%if %{with kernel}
-%files -n kernel%{_alt_kernel}-%{pname}
-%defattr(644,root,root,755)
-/lib/modules/%{_kernel_ver}/misc/dahdi*.ko*
-/lib/modules/%{_kernel_ver}/misc/pciradio.ko*
-/lib/modules/%{_kernel_ver}/misc/tor2.ko*
-/lib/modules/%{_kernel_ver}/misc/wcb4xxp.ko*
-/lib/modules/%{_kernel_ver}/misc/wcfxo.ko*
-/lib/modules/%{_kernel_ver}/misc/wct1xxp.ko*
-/lib/modules/%{_kernel_ver}/misc/wct4xxp.ko*
-/lib/modules/%{_kernel_ver}/misc/wctc4xxp.ko*
-/lib/modules/%{_kernel_ver}/misc/wctdm.ko*
-/lib/modules/%{_kernel_ver}/misc/wctdm24xxp.ko*
-/lib/modules/%{_kernel_ver}/misc/wcte11xp.ko*
-/lib/modules/%{_kernel_ver}/misc/wcte12xp.ko*
-%if %{with xpp}
-/lib/modules/%{_kernel_ver}/misc/xpd_*.ko*
-/lib/modules/%{_kernel_ver}/misc/xpp.ko*
-/lib/modules/%{_kernel_ver}/misc/xpp_usb.ko*
-%endif
 %endif
This page took 0.154404 seconds and 4 git commands to generate.