]> git.pld-linux.org Git - packages/dahdi-linux.git/blame - dahdi-linux.spec
- rebuild for kernel-3.7.5-1
[packages/dahdi-linux.git] / dahdi-linux.spec
CommitLineData
563fc4ec 1#
2# TODO:
f50e30c4 3# - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
cc9ccfe5 4# - Fix --without xpp:
5# + check_modules
6# unpackaged module: drivers/dahdi/xpp/xpd_bri
7# unpackaged module: drivers/dahdi/xpp/xpd_fxo
8# unpackaged module: drivers/dahdi/xpp/xpd_fxs
9# unpackaged module: drivers/dahdi/xpp/xpd_pri
10# unpackaged module: drivers/dahdi/xpp/xpp
11# unpackaged module: drivers/dahdi/xpp/xpp_usb
563fc4ec 12#
563fc4ec 13# Conditional build:
14%bcond_without dist_kernel # without distribution kernel
f3ae6389 15%bcond_without kernel # don't build kernel modules
563fc4ec 16%bcond_with oslec # with Open Source Line Echo Canceller
563fc4ec 17%bcond_without xpp # without Astribank
56c839b0 18%bcond_without userspace # don't build userspace packages
563fc4ec 19%bcond_with verbose
20
56c839b0 21%if "%{_alt_kernel}" != "%{nil}"
22%undefine with_userspace
23%endif
24
563fc4ec 25%ifarch sparc
26%undefine with_smp
27%endif
28%ifarch alpha
29%undefine with_xpp
30%endif
f3ae6389 31%if %{without kernel}
32%undefine with_dist_kernel
33%endif
563fc4ec 34
94613715 35%define rel 2
563fc4ec 36%define pname dahdi-linux
37%define FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
38Summary: DAHDI telephony device support
39Summary(pl.UTF-8): Obsługa urządzeń telefonicznych DAHDI
40Name: %{pname}%{_alt_kernel}
3f765485 41Version: 2.6.1
b800683f 42Release: %{rel}
563fc4ec 43License: GPL
44Group: Base/Kernel
64471470 45Source0: http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
3f765485 46# Source0-md5: 75932fe3d4a6e656165aaaa7a1377305
563fc4ec 47Source3: %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
48# Source3-md5: 88db9b7a07d8392736171b1b3e6bcc66
49Source4: %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
50# Source4-md5: c1f1a18d3e20d283f42c71e580a64b5a
51Source5: %{FIRMWARE_URL}/dahdi-fw-vpmadt032-1.07.tar.gz
52# Source5-md5: e1c7231d6225ac999cb18f4e858f66b6
53Source6: %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
54# Source6-md5: 2ea860bb8a9d8ede2858b9557b74ee3c
d2a401d3 55Source7: %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
56# Source7-md5: a7f3886942bb3e9fed349a41b3390c9f
8be0f738 57Patch0: %{pname}-build.patch
e4bd3df2 58# http://oss.axsentis.de/people/stkn/openzap/dahdi-2.4.0-linux-2.6.37.patch
563fc4ec 59URL: http://www.asterisk.org/
f877d867 60%if %{with dist_kernel}
563fc4ec 61BuildRequires: kernel%{_alt_kernel}-module-build
563fc4ec 62%endif
563fc4ec 63BuildRequires: perl-base
563fc4ec 64BuildRequires: rpmbuild(macros) >= 1.379
563fc4ec 65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67# Rules:
68# - modules_X: single modules, just name module with no suffix
69# - modules_X: subdir modules are just directory name with slash like dirname/
70# - keep X and X_in in sync
71# - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
72
8be0f738 73%define modules_1 dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_ethmf.o dahdi_dynamic_loc.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o pciradio.o tor2.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o
74%define modules_1_in dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_ethmf,dahdi_dynamic_loc,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,pciradio,tor2,wcfxo,wct1xxp,wctdm,wcte11xp
d2a401d3 75%define modules_2 voicebus/ wct4xxp/ wcte12xp/ %{?with_xpp:xpp/}
141723f4 76%define modules_2_in voicebus/dahdi_voicebus,wct4xxp/wct4xxp,wcte12xp/wcte12xp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_echo,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
563fc4ec 77%ifnarch alpha
78%define modules_nalpha wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
79%define modules_nalpha_in wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
563fc4ec 80%endif
b800683f 81%define modules %{modules_1} %{modules_2}%{?modules_nalpha: %{modules_nalpha}}
82%define modules_in %{modules_1_in},%{modules_2_in}%{?modules_nalpha:,%{modules_nalpha_in}}
563fc4ec 83
84%description
85DAHDI telephony device driver.
86
87%description -l pl.UTF-8
88Sterownik do urządzeń telefonicznych DAHDI.
89
90%package devel
91Summary: Header files for dahdi interface
3f765485 92Summary(pl.UTF-8): Pliki nagłówkowe interfejsu dahdi
563fc4ec 93Group: Development/Libraries
563fc4ec 94
95%description devel
96Header files for dahdi interface.
97
3f765485
JB
98%description devel -l pl.UTF-8
99Pliki nagłówkowe interfejsu dahdi.
100
b448351d 101%package udev
102Summary: udev rules for DAHDI kernel modules
103Summary(pl.UTF-8): Reguły udev dla modułów jądra Linuksa dla DAHDI
104Release: %{rel}
105Group: Base/Kernel
6e3c0f33 106Requires: dahdi-tools >= 2.2.0
b448351d 107Requires: udev-core
108
109%description udev
110udev rules for DAHDI kernel modules.
111
112%description udev -l pl.UTF-8
113Reguły udev dla modułów jądra Linuksa dla DAHDI.
114
563fc4ec 115%package -n kernel%{_alt_kernel}-%{pname}
116Summary: DAHDI Linux kernel driver
117Summary(pl.UTF-8): Sterownik DAHDI dla jądra Linuksa
118Release: %{rel}@%{_kernel_ver_str}
119Group: Base/Kernel
120Requires(post,postun): /sbin/depmod
121%if %{with dist_kernel}
122%requires_releq_kernel
123Requires(postun): %releq_kernel
124%{?with_oslec:Requires: kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}
125%endif
126
127%description -n kernel%{_alt_kernel}-%{pname}
128DAHDI telephony Linux kernel driver.
129
130%description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8
131Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.
132
133%prep
134%setup -q -n %{pname}-%{version}
c278c563 135%patch0 -p1
563fc4ec 136
d2a401d3 137for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
563fc4ec 138 ln -s $a drivers/dahdi/firmware
139 tar -C drivers/dahdi/firmware -xzf $a
140done
141
142cat > download-logger <<'EOF'
143#!/bin/sh
144# keep log of files make wanted to download in firmware/ dir
145echo "$@" >> download.log
146EOF
147chmod a+rx download-logger
148
149%build
150%{__make} include/dahdi/version.h
151
f3ae6389 152%if %{with kernel}
f877d867 153%build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include
563fc4ec 154
9f74732a
ER
155# check that all built .ko is handled by build_kernel_modules
156# (renamed to either -dist, -up, or -smp suffix)
157# if some missing, check the 'modules*' macros above
563fc4ec 158check_modules() {
159 err=0
160 for a in drivers/dahdi/{*/,}*.ko; do
161 [[ $a = *-dist.ko ]] && continue
162 [[ $a = *-up.ko ]] && continue
163 [[ $a = *-smp.ko ]] && continue
164 echo >&2 "unpackaged module: ${a%.ko}"
165 err=1
166 done
167
168 [ $err = 0 ] || exit 1
169}
60ab0550 170#check_modules
f3ae6389 171%endif
563fc4ec 172
173%install
174rm -rf $RPM_BUILD_ROOT
175mkdir $RPM_BUILD_ROOT%{_includedir}/dahdi -p
f3ae6389 176%if %{with kernel}
563fc4ec 177cd drivers/dahdi
178%install_kernel_modules -m %{modules_in} -d misc
179cd ../..
f3ae6389 180%endif
563fc4ec 181
56c839b0 182%if %{with userspace}
b448351d 183install -d $RPM_BUILD_ROOT/etc/udev/rules.d
184
3f765485
JB
185%{__make} install-devices install-include \
186 DESTDIR=$RPM_BUILD_ROOT
56c839b0 187%endif
563fc4ec 188
189%clean
190rm -rf $RPM_BUILD_ROOT
191
192%post -n kernel%{_alt_kernel}-%{pname}
193%depmod %{_kernel_ver}
194
195%postun -n kernel%{_alt_kernel}-%{pname}
196%depmod %{_kernel_ver}
197
56c839b0 198%if %{with userspace}
563fc4ec 199%files devel
b603dc42 200%defattr(644,root,root,755)
563fc4ec 201%{_includedir}/dahdi
202
b448351d 203%files udev
204%defattr(644,root,root,755)
205%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/dahdi.rules
206%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xpp.rules
56c839b0 207%endif
b448351d 208
f3ae6389 209%if %{with kernel}
563fc4ec 210%files -n kernel%{_alt_kernel}-%{pname}
211%defattr(644,root,root,755)
212/lib/modules/%{_kernel_ver}/misc/*.ko*
f3ae6389 213%endif
This page took 0.060411 seconds and 4 git commands to generate.