]> git.pld-linux.org Git - packages/dahdi-linux.git/blame - dahdi-linux.spec
- release 8
[packages/dahdi-linux.git] / dahdi-linux.spec
CommitLineData
563fc4ec 1#
2# TODO:
f50e30c4 3# - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
cc9ccfe5 4# - Fix --without xpp:
5# + check_modules
6# unpackaged module: drivers/dahdi/xpp/xpd_bri
7# unpackaged module: drivers/dahdi/xpp/xpd_fxo
8# unpackaged module: drivers/dahdi/xpp/xpd_fxs
9# unpackaged module: drivers/dahdi/xpp/xpd_pri
10# unpackaged module: drivers/dahdi/xpp/xpp
11# unpackaged module: drivers/dahdi/xpp/xpp_usb
563fc4ec 12#
563fc4ec 13# Conditional build:
14%bcond_without dist_kernel # without distribution kernel
f3ae6389 15%bcond_without kernel # don't build kernel modules
563fc4ec 16%bcond_with oslec # with Open Source Line Echo Canceller
563fc4ec 17%bcond_without xpp # without Astribank
56c839b0 18%bcond_without userspace # don't build userspace packages
563fc4ec 19%bcond_with verbose
20
56c839b0 21%if "%{_alt_kernel}" != "%{nil}"
22%undefine with_userspace
23%endif
24
563fc4ec 25%ifarch sparc
26%undefine with_smp
27%endif
28%ifarch alpha
29%undefine with_xpp
30%endif
f3ae6389 31%if %{without kernel}
32%undefine with_dist_kernel
33%endif
563fc4ec 34
0d8020df 35%define rel 8
563fc4ec 36%define pname dahdi-linux
37%define FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
38Summary: DAHDI telephony device support
39Summary(pl.UTF-8): Obsługa urządzeń telefonicznych DAHDI
40Name: %{pname}%{_alt_kernel}
8e2ce037 41Version: 2.6.0
b800683f 42Release: %{rel}
563fc4ec 43License: GPL
44Group: Base/Kernel
64471470 45Source0: http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
8e2ce037 46# Source0-md5: ea35ad29dafe5490028ff642c35ef9a2
563fc4ec 47Source3: %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
48# Source3-md5: 88db9b7a07d8392736171b1b3e6bcc66
49Source4: %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
50# Source4-md5: c1f1a18d3e20d283f42c71e580a64b5a
51Source5: %{FIRMWARE_URL}/dahdi-fw-vpmadt032-1.07.tar.gz
52# Source5-md5: e1c7231d6225ac999cb18f4e858f66b6
53Source6: %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
54# Source6-md5: 2ea860bb8a9d8ede2858b9557b74ee3c
d2a401d3 55Source7: %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
56# Source7-md5: a7f3886942bb3e9fed349a41b3390c9f
8be0f738 57Patch0: %{pname}-build.patch
e4bd3df2 58# http://oss.axsentis.de/people/stkn/openzap/dahdi-2.4.0-linux-2.6.37.patch
8be0f738 59Patch1: dahdi-2.4.0-linux-2.6.37.patch
563fc4ec 60URL: http://www.asterisk.org/
f877d867 61%if %{with dist_kernel}
563fc4ec 62BuildRequires: kernel%{_alt_kernel}-module-build
563fc4ec 63%endif
563fc4ec 64BuildRequires: perl-base
563fc4ec 65BuildRequires: rpmbuild(macros) >= 1.379
563fc4ec 66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68# Rules:
69# - modules_X: single modules, just name module with no suffix
70# - modules_X: subdir modules are just directory name with slash like dirname/
71# - keep X and X_in in sync
72# - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
73
8be0f738 74%define modules_1 dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_ethmf.o dahdi_dynamic_loc.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o pciradio.o tor2.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o
75%define modules_1_in dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_ethmf,dahdi_dynamic_loc,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,pciradio,tor2,wcfxo,wct1xxp,wctdm,wcte11xp
d2a401d3 76%define modules_2 voicebus/ wct4xxp/ wcte12xp/ %{?with_xpp:xpp/}
141723f4 77%define modules_2_in voicebus/dahdi_voicebus,wct4xxp/wct4xxp,wcte12xp/wcte12xp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_echo,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
563fc4ec 78%ifnarch alpha
79%define modules_nalpha wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
80%define modules_nalpha_in wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
563fc4ec 81%endif
b800683f 82%define modules %{modules_1} %{modules_2}%{?modules_nalpha: %{modules_nalpha}}
83%define modules_in %{modules_1_in},%{modules_2_in}%{?modules_nalpha:,%{modules_nalpha_in}}
563fc4ec 84
85%description
86DAHDI telephony device driver.
87
88%description -l pl.UTF-8
89Sterownik do urządzeń telefonicznych DAHDI.
90
91%package devel
92Summary: Header files for dahdi interface
93Group: Development/Libraries
94# if base package contains shared library for which these headers are
95#Requires: %{name} = %{version}-%{release}
96# if -libs package contains shared library for which these headers are
97#Requires: %{name}-libs = %{version}-%{release}
98
99%description devel
100Header files for dahdi interface.
101
b448351d 102%package udev
103Summary: udev rules for DAHDI kernel modules
104Summary(pl.UTF-8): Reguły udev dla modułów jądra Linuksa dla DAHDI
105Release: %{rel}
106Group: Base/Kernel
6e3c0f33 107Requires: dahdi-tools >= 2.2.0
b448351d 108Requires: udev-core
109
110%description udev
111udev rules for DAHDI kernel modules.
112
113%description udev -l pl.UTF-8
114Reguły udev dla modułów jądra Linuksa dla DAHDI.
115
563fc4ec 116%package -n kernel%{_alt_kernel}-%{pname}
117Summary: DAHDI Linux kernel driver
118Summary(pl.UTF-8): Sterownik DAHDI dla jądra Linuksa
119Release: %{rel}@%{_kernel_ver_str}
120Group: Base/Kernel
121Requires(post,postun): /sbin/depmod
122%if %{with dist_kernel}
123%requires_releq_kernel
124Requires(postun): %releq_kernel
125%{?with_oslec:Requires: kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}
126%endif
127
128%description -n kernel%{_alt_kernel}-%{pname}
129DAHDI telephony Linux kernel driver.
130
131%description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8
132Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.
133
134%prep
135%setup -q -n %{pname}-%{version}
c278c563 136%patch0 -p1
8be0f738 137#%patch1 -p1
563fc4ec 138
d2a401d3 139for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
563fc4ec 140 ln -s $a drivers/dahdi/firmware
141 tar -C drivers/dahdi/firmware -xzf $a
142done
143
144cat > download-logger <<'EOF'
145#!/bin/sh
146# keep log of files make wanted to download in firmware/ dir
147echo "$@" >> download.log
148EOF
149chmod a+rx download-logger
150
151%build
152%{__make} include/dahdi/version.h
153
f3ae6389 154%if %{with kernel}
f877d867 155%build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include
563fc4ec 156
157check_modules() {
158 err=0
159 for a in drivers/dahdi/{*/,}*.ko; do
160 [[ $a = *-dist.ko ]] && continue
161 [[ $a = *-up.ko ]] && continue
162 [[ $a = *-smp.ko ]] && continue
163 echo >&2 "unpackaged module: ${a%.ko}"
164 err=1
165 done
166
167 [ $err = 0 ] || exit 1
168}
60ab0550 169#check_modules
f3ae6389 170%endif
563fc4ec 171
172%install
173rm -rf $RPM_BUILD_ROOT
174mkdir $RPM_BUILD_ROOT%{_includedir}/dahdi -p
f3ae6389 175%if %{with kernel}
563fc4ec 176cd drivers/dahdi
177%install_kernel_modules -m %{modules_in} -d misc
178cd ../..
f3ae6389 179%endif
563fc4ec 180
56c839b0 181%if %{with userspace}
b448351d 182install -d $RPM_BUILD_ROOT/etc/udev/rules.d
183
184%{make} \
185 DESTDIR=$RPM_BUILD_ROOT \
186 install-devices \
187 install-include
56c839b0 188%endif
563fc4ec 189
190%clean
191rm -rf $RPM_BUILD_ROOT
192
193%post -n kernel%{_alt_kernel}-%{pname}
194%depmod %{_kernel_ver}
195
196%postun -n kernel%{_alt_kernel}-%{pname}
197%depmod %{_kernel_ver}
198
56c839b0 199%if %{with userspace}
563fc4ec 200%files devel
b603dc42 201%defattr(644,root,root,755)
563fc4ec 202%{_includedir}/dahdi
203
b448351d 204%files udev
205%defattr(644,root,root,755)
206%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/dahdi.rules
207%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xpp.rules
56c839b0 208%endif
b448351d 209
f3ae6389 210%if %{with kernel}
563fc4ec 211%files -n kernel%{_alt_kernel}-%{pname}
212%defattr(644,root,root,755)
213/lib/modules/%{_kernel_ver}/misc/*.ko*
f3ae6389 214%endif
This page took 0.089535 seconds and 4 git commands to generate.