]> git.pld-linux.org Git - packages/dahdi-linux.git/blame - dahdi-linux.spec
- added fixes from upstream, now it builds with 2.6.31
[packages/dahdi-linux.git] / dahdi-linux.spec
CommitLineData
563fc4ec 1#
2# TODO:
f50e30c4 3# - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
563fc4ec 4#
563fc4ec 5# Conditional build:
6%bcond_without dist_kernel # without distribution kernel
7%bcond_with oslec # with Open Source Line Echo Canceller
563fc4ec 8%bcond_without xpp # without Astribank
9%bcond_with verbose
10
11%ifarch sparc
12%undefine with_smp
13%endif
14%ifarch alpha
15%undefine with_xpp
16%endif
17
39ecdd6c 18%define rel 1
563fc4ec 19%define pname dahdi-linux
20%define FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
21Summary: DAHDI telephony device support
22Summary(pl.UTF-8): Obsługa urządzeń telefonicznych DAHDI
23Name: %{pname}%{_alt_kernel}
39ecdd6c 24Version: 2.2.0.2
b800683f 25Release: %{rel}
563fc4ec 26License: GPL
27Group: Base/Kernel
b603dc42 28Source0: http://downloads.digium.com/pub/telephony/dahdi-linux/dahdi-linux-%{version}.tar.gz
39ecdd6c 29# Source0-md5: 1f932729ad28f2f028afcf2cc5ccf7ba
563fc4ec 30Source3: %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
31# Source3-md5: 88db9b7a07d8392736171b1b3e6bcc66
32Source4: %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
33# Source4-md5: c1f1a18d3e20d283f42c71e580a64b5a
34Source5: %{FIRMWARE_URL}/dahdi-fw-vpmadt032-1.07.tar.gz
35# Source5-md5: e1c7231d6225ac999cb18f4e858f66b6
36Source6: %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
37# Source6-md5: 2ea860bb8a9d8ede2858b9557b74ee3c
c278c563 38Patch0: %{pname}-svn-fixes.patch
563fc4ec 39URL: http://www.asterisk.org/
40%if %{with kernel} && %{with dist_kernel}
41BuildRequires: kernel%{_alt_kernel}-module-build
42BuildRequires: module-init-tools
43%endif
44BuildRequires: newt-devel
45BuildRequires: perl-base
46BuildRequires: perl-tools-pod
47BuildRequires: rpmbuild(macros) >= 1.379
563fc4ec 48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50# Rules:
51# - modules_X: single modules, just name module with no suffix
52# - modules_X: subdir modules are just directory name with slash like dirname/
53# - keep X and X_in in sync
54# - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
55
21a65756 56%define modules_1 dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_loc.o dahdi_dummy.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o pciradio.o tor2.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o
57%define modules_1_in dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_loc,dahdi_dummy,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,pciradio,tor2,wcfxo,wct1xxp,wctdm,wcte11xp
58%define modules_2 voicebuss wct4xxp/ wcte12xp/ %{?with_xpp:xpp/}
b800683f 59%define modules_2_in voicebus/dahdi_voicebus,wct4xxp/wct4xxp,wcte12xp/wcte12xp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
563fc4ec 60%ifnarch alpha
61%define modules_nalpha wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
62%define modules_nalpha_in wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
63
64%endif
b800683f 65%define modules %{modules_1} %{modules_2}%{?modules_nalpha: %{modules_nalpha}}
66%define modules_in %{modules_1_in},%{modules_2_in}%{?modules_nalpha:,%{modules_nalpha_in}}
563fc4ec 67
68%description
69DAHDI telephony device driver.
70
71%description -l pl.UTF-8
72Sterownik do urządzeń telefonicznych DAHDI.
73
74%package devel
75Summary: Header files for dahdi interface
76Group: Development/Libraries
77# if base package contains shared library for which these headers are
78#Requires: %{name} = %{version}-%{release}
79# if -libs package contains shared library for which these headers are
80#Requires: %{name}-libs = %{version}-%{release}
81
82%description devel
83Header files for dahdi interface.
84
85%package -n kernel%{_alt_kernel}-%{pname}
86Summary: DAHDI Linux kernel driver
87Summary(pl.UTF-8): Sterownik DAHDI dla jądra Linuksa
88Release: %{rel}@%{_kernel_ver_str}
89Group: Base/Kernel
90Requires(post,postun): /sbin/depmod
91%if %{with dist_kernel}
92%requires_releq_kernel
93Requires(postun): %releq_kernel
94%{?with_oslec:Requires: kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}
95%endif
96
97%description -n kernel%{_alt_kernel}-%{pname}
98DAHDI telephony Linux kernel driver.
99
100%description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8
101Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.
102
103%prep
104%setup -q -n %{pname}-%{version}
c278c563 105%patch0 -p1
563fc4ec 106
107for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6}; do
108 ln -s $a drivers/dahdi/firmware
109 tar -C drivers/dahdi/firmware -xzf $a
110done
111
112cat > download-logger <<'EOF'
113#!/bin/sh
114# keep log of files make wanted to download in firmware/ dir
115echo "$@" >> download.log
116EOF
117chmod a+rx download-logger
118
119%build
120%{__make} include/dahdi/version.h
121
122%build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include
123
124check_modules() {
125 err=0
126 for a in drivers/dahdi/{*/,}*.ko; do
127 [[ $a = *-dist.ko ]] && continue
128 [[ $a = *-up.ko ]] && continue
129 [[ $a = *-smp.ko ]] && continue
130 echo >&2 "unpackaged module: ${a%.ko}"
131 err=1
132 done
133
134 [ $err = 0 ] || exit 1
135}
136check_modules
137
138%install
139rm -rf $RPM_BUILD_ROOT
140mkdir $RPM_BUILD_ROOT%{_includedir}/dahdi -p
141cd drivers/dahdi
142%install_kernel_modules -m %{modules_in} -d misc
143cd ../..
144
145install include/dahdi/*.h $RPM_BUILD_ROOT%{_includedir}/dahdi/
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%post -n kernel%{_alt_kernel}-%{pname}
151%depmod %{_kernel_ver}
152
153%postun -n kernel%{_alt_kernel}-%{pname}
154%depmod %{_kernel_ver}
155
156%files devel
b603dc42 157%defattr(644,root,root,755)
563fc4ec 158%{_includedir}/dahdi
159
160%files -n kernel%{_alt_kernel}-%{pname}
161%defattr(644,root,root,755)
162/lib/modules/%{_kernel_ver}/misc/*.ko*
This page took 0.149824 seconds and 4 git commands to generate.