]> git.pld-linux.org Git - packages/czmq.git/commitdiff
- updated to 3.0.2 (note: new soname) auto/th/czmq-3.0.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Aug 2015 07:23:14 +0000 (09:23 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Aug 2015 07:23:29 +0000 (09:23 +0200)
- updated no-Werror patch
- added link patch

czmq-link.patch [new file with mode: 0644]
czmq.spec
no-Werror.patch

diff --git a/czmq-link.patch b/czmq-link.patch
new file mode 100644 (file)
index 0000000..cbfc898
--- /dev/null
@@ -0,0 +1,10 @@
+--- czmq-3.0.2/Makefile.am.orig        2015-06-08 09:27:00.000000000 +0200
++++ czmq-3.0.2/Makefile.am     2015-08-01 08:54:46.187642532 +0200
+@@ -10,6 +10,7 @@
+     -I$(srcdir)/include
+ project_libs = \
++    -lpthread \
+     ${zmq_LIBS}
+ SUBDIRS =
index 86d4e5f50ef8c14c19d7c9c54258dbe2a46de309..310116583b1997522c0f8b7dc01cbf518f7c1959 100644 (file)
--- a/czmq.spec
+++ b/czmq.spec
@@ -1,16 +1,20 @@
 Summary:       High-level C binding for 0MQ
 Summary(pl.UTF-8):     Wysokopoziomowe wiązania C dla 0MQ
 Name:          czmq
-Version:       2.2.0
-Release:       3
+Version:       3.0.2
+Release:       1
 License:       LGPL v3+
 Group:         Libraries
 Source0:       http://download.zeromq.org/%{name}-%{version}.tar.gz
-# Source0-md5: b9c060727275a98e866d4db26345c2d8
+# Source0-md5: 7697688bf65a35bc33ae2db51ebb0e3b
 Patch0:                no-Werror.patch
+Patch1:                %{name}-link.patch
 URL:           http://zeromq.org/
 BuildRequires: asciidoc
+BuildRequires: autoconf >= 2.61
+BuildRequires: automake
 BuildRequires: libsodium-devel
+BuildRequires: libtool
 BuildRequires: libuuid-devel
 BuildRequires: xmlto
 BuildRequires: zeromq-devel >= 4
@@ -51,8 +55,14 @@ Statyczna biblioteka CZMQ.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
+%{__libtoolize}
+%{__aclocal} -I config
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 # use include subdir - file names could be too common (zfile.h etc.)
 %configure \
        --disable-silent-rules \
@@ -70,28 +80,30 @@ rm -rf $RPM_BUILD_ROOT
 
 # too common name
 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{makecert,czmq_makecert}
-
-# gsl scripts, most likely shouldn't be installed
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/*.gsl
+%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/{makecert,czmq_makecert}.1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS NEWS
+%doc AUTHORS NEWS README.md
 %attr(755,root,root) %{_bindir}/czmq_makecert
-%attr(755,root,root) %{_bindir}/czmq_selftest
 %attr(755,root,root) %{_libdir}/libczmq.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libczmq.so.1
+%attr(755,root,root) %ghost %{_libdir}/libczmq.so.3
+%{_mandir}/man1/czmq_makecert.1*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libczmq.so
 %{_includedir}/czmq
 %{_pkgconfigdir}/libczmq.pc
+%{_mandir}/man3/zactor.3*
+%{_mandir}/man3/zarmour.3*
 %{_mandir}/man3/zauth.3*
+%{_mandir}/man3/zauth_v2.3*
 %{_mandir}/man3/zbeacon.3*
+%{_mandir}/man3/zbeacon_v2.3*
 %{_mandir}/man3/zcert.3*
 %{_mandir}/man3/zcertstore.3*
 %{_mandir}/man3/zchunk.3*
@@ -103,16 +115,23 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/zdir_patch.3*
 %{_mandir}/man3/zfile.3*
 %{_mandir}/man3/zframe.3*
+%{_mandir}/man3/zgossip.3*
 %{_mandir}/man3/zhash.3*
+%{_mandir}/man3/zhashx.3*
+%{_mandir}/man3/ziflist.3*
 %{_mandir}/man3/zlist.3*
-%{_mandir}/man3/zlog.3*
+%{_mandir}/man3/zlistx.3*
 %{_mandir}/man3/zloop.3*
 %{_mandir}/man3/zmonitor.3*
+%{_mandir}/man3/zmonitor_v2.3*
 %{_mandir}/man3/zmsg.3*
 %{_mandir}/man3/zmutex.3*
 %{_mandir}/man3/zpoller.3*
 %{_mandir}/man3/zproxy.3*
+%{_mandir}/man3/zproxy_v2.3*
 %{_mandir}/man3/zrex.3*
+%{_mandir}/man3/zsock.3*
+%{_mandir}/man3/zsock_option.3*
 %{_mandir}/man3/zsocket.3*
 %{_mandir}/man3/zsockopt.3*
 %{_mandir}/man3/zstr.3*
index 38344c371b8c6d0c832f35c0aba0bf5f62effe55..ed9256f084405051aac36e885d0b0fc7a3b81453 100644 (file)
@@ -1,11 +1,11 @@
---- czmq-2.2.0/configure.ac~   2014-04-23 14:46:58.000000000 +0200
-+++ czmq-2.2.0/configure.ac    2015-01-26 20:11:55.802471286 +0100
-@@ -295,7 +295,7 @@
+--- czmq-3.0.2/configure.ac.orig       2015-08-01 07:43:07.877822916 +0200
++++ czmq-3.0.2/configure.ac    2015-08-01 08:08:51.497758136 +0200
+@@ -246,7 +246,7 @@
  
  # These options are GNU compiler specific.
  if test "x$GCC" = "xyes"; then
--    CPPFLAGS="-pedantic -Werror -Wall ${CPPFLAGS}"
-+    CPPFLAGS="-pedantic -Wall ${CPPFLAGS}"
+-    CPPFLAGS="-pedantic -Werror -Wall -Wc++-compat ${CPPFLAGS}"
++    CPPFLAGS="-pedantic -Wall -Wc++-compat ${CPPFLAGS}"
  fi
  
- AM_CONDITIONAL(ON_MINGW, test "x$czmq_on_mingw32" = "xyes")
+ AM_CONDITIONAL(ENABLE_SHARED, test "x$enable_shared" = "xyes")
This page took 0.150777 seconds and 4 git commands to generate.