]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- there is no x509 plugin, added to Obsoletes
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite 2 plugin
11 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # enable opie plugin
14 %bcond_with     srp             # build srp pluggin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.25
28 Release:        1
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
32 # Source0-md5:  341cffe829a4d71f2a6503d669d5a946
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-keytab.patch
47 Patch9:         %{name}-sizes.patch
48 Patch10:        %{name}-nagios-plugin.patch
49 Patch11:        %{name}-parallel-make.patch
50 Patch12:        %{name}-gssapi-detect.patch
51 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
52 Patch14:        %{name}-ac-libs.patch
53 Patch15:        %{name}-pam.patch
54 Patch16:        %{name}-gssapi_ext.patch
55 URL:            http://asg.web.cmu.edu/sasl/
56 BuildRequires:  autoconf >= 2.54
57 BuildRequires:  automake >= 1:1.7
58 %{?with_authlib:BuildRequires:  courier-authlib-devel}
59 BuildRequires:  db-devel
60 BuildRequires:  ed
61 BuildRequires:  groff
62 %{?with_gssapi:BuildRequires:   heimdal-devel}
63 BuildRequires:  libtool >= 1.4
64 %{?with_mysql:BuildRequires:    mysql-devel}
65 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
66 BuildRequires:  openssl-devel >= 0.9.7d
67 %{?with_opie:BuildRequires:     opie-devel}
68 BuildRequires:  pam-devel
69 %{?with_pgsql:BuildRequires:    postgresql-devel}
70 BuildRequires:  rpmbuild(macros) >= 1.268
71 %{?with_sqlite:BuildRequires:   sqlite-devel}
72 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
73 Requires:       pam >= 0.79.0
74 Requires:       %{name}-libs = %{version}-%{release}
75 Obsoletes:      cyrus-sasl-x509
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %define         _sysconfdir     /etc/sasl
79
80 %define         specflags       -fno-strict-aliasing
81
82 %description
83 This is an implementation of the SASL API, useful for adding
84 authentication, authorization, and security to network protocols. The
85 SASL protocol itself is documented in rfc2222; the API standard is a
86 work in progress.
87
88 Note: remember to install appropriate plugins, or you won't have any
89 authentication mechanisms available.
90
91 %description -l pl.UTF-8
92 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
93 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
94 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
95 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
96 RFC 2222; standaryzacja API jest w toku.
97
98 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
99 doinstalować odpowiednie wtyczki.
100
101 %description -l pt_BR.UTF-8
102 Esta é uma implementação da API SASL, útil para acrescentar
103 autenticação, autorização e seguança (criptografia) para protocolos de
104 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
105 ainda está em desenvolvimento.
106
107 %description -l ru.UTF-8
108 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
109 Authentication and Security Layer, метод для добавления поддержки
110 аутентикации к протоколам, основанным на соединениях.
111
112 %description -l uk.UTF-8
113 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
114 Authentication and Security Layer, метод для додання підтримки
115 аутентикації до протоколів, базованих на з'єднаннях.
116
117 %package libs
118 Summary:        cyrus-sasl library itself
119 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
120 Group:          Libraries
121 Requires(post,postun):  /sbin/ldconfig
122 Conflicts:      cyrus-sasl < 2.1.23-8
123
124 %description libs
125 cyrus-sasl library itself.
126
127 %description libs -l pl.UTF-8
128 Sama biblioteka cyrus-sasl.
129
130 %package devel
131 Summary:        Header files and documentation for cyrus-sasl
132 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
133 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
134 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
135 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
136 Group:          Development/Libraries
137 Requires:       %{name} = %{version}-%{release}
138
139 %description devel
140 This includes the header files and documentation needed to develop
141 applications which use SASL.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
145
146 %description devel -l pt_BR.UTF-8
147 Este pacote inclui os arquivos de cabeçalho e documentação necessários
148 para desenvolver aplicativos que usem SASL.
149
150 %description devel -l ru.UTF-8
151 Хедеры и библиотеки, необходимые для разработки приложений,
152 использующих Cyrus SASL.
153
154 %description devel -l uk.UTF-8
155 Хедери та бібліотеки, необхідні для розробки програм, що
156 використовують Cyrus SASL.
157
158 %package static
159 Summary:        Static cyrus-sasl libraries
160 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
161 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
162 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
163 Group:          Development/Libraries
164 Requires:       %{name}-devel = %{version}-%{release}
165
166 %description static
167 Static cyrus-sasl libraries.
168
169 %description static -l pl.UTF-8
170 Statyczne biblioteki cyrus-sasl.
171
172 %description static -l ru.UTF-8
173 Статические библиотеки, необходимые для разработки приложений,
174 использующих Cyrus SASL.
175
176 %description static -l uk.UTF-8
177 Статичні бібліотеки, необхідні для розробки програм, що використовують
178 Cyrus SASL.
179
180 %package anonymous
181 Summary:        Anonymous Cyrus SASL plugin
182 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
183 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186
187 %description anonymous
188 This plugin implements the SASL ANONYMOUS mechanism, used for
189 anonymous authentication.
190
191 %description anonymous -l pl.UTF-8
192 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
193 anonimowego uwierzytelniania.
194
195 %description anonymous -l pt_BR.UTF-8
196 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
197 autenticação anônima.
198
199 %package cram-md5
200 Summary:        Cram-MD5 Cyrus SASL plugin
201 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
202 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
203 Group:          Libraries
204 Requires:       %{name} = %{version}-%{release}
205
206 %description cram-md5
207 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
208 mandatory-to-implement authentication mechanism for a number of
209 protocols; it uses MD5 with a challenge/response system to
210 authenticate the user.
211
212 %description cram-md5 -l pl.UTF-8
213 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
214 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
215 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
216 systemem challenge/response.
217
218 %description cram-md5 -l pt_BR.UTF-8
219 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
220 mecanismo de autenticação obrigatório de ser implementado para vários
221 protocolos: ele usa MD5 com um sistema de desafio/resposta para
222 autenticar o usuário.
223
224 %package digest-md5
225 Summary:        Digest-MD5 Cyrus SASL plugin
226 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
227 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
228 Group:          Libraries
229 Requires:       %{name} = %{version}-%{release}
230
231 %description digest-md5
232 This plugin implements the latest draft of the SASL DIGEST-MD5
233 mechanism. Although not yet finalized, this is likely to become the
234 new mandatory-to-implement authentication system in all new protocols.
235 It's based on the digest md5 authentication system designed for HTTP.
236
237 %description digest-md5 -l pl.UTF-8
238 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
239 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
240 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
241 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
242 Digest-MD5 zaprojektowanym dla HTTP.
243
244 %description digest-md5 -l pt_BR.UTF-8
245 Este plugin implementa a última versão da especificação do mecanismo
246 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
247 provavelmente será o novo sistema de autenticação obrigatório para
248 protocolos novos. Ele é baseado na autenticação md5 digest
249 desenvolvida para HTTP.
250
251 %package gssapi
252 Summary:        GSSAPI Cyrus SASL plugin
253 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
254 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257
258 %description gssapi
259 This plugin implements the SASL GSSAPI mechanism, used for
260 GSSAPI/Kerberos5 authentication.
261
262 %description gssapi -l pl.UTF-8
263 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
264 uwierzytelniania z użyciem GSSAPI/Kerberos5.
265
266 %description gssapi -l pt_BR.UTF-8
267 Este plugin implementa o mecanismo SASL GSSAPI, usado para
268 autenticação Kerberos/GSSAPI.
269
270 %package login
271 Summary:        Unsupported Login Cyrus SASL plugin
272 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
273 Group:          Libraries
274 Requires:       %{name} = %{version}-%{release}
275
276 %description login
277 Unsupported LOGIN Cyrus SASL plugin.
278
279 %description login -l pl.UTF-8
280 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
281 SASL.
282
283 %package mysql
284 Summary:        Cyrus SASL MySQL plugin
285 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description mysql
290 Cyrus SASL MySQL plugin.
291
292 %description mysql -l pl.UTF-8
293 Wtyczka MySQL do Cyrus SASL.
294
295 %package opie
296 Summary:        OPIE Cyrus SASL plugin
297 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
298 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
299 Group:          Libraries
300 Requires:       %{name} = %{version}-%{release}
301
302 %description opie
303 This plugin implements the SASL OPIE (One Time Password) mechanism.
304
305 %description opie -l pl.UTF-8
306 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
307 SASL.
308
309 %package otp
310 Summary:        OTP Cyrus SASL plugin
311 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
312 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
313 Group:          Libraries
314 Requires:       %{name} = %{version}-%{release}
315
316 %description otp
317 This plugin implements the SASL OTP (One Time Password) mechanism.
318
319 %description otp -l pl.UTF-8
320 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
321 SASL.
322
323 %package pgsql
324 Summary:        Cyrus SASL PostgreSQL plugin
325 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
326 Group:          Libraries
327 Requires:       %{name} = %{version}-%{release}
328
329 %description pgsql
330 Cyrus SASL PostgreSQL plugin.
331
332 %description pgsql -l pl.UTF-8
333 Wtyczka PostgreSQL do Cyrus SASL.
334
335 %package plain
336 Summary:        Plain Cyrus SASL plugin
337 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
338 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
339 Group:          Libraries
340 Requires:       %{name} = %{version}-%{release}
341
342 %description plain
343 This plugin implements the SASL PLAIN mechanism. Although insecure,
344 PLAIN is useful for transitioning to new security mechanisms, as this
345 is the only mechanism which gives the server a copy of the user's
346 password.
347
348 %description plain -l pl.UTF-8
349 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
350 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
351 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
352 który udostępnia serwerowi kopię hasła użytkownika.
353
354 %description plain -l pt_BR.UTF-8
355 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
356 mecanismo é útil durante transições para novos mecanismos de
357 segurança, pois é o único esquema que fornece uma cópia da senha do
358 usuário para o servidor.
359
360 %package sasldb
361 Summary:        Cyrus SASL sasldb plugin
362 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
363 Group:          Libraries
364 Requires:       %{name} = %{version}-%{release}
365
366 %description sasldb
367 Cyrus SASL sasldb plugin.
368
369 %description sasldb -l pl.UTF-8
370 Wtyczka sasldb do Cyrus SASL.
371
372 %package scram
373 Summary:        SCRAM Cyrus SASL plugin
374 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
375 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
376 Group:          Libraries
377 Requires:       %{name} = %{version}-%{release}
378
379 %description scram
380 This plugin implements the SASL SCRAM-MD5 mechanism.
381
382 %description scram -l pl.UTF-8
383 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
384
385 %description scram -l pt_BR.UTF-8
386 Este plugin implementa o mecanismo SASL SCRAM.
387
388 %package sqlite
389 Summary:        Cyrus SQLite 2 PostgreSQL plugin
390 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
391 Group:          Libraries
392 Requires:       %{name} = %{version}-%{release}
393
394 %description sqlite
395 Cyrus SASL SQLite 2 plugin.
396
397 %description sqlite -l pl.UTF-8
398 Wtyczka SQLite 2 do Cyrus SASL.
399
400 %package sqlite3
401 Summary:        Cyrus SQLite 3 PostgreSQL plugin
402 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
403 Group:          Libraries
404 Requires:       %{name} = %{version}-%{release}
405
406 %description sqlite3
407 Cyrus SASL SQLite 3 plugin.
408
409 %description sqlite3 -l pl.UTF-8
410 Wtyczka SQLite 3 do Cyrus SASL.
411
412 %package srp
413 Summary:        SRP Cyrus SASL plugin
414 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
415 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
416 Group:          Libraries
417 Requires:       %{name} = %{version}-%{release}
418
419 %description srp
420 This plugin implements the SASL SRP mechanism, based on the Secure
421 Remote Password protocol. This mechanism performs mutual
422 authentication and can provide a security layer with replay detection,
423 integrity protection and/or condifentiality protection.
424
425 %description srp -l pl.UTF-8
426 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
427 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
428 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
429 powtarzania, zabezpieczeniem integralności i/lub poufności.
430
431 %description srp -l pt_BR.UTF-8
432 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
433 (Secure Remote Password). Este mecanismo oferece autenticação mútua
434 (do cliente e do servidor) e pode prover uma camada de segurança com
435 detecção de ataques de replay, garantia de integridade e/ou
436 confidencialidade.
437
438 %package pwcheck
439 Summary:        Cyrus SASL pwcheck helper
440 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
441 Group:          Libraries
442 Requires:       %{name} = %{version}-%{release}
443
444 %description pwcheck
445 Cyrus SASL pwcheck helper.
446
447 %description pwcheck -l pl.UTF-8
448 Program pomocniczy pwcheck do Cyrus SASL.
449
450 %package saslauthd
451 Summary:        Cyrus SASL authd
452 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
453 Group:          Daemons
454 Requires(post,preun):   /sbin/chkconfig
455 Requires:       %{name} = %{version}-%{release}
456 Requires:       /sbin/chkconfig
457 Requires:       rc-scripts
458
459 %description saslauthd
460 Cyrus SASL authd.
461
462 %description saslauthd -l pl.UTF-8
463 Demon authd do Cyrus SASL.
464
465 %package -n nagios-plugin-check_saslauthd
466 Summary:        Nagios plugin to check health of saslauthd
467 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
468 Group:          Networking
469 Requires:       nagios-core
470
471 %description -n nagios-plugin-check_saslauthd
472 Nagios plugin to check health of saslauthd.
473
474 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
475 Wtyczka Nagiosa do sprawdzania działania saslauthd.
476
477 %prep
478 %setup -q
479 %patch0 -p1
480 %patch1 -p1
481 %patch2 -p1
482 %patch3 -p1
483 %patch4 -p1
484 %if %{with cryptedpw}
485 %patch5 -p1
486 %patch6 -p1
487 %endif
488 %patch7 -p1
489 %patch8 -p1
490 %patch9 -p1
491 %patch10 -p1
492 %patch11 -p1
493 %patch12 -p1
494 %patch13 -p0
495 %patch14 -p1
496 %patch15 -p1
497 %patch16 -p1
498
499 cd doc
500 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
501 ls rfc*.txt >> rfc-compliance
502 rm -f rfc*.txt
503 cd ..
504
505 # old version
506 %{__rm} config/libtool.m4
507
508 # update to our paths
509 sed -i -e '
510         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
511         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
512         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
513         s,/var/state/saslauthd,/var/lib/sasl2,g
514 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
515
516 %build
517 %{__libtoolize}
518 %{__aclocal} -I cmulocal -I config
519 %{__autoheader}
520 %{__autoconf}
521 %{__automake}
522 cd saslauthd
523 %{__aclocal} -I ../cmulocal -I ../config
524 %{__autoheader}
525 %{__autoconf}
526 %{__automake}
527 cd ..
528 %configure \
529         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
530         --disable-krb4 \
531         %{!?with_gssapi: --disable-gssapi} \
532         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
533         --enable-login \
534         --enable-sample \
535         --enable-httpform \
536         --enable-sql \
537         %{?with_srp: --enable-srp} \
538         --enable-static \
539         --with-plugindir=%{_libdir}/sasl2 \
540         --with-configdir=%{_sysconfdir} \
541         --with-dblib=berkeley \
542         --with-dbpath=/var/lib/sasl2/sasl.db \
543         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
544         %{?with_ldap: --with-ldap=%{_prefix}} \
545         %{?with_mysql: --with-mysql=%{_prefix}} \
546         %{?with_pgsql: --with-pgsql=%{_prefix}} \
547         %{?with_sqlite: --with-sqlite=%{_prefix}} \
548         %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
549         %{?with_opie: --with-opie=%{_prefix}} \
550         --with-pam \
551         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
552         --with-saslauthd=/var/lib/sasl2
553
554 %{__make}
555
556 %{__make} -C saslauthd testsaslauthd
557 %{__make} -C saslauthd saslcache
558 %{__make} -C sample sample-client sample-server
559
560 cd doc
561 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
562 for i in $RFCLIST; do
563         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
564         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
565 done
566
567 %install
568 rm -rf $RPM_BUILD_ROOT
569 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
570                 $RPM_BUILD_ROOT%{_mandir}/man8
571
572 %{__make} install \
573         sasldir=%{_libdir}/sasl2 \
574         DESTDIR=$RPM_BUILD_ROOT
575
576 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
577
578 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
579 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
580
581 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
582
583 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
584
585 # create empty config
586 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
587 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
588 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
589 cp -a %{SOURCE3} cyrus.pam
590
591 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
592
593 # sample programs for testing sasl
594 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
595 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
596
597 # package for ghost
598 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
599
600 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
601 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
602
603 %clean
604 rm -rf $RPM_BUILD_ROOT
605
606 %post   libs -p /sbin/ldconfig
607 %postun libs -p /sbin/ldconfig
608
609 %post saslauthd
610 /sbin/chkconfig --add saslauthd
611 %service saslauthd restart
612
613 %preun saslauthd
614 if [ "$1" = "0" ]; then
615         %service saslauthd stop
616         /sbin/chkconfig --del saslauthd
617 fi
618
619 %triggerin saslauthd -- pam
620 # restart saslauthd if pam is upgraded
621 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
622 if [ "$2" != 1 ]; then
623         %service -q saslauthd restart
624 fi
625
626 %files
627 %defattr(644,root,root,755)
628 %doc AUTHORS COPYING ChangeLog NEWS README
629 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
630 %dir %{_sysconfdir}
631 %dir %{_libdir}/sasl2
632 # sample programs to subpackage instead?
633 %attr(755,root,root) %{_bindir}/sasl-sample-client
634 %attr(755,root,root) %{_bindir}/sasl-sample-server
635 %attr(755,root,root) %{_sbindir}/pluginviewer
636 %attr(755,root,root) %{_sbindir}/sasldblistusers2
637 %attr(755,root,root) %{_sbindir}/saslpasswd2
638 %dir /var/lib/sasl2
639 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
640 %{_mandir}/man8/pluginviewer.8*
641 %{_mandir}/man8/sasldblistusers2.8*
642 %{_mandir}/man8/saslpasswd2.8*
643
644 %files libs
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
648
649 %files devel
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/libsasl2.so
652 %attr(755,root,root) %{_libdir}/libsasl.so
653 %{_libdir}/libsasl2.la
654 %{_includedir}/sasl
655 %{_mandir}/man3/sasl*.3*
656
657 %files static
658 %defattr(644,root,root,755)
659 %{_libdir}/libsasl2.a
660
661 %files anonymous
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
664
665 %if %{with gssapi}
666 %files gssapi
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
669 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
670 %endif
671
672 %files cram-md5
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
675
676 %files digest-md5
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
679
680 %files login
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
683
684 %if %{with mysql}
685 %files mysql
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
688 %endif
689
690 %files otp
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
693
694 %if %{with opie}
695 %files opie
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
698 %endif
699
700 %if %{with pgsql}
701 %files pgsql
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
704 %endif
705
706 %files plain
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
709
710 %files sasldb
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
713
714 %files scram
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
717
718 %if %{with sqlite}
719 %files sqlite
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
722 %endif
723
724 %if %{with sqlite3}
725 %files sqlite3
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
728 %endif
729
730 %if %{with srp}
731 %files srp
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
734 %endif
735
736 %if %{with pwcheck}
737 %files pwcheck
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_sbindir}/pwcheck
740 %endif
741
742 %files saslauthd
743 %defattr(644,root,root,755)
744 %doc cyrus.pam
745 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
746 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
747 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
748 %attr(755,root,root) %{_sbindir}/saslauthd
749 %attr(755,root,root) %{_sbindir}/testsaslauthd
750 %attr(755,root,root) %{_sbindir}/saslcache
751 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
752 %ghost /var/lib/sasl2/cache.flock
753 %ghost /var/lib/sasl2/cache.mmap
754 %ghost /var/lib/sasl2/mux
755 %ghost /var/lib/sasl2/mux.accept
756 %ghost /var/lib/sasl2/saslauthd.pid
757 %{_mandir}/man8/saslauthd.8*
758
759 %files -n nagios-plugin-check_saslauthd
760 %defattr(644,root,root,755)
761 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
762 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 1.866214 seconds and 4 git commands to generate.