]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- make cryptpw build as default
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # TODO:
3 # - add ldap plugin from openldap sources
4 #
5 # Conditional build:
6 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
7 %bcond_without  ldap            # disable LDAP support for saslauthd
8 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
9 %bcond_without  mysql           # don't build MySQL pluggin
10 %bcond_without  pgsql           # do not build PostgreSQL pluggin
11 %bcond_without  sqlite          # do not enable sqlite plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # enable opie plugin
14 %bcond_with     srp             # build srp pluggin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 %bcond_with     x509            # build x509 plugin (no sources in package???)
17 #
18 %if %{without mysql} && %{without pgsql}
19 %undefine with_cryptedpw
20 %endif
21
22 Summary:        The SASL library API for the Cyrus mail system
23 Summary(pl):    Biblioteka Cyrus SASL
24 Summary(pt_BR): Implementação da API SASL
25 Summary(ru):    âÉÂÌÉÏÔÅËÁ Cyrus SASL
26 Summary(uk):    â¦Â̦ÏÔÅËÁ Cyrus SASL
27 Name:           cyrus-sasl
28 Version:        2.1.21
29 Release:        8
30 License:        distributable
31 Group:          Libraries
32 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
33 # Source0-md5:  dde02db234dea892bee298390890502e
34 Source1:        saslauthd.init
35 Source2:        saslauthd.sysconfig
36 Source3:        %{name}.pam
37 Patch0:         %{name}-configdir.patch
38 Patch1:         %{name}-nolibs.patch
39 Patch2:         %{name}-lt.patch
40 Patch3:         %{name}-split-sql.patch
41 Patch4:         %{name}-opie.patch
42 Patch5:         %{name}-gcc4.patch
43 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
44 Patch6:         %{name}-cryptedpw.patch
45 Patch7:         %{name}-md5sum-passwords.patch
46 URL:            http://asg.web.cmu.edu/sasl/
47 BuildRequires:  autoconf >= 2.54
48 BuildRequires:  automake
49 %{?with_authlib:BuildRequires:  courier-authlib-devel}
50 BuildRequires:  db-devel
51 BuildRequires:  ed
52 BuildRequires:  groff
53 %{?with_gssapi:BuildRequires:   heimdal-devel >= 0.7}
54 BuildRequires:  libtool >= 1.4
55 %{?with_mysql:BuildRequires:    mysql-devel}
56 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
57 BuildRequires:  openssl-devel >= 0.9.7d
58 %{?with_opie:BuildRequires:     opie-devel}
59 BuildRequires:  pam-devel
60 %{?with_pgsql:BuildRequires:    postgresql-devel}
61 %{?with_sqlite:BuildRequires:   sqlite-devel}
62 Requires:       pam >= 0.79.0
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _sysconfdir     /etc/sasl
66
67 %define         specflags       -fno-strict-aliasing
68
69 %description
70 This is an implementation of the SASL API, useful for adding
71 authentication, authorization, and security to network protocols. The
72 SASL protocol itself is documented in rfc2222; the API standard is a
73 work in progress.
74
75 Note: remember to install appropriate plugins, or you won't have any
76 authentication mechanisms available.
77
78 %description -l pl
79 Pakiet cyrus-sasl zawiera implementacjê biblioteki API SASL dla
80 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
81 tak¿e do dodawania uwierzytelniania, autoryzacji oraz zwiêkszania
82 bezpieczeñstwa protoko³ów sieciowych. Sam protokó³ SASL jest opisany w
83 RFC 2222; standaryzacja API jest w toku.
84
85 Uwaga: aby by³y dostêpne jakiekolwiek mechanizmy autoryzacji, nale¿y
86 doinstalowaæ odpowiednie wtyczki.
87
88 %description -l pt_BR
89 Esta é uma implementação da API SASL, útil para acrescentar
90 autenticação, autorização e seguança (criptografia) para protocolos de
91 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
92 ainda está em desenvolvimento.
93
94 %description -l ru
95 ðÁËÅÔ cyrus-sasl ÓÏÄÅÒÖÉÔ ÒÅÁÌÉÚÁÃÉÀ Cyrus SASL. SASL - ÜÔÏ Simple
96 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÂÁ×ÌÅÎÉÑ ÐÏÄÄÅÒÖËÉ
97 ÁÕÔÅÎÔÉËÁÃÉÉ Ë ÐÒÏÔÏËÏÌÁÍ, ÏÓÎÏ×ÁÎÎÙÍ ÎÁ ÓÏÅÄÉÎÅÎÉÑÈ.
98
99 %description -l uk
100 ðÁËÅÔ cyrus-sasl Í¦ÓÔÉÔØ ÒÅÁ̦ÚÁæÀ Cyrus SASL. SASL - ÃÅ Simple
101 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÄÁÎÎѠЦÄÔÒÉÍËÉ
102 ÁÕÔÅÎÔÉËÁ槠ÄÏ ÐÒÏÔÏËÏ̦×, ÂÁÚÏ×ÁÎÉÈ ÎÁ Ú'¤ÄÎÁÎÎÑÈ.
103
104 %package devel
105 Summary:        Header files and documentation for cyrus-sasl
106 Summary(pl):    Pliki nag³ówkowe i dokumentacja dla cyrus-sasl
107 Summary(pt_BR): Exemplos e arquivos para desenvolvimento com SASL
108 Summary(ru):    æÁÊÌÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎѠڠ¦Â̦ÏÔÅËÏÀ Cyrus SASL
109 Summary(ru):    æÁÊÌÙ ÄÌÑ ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ Ó ÂÉÂÌÉÏÔÅËÏÊ Cyrus SASL
110 Group:          Development/Libraries
111 Requires:       %{name} = %{version}-%{release}
112
113 %description devel
114 This includes the header files and documentation needed to develop
115 applications which use SASL.
116
117 %description devel -l pl
118 Pliki nag³ówkowe i dokumentacja dla cyrus-sasl.
119
120 %description devel -l pt_BR
121 Este pacote inclui os arquivos de cabeçalho e documentação necessários
122 para desenvolver aplicativos que usem SASL.
123
124 %description devel -l ru
125 èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
126 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
127
128 %description devel -l uk
129 èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
130 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ Cyrus SASL.
131
132 %package static
133 Summary:        Static cyrus-sasl libraries
134 Summary(pl):    Statyczne biblioteki cyrus-sasl
135 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ Cyrus SASL
136 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ Cyrus SASL
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}-%{release}
139
140 %description static
141 Static cyrus-sasl libraries.
142
143 %description static -l pl
144 Statyczne biblioteki cyrus-sasl.
145
146 %description static -l ru
147 óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
148 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
149
150 %description static -l uk
151 óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ
152 Cyrus SASL.
153
154 %package cram-md5
155 Summary:        Cram-MD5 Cyrus SASL plugin
156 Summary(pl):    Wtyczka Cram-MD5 do Cyrus SASL
157 Summary(pt_BR): Mecanismo SASL CRAM-MD5
158 Group:          Libraries
159 Requires:       %{name} = %{version}-%{release}
160
161 %description cram-md5
162 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
163 mandatory-to-implement authentication mechanism for a number of
164 protocols; it uses MD5 with a challenge/response system to
165 authenticate the user.
166
167 %description cram-md5 -l pl
168 Wtyczka dodaj±ca obs³ugê mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
169 jest obowi±zkowym do zaimplementowania mechanizmem uwierzytelniania
170 dla wielu protoko³ów; do uwierzytelnienia u¿ytkownika u¿ywa MD5 wraz z
171 systemem challenge/response.
172
173 %description cram-md5 -l pt_BR
174 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
175 mecanismo de autenticação obrigatório de ser implementado para vários
176 protocolos: ele usa MD5 com um sistema de desafio/resposta para
177 autenticar o usuário.
178
179 %package digest-md5
180 Summary:        Digest-MD5 Cyrus SASL plugin
181 Summary(pl):    Wtyczka Digest-MD5 do Cyrus SASL
182 Summary(pt_BR): Mecanismo SASL DIGEST-MD5
183 Group:          Libraries
184 Requires:       %{name} = %{version}-%{release}
185
186 %description digest-md5
187 This plugin implements the latest draft of the SASL DIGEST-MD5
188 mechanism. Although not yet finalized, this is likely to become the
189 new mandatory-to-implement authentication system in all new protocols.
190 It's based on the digest md5 authentication system designed for HTTP.
191
192 %description digest-md5 -l pl
193 Wtyczka dodaj±ca najnowsz± wersjê mechanizmu DIGEST-MD5 do Cyrus SASL.
194 Pomimo tego, ¿e nie jest jeszcze ukoñczony, najprawdopodobniej stanie
195 siê obowi±zkowym do zaimplementowania systemem uwierzytelniania we
196 wszystkich nowych protoko³ach. Bazuje na systemie uwierzytelniania
197 Digest-MD5 zaprojektowanym dla HTTP.
198
199 %description digest-md5 -l pt_BR
200 Este plugin implementa a última versão da especificação do mecanismo
201 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
202 provavelmente será o novo sistema de autenticação obrigatório para
203 protocolos novos. Ele é baseado na autenticação md5 digest
204 desenvolvida para HTTP.
205
206 %package plain
207 Summary:        Plain Cyrus SASL plugin
208 Summary(pl):    Wtyczka plain do Cyrus SASL
209 Summary(pt_BR): Mecanismo SASL PLAIN
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212
213 %description plain
214 This plugin implements the SASL PLAIN mechanism. Although insecure,
215 PLAIN is useful for transitioning to new security mechanisms, as this
216 is the only mechanism which gives the server a copy of the user's
217 password.
218
219 %description plain -l pl
220 Wtyczka dodaj±ca obs³ugê mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
221 ¿e nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
222 nowe mechanizmu bezpieczeñstwa, jako ¿e jest to jedyny mechanizm,
223 który udostêpnia serwerowi kopiê has³a u¿ytkownika.
224
225 %description plain -l pt_BR
226 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
227 mecanismo é útil durante transições para novos mecanismos de
228 segurança, pois é o único esquema que fornece uma cópia da senha do
229 usuário para o servidor.
230
231 %package anonymous
232 Summary:        Anonymous Cyrus SASL plugin
233 Summary(pl):    Wtyczka anonymous do Cyrus SASL
234 Summary(pt_BR): Mecanismo SASL ANONYMOUS
235 Group:          Libraries
236 Requires:       %{name} = %{version}-%{release}
237
238 %description anonymous
239 This plugin implements the SASL ANONYMOUS mechanism, used for
240 anonymous authentication.
241
242 %description anonymous -l pl
243 Wtyczka dodaj±ca obs³ugê mechanizmu ANONYMOUS do Cyrus SASL. S³u¿y do
244 anonimowego uwierzytelniania.
245
246 %description anonymous -l pt_BR
247 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
248 autenticação anônima.
249
250 %package gssapi
251 Summary:        GSSAPI Cyrus SASL plugin
252 Summary(pl):    Wtyczka GSSAPI do Cyrus SASL
253 Summary(pt_BR): Mecanismo SASL GSSAPI
254 Group:          Libraries
255 Requires:       %{name} = %{version}-%{release}
256
257 %description gssapi
258 This plugin implements the SASL GSSAPI mechanism, used for
259 GSSAPI/Kerberos5 authentication.
260
261 %description gssapi -l pl
262 Wtyczka dodaj±ca obs³ugê mechanizmu SASL GSSAPI, u¿ywanego do
263 uwierzytelniania z u¿yciem GSSAPI/Kerberos5.
264
265 %description gssapi -l pt_BR
266 Este plugin implementa o mecanismo SASL GSSAPI, usado para
267 autenticação Kerberos/GSSAPI.
268
269 %package login
270 Summary:        Unsupported Login Cyrus SASL plugin
271 Summary(pl):    Nie wspierana wtyczka Login do Cyrus SASL
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274
275 %description login
276 Unsupported LOGIN Cyrus SASL plugin.
277
278 %description login -l pl
279 Wtyczka dodaj±ca obs³ugê nie wspieranego mechanizmu LOGIN do Cyrus
280 SASL.
281
282 %package srp
283 Summary:        SRP Cyrus SASL plugin
284 Summary(pl):    Wtyczka SRP do Cyrus SASL
285 Summary(pt_BR): Mecanismo SASL SRP
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description srp
290 This plugin implements the SASL SRP mechanism, based on the Secure
291 Remote Password protocol. This mechanism performs mutual
292 authentication and can provide a security layer with replay detection,
293 integrity protection and/or condifentiality protection.
294
295 %description srp -l pl
296 Wtyczka dodaj±ca obs³ugê mechanizmu SRP do Cyrus SASL. Bazuje na
297 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
298 uwierzytelnienia i mo¿e dodawaæ warstwê bezpieczeñstwa z wykrywaniem
299 powtarzania, zabezpieczeniem integralno¶ci i/lub poufno¶ci.
300
301 %description srp -l pt_BR
302 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
303 (Secure Remote Password). Este mecanismo oferece autenticação mútua
304 (do cliente e do servidor) e pode prover uma camada de segurança com
305 detecção de ataques de replay, garantia de integridade e/ou
306 confidencialidade.
307
308 %package otp
309 Summary:        OTP Cyrus SASL plugin
310 Summary(pl):    Wtyczka OTP do Cyrus SASL
311 Summary(pt_BR): Mecanismo SASL OTP
312 Group:          Libraries
313 Requires:       %{name} = %{version}-%{release}
314
315 %description otp
316 This plugin implements the SASL OTP (One Time Password) mechanism.
317
318 %description otp -l pl
319 Wtyczka dodaj±ca obs³ugê mechanizmu OTP (has³a jednorazowe) do Cyrus
320 SASL.
321
322 %package opie
323 Summary:        OPIE Cyrus SASL plugin
324 Summary(pl):    Wtyczka OPIE do Cyrus SASL
325 Summary(pt_BR): Mecanismo SASL OPIE
326 Group:          Libraries
327 Requires:       %{name} = %{version}-%{release}
328
329 %description opie
330 This plugin implements the SASL OPIE (One Time Password) mechanism.
331
332 %description opie -l pl
333 Wtyczka dodaj±ca obs³ugê mechanizmu OPIE (has³a jednorazowe) do Cyrus
334 SASL.
335
336 %package x509
337 Summary:        x509 Cyrus SASL plugin
338 Summary(pl):    Wtyczka x509 do Cyrus SASL
339 Group:          Libraries
340 Requires:       %{name} = %{version}-%{release}
341
342 %description x509
343 x509 Cyrus SASL plugin.
344
345 %description x509 -l pl
346 Wtyczka x509 do Cyrus SASL.
347
348 %package saslauthd
349 Summary:        Cyrus SASL authd
350 Summary(pl):    Demon authd do Cyrus SASL
351 Group:          Daemons
352 Requires(post,preun):   /sbin/chkconfig
353 Requires:       %{name} = %{version}-%{release}
354 Requires:       rc-scripts
355
356 %description saslauthd
357 Cyrus SASL authd.
358
359 %description saslauthd -l pl
360 Demon authd do Cyrus SASL.
361
362 %package pwcheck
363 Summary:        Cyrus SASL pwcheck helper
364 Summary(pl):    Program pomocniczy pwcheck do Cyrus SASL
365 Group:          Libraries
366 Requires:       %{name} = %{version}-%{release}
367
368 %description pwcheck
369 Cyrus SASL pwcheck helper.
370
371 %description pwcheck -l pl
372 Program pomocniczy pwcheck do Cyrus SASL.
373
374 %package sasldb
375 Summary:        Cyrus SASL sasldb plugin
376 Summary(pl):    Wtyczka sasldb do Cyrus SASL
377 Group:          Libraries
378 Requires:       %{name} = %{version}-%{release}
379
380 %description sasldb
381 Cyrus SASL sasldb plugin.
382
383 %description sasldb -l pl
384 Wtyczka sasldb do Cyrus SASL.
385
386 %package mysql
387 Summary:        Cyrus SASL MySQL plugin
388 Summary(pl):    Wtyczka MySQL do Cyrus SASL
389 Group:          Libraries
390 Requires:       %{name} = %{version}-%{release}
391
392 %description mysql
393 Cyrus SASL MySQL plugin.
394
395 %description mysql -l pl
396 Wtyczka MySQL do Cyrus SASL.
397
398 %package pgsql
399 Summary:        Cyrus SASL PostgreSQL plugin
400 Summary(pl):    Wtyczka PostgreSQL do Cyrus SASL
401 Group:          Libraries
402 Requires:       %{name} = %{version}-%{release}
403
404 %description pgsql
405 Cyrus SASL PostgreSQL plugin.
406
407 %description pgsql -l pl
408 Wtyczka PostgreSQL do Cyrus SASL.
409
410 %package sqlite
411 Summary:        Cyrus SQLite PostgreSQL plugin
412 Summary(pl):    Wtyczka SQLite do Cyrus SASL
413 Group:          Libraries
414 Requires:       %{name} = %{version}-%{release}
415
416 %description sqlite
417 Cyrus SASL SQLite plugin.
418
419 %description sqlite -l pl
420 Wtyczka SQLite do Cyrus SASL.
421
422 %prep
423 %setup -q
424 %patch0 -p1
425 %patch1 -p1
426 %patch2 -p1
427 %patch3 -p1
428 %patch4 -p1
429 %patch5 -p1
430 %if %{with cryptedpw}
431 %patch6 -p1
432 %patch7 -p1
433 %endif
434
435 cd doc
436 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
437 ls rfc*.txt >> rfc-compliance
438 rm -f rfc*.txt
439 cd ..
440
441 rm -rf autom4te.cache saslauthd/autom4te.cache
442 # acinclude.m4 contains only old libtool.m4
443 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
444
445 %build
446 %{__libtoolize}
447 %{__aclocal} -I cmulocal -I config
448 %{__autoheader}
449 %{__automake}
450 %{__autoconf}
451
452 cd saslauthd
453 %{__libtoolize}
454 %{__aclocal} -I ../cmulocal -I ../config -I config
455 %{__autoheader}
456 %{__automake}
457 %{__autoconf}
458 cd ..
459
460 %configure \
461         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
462         --disable-krb4 \
463         %{!?with_gssapi: --disable-gssapi} \
464         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
465         --enable-login \
466         --enable-sql \
467         %{?with_srp: --enable-srp} \
468         --enable-static \
469         --with-plugindir=%{_libdir}/sasl2 \
470         --with-configdir=%{_sysconfdir} \
471         --with-dblib=berkeley \
472         --with-dbpath=/var/lib/sasl2/sasl.db \
473         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
474         %{?with_ldap: --with-ldap=%{_prefix}} \
475         %{?with_mysql: --with-mysql=%{_prefix}} \
476         %{?with_pgsql: --with-pgsql=%{_prefix}} \
477         %{?with_sqlite: --with-sqlite=%{_prefix}} \
478         %{?with_opie: --with-opie=%{_prefix}} \
479         --with-pam \
480         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
481         --with-saslauthd=/var/lib/sasl2
482 %{__make}
483
484 %{__make} -C saslauthd testsaslauthd
485 %{__make} -C saslauthd saslcache
486
487 cd doc
488 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
489 for i in $RFCLIST; do
490         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
491         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
492 done
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
497                 $RPM_BUILD_ROOT%{_mandir}/man8
498
499 %{__make} install \
500         sasldir=%{_libdir}/sasl2 \
501         DESTDIR=$RPM_BUILD_ROOT
502
503 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
504 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
505
506 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
507 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
508
509 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
510
511 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
512
513 # create empty config
514 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
515 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
516 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
517 install %{SOURCE3} ./cyrus.pam
518
519 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
520
521 # sample programs for testing sasl
522 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
523 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
524
525 %clean
526 rm -rf $RPM_BUILD_ROOT
527
528 %post   -p /sbin/ldconfig
529 %postun -p /sbin/ldconfig
530
531 %post saslauthd
532 /sbin/chkconfig --add saslauthd
533 if [ -f /var/lock/subsys/saslauthd ]; then
534         /etc/rc.d/init.d/saslauthd restart 1>&2
535 else
536         echo "Run \"/etc/rc.d/init.d/saslauthd start\" to start saslauthd."
537 fi
538
539 %preun saslauthd
540 if [ "$1" = "0" ]; then
541         if [ -f /var/lock/subsys/saslauthd ]; then
542                 /etc/rc.d/init.d/saslauthd stop 1>&2
543         fi
544         /sbin/chkconfig --del saslauthd
545 fi
546
547 %files
548 %defattr(644,root,root,755)
549 %doc AUTHORS COPYING ChangeLog NEWS README
550 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
551 %dir %{_sysconfdir}
552 %dir %{_libdir}/sasl2
553 %dir /var/lib/sasl2
554 %attr(755,root,root) %{_libdir}/lib*.so.*.*
555 # sample programs to subpackage instead?
556 %attr(755,root,root) %{_bindir}/sasl-sample-client
557 %attr(755,root,root) %{_bindir}/sasl-sample-server
558 %attr(755,root,root) %{_sbindir}/sasldblistusers2
559 %attr(755,root,root) %{_sbindir}/saslpasswd2
560
561 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
562 %{_mandir}/man8/sasldblistusers2.*
563 %{_mandir}/man8/saslpasswd2.*
564
565 %files devel
566 %defattr(644,root,root,755)
567 %{_includedir}/sasl
568 %attr(755,root,root) %{_libdir}/lib*.so
569 %{_libdir}/lib*.la
570 %{_mandir}/man3/*
571
572 %files static
573 %defattr(644,root,root,755)
574 %{_libdir}/lib*.a
575
576 %files anonymous
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
579
580 %if %{with gssapi}
581 %files gssapi
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
584 %endif
585
586 %files cram-md5
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
589
590 %files digest-md5
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
593
594 %files login
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
597
598 %files otp
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
601
602 %if %{with opie}
603 %files opie
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
606 %endif
607
608 %files plain
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
611
612 %files sasldb
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
615
616 %if %{with mysql}
617 %files mysql
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
620 %endif
621
622 %if %{with pgsql}
623 %files pgsql
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
626 %endif
627
628 %if %{with sqlite}
629 %files sqlite
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
632 %endif
633
634 %if %{with srp}
635 %files srp
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
638 %endif
639
640 %if %{with x509}
641 %files x509
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
644 %endif
645
646 %if %{with pwcheck}
647 %files pwcheck
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_sbindir}/pwcheck
650 %endif
651
652 %files saslauthd
653 %defattr(644,root,root,755)
654 %doc cyrus.pam
655 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
656 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
657 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
658 %attr(755,root,root) %{_sbindir}/saslauthd
659 %attr(755,root,root) %{_sbindir}/testsaslauthd
660 %attr(755,root,root) %{_sbindir}/saslcache
661 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
662 %{_mandir}/man8/saslauthd.*
This page took 2.834728 seconds and 4 git commands to generate.