]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- rel 3
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite 2 plugin
11 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # OTP plugin using opie library instead of internal code
14 %bcond_with     srp             # build srp plugin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.25
28 Release:        3
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
32 # Source0-md5:  341cffe829a4d71f2a6503d669d5a946
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-keytab.patch
47 Patch9:         %{name}-sizes.patch
48 Patch10:        %{name}-nagios-plugin.patch
49 Patch11:        %{name}-parallel-make.patch
50 Patch12:        %{name}-gssapi-detect.patch
51 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
52 Patch14:        %{name}-ac-libs.patch
53 Patch15:        %{name}-pam.patch
54 Patch16:        %{name}-gssapi_ext.patch
55 Patch17:        0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
56 Patch18:        0033-fix_segfault_in_GSSAPI.patch
57 Patch19:        0034-fix_dovecot_authentication.patch
58 URL:            http://asg.web.cmu.edu/sasl/
59 BuildRequires:  autoconf >= 2.54
60 BuildRequires:  automake >= 1:1.7
61 %{?with_authlib:BuildRequires:  courier-authlib-devel}
62 BuildRequires:  db-devel
63 BuildRequires:  ed
64 BuildRequires:  groff
65 %{?with_gssapi:BuildRequires:   heimdal-devel}
66 BuildRequires:  libtool >= 1.4
67 %{?with_mysql:BuildRequires:    mysql-devel}
68 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
69 BuildRequires:  openssl-devel >= 0.9.7d
70 %{?with_opie:BuildRequires:     opie-devel}
71 BuildRequires:  pam-devel
72 %{?with_pgsql:BuildRequires:    postgresql-devel}
73 BuildRequires:  rpmbuild(macros) >= 1.268
74 %{?with_sqlite:BuildRequires:   sqlite-devel}
75 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
76 Requires:       pam >= 0.79.0
77 Requires:       %{name}-libs = %{version}-%{release}
78 Obsoletes:      cyrus-sasl-x509 < %{version}
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         _sysconfdir     /etc/sasl
82
83 %define         specflags       -fno-strict-aliasing
84
85 %description
86 This is an implementation of the SASL API, useful for adding
87 authentication, authorization, and security to network protocols. The
88 SASL protocol itself is documented in rfc2222; the API standard is a
89 work in progress.
90
91 Note: remember to install appropriate plugins, or you won't have any
92 authentication mechanisms available.
93
94 %description -l pl.UTF-8
95 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
96 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
97 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
98 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
99 RFC 2222; standaryzacja API jest w toku.
100
101 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
102 doinstalować odpowiednie wtyczki.
103
104 %description -l pt_BR.UTF-8
105 Esta é uma implementação da API SASL, útil para acrescentar
106 autenticação, autorização e seguança (criptografia) para protocolos de
107 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
108 ainda está em desenvolvimento.
109
110 %description -l ru.UTF-8
111 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
112 Authentication and Security Layer, метод для добавления поддержки
113 аутентикации к протоколам, основанным на соединениях.
114
115 %description -l uk.UTF-8
116 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
117 Authentication and Security Layer, метод для додання підтримки
118 аутентикації до протоколів, базованих на з'єднаннях.
119
120 %package libs
121 Summary:        cyrus-sasl library itself
122 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
123 Group:          Libraries
124 Requires(post,postun):  /sbin/ldconfig
125 Conflicts:      cyrus-sasl < 2.1.23-8
126
127 %description libs
128 cyrus-sasl library itself.
129
130 %description libs -l pl.UTF-8
131 Sama biblioteka cyrus-sasl.
132
133 %package devel
134 Summary:        Header files and documentation for cyrus-sasl
135 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
136 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
137 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
138 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
139 Group:          Development/Libraries
140 Requires:       %{name} = %{version}-%{release}
141
142 %description devel
143 This includes the header files and documentation needed to develop
144 applications which use SASL.
145
146 %description devel -l pl.UTF-8
147 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
148
149 %description devel -l pt_BR.UTF-8
150 Este pacote inclui os arquivos de cabeçalho e documentação necessários
151 para desenvolver aplicativos que usem SASL.
152
153 %description devel -l ru.UTF-8
154 Хедеры и библиотеки, необходимые для разработки приложений,
155 использующих Cyrus SASL.
156
157 %description devel -l uk.UTF-8
158 Хедери та бібліотеки, необхідні для розробки програм, що
159 використовують Cyrus SASL.
160
161 %package static
162 Summary:        Static cyrus-sasl libraries
163 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
164 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
165 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
166 Group:          Development/Libraries
167 Requires:       %{name}-devel = %{version}-%{release}
168
169 %description static
170 Static cyrus-sasl libraries.
171
172 %description static -l pl.UTF-8
173 Statyczne biblioteki cyrus-sasl.
174
175 %description static -l ru.UTF-8
176 Статические библиотеки, необходимые для разработки приложений,
177 использующих Cyrus SASL.
178
179 %description static -l uk.UTF-8
180 Статичні бібліотеки, необхідні для розробки програм, що використовують
181 Cyrus SASL.
182
183 %package anonymous
184 Summary:        Anonymous Cyrus SASL plugin
185 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
186 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
187 Group:          Libraries
188 Requires:       %{name} = %{version}-%{release}
189
190 %description anonymous
191 This plugin implements the SASL ANONYMOUS mechanism, used for
192 anonymous authentication.
193
194 %description anonymous -l pl.UTF-8
195 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
196 anonimowego uwierzytelniania.
197
198 %description anonymous -l pt_BR.UTF-8
199 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
200 autenticação anônima.
201
202 %package cram-md5
203 Summary:        Cram-MD5 Cyrus SASL plugin
204 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
205 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
206 Group:          Libraries
207 Requires:       %{name} = %{version}-%{release}
208
209 %description cram-md5
210 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
211 mandatory-to-implement authentication mechanism for a number of
212 protocols; it uses MD5 with a challenge/response system to
213 authenticate the user.
214
215 %description cram-md5 -l pl.UTF-8
216 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
217 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
218 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
219 systemem challenge/response.
220
221 %description cram-md5 -l pt_BR.UTF-8
222 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
223 mecanismo de autenticação obrigatório de ser implementado para vários
224 protocolos: ele usa MD5 com um sistema de desafio/resposta para
225 autenticar o usuário.
226
227 %package digest-md5
228 Summary:        Digest-MD5 Cyrus SASL plugin
229 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
230 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
231 Group:          Libraries
232 Requires:       %{name} = %{version}-%{release}
233
234 %description digest-md5
235 This plugin implements the latest draft of the SASL DIGEST-MD5
236 mechanism. Although not yet finalized, this is likely to become the
237 new mandatory-to-implement authentication system in all new protocols.
238 It's based on the digest md5 authentication system designed for HTTP.
239
240 %description digest-md5 -l pl.UTF-8
241 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
242 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
243 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
244 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
245 Digest-MD5 zaprojektowanym dla HTTP.
246
247 %description digest-md5 -l pt_BR.UTF-8
248 Este plugin implementa a última versão da especificação do mecanismo
249 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
250 provavelmente será o novo sistema de autenticação obrigatório para
251 protocolos novos. Ele é baseado na autenticação md5 digest
252 desenvolvida para HTTP.
253
254 %package gssapi
255 Summary:        GSSAPI Cyrus SASL plugin
256 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
257 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
258 Group:          Libraries
259 Requires:       %{name} = %{version}-%{release}
260
261 %description gssapi
262 This plugin implements the SASL GSSAPI mechanism, used for
263 GSSAPI/Kerberos5 authentication.
264
265 %description gssapi -l pl.UTF-8
266 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
267 uwierzytelniania z użyciem GSSAPI/Kerberos5.
268
269 %description gssapi -l pt_BR.UTF-8
270 Este plugin implementa o mecanismo SASL GSSAPI, usado para
271 autenticação Kerberos/GSSAPI.
272
273 %package login
274 Summary:        Unsupported Login Cyrus SASL plugin
275 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
276 Group:          Libraries
277 Requires:       %{name} = %{version}-%{release}
278
279 %description login
280 Unsupported LOGIN Cyrus SASL plugin.
281
282 %description login -l pl.UTF-8
283 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
284 SASL.
285
286 %package mysql
287 Summary:        Cyrus SASL MySQL plugin
288 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
289 Group:          Libraries
290 Requires:       %{name} = %{version}-%{release}
291
292 %description mysql
293 Cyrus SASL MySQL plugin.
294
295 %description mysql -l pl.UTF-8
296 Wtyczka MySQL do Cyrus SASL.
297
298 %package otp
299 Summary:        OTP Cyrus SASL plugin
300 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
301 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
302 Group:          Libraries
303 Requires:       %{name} = %{version}-%{release}
304 Obsoletes:      cyrus-sasl-opie < %{version}
305
306 %description otp
307 This plugin implements the SASL OTP (One Time Password) mechanism.
308
309 %description otp -l pl.UTF-8
310 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
311 SASL.
312
313 %package pgsql
314 Summary:        Cyrus SASL PostgreSQL plugin
315 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
316 Group:          Libraries
317 Requires:       %{name} = %{version}-%{release}
318
319 %description pgsql
320 Cyrus SASL PostgreSQL plugin.
321
322 %description pgsql -l pl.UTF-8
323 Wtyczka PostgreSQL do Cyrus SASL.
324
325 %package plain
326 Summary:        Plain Cyrus SASL plugin
327 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
328 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
329 Group:          Libraries
330 Requires:       %{name} = %{version}-%{release}
331
332 %description plain
333 This plugin implements the SASL PLAIN mechanism. Although insecure,
334 PLAIN is useful for transitioning to new security mechanisms, as this
335 is the only mechanism which gives the server a copy of the user's
336 password.
337
338 %description plain -l pl.UTF-8
339 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
340 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
341 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
342 który udostępnia serwerowi kopię hasła użytkownika.
343
344 %description plain -l pt_BR.UTF-8
345 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
346 mecanismo é útil durante transições para novos mecanismos de
347 segurança, pois é o único esquema que fornece uma cópia da senha do
348 usuário para o servidor.
349
350 %package sasldb
351 Summary:        Cyrus SASL sasldb plugin
352 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
353 Group:          Libraries
354 Requires:       %{name} = %{version}-%{release}
355
356 %description sasldb
357 Cyrus SASL sasldb plugin.
358
359 %description sasldb -l pl.UTF-8
360 Wtyczka sasldb do Cyrus SASL.
361
362 %package scram
363 Summary:        SCRAM Cyrus SASL plugin
364 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
365 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
366 Group:          Libraries
367 Requires:       %{name} = %{version}-%{release}
368
369 %description scram
370 This plugin implements the SASL SCRAM-MD5 mechanism.
371
372 %description scram -l pl.UTF-8
373 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
374
375 %description scram -l pt_BR.UTF-8
376 Este plugin implementa o mecanismo SASL SCRAM.
377
378 %package sqlite
379 Summary:        Cyrus SQLite 2 PostgreSQL plugin
380 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
381 Group:          Libraries
382 Requires:       %{name} = %{version}-%{release}
383
384 %description sqlite
385 Cyrus SASL SQLite 2 plugin.
386
387 %description sqlite -l pl.UTF-8
388 Wtyczka SQLite 2 do Cyrus SASL.
389
390 %package sqlite3
391 Summary:        Cyrus SQLite 3 PostgreSQL plugin
392 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
393 Group:          Libraries
394 Requires:       %{name} = %{version}-%{release}
395
396 %description sqlite3
397 Cyrus SASL SQLite 3 plugin.
398
399 %description sqlite3 -l pl.UTF-8
400 Wtyczka SQLite 3 do Cyrus SASL.
401
402 %package srp
403 Summary:        SRP Cyrus SASL plugin
404 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
405 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
406 Group:          Libraries
407 Requires:       %{name} = %{version}-%{release}
408
409 %description srp
410 This plugin implements the SASL SRP mechanism, based on the Secure
411 Remote Password protocol. This mechanism performs mutual
412 authentication and can provide a security layer with replay detection,
413 integrity protection and/or condifentiality protection.
414
415 %description srp -l pl.UTF-8
416 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
417 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
418 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
419 powtarzania, zabezpieczeniem integralności i/lub poufności.
420
421 %description srp -l pt_BR.UTF-8
422 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
423 (Secure Remote Password). Este mecanismo oferece autenticação mútua
424 (do cliente e do servidor) e pode prover uma camada de segurança com
425 detecção de ataques de replay, garantia de integridade e/ou
426 confidencialidade.
427
428 %package pwcheck
429 Summary:        Cyrus SASL pwcheck helper
430 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
431 Group:          Libraries
432 Requires:       %{name} = %{version}-%{release}
433
434 %description pwcheck
435 Cyrus SASL pwcheck helper.
436
437 %description pwcheck -l pl.UTF-8
438 Program pomocniczy pwcheck do Cyrus SASL.
439
440 %package saslauthd
441 Summary:        Cyrus SASL authd
442 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
443 Group:          Daemons
444 Requires(post,preun):   /sbin/chkconfig
445 Requires:       %{name} = %{version}-%{release}
446 Requires:       /sbin/chkconfig
447 Requires:       rc-scripts
448
449 %description saslauthd
450 Cyrus SASL authd.
451
452 %description saslauthd -l pl.UTF-8
453 Demon authd do Cyrus SASL.
454
455 %package -n nagios-plugin-check_saslauthd
456 Summary:        Nagios plugin to check health of saslauthd
457 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
458 Group:          Networking
459 Requires:       nagios-core
460
461 %description -n nagios-plugin-check_saslauthd
462 Nagios plugin to check health of saslauthd.
463
464 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
465 Wtyczka Nagiosa do sprawdzania działania saslauthd.
466
467 %prep
468 %setup -q
469 %patch0 -p1
470 %patch1 -p1
471 %patch2 -p1
472 %patch3 -p1
473 %patch4 -p1
474 %if %{with cryptedpw}
475 %patch5 -p1
476 %patch6 -p1
477 %endif
478 %patch7 -p1
479 %patch8 -p1
480 %patch9 -p1
481 %patch10 -p1
482 %patch11 -p1
483 %patch12 -p1
484 %patch13 -p0
485 %patch14 -p1
486 %patch15 -p1
487 %patch16 -p1
488 %patch17 -p1
489 %patch18 -p1
490 %patch19 -p1
491
492 cd doc
493 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
494 ls rfc*.txt >> rfc-compliance
495 rm -f rfc*.txt
496 cd ..
497
498 # old version
499 %{__rm} config/libtool.m4
500
501 # update to our paths
502 sed -i -e '
503         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
504         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
505         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
506         s,/var/state/saslauthd,/var/lib/sasl2,g
507 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
508
509 %build
510 %{__libtoolize}
511 %{__aclocal} -I cmulocal -I config
512 %{__autoheader}
513 %{__autoconf}
514 %{__automake}
515 cd saslauthd
516 %{__aclocal} -I ../cmulocal -I ../config
517 %{__autoheader}
518 %{__autoconf}
519 %{__automake}
520 cd ..
521 %configure \
522         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
523         --disable-krb4 \
524         %{!?with_gssapi: --disable-gssapi} \
525         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
526         --enable-login \
527         --enable-sample \
528         --enable-httpform \
529         --enable-sql \
530         %{?with_srp: --enable-srp} \
531         --enable-static \
532         --with-plugindir=%{_libdir}/sasl2 \
533         --with-configdir=%{_sysconfdir} \
534         --with-dblib=berkeley \
535         --with-dbpath=/var/lib/sasl2/sasl.db \
536         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
537         %{?with_ldap: --with-ldap=%{_prefix}} \
538         %{?with_mysql: --with-mysql=%{_prefix}} \
539         %{?with_pgsql: --with-pgsql=%{_prefix}} \
540         %{?with_sqlite: --with-sqlite=%{_prefix}} \
541         %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
542         %{?with_opie: --with-opie=%{_prefix}} \
543         --with-pam \
544         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
545         --with-saslauthd=/var/lib/sasl2
546
547 %{__make}
548
549 %{__make} -C saslauthd testsaslauthd
550 %{__make} -C saslauthd saslcache
551 %{__make} -C sample sample-client sample-server
552
553 cd doc
554 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
555 for i in $RFCLIST; do
556         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
557         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
558 done
559
560 %install
561 rm -rf $RPM_BUILD_ROOT
562 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
563                 $RPM_BUILD_ROOT%{_mandir}/man8
564
565 %{__make} install \
566         sasldir=%{_libdir}/sasl2 \
567         DESTDIR=$RPM_BUILD_ROOT
568
569 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
570
571 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
572 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
573
574 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
575
576 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
577
578 # create empty config
579 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
580 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
581 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
582 cp -a %{SOURCE3} cyrus.pam
583
584 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
585
586 # sample programs for testing sasl
587 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
588 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
589
590 # package for ghost
591 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
592
593 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
594 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
595
596 %clean
597 rm -rf $RPM_BUILD_ROOT
598
599 %post   libs -p /sbin/ldconfig
600 %postun libs -p /sbin/ldconfig
601
602 %post saslauthd
603 /sbin/chkconfig --add saslauthd
604 %service saslauthd restart
605
606 %preun saslauthd
607 if [ "$1" = "0" ]; then
608         %service saslauthd stop
609         /sbin/chkconfig --del saslauthd
610 fi
611
612 %triggerin saslauthd -- pam
613 # restart saslauthd if pam is upgraded
614 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
615 if [ "$2" != 1 ]; then
616         %service -q saslauthd restart
617 fi
618
619 %files
620 %defattr(644,root,root,755)
621 %doc AUTHORS COPYING ChangeLog NEWS README
622 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
623 %dir %{_sysconfdir}
624 %dir %{_libdir}/sasl2
625 # sample programs to subpackage instead?
626 %attr(755,root,root) %{_bindir}/sasl-sample-client
627 %attr(755,root,root) %{_bindir}/sasl-sample-server
628 %attr(755,root,root) %{_sbindir}/pluginviewer
629 %attr(755,root,root) %{_sbindir}/sasldblistusers2
630 %attr(755,root,root) %{_sbindir}/saslpasswd2
631 %dir /var/lib/sasl2
632 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
633 %{_mandir}/man8/pluginviewer.8*
634 %{_mandir}/man8/sasldblistusers2.8*
635 %{_mandir}/man8/saslpasswd2.8*
636
637 %files libs
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
640 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
641
642 %files devel
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/libsasl2.so
645 %attr(755,root,root) %{_libdir}/libsasl.so
646 %{_libdir}/libsasl2.la
647 %{_includedir}/sasl
648 %{_mandir}/man3/sasl*.3*
649
650 %files static
651 %defattr(644,root,root,755)
652 %{_libdir}/libsasl2.a
653
654 %files anonymous
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
657
658 %if %{with gssapi}
659 %files gssapi
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
662 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
663 %endif
664
665 %files cram-md5
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
668
669 %files digest-md5
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
672
673 %files login
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
676
677 %if %{with mysql}
678 %files mysql
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
681 %endif
682
683 %files otp
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
686
687 %if %{with pgsql}
688 %files pgsql
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
691 %endif
692
693 %files plain
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
696
697 %files sasldb
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
700
701 %files scram
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
704
705 %if %{with sqlite}
706 %files sqlite
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
709 %endif
710
711 %if %{with sqlite3}
712 %files sqlite3
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
715 %endif
716
717 %if %{with srp}
718 %files srp
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
721 %endif
722
723 %if %{with pwcheck}
724 %files pwcheck
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_sbindir}/pwcheck
727 %endif
728
729 %files saslauthd
730 %defattr(644,root,root,755)
731 %doc cyrus.pam
732 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
733 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
734 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
735 %attr(755,root,root) %{_sbindir}/saslauthd
736 %attr(755,root,root) %{_sbindir}/testsaslauthd
737 %attr(755,root,root) %{_sbindir}/saslcache
738 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
739 %ghost /var/lib/sasl2/cache.flock
740 %ghost /var/lib/sasl2/cache.mmap
741 %ghost /var/lib/sasl2/mux
742 %ghost /var/lib/sasl2/mux.accept
743 %ghost /var/lib/sasl2/saslauthd.pid
744 %{_mandir}/man8/saslauthd.8*
745
746 %files -n nagios-plugin-check_saslauthd
747 %defattr(644,root,root,755)
748 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
749 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.18806 seconds and 4 git commands to generate.