]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- added heimdal bcond
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 %bcond_with     heimdal         # build GSSAPI against Heimdal
17 #
18 %if %{without mysql} && %{without pgsql}
19 %undefine with_cryptedpw
20 %endif
21
22 Summary:        The SASL library API for the Cyrus mail system
23 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
24 Summary(pt_BR.UTF-8):   Implementação da API SASL
25 Summary(ru.UTF-8):      Библиотека Cyrus SASL
26 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
27 Name:           cyrus-sasl
28 Version:        2.1.22
29 Release:        15
30 License:        distributable
31 Group:          Libraries
32 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
33 # Source0-md5:  45dde9d19193ae9dd388eb68b2027bc9
34 Source1:        saslauthd.init
35 Source2:        saslauthd.sysconfig
36 Source3:        %{name}.pam
37 Source4:        check_saslauthd.cfg
38 Patch0:         %{name}-nolibs.patch
39 Patch1:         %{name}-lt.patch
40 Patch2:         %{name}-split-sql.patch
41 Patch3:         %{name}-opie.patch
42 Patch4:         %{name}-gcc4.patch
43 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
44 Patch5:         %{name}-cryptedpw.patch
45 Patch6:         %{name}-md5sum-passwords.patch
46 Patch7:         %{name}-db.patch
47 Patch8:         %{name}-automake_1_10.patch
48 Patch9:         %{name}-digest-commas.patch
49 Patch10:        %{name}-keytab.patch
50 Patch11:        %{name}-sizes.patch
51 Patch12:        %{name}-nagios-plugin.patch
52 URL:            http://asg.web.cmu.edu/sasl/
53 BuildRequires:  autoconf >= 2.54
54 BuildRequires:  automake
55 %{?with_authlib:BuildRequires:  courier-authlib-devel}
56 BuildRequires:  db-devel
57 BuildRequires:  ed
58 BuildRequires:  groff
59 %if %{with heimdal}
60 %{?with_gssapi:BuildRequires:   heimdal-devel}
61 %else
62 %{?with_gssapi:BuildRequires:   krb5-devel}
63 %endif
64 BuildRequires:  libtool >= 1.4
65 %{?with_mysql:BuildRequires:    mysql-devel}
66 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
67 BuildRequires:  openssl-devel >= 0.9.7d
68 %{?with_opie:BuildRequires:     opie-devel}
69 BuildRequires:  pam-devel
70 %{?with_pgsql:BuildRequires:    postgresql-devel}
71 BuildRequires:  rpmbuild(macros) >= 1.268
72 %{?with_sqlite:BuildRequires:   sqlite-devel}
73 Requires:       pam >= 0.79.0
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _sysconfdir     /etc/sasl
77
78 %define         specflags       -fno-strict-aliasing
79
80 %description
81 This is an implementation of the SASL API, useful for adding
82 authentication, authorization, and security to network protocols. The
83 SASL protocol itself is documented in rfc2222; the API standard is a
84 work in progress.
85
86 Note: remember to install appropriate plugins, or you won't have any
87 authentication mechanisms available.
88
89 %description -l pl.UTF-8
90 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
91 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
92 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
93 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
94 RFC 2222; standaryzacja API jest w toku.
95
96 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
97 doinstalować odpowiednie wtyczki.
98
99 %description -l pt_BR.UTF-8
100 Esta é uma implementação da API SASL, útil para acrescentar
101 autenticação, autorização e seguança (criptografia) para protocolos de
102 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
103 ainda está em desenvolvimento.
104
105 %description -l ru.UTF-8
106 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
107 Authentication and Security Layer, метод для добавления поддержки
108 аутентикации к протоколам, основанным на соединениях.
109
110 %description -l uk.UTF-8
111 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
112 Authentication and Security Layer, метод для додання підтримки
113 аутентикації до протоколів, базованих на з'єднаннях.
114
115 %package devel
116 Summary:        Header files and documentation for cyrus-sasl
117 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
118 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
119 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
120 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
121 Group:          Development/Libraries
122 Requires:       %{name} = %{version}-%{release}
123
124 %description devel
125 This includes the header files and documentation needed to develop
126 applications which use SASL.
127
128 %description devel -l pl.UTF-8
129 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
130
131 %description devel -l pt_BR.UTF-8
132 Este pacote inclui os arquivos de cabeçalho e documentação necessários
133 para desenvolver aplicativos que usem SASL.
134
135 %description devel -l ru.UTF-8
136 Хедеры и библиотеки, необходимые для разработки приложений,
137 использующих Cyrus SASL.
138
139 %description devel -l uk.UTF-8
140 Хедери та бібліотеки, необхідні для розробки програм, що
141 використовують Cyrus SASL.
142
143 %package static
144 Summary:        Static cyrus-sasl libraries
145 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
146 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
147 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150
151 %description static
152 Static cyrus-sasl libraries.
153
154 %description static -l pl.UTF-8
155 Statyczne biblioteki cyrus-sasl.
156
157 %description static -l ru.UTF-8
158 Статические библиотеки, необходимые для разработки приложений,
159 использующих Cyrus SASL.
160
161 %description static -l uk.UTF-8
162 Статичні бібліотеки, необхідні для розробки програм, що використовують
163 Cyrus SASL.
164
165 %package cram-md5
166 Summary:        Cram-MD5 Cyrus SASL plugin
167 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
168 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
169 Group:          Libraries
170 Requires:       %{name} = %{version}-%{release}
171
172 %description cram-md5
173 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
174 mandatory-to-implement authentication mechanism for a number of
175 protocols; it uses MD5 with a challenge/response system to
176 authenticate the user.
177
178 %description cram-md5 -l pl.UTF-8
179 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
180 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
181 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
182 systemem challenge/response.
183
184 %description cram-md5 -l pt_BR.UTF-8
185 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
186 mecanismo de autenticação obrigatório de ser implementado para vários
187 protocolos: ele usa MD5 com um sistema de desafio/resposta para
188 autenticar o usuário.
189
190 %package digest-md5
191 Summary:        Digest-MD5 Cyrus SASL plugin
192 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
193 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
194 Group:          Libraries
195 Requires:       %{name} = %{version}-%{release}
196
197 %description digest-md5
198 This plugin implements the latest draft of the SASL DIGEST-MD5
199 mechanism. Although not yet finalized, this is likely to become the
200 new mandatory-to-implement authentication system in all new protocols.
201 It's based on the digest md5 authentication system designed for HTTP.
202
203 %description digest-md5 -l pl.UTF-8
204 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
205 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
206 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
207 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
208 Digest-MD5 zaprojektowanym dla HTTP.
209
210 %description digest-md5 -l pt_BR.UTF-8
211 Este plugin implementa a última versão da especificação do mecanismo
212 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
213 provavelmente será o novo sistema de autenticação obrigatório para
214 protocolos novos. Ele é baseado na autenticação md5 digest
215 desenvolvida para HTTP.
216
217 %package plain
218 Summary:        Plain Cyrus SASL plugin
219 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
220 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
221 Group:          Libraries
222 Requires:       %{name} = %{version}-%{release}
223
224 %description plain
225 This plugin implements the SASL PLAIN mechanism. Although insecure,
226 PLAIN is useful for transitioning to new security mechanisms, as this
227 is the only mechanism which gives the server a copy of the user's
228 password.
229
230 %description plain -l pl.UTF-8
231 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
232 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
233 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
234 który udostępnia serwerowi kopię hasła użytkownika.
235
236 %description plain -l pt_BR.UTF-8
237 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
238 mecanismo é útil durante transições para novos mecanismos de
239 segurança, pois é o único esquema que fornece uma cópia da senha do
240 usuário para o servidor.
241
242 %package anonymous
243 Summary:        Anonymous Cyrus SASL plugin
244 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
245 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
246 Group:          Libraries
247 Requires:       %{name} = %{version}-%{release}
248
249 %description anonymous
250 This plugin implements the SASL ANONYMOUS mechanism, used for
251 anonymous authentication.
252
253 %description anonymous -l pl.UTF-8
254 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
255 anonimowego uwierzytelniania.
256
257 %description anonymous -l pt_BR.UTF-8
258 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
259 autenticação anônima.
260
261 %package gssapi
262 Summary:        GSSAPI Cyrus SASL plugin
263 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
264 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
265 Group:          Libraries
266 Requires:       %{name} = %{version}-%{release}
267
268 %description gssapi
269 This plugin implements the SASL GSSAPI mechanism, used for
270 GSSAPI/Kerberos5 authentication.
271
272 %description gssapi -l pl.UTF-8
273 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
274 uwierzytelniania z użyciem GSSAPI/Kerberos5.
275
276 %description gssapi -l pt_BR.UTF-8
277 Este plugin implementa o mecanismo SASL GSSAPI, usado para
278 autenticação Kerberos/GSSAPI.
279
280 %package login
281 Summary:        Unsupported Login Cyrus SASL plugin
282 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
283 Group:          Libraries
284 Requires:       %{name} = %{version}-%{release}
285
286 %description login
287 Unsupported LOGIN Cyrus SASL plugin.
288
289 %description login -l pl.UTF-8
290 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
291 SASL.
292
293 %package srp
294 Summary:        SRP Cyrus SASL plugin
295 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
296 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
297 Group:          Libraries
298 Requires:       %{name} = %{version}-%{release}
299
300 %description srp
301 This plugin implements the SASL SRP mechanism, based on the Secure
302 Remote Password protocol. This mechanism performs mutual
303 authentication and can provide a security layer with replay detection,
304 integrity protection and/or condifentiality protection.
305
306 %description srp -l pl.UTF-8
307 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
308 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
309 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
310 powtarzania, zabezpieczeniem integralności i/lub poufności.
311
312 %description srp -l pt_BR.UTF-8
313 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
314 (Secure Remote Password). Este mecanismo oferece autenticação mútua
315 (do cliente e do servidor) e pode prover uma camada de segurança com
316 detecção de ataques de replay, garantia de integridade e/ou
317 confidencialidade.
318
319 %package otp
320 Summary:        OTP Cyrus SASL plugin
321 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
322 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
323 Group:          Libraries
324 Requires:       %{name} = %{version}-%{release}
325
326 %description otp
327 This plugin implements the SASL OTP (One Time Password) mechanism.
328
329 %description otp -l pl.UTF-8
330 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
331 SASL.
332
333 %package opie
334 Summary:        OPIE Cyrus SASL plugin
335 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
336 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
337 Group:          Libraries
338 Requires:       %{name} = %{version}-%{release}
339
340 %description opie
341 This plugin implements the SASL OPIE (One Time Password) mechanism.
342
343 %description opie -l pl.UTF-8
344 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
345 SASL.
346
347 %package x509
348 Summary:        x509 Cyrus SASL plugin
349 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
350 Group:          Libraries
351 Requires:       %{name} = %{version}-%{release}
352
353 %description x509
354 x509 Cyrus SASL plugin.
355
356 %description x509 -l pl.UTF-8
357 Wtyczka x509 do Cyrus SASL.
358
359 %package saslauthd
360 Summary:        Cyrus SASL authd
361 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
362 Group:          Daemons
363 Requires(post,preun):   /sbin/chkconfig
364 Requires:       %{name} = %{version}-%{release}
365 Requires:       /sbin/chkconfig
366 Requires:       rc-scripts
367
368 %description saslauthd
369 Cyrus SASL authd.
370
371 %description saslauthd -l pl.UTF-8
372 Demon authd do Cyrus SASL.
373
374 %package pwcheck
375 Summary:        Cyrus SASL pwcheck helper
376 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
377 Group:          Libraries
378 Requires:       %{name} = %{version}-%{release}
379
380 %description pwcheck
381 Cyrus SASL pwcheck helper.
382
383 %description pwcheck -l pl.UTF-8
384 Program pomocniczy pwcheck do Cyrus SASL.
385
386 %package sasldb
387 Summary:        Cyrus SASL sasldb plugin
388 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
389 Group:          Libraries
390 Requires:       %{name} = %{version}-%{release}
391
392 %description sasldb
393 Cyrus SASL sasldb plugin.
394
395 %description sasldb -l pl.UTF-8
396 Wtyczka sasldb do Cyrus SASL.
397
398 %package mysql
399 Summary:        Cyrus SASL MySQL plugin
400 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
401 Group:          Libraries
402 Requires:       %{name} = %{version}-%{release}
403
404 %description mysql
405 Cyrus SASL MySQL plugin.
406
407 %description mysql -l pl.UTF-8
408 Wtyczka MySQL do Cyrus SASL.
409
410 %package pgsql
411 Summary:        Cyrus SASL PostgreSQL plugin
412 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
413 Group:          Libraries
414 Requires:       %{name} = %{version}-%{release}
415
416 %description pgsql
417 Cyrus SASL PostgreSQL plugin.
418
419 %description pgsql -l pl.UTF-8
420 Wtyczka PostgreSQL do Cyrus SASL.
421
422 %package sqlite
423 Summary:        Cyrus SQLite PostgreSQL plugin
424 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
425 Group:          Libraries
426 Requires:       %{name} = %{version}-%{release}
427
428 %description sqlite
429 Cyrus SASL SQLite plugin.
430
431 %description sqlite -l pl.UTF-8
432 Wtyczka SQLite do Cyrus SASL.
433
434 %package -n nagios-plugin-check_saslauthd
435 Summary:        Nagios plugin to check health of saslauthd
436 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
437 Group:          Networking
438 Requires:       nagios-core
439
440 %description -n nagios-plugin-check_saslauthd
441 Nagios plugin to check health of saslauthd.
442
443 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
444 Wtyczka Nagiosa do sprawdzania działania saslauthd.
445
446 %prep
447 %setup -q
448 %patch0 -p1
449 %patch1 -p1
450 %patch2 -p1
451 %patch3 -p1
452 %patch4 -p1
453 %if %{with cryptedpw}
454 %patch5 -p1
455 %patch6 -p1
456 %endif
457 %patch7 -p1
458 %patch8 -p1
459 %patch9 -p2
460 %patch10 -p1
461 %patch11 -p1
462 %patch12 -p1
463
464 cd doc
465 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
466 ls rfc*.txt >> rfc-compliance
467 rm -f rfc*.txt
468 cd ..
469
470 rm -rf autom4te.cache saslauthd/autom4te.cache
471 # acinclude.m4 contains only old libtool.m4
472 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
473
474 %build
475 %{__libtoolize}
476 %{__aclocal} -I cmulocal -I config
477 %{__autoheader}
478 %{__automake}
479 %{__autoconf}
480
481 cd saslauthd
482 %{__libtoolize}
483 %{__aclocal} -I ../cmulocal -I ../config -I config
484 %{__autoheader}
485 %{__automake}
486 %{__autoconf}
487 cd ..
488
489 %configure \
490         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
491         --disable-krb4 \
492         %{!?with_gssapi: --disable-gssapi} \
493 %if %{with heimdal}
494         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
495 %else
496         %{?with_gssapi: --enable-gssapi --with-gss_impl=mit} \
497 %endif
498         --enable-login \
499         --enable-sample \
500         --enable-httpform \
501         --enable-sql \
502         %{?with_srp: --enable-srp} \
503         --enable-static \
504         --with-plugindir=%{_libdir}/sasl2 \
505         --with-configdir=%{_sysconfdir} \
506         --with-dblib=berkeley \
507         --with-dbpath=/var/lib/sasl2/sasl.db \
508         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
509         %{?with_ldap: --with-ldap=%{_prefix}} \
510         %{?with_mysql: --with-mysql=%{_prefix}} \
511         %{?with_pgsql: --with-pgsql=%{_prefix}} \
512         %{?with_sqlite: --with-sqlite=%{_prefix}} \
513         %{?with_opie: --with-opie=%{_prefix}} \
514         --with-pam \
515         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
516         --with-saslauthd=/var/lib/sasl2
517 %{__make}
518
519 %{__make} -C saslauthd testsaslauthd
520 %{__make} -C saslauthd saslcache
521
522 cd doc
523 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
524 for i in $RFCLIST; do
525         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
526         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
527 done
528
529 %install
530 rm -rf $RPM_BUILD_ROOT
531 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
532                 $RPM_BUILD_ROOT%{_mandir}/man8
533
534 %{__make} install \
535         sasldir=%{_libdir}/sasl2 \
536         DESTDIR=$RPM_BUILD_ROOT
537
538 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
539 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
540
541 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
542 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
543
544 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
545
546 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
547
548 # create empty config
549 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
550 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
551 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
552 install %{SOURCE3} cyrus.pam
553
554 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
555
556 # sample programs for testing sasl
557 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
558 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
559
560 # package for ghost
561 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
562
563 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
564 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
565
566 %clean
567 rm -rf $RPM_BUILD_ROOT
568
569 %post   -p /sbin/ldconfig
570 %postun -p /sbin/ldconfig
571
572 %post saslauthd
573 /sbin/chkconfig --add saslauthd
574 %service saslauthd restart
575
576 %preun saslauthd
577 if [ "$1" = "0" ]; then
578         %service saslauthd stop
579         /sbin/chkconfig --del saslauthd
580 fi
581
582 %files
583 %defattr(644,root,root,755)
584 %doc AUTHORS COPYING ChangeLog NEWS README
585 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
586 %dir %{_sysconfdir}
587 %dir %{_libdir}/sasl2
588 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
590 # sample programs to subpackage instead?
591 %attr(755,root,root) %{_bindir}/sasl-sample-client
592 %attr(755,root,root) %{_bindir}/sasl-sample-server
593 %attr(755,root,root) %{_sbindir}/pluginviewer
594 %attr(755,root,root) %{_sbindir}/sasldblistusers2
595 %attr(755,root,root) %{_sbindir}/saslpasswd2
596 %dir /var/lib/sasl2
597 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
598 %{_mandir}/man8/pluginviewer.8*
599 %{_mandir}/man8/sasldblistusers2.8*
600 %{_mandir}/man8/saslpasswd2.8*
601
602 %files devel
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/libsasl2.so
605 %attr(755,root,root) %{_libdir}/libsasl.so
606 %{_libdir}/libsasl2.la
607 %{_includedir}/sasl
608 %{_mandir}/man3/sasl*.3*
609
610 %files static
611 %defattr(644,root,root,755)
612 %{_libdir}/libsasl2.a
613
614 %files anonymous
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
617
618 %if %{with gssapi}
619 %files gssapi
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
622 %endif
623
624 %files cram-md5
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
627
628 %files digest-md5
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
631
632 %files login
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
635
636 %files otp
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
639
640 %if %{with opie}
641 %files opie
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
644 %endif
645
646 %files plain
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
649
650 %files sasldb
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
653
654 %if %{with mysql}
655 %files mysql
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
658 %endif
659
660 %if %{with pgsql}
661 %files pgsql
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
664 %endif
665
666 %if %{with sqlite}
667 %files sqlite
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
670 %endif
671
672 %if %{with srp}
673 %files srp
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
676 %endif
677
678 %if %{with x509}
679 %files x509
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
682 %endif
683
684 %if %{with pwcheck}
685 %files pwcheck
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_sbindir}/pwcheck
688 %endif
689
690 %files saslauthd
691 %defattr(644,root,root,755)
692 %doc cyrus.pam
693 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
694 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
695 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
696 %attr(755,root,root) %{_sbindir}/saslauthd
697 %attr(755,root,root) %{_sbindir}/testsaslauthd
698 %attr(755,root,root) %{_sbindir}/saslcache
699 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
700 %ghost /var/lib/sasl2/cache.flock
701 %ghost /var/lib/sasl2/cache.mmap
702 %ghost /var/lib/sasl2/mux
703 %ghost /var/lib/sasl2/mux.accept
704 %ghost /var/lib/sasl2/saslauthd.pid
705 %{_mandir}/man8/saslauthd.8*
706
707 %files -n nagios-plugin-check_saslauthd
708 %defattr(644,root,root,755)
709 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
710 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.080408 seconds and 4 git commands to generate.