]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- rebuild with new db4.5
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl):    Biblioteka Cyrus SASL
23 Summary(pt_BR): Implementação da API SASL
24 Summary(ru):    âÉÂÌÉÏÔÅËÁ Cyrus SASL
25 Summary(uk):    â¦Â̦ÏÔÅËÁ Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.22
28 Release:        3
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  45dde9d19193ae9dd388eb68b2027bc9
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Patch0:         %{name}-nolibs.patch
37 Patch1:         %{name}-lt.patch
38 Patch2:         %{name}-split-sql.patch
39 Patch3:         %{name}-opie.patch
40 Patch4:         %{name}-gcc4.patch
41 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
42 Patch5:         %{name}-cryptedpw.patch
43 Patch6:         %{name}-md5sum-passwords.patch
44 URL:            http://asg.web.cmu.edu/sasl/
45 BuildRequires:  autoconf >= 2.54
46 BuildRequires:  automake
47 %{?with_authlib:BuildRequires:  courier-authlib-devel}
48 BuildRequires:  db-devel
49 BuildRequires:  ed
50 BuildRequires:  groff
51 %{?with_gssapi:BuildRequires:   heimdal-devel >= 0.7}
52 BuildRequires:  libtool >= 1.4
53 %{?with_mysql:BuildRequires:    mysql-devel}
54 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
55 BuildRequires:  openssl-devel >= 0.9.7d
56 %{?with_opie:BuildRequires:     opie-devel}
57 BuildRequires:  pam-devel
58 %{?with_pgsql:BuildRequires:    postgresql-devel}
59 BuildRequires:  rpmbuild(macros) >= 1.268
60 %{?with_sqlite:BuildRequires:   sqlite-devel}
61 Requires:       pam >= 0.79.0
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _sysconfdir     /etc/sasl
65
66 %define         specflags       -fno-strict-aliasing
67
68 %description
69 This is an implementation of the SASL API, useful for adding
70 authentication, authorization, and security to network protocols. The
71 SASL protocol itself is documented in rfc2222; the API standard is a
72 work in progress.
73
74 Note: remember to install appropriate plugins, or you won't have any
75 authentication mechanisms available.
76
77 %description -l pl
78 Pakiet cyrus-sasl zawiera implementacjê biblioteki API SASL dla
79 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
80 tak¿e do dodawania uwierzytelniania, autoryzacji oraz zwiêkszania
81 bezpieczeñstwa protoko³ów sieciowych. Sam protokó³ SASL jest opisany w
82 RFC 2222; standaryzacja API jest w toku.
83
84 Uwaga: aby by³y dostêpne jakiekolwiek mechanizmy autoryzacji, nale¿y
85 doinstalowaæ odpowiednie wtyczki.
86
87 %description -l pt_BR
88 Esta é uma implementação da API SASL, útil para acrescentar
89 autenticação, autorização e seguança (criptografia) para protocolos de
90 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
91 ainda está em desenvolvimento.
92
93 %description -l ru
94 ðÁËÅÔ cyrus-sasl ÓÏÄÅÒÖÉÔ ÒÅÁÌÉÚÁÃÉÀ Cyrus SASL. SASL - ÜÔÏ Simple
95 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÂÁ×ÌÅÎÉÑ ÐÏÄÄÅÒÖËÉ
96 ÁÕÔÅÎÔÉËÁÃÉÉ Ë ÐÒÏÔÏËÏÌÁÍ, ÏÓÎÏ×ÁÎÎÙÍ ÎÁ ÓÏÅÄÉÎÅÎÉÑÈ.
97
98 %description -l uk
99 ðÁËÅÔ cyrus-sasl Í¦ÓÔÉÔØ ÒÅÁ̦ÚÁæÀ Cyrus SASL. SASL - ÃÅ Simple
100 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÄÁÎÎѠЦÄÔÒÉÍËÉ
101 ÁÕÔÅÎÔÉËÁ槠ÄÏ ÐÒÏÔÏËÏ̦×, ÂÁÚÏ×ÁÎÉÈ ÎÁ Ú'¤ÄÎÁÎÎÑÈ.
102
103 %package devel
104 Summary:        Header files and documentation for cyrus-sasl
105 Summary(pl):    Pliki nag³ówkowe i dokumentacja dla cyrus-sasl
106 Summary(pt_BR): Exemplos e arquivos para desenvolvimento com SASL
107 Summary(ru):    æÁÊÌÙ ÄÌÑ ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ Ó ÂÉÂÌÉÏÔÅËÏÊ Cyrus SASL
108 Summary(uk):    æÁÊÌÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎѠڠ¦Â̦ÏÔÅËÏÀ Cyrus SASL
109 Group:          Development/Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description devel
113 This includes the header files and documentation needed to develop
114 applications which use SASL.
115
116 %description devel -l pl
117 Pliki nag³ówkowe i dokumentacja dla cyrus-sasl.
118
119 %description devel -l pt_BR
120 Este pacote inclui os arquivos de cabeçalho e documentação necessários
121 para desenvolver aplicativos que usem SASL.
122
123 %description devel -l ru
124 èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
125 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
126
127 %description devel -l uk
128 èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
129 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ Cyrus SASL.
130
131 %package static
132 Summary:        Static cyrus-sasl libraries
133 Summary(pl):    Statyczne biblioteki cyrus-sasl
134 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ Cyrus SASL
135 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ Cyrus SASL
136 Group:          Development/Libraries
137 Requires:       %{name}-devel = %{version}-%{release}
138
139 %description static
140 Static cyrus-sasl libraries.
141
142 %description static -l pl
143 Statyczne biblioteki cyrus-sasl.
144
145 %description static -l ru
146 óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
147 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
148
149 %description static -l uk
150 óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ
151 Cyrus SASL.
152
153 %package cram-md5
154 Summary:        Cram-MD5 Cyrus SASL plugin
155 Summary(pl):    Wtyczka Cram-MD5 do Cyrus SASL
156 Summary(pt_BR): Mecanismo SASL CRAM-MD5
157 Group:          Libraries
158 Requires:       %{name} = %{version}-%{release}
159
160 %description cram-md5
161 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
162 mandatory-to-implement authentication mechanism for a number of
163 protocols; it uses MD5 with a challenge/response system to
164 authenticate the user.
165
166 %description cram-md5 -l pl
167 Wtyczka dodaj±ca obs³ugê mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
168 jest obowi±zkowym do zaimplementowania mechanizmem uwierzytelniania
169 dla wielu protoko³ów; do uwierzytelnienia u¿ytkownika u¿ywa MD5 wraz z
170 systemem challenge/response.
171
172 %description cram-md5 -l pt_BR
173 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
174 mecanismo de autenticação obrigatório de ser implementado para vários
175 protocolos: ele usa MD5 com um sistema de desafio/resposta para
176 autenticar o usuário.
177
178 %package digest-md5
179 Summary:        Digest-MD5 Cyrus SASL plugin
180 Summary(pl):    Wtyczka Digest-MD5 do Cyrus SASL
181 Summary(pt_BR): Mecanismo SASL DIGEST-MD5
182 Group:          Libraries
183 Requires:       %{name} = %{version}-%{release}
184
185 %description digest-md5
186 This plugin implements the latest draft of the SASL DIGEST-MD5
187 mechanism. Although not yet finalized, this is likely to become the
188 new mandatory-to-implement authentication system in all new protocols.
189 It's based on the digest md5 authentication system designed for HTTP.
190
191 %description digest-md5 -l pl
192 Wtyczka dodaj±ca najnowsz± wersjê mechanizmu DIGEST-MD5 do Cyrus SASL.
193 Pomimo tego, ¿e nie jest jeszcze ukoñczony, najprawdopodobniej stanie
194 siê obowi±zkowym do zaimplementowania systemem uwierzytelniania we
195 wszystkich nowych protoko³ach. Bazuje na systemie uwierzytelniania
196 Digest-MD5 zaprojektowanym dla HTTP.
197
198 %description digest-md5 -l pt_BR
199 Este plugin implementa a última versão da especificação do mecanismo
200 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
201 provavelmente será o novo sistema de autenticação obrigatório para
202 protocolos novos. Ele é baseado na autenticação md5 digest
203 desenvolvida para HTTP.
204
205 %package plain
206 Summary:        Plain Cyrus SASL plugin
207 Summary(pl):    Wtyczka plain do Cyrus SASL
208 Summary(pt_BR): Mecanismo SASL PLAIN
209 Group:          Libraries
210 Requires:       %{name} = %{version}-%{release}
211
212 %description plain
213 This plugin implements the SASL PLAIN mechanism. Although insecure,
214 PLAIN is useful for transitioning to new security mechanisms, as this
215 is the only mechanism which gives the server a copy of the user's
216 password.
217
218 %description plain -l pl
219 Wtyczka dodaj±ca obs³ugê mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
220 ¿e nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
221 nowe mechanizmu bezpieczeñstwa, jako ¿e jest to jedyny mechanizm,
222 który udostêpnia serwerowi kopiê has³a u¿ytkownika.
223
224 %description plain -l pt_BR
225 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
226 mecanismo é útil durante transições para novos mecanismos de
227 segurança, pois é o único esquema que fornece uma cópia da senha do
228 usuário para o servidor.
229
230 %package anonymous
231 Summary:        Anonymous Cyrus SASL plugin
232 Summary(pl):    Wtyczka anonymous do Cyrus SASL
233 Summary(pt_BR): Mecanismo SASL ANONYMOUS
234 Group:          Libraries
235 Requires:       %{name} = %{version}-%{release}
236
237 %description anonymous
238 This plugin implements the SASL ANONYMOUS mechanism, used for
239 anonymous authentication.
240
241 %description anonymous -l pl
242 Wtyczka dodaj±ca obs³ugê mechanizmu ANONYMOUS do Cyrus SASL. S³u¿y do
243 anonimowego uwierzytelniania.
244
245 %description anonymous -l pt_BR
246 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
247 autenticação anônima.
248
249 %package gssapi
250 Summary:        GSSAPI Cyrus SASL plugin
251 Summary(pl):    Wtyczka GSSAPI do Cyrus SASL
252 Summary(pt_BR): Mecanismo SASL GSSAPI
253 Group:          Libraries
254 Requires:       %{name} = %{version}-%{release}
255
256 %description gssapi
257 This plugin implements the SASL GSSAPI mechanism, used for
258 GSSAPI/Kerberos5 authentication.
259
260 %description gssapi -l pl
261 Wtyczka dodaj±ca obs³ugê mechanizmu SASL GSSAPI, u¿ywanego do
262 uwierzytelniania z u¿yciem GSSAPI/Kerberos5.
263
264 %description gssapi -l pt_BR
265 Este plugin implementa o mecanismo SASL GSSAPI, usado para
266 autenticação Kerberos/GSSAPI.
267
268 %package login
269 Summary:        Unsupported Login Cyrus SASL plugin
270 Summary(pl):    Nie wspierana wtyczka Login do Cyrus SASL
271 Group:          Libraries
272 Requires:       %{name} = %{version}-%{release}
273
274 %description login
275 Unsupported LOGIN Cyrus SASL plugin.
276
277 %description login -l pl
278 Wtyczka dodaj±ca obs³ugê nie wspieranego mechanizmu LOGIN do Cyrus
279 SASL.
280
281 %package srp
282 Summary:        SRP Cyrus SASL plugin
283 Summary(pl):    Wtyczka SRP do Cyrus SASL
284 Summary(pt_BR): Mecanismo SASL SRP
285 Group:          Libraries
286 Requires:       %{name} = %{version}-%{release}
287
288 %description srp
289 This plugin implements the SASL SRP mechanism, based on the Secure
290 Remote Password protocol. This mechanism performs mutual
291 authentication and can provide a security layer with replay detection,
292 integrity protection and/or condifentiality protection.
293
294 %description srp -l pl
295 Wtyczka dodaj±ca obs³ugê mechanizmu SRP do Cyrus SASL. Bazuje na
296 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
297 uwierzytelnienia i mo¿e dodawaæ warstwê bezpieczeñstwa z wykrywaniem
298 powtarzania, zabezpieczeniem integralno¶ci i/lub poufno¶ci.
299
300 %description srp -l pt_BR
301 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
302 (Secure Remote Password). Este mecanismo oferece autenticação mútua
303 (do cliente e do servidor) e pode prover uma camada de segurança com
304 detecção de ataques de replay, garantia de integridade e/ou
305 confidencialidade.
306
307 %package otp
308 Summary:        OTP Cyrus SASL plugin
309 Summary(pl):    Wtyczka OTP do Cyrus SASL
310 Summary(pt_BR): Mecanismo SASL OTP
311 Group:          Libraries
312 Requires:       %{name} = %{version}-%{release}
313
314 %description otp
315 This plugin implements the SASL OTP (One Time Password) mechanism.
316
317 %description otp -l pl
318 Wtyczka dodaj±ca obs³ugê mechanizmu OTP (has³a jednorazowe) do Cyrus
319 SASL.
320
321 %package opie
322 Summary:        OPIE Cyrus SASL plugin
323 Summary(pl):    Wtyczka OPIE do Cyrus SASL
324 Summary(pt_BR): Mecanismo SASL OPIE
325 Group:          Libraries
326 Requires:       %{name} = %{version}-%{release}
327
328 %description opie
329 This plugin implements the SASL OPIE (One Time Password) mechanism.
330
331 %description opie -l pl
332 Wtyczka dodaj±ca obs³ugê mechanizmu OPIE (has³a jednorazowe) do Cyrus
333 SASL.
334
335 %package x509
336 Summary:        x509 Cyrus SASL plugin
337 Summary(pl):    Wtyczka x509 do Cyrus SASL
338 Group:          Libraries
339 Requires:       %{name} = %{version}-%{release}
340
341 %description x509
342 x509 Cyrus SASL plugin.
343
344 %description x509 -l pl
345 Wtyczka x509 do Cyrus SASL.
346
347 %package saslauthd
348 Summary:        Cyrus SASL authd
349 Summary(pl):    Demon authd do Cyrus SASL
350 Group:          Daemons
351 Requires(post,preun):   /sbin/chkconfig
352 Requires:       %{name} = %{version}-%{release}
353 Requires:       /sbin/chkconfig
354 Requires:       rc-scripts
355
356 %description saslauthd
357 Cyrus SASL authd.
358
359 %description saslauthd -l pl
360 Demon authd do Cyrus SASL.
361
362 %package pwcheck
363 Summary:        Cyrus SASL pwcheck helper
364 Summary(pl):    Program pomocniczy pwcheck do Cyrus SASL
365 Group:          Libraries
366 Requires:       %{name} = %{version}-%{release}
367
368 %description pwcheck
369 Cyrus SASL pwcheck helper.
370
371 %description pwcheck -l pl
372 Program pomocniczy pwcheck do Cyrus SASL.
373
374 %package sasldb
375 Summary:        Cyrus SASL sasldb plugin
376 Summary(pl):    Wtyczka sasldb do Cyrus SASL
377 Group:          Libraries
378 Requires:       %{name} = %{version}-%{release}
379
380 %description sasldb
381 Cyrus SASL sasldb plugin.
382
383 %description sasldb -l pl
384 Wtyczka sasldb do Cyrus SASL.
385
386 %package mysql
387 Summary:        Cyrus SASL MySQL plugin
388 Summary(pl):    Wtyczka MySQL do Cyrus SASL
389 Group:          Libraries
390 Requires:       %{name} = %{version}-%{release}
391
392 %description mysql
393 Cyrus SASL MySQL plugin.
394
395 %description mysql -l pl
396 Wtyczka MySQL do Cyrus SASL.
397
398 %package pgsql
399 Summary:        Cyrus SASL PostgreSQL plugin
400 Summary(pl):    Wtyczka PostgreSQL do Cyrus SASL
401 Group:          Libraries
402 Requires:       %{name} = %{version}-%{release}
403
404 %description pgsql
405 Cyrus SASL PostgreSQL plugin.
406
407 %description pgsql -l pl
408 Wtyczka PostgreSQL do Cyrus SASL.
409
410 %package sqlite
411 Summary:        Cyrus SQLite PostgreSQL plugin
412 Summary(pl):    Wtyczka SQLite do Cyrus SASL
413 Group:          Libraries
414 Requires:       %{name} = %{version}-%{release}
415
416 %description sqlite
417 Cyrus SASL SQLite plugin.
418
419 %description sqlite -l pl
420 Wtyczka SQLite do Cyrus SASL.
421
422 %prep
423 %setup -q
424 %patch0 -p1
425 %patch1 -p1
426 %patch2 -p1
427 %patch3 -p1
428 %patch4 -p1
429 %if %{with cryptedpw}
430 %patch5 -p1
431 %patch6 -p1
432 %endif
433
434 cd doc
435 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
436 ls rfc*.txt >> rfc-compliance
437 rm -f rfc*.txt
438 cd ..
439
440 rm -rf autom4te.cache saslauthd/autom4te.cache
441 # acinclude.m4 contains only old libtool.m4
442 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
443
444 %build
445 %{__libtoolize}
446 %{__aclocal} -I cmulocal -I config
447 %{__autoheader}
448 %{__automake}
449 %{__autoconf}
450
451 cd saslauthd
452 %{__libtoolize}
453 %{__aclocal} -I ../cmulocal -I ../config -I config
454 %{__autoheader}
455 %{__automake}
456 %{__autoconf}
457 cd ..
458
459 %configure \
460         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
461         --disable-krb4 \
462         %{!?with_gssapi: --disable-gssapi} \
463         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
464         --enable-login \
465         --enable-sample \
466         --enable-sql \
467         %{?with_srp: --enable-srp} \
468         --enable-static \
469         --with-plugindir=%{_libdir}/sasl2 \
470         --with-configdir=%{_sysconfdir} \
471         --with-dblib=berkeley \
472         --with-dbpath=/var/lib/sasl2/sasl.db \
473         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
474         %{?with_ldap: --with-ldap=%{_prefix}} \
475         %{?with_mysql: --with-mysql=%{_prefix}} \
476         %{?with_pgsql: --with-pgsql=%{_prefix}} \
477         %{?with_sqlite: --with-sqlite=%{_prefix}} \
478         %{?with_opie: --with-opie=%{_prefix}} \
479         --with-pam \
480         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
481         --with-saslauthd=/var/lib/sasl2
482 %{__make}
483
484 %{__make} -C saslauthd testsaslauthd
485 %{__make} -C saslauthd saslcache
486
487 cd doc
488 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
489 for i in $RFCLIST; do
490         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
491         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
492 done
493
494 %install
495 rm -rf $RPM_BUILD_ROOT
496 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
497                 $RPM_BUILD_ROOT%{_mandir}/man8
498
499 %{__make} install \
500         sasldir=%{_libdir}/sasl2 \
501         DESTDIR=$RPM_BUILD_ROOT
502
503 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
504 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
505
506 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
507 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
508
509 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
510
511 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
512
513 # create empty config
514 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
515 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
516 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
517 install %{SOURCE3} ./cyrus.pam
518
519 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
520
521 # sample programs for testing sasl
522 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
523 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
524
525 %clean
526 rm -rf $RPM_BUILD_ROOT
527
528 %post   -p /sbin/ldconfig
529 %postun -p /sbin/ldconfig
530
531 %post saslauthd
532 /sbin/chkconfig --add saslauthd
533 %service saslauthd restart
534
535 %preun saslauthd
536 if [ "$1" = "0" ]; then
537         %service saslauthd stop
538         /sbin/chkconfig --del saslauthd
539 fi
540
541 %files
542 %defattr(644,root,root,755)
543 %doc AUTHORS COPYING ChangeLog NEWS README
544 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
545 %dir %{_sysconfdir}
546 %dir %{_libdir}/sasl2
547 %dir /var/lib/sasl2
548 %attr(755,root,root) %{_libdir}/lib*.so.*.*
549 # sample programs to subpackage instead?
550 %attr(755,root,root) %{_bindir}/sasl-sample-client
551 %attr(755,root,root) %{_bindir}/sasl-sample-server
552 %attr(755,root,root) %{_sbindir}/pluginviewer
553 %attr(755,root,root) %{_sbindir}/sasldblistusers2
554 %attr(755,root,root) %{_sbindir}/saslpasswd2
555
556 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
557 %{_mandir}/man8/pluginviewer.8*
558 %{_mandir}/man8/sasldblistusers2.8*
559 %{_mandir}/man8/saslpasswd2.8*
560
561 %files devel
562 %defattr(644,root,root,755)
563 %{_includedir}/sasl
564 %attr(755,root,root) %{_libdir}/lib*.so
565 %{_libdir}/lib*.la
566 %{_mandir}/man3/*
567
568 %files static
569 %defattr(644,root,root,755)
570 %{_libdir}/lib*.a
571
572 %files anonymous
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
575
576 %if %{with gssapi}
577 %files gssapi
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
580 %endif
581
582 %files cram-md5
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
585
586 %files digest-md5
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
589
590 %files login
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
593
594 %files otp
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
597
598 %if %{with opie}
599 %files opie
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
602 %endif
603
604 %files plain
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
607
608 %files sasldb
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
611
612 %if %{with mysql}
613 %files mysql
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
616 %endif
617
618 %if %{with pgsql}
619 %files pgsql
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
622 %endif
623
624 %if %{with sqlite}
625 %files sqlite
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
628 %endif
629
630 %if %{with srp}
631 %files srp
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
634 %endif
635
636 %if %{with x509}
637 %files x509
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
640 %endif
641
642 %if %{with pwcheck}
643 %files pwcheck
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_sbindir}/pwcheck
646 %endif
647
648 %files saslauthd
649 %defattr(644,root,root,755)
650 %doc cyrus.pam
651 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
652 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
653 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
654 %attr(755,root,root) %{_sbindir}/saslauthd
655 %attr(755,root,root) %{_sbindir}/testsaslauthd
656 %attr(755,root,root) %{_sbindir}/saslcache
657 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
658 %{_mandir}/man8/saslauthd.8*
This page took 0.643125 seconds and 4 git commands to generate.