]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
rebuild with openssl 3.0.0
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # Conditional build:
3 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
4 %bcond_without  ldap            # disable LDAP support for saslauthd
5 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
6 %bcond_without  mysql           # don't build MySQL plugin
7 %bcond_without  ntlm            # do not build NTLM plugin
8 %bcond_without  pgsql           # do not build PostgreSQL plugin
9 %bcond_without  sqlite          # do not enable sqlite 2 plugin
10 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # OTP plugin using opie library instead of internal code
13 %bcond_with     srp             # build srp plugin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 #
16 %if %{without mysql} && %{without pgsql}
17 %undefine with_cryptedpw
18 %endif
19
20 Summary:        The SASL library API for the Cyrus mail system
21 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
22 Summary(pt_BR.UTF-8):   Implementação da API SASL
23 Summary(ru.UTF-8):      Библиотека Cyrus SASL
24 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
25 Name:           cyrus-sasl
26 Version:        2.1.27
27 Release:        2
28 License:        distributable
29 Group:          Libraries
30 #Source0Download: https://github.com/cyrusimap/cyrus-sasl/releases
31 Source0:        https://github.com/cyrusimap/cyrus-sasl/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
32 # Source0-md5:  a33820c66e0622222c5aefafa1581083
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
42 Patch5:         %{name}-cryptedpw.patch
43 Patch6:         %{name}-md5sum-passwords.patch
44 Patch7:         %{name}-db.patch
45 Patch9:         %{name}-sizes.patch
46 Patch10:        %{name}-nagios-plugin.patch
47 Patch12:        %{name}-gssapi-detect.patch
48 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
49 Patch14:        %{name}-ac-libs.patch
50 Patch20:        %{name}-auxprop.patch
51 Patch21:        0030-dont_use_la_files_for_opening_plugins.patch
52 Patch22:        sphinx.patch
53 URL:            https://www.cyrusimap.org/sasl/
54 BuildRequires:  autoconf >= 2.63
55 BuildRequires:  automake >= 1:1.11
56 %{?with_authlib:BuildRequires:  courier-authlib-devel}
57 BuildRequires:  db-devel
58 BuildRequires:  ed
59 BuildRequires:  groff
60 %{?with_gssapi:BuildRequires:   heimdal-devel}
61 BuildRequires:  libtool >= 1.4
62 %{?with_mysql:BuildRequires:    mysql-devel}
63 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
64 BuildRequires:  openssl-devel >= 0.9.7d
65 %{?with_opie:BuildRequires:     opie-devel}
66 BuildRequires:  pam-devel
67 %{?with_pgsql:BuildRequires:    postgresql-devel}
68 BuildRequires:  rpmbuild(macros) >= 1.268
69 BuildRequires:  sphinx-pdg-2
70 %{?with_sqlite:BuildRequires:   sqlite-devel}
71 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
72 Requires:       pam >= 0.79.0
73 Requires:       %{name}-libs = %{version}-%{release}
74 Obsoletes:      cyrus-sasl-x509 < %{version}
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _sysconfdir     /etc/sasl
78
79 %define         specflags       -fno-strict-aliasing
80
81 %description
82 This is an implementation of the SASL API, useful for adding
83 authentication, authorization, and security to network protocols. The
84 SASL protocol itself is documented in rfc2222; the API standard is a
85 work in progress.
86
87 Note: remember to install appropriate plugins, or you won't have any
88 authentication mechanisms available.
89
90 %description -l pl.UTF-8
91 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
92 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
93 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
94 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
95 RFC 2222; standaryzacja API jest w toku.
96
97 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
98 doinstalować odpowiednie wtyczki.
99
100 %description -l pt_BR.UTF-8
101 Esta é uma implementação da API SASL, útil para acrescentar
102 autenticação, autorização e seguança (criptografia) para protocolos de
103 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
104 ainda está em desenvolvimento.
105
106 %description -l ru.UTF-8
107 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
108 Authentication and Security Layer, метод для добавления поддержки
109 аутентикации к протоколам, основанным на соединениях.
110
111 %description -l uk.UTF-8
112 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
113 Authentication and Security Layer, метод для додання підтримки
114 аутентикації до протоколів, базованих на з'єднаннях.
115
116 %package libs
117 Summary:        cyrus-sasl library itself
118 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
119 Group:          Libraries
120 Requires(post,postun):  /sbin/ldconfig
121 Conflicts:      cyrus-sasl < 2.1.23-8
122
123 %description libs
124 cyrus-sasl library itself.
125
126 %description libs -l pl.UTF-8
127 Sama biblioteka cyrus-sasl.
128
129 %package devel
130 Summary:        Header files and documentation for cyrus-sasl
131 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
132 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
133 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
134 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
135 Group:          Development/Libraries
136 Requires:       %{name} = %{version}-%{release}
137
138 %description devel
139 This includes the header files and documentation needed to develop
140 applications which use SASL.
141
142 %description devel -l pl.UTF-8
143 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
144
145 %description devel -l pt_BR.UTF-8
146 Este pacote inclui os arquivos de cabeçalho e documentação necessários
147 para desenvolver aplicativos que usem SASL.
148
149 %description devel -l ru.UTF-8
150 Хедеры и библиотеки, необходимые для разработки приложений,
151 использующих Cyrus SASL.
152
153 %description devel -l uk.UTF-8
154 Хедери та бібліотеки, необхідні для розробки програм, що
155 використовують Cyrus SASL.
156
157 %package static
158 Summary:        Static cyrus-sasl libraries
159 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
160 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
161 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
162 Group:          Development/Libraries
163 Requires:       %{name}-devel = %{version}-%{release}
164
165 %description static
166 Static cyrus-sasl libraries.
167
168 %description static -l pl.UTF-8
169 Statyczne biblioteki cyrus-sasl.
170
171 %description static -l ru.UTF-8
172 Статические библиотеки, необходимые для разработки приложений,
173 использующих Cyrus SASL.
174
175 %description static -l uk.UTF-8
176 Статичні бібліотеки, необхідні для розробки програм, що використовують
177 Cyrus SASL.
178
179 %package anonymous
180 Summary:        Anonymous Cyrus SASL plugin
181 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
182 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
183 Group:          Libraries
184 Requires:       %{name} = %{version}-%{release}
185
186 %description anonymous
187 This plugin implements the SASL ANONYMOUS mechanism, used for
188 anonymous authentication.
189
190 %description anonymous -l pl.UTF-8
191 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
192 anonimowego uwierzytelniania.
193
194 %description anonymous -l pt_BR.UTF-8
195 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
196 autenticação anônima.
197
198 %package cram-md5
199 Summary:        Cram-MD5 Cyrus SASL plugin
200 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
201 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
202 Group:          Libraries
203 Requires:       %{name} = %{version}-%{release}
204
205 %description cram-md5
206 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
207 mandatory-to-implement authentication mechanism for a number of
208 protocols; it uses MD5 with a challenge/response system to
209 authenticate the user.
210
211 %description cram-md5 -l pl.UTF-8
212 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
213 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
214 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
215 systemem challenge/response.
216
217 %description cram-md5 -l pt_BR.UTF-8
218 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
219 mecanismo de autenticação obrigatório de ser implementado para vários
220 protocolos: ele usa MD5 com um sistema de desafio/resposta para
221 autenticar o usuário.
222
223 %package digest-md5
224 Summary:        Digest-MD5 Cyrus SASL plugin
225 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
226 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
227 Group:          Libraries
228 Requires:       %{name} = %{version}-%{release}
229
230 %description digest-md5
231 This plugin implements the latest draft of the SASL DIGEST-MD5
232 mechanism. Although not yet finalized, this is likely to become the
233 new mandatory-to-implement authentication system in all new protocols.
234 It's based on the digest md5 authentication system designed for HTTP.
235
236 %description digest-md5 -l pl.UTF-8
237 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
238 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
239 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
240 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
241 Digest-MD5 zaprojektowanym dla HTTP.
242
243 %description digest-md5 -l pt_BR.UTF-8
244 Este plugin implementa a última versão da especificação do mecanismo
245 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
246 provavelmente será o novo sistema de autenticação obrigatório para
247 protocolos novos. Ele é baseado na autenticação md5 digest
248 desenvolvida para HTTP.
249
250 %package gssapi
251 Summary:        GSSAPI Cyrus SASL plugin
252 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
253 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
254 Group:          Libraries
255 Requires:       %{name} = %{version}-%{release}
256
257 %description gssapi
258 This plugin implements the SASL GSSAPI mechanism, used for
259 GSSAPI/Kerberos5 authentication.
260
261 %description gssapi -l pl.UTF-8
262 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
263 uwierzytelniania z użyciem GSSAPI/Kerberos5.
264
265 %description gssapi -l pt_BR.UTF-8
266 Este plugin implementa o mecanismo SASL GSSAPI, usado para
267 autenticação Kerberos/GSSAPI.
268
269 %package login
270 Summary:        Unsupported Login Cyrus SASL plugin
271 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274
275 %description login
276 Unsupported LOGIN Cyrus SASL plugin.
277
278 %description login -l pl.UTF-8
279 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
280 SASL.
281
282 %package mysql
283 Summary:        Cyrus SASL MySQL plugin
284 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
285 Group:          Libraries
286 Requires:       %{name} = %{version}-%{release}
287
288 %description mysql
289 Cyrus SASL MySQL plugin.
290
291 %description mysql -l pl.UTF-8
292 Wtyczka MySQL do Cyrus SASL.
293
294 %package ntlm
295 Summary:        Cyrus SASL NTLM plugin
296 Summary(pl.UTF-8):      Wtyczka NTLM do Cyrus SASL
297 Group:          Libraries
298 Requires:       %{name} = %{version}-%{release}
299
300 %description ntlm
301 Cyrus SASL NTLM plugin.
302
303 %description ntlm -l pl.UTF-8
304 Wtyczka NTLM do Cyrus SASL.
305
306 %package otp
307 Summary:        OTP Cyrus SASL plugin
308 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
309 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
310 Group:          Libraries
311 Requires:       %{name} = %{version}-%{release}
312 Obsoletes:      cyrus-sasl-opie < %{version}
313
314 %description otp
315 This plugin implements the SASL OTP (One Time Password) mechanism.
316
317 %description otp -l pl.UTF-8
318 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
319 SASL.
320
321 %package pgsql
322 Summary:        Cyrus SASL PostgreSQL plugin
323 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
324 Group:          Libraries
325 Requires:       %{name} = %{version}-%{release}
326
327 %description pgsql
328 Cyrus SASL PostgreSQL plugin.
329
330 %description pgsql -l pl.UTF-8
331 Wtyczka PostgreSQL do Cyrus SASL.
332
333 %package plain
334 Summary:        Plain Cyrus SASL plugin
335 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
336 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
337 Group:          Libraries
338 Requires:       %{name} = %{version}-%{release}
339
340 %description plain
341 This plugin implements the SASL PLAIN mechanism. Although insecure,
342 PLAIN is useful for transitioning to new security mechanisms, as this
343 is the only mechanism which gives the server a copy of the user's
344 password.
345
346 %description plain -l pl.UTF-8
347 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
348 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
349 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
350 który udostępnia serwerowi kopię hasła użytkownika.
351
352 %description plain -l pt_BR.UTF-8
353 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
354 mecanismo é útil durante transições para novos mecanismos de
355 segurança, pois é o único esquema que fornece uma cópia da senha do
356 usuário para o servidor.
357
358 %package sasldb
359 Summary:        Cyrus SASL sasldb plugin
360 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
361 Group:          Libraries
362 Requires:       %{name} = %{version}-%{release}
363
364 %description sasldb
365 Cyrus SASL sasldb plugin.
366
367 %description sasldb -l pl.UTF-8
368 Wtyczka sasldb do Cyrus SASL.
369
370 %package ldapdb
371 Summary:        Cyrus SASL LDAPDB plugin
372 Summary(pl.UTF-8):      Wtyczka LDAPDB do Cyrus SASL
373 Group:          Libraries
374 Requires:       %{name} = %{version}-%{release}
375
376 %description ldapdb
377 Cyrus SASL ldapdb plugin.
378
379 %description ldapdb -l pl.UTF-8
380 Wtyczka ldapdb do Cyrus SASL.
381
382 %package passdss
383 Summary:        PASSDSS Cyrus SASL plugin
384 Summary(pl.UTF-8):      Wtyczka PASSDSS do Cyrus SASL
385 Summary(pt_BR.UTF-8):   Mecanismo SASL PASSDSS
386 Group:          Libraries
387 Requires:       %{name} = %{version}-%{release}
388
389 %description passdss
390 This plugin implements the PASSDSS 3DES mechanism.
391
392 %description passdss -l pl.UTF-8
393 Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
394
395 %description passdss -l pt_BR.UTF-8
396 Este plugin implementa o mecanismo SASL PASSDSS 3DES.
397
398 %package scram
399 Summary:        SCRAM Cyrus SASL plugin
400 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
401 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
402 Group:          Libraries
403 Requires:       %{name} = %{version}-%{release}
404
405 %description scram
406 This plugin implements the SASL SCRAM-MD5 mechanism.
407
408 %description scram -l pl.UTF-8
409 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
410
411 %description scram -l pt_BR.UTF-8
412 Este plugin implementa o mecanismo SASL SCRAM.
413
414 %package sqlite
415 Summary:        Cyrus SQLite 2 PostgreSQL plugin
416 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
417 Group:          Libraries
418 Requires:       %{name} = %{version}-%{release}
419
420 %description sqlite
421 Cyrus SASL SQLite 2 plugin.
422
423 %description sqlite -l pl.UTF-8
424 Wtyczka SQLite 2 do Cyrus SASL.
425
426 %package sqlite3
427 Summary:        Cyrus SQLite 3 PostgreSQL plugin
428 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
429 Group:          Libraries
430 Requires:       %{name} = %{version}-%{release}
431
432 %description sqlite3
433 Cyrus SASL SQLite 3 plugin.
434
435 %description sqlite3 -l pl.UTF-8
436 Wtyczka SQLite 3 do Cyrus SASL.
437
438 %package srp
439 Summary:        SRP Cyrus SASL plugin
440 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
441 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
442 Group:          Libraries
443 Requires:       %{name} = %{version}-%{release}
444
445 %description srp
446 This plugin implements the SASL SRP mechanism, based on the Secure
447 Remote Password protocol. This mechanism performs mutual
448 authentication and can provide a security layer with replay detection,
449 integrity protection and/or condifentiality protection.
450
451 %description srp -l pl.UTF-8
452 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
453 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
454 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
455 powtarzania, zabezpieczeniem integralności i/lub poufności.
456
457 %description srp -l pt_BR.UTF-8
458 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
459 (Secure Remote Password). Este mecanismo oferece autenticação mútua
460 (do cliente e do servidor) e pode prover uma camada de segurança com
461 detecção de ataques de replay, garantia de integridade e/ou
462 confidencialidade.
463
464 %package pwcheck
465 Summary:        Cyrus SASL pwcheck helper
466 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
467 Group:          Libraries
468 Requires:       %{name} = %{version}-%{release}
469
470 %description pwcheck
471 Cyrus SASL pwcheck helper.
472
473 %description pwcheck -l pl.UTF-8
474 Program pomocniczy pwcheck do Cyrus SASL.
475
476 %package saslauthd
477 Summary:        Cyrus SASL authd
478 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
479 Group:          Daemons
480 Requires(post,preun):   /sbin/chkconfig
481 Requires:       %{name} = %{version}-%{release}
482 Requires:       /sbin/chkconfig
483 Requires:       rc-scripts
484
485 %description saslauthd
486 Cyrus SASL authd.
487
488 %description saslauthd -l pl.UTF-8
489 Demon authd do Cyrus SASL.
490
491 %package -n nagios-plugin-check_saslauthd
492 Summary:        Nagios plugin to check health of saslauthd
493 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
494 Group:          Networking
495 Requires:       nagios-core
496
497 %description -n nagios-plugin-check_saslauthd
498 Nagios plugin to check health of saslauthd.
499
500 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
501 Wtyczka Nagiosa do sprawdzania działania saslauthd.
502
503 %prep
504 %setup -q
505 %patch0 -p1
506 %patch1 -p1
507 %patch2 -p1
508 %patch3 -p1
509 %if %{with cryptedpw}
510 %patch5 -p1
511 %patch6 -p1
512 %endif
513 %patch7 -p1
514 %patch9 -p1
515 %patch10 -p1
516 %patch12 -p1
517 %patch13 -p1
518 %patch14 -p1
519 %patch20 -p1
520 %patch21 -p1
521 %patch22 -p1
522
523 # update to our paths
524 sed -i -e '
525         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
526         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
527         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
528         s,/var/state/saslauthd,/var/lib/sasl2,g
529 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/legacy/sysadmin.html
530
531 %build
532 %{__libtoolize}
533 %{__aclocal} -I m4
534 %{__autoconf}
535 %{__autoheader}
536 %{__automake}
537 %configure \
538         SPHINX_BUILD=/usr/bin/sphinx-build-2 \
539         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
540         %{!?with_gssapi:--disable-gssapi} \
541         %{?with_gssapi:--enable-gssapi --with-gss_impl=heimdal} \
542         --enable-httpform \
543         --disable-krb4 \
544         %{?with_ldap:--enable-ldapdb} \
545         --enable-login \
546         --enable-passdss \
547         --enable-sample \
548         --enable-sql \
549         %{?with_srp:--enable-srp} \
550         --enable-static \
551         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
552         --with-configdir=%{_sysconfdir} \
553         --with-dblib=berkeley \
554         --with-dbpath=/var/lib/sasl2/sasl.db \
555         %{?with_ldap:--with-ldap} \
556         %{?with_mysql:--with-mysql=%{_prefix}} \
557         %{?with_ntlm:--enable-ntlm} \
558         %{?with_opie:--with-opie=%{_prefix}} \
559         --with-pam \
560         %{?with_pgsql:--with-pgsql=%{_prefix}} \
561         --with-plugindir=%{_libdir}/sasl2 \
562         %{?with_pwcheck:--with-pwcheck=/var/lib/sasl2} \
563         --with-saslauthd=/var/lib/sasl2 \
564         %{?with_sqlite:--with-sqlite=%{_prefix}} \
565         %{?with_sqlite3:--with-sqlite3=%{_prefix}}
566
567 %{__make}
568
569 %{__make} -C saslauthd testsaslauthd
570 %{__make} -C saslauthd saslcache
571 %{__make} -C sample sample-client sample-server
572
573 %{__rm} -rf doc/html/{_sources,objects.inv,.buildinfo}
574
575 %install
576 rm -rf $RPM_BUILD_ROOT
577 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
578                 $RPM_BUILD_ROOT%{_mandir}/man8
579
580 %{__make} install \
581         sasldir=%{_libdir}/sasl2 \
582         DESTDIR=$RPM_BUILD_ROOT
583
584 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
585
586 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
587 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
588
589 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
590
591 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
592
593 # create empty config
594 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
595 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
596 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
597 cp -a %{SOURCE3} cyrus.pam
598
599 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
600
601 # sample programs for testing sasl
602 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
603 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
604
605 # package for ghost
606 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
607
608 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
609 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
610
611 %clean
612 rm -rf $RPM_BUILD_ROOT
613
614 %post   libs -p /sbin/ldconfig
615 %postun libs -p /sbin/ldconfig
616
617 %post saslauthd
618 /sbin/chkconfig --add saslauthd
619 %service saslauthd restart
620
621 %preun saslauthd
622 if [ "$1" = "0" ]; then
623         %service saslauthd stop
624         /sbin/chkconfig --del saslauthd
625 fi
626
627 %triggerin saslauthd -- pam
628 # restart saslauthd if pam is upgraded
629 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
630 if [ "$2" != 1 ]; then
631         %service -q saslauthd restart
632 fi
633
634 %files
635 %defattr(644,root,root,755)
636 %doc AUTHORS COPYING ChangeLog README doc/legacy/{TODO,*.html,*.fig} doc/html
637 %dir %{_sysconfdir}
638 %dir %{_libdir}/sasl2
639 # sample programs to subpackage instead?
640 %attr(755,root,root) %{_bindir}/sasl-sample-client
641 %attr(755,root,root) %{_bindir}/sasl-sample-server
642 %attr(755,root,root) %{_sbindir}/pluginviewer
643 %attr(755,root,root) %{_sbindir}/sasldblistusers2
644 %attr(755,root,root) %{_sbindir}/saslpasswd2
645 %dir /var/lib/sasl2
646 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
647 %{_mandir}/man8/pluginviewer.8*
648 %{_mandir}/man8/sasldblistusers2.8*
649 %{_mandir}/man8/saslpasswd2.8*
650
651 %files libs
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.3
655
656 %files devel
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libsasl2.so
659 %attr(755,root,root) %{_libdir}/libsasl.so
660 %{_libdir}/libsasl2.la
661 %{_includedir}/sasl
662 %{_pkgconfigdir}/libsasl2.pc
663 %{_mandir}/man3/sasl*.3*
664
665 %files static
666 %defattr(644,root,root,755)
667 %{_libdir}/libsasl2.a
668
669 %files anonymous
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
672
673 %if %{with gssapi}
674 %files gssapi
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
677 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
678 %endif
679
680 %files cram-md5
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
683
684 %files digest-md5
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
687
688 %files login
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
691
692 %if %{with mysql}
693 %files mysql
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
696 %endif
697
698 %if %{with ntlm}
699 %files ntlm
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/sasl2/libntlm.so*
702 %endif
703
704 %files otp
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
707
708 %if %{with pgsql}
709 %files pgsql
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
712 %endif
713
714 %files plain
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
717
718 %files sasldb
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
721
722 %if %{with ldap}
723 %files ldapdb
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
726 %endif
727
728 %files passdss
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
731
732 %files scram
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
735
736 %if %{with sqlite}
737 %files sqlite
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
740 %endif
741
742 %if %{with sqlite3}
743 %files sqlite3
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
746 %endif
747
748 %if %{with srp}
749 %files srp
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
752 %endif
753
754 %if %{with pwcheck}
755 %files pwcheck
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_sbindir}/pwcheck
758 %endif
759
760 %files saslauthd
761 %defattr(644,root,root,755)
762 %doc cyrus.pam saslauthd/{COPYING,LDAP_SASLAUTHD}
763 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
764 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
765 %attr(755,root,root) %{_sbindir}/saslauthd
766 %attr(755,root,root) %{_sbindir}/testsaslauthd
767 %attr(755,root,root) %{_sbindir}/saslcache
768 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
769 %ghost /var/lib/sasl2/cache.flock
770 %ghost /var/lib/sasl2/cache.mmap
771 %ghost /var/lib/sasl2/mux
772 %ghost /var/lib/sasl2/mux.accept
773 %ghost /var/lib/sasl2/saslauthd.pid
774 %{_mandir}/man8/saslauthd.8*
775
776 %files -n nagios-plugin-check_saslauthd
777 %defattr(644,root,root,755)
778 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
779 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.101111 seconds and 4 git commands to generate.