]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- rel 8
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.23
28 Release:        8
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  2eb0e48106f0e9cd8001e654f267ecbc
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-automake_1_10.patch
47 Patch9:         %{name}-digest-commas.patch
48 Patch10:        %{name}-keytab.patch
49 Patch11:        %{name}-sizes.patch
50 Patch12:        %{name}-nagios-plugin.patch
51 Patch13:        %{name}-parallel-make.patch
52 Patch14:        %{name}-gssapi-detect.patch
53 Patch15:                %{name}-saslauthd-httpform-urlescape.patch
54 URL:            http://asg.web.cmu.edu/sasl/
55 BuildRequires:  autoconf >= 2.54
56 BuildRequires:  automake >= 1:1.7
57 %{?with_authlib:BuildRequires:  courier-authlib-devel}
58 BuildRequires:  db-devel
59 BuildRequires:  ed
60 BuildRequires:  groff
61 %{?with_gssapi:BuildRequires:   heimdal-devel}
62 BuildRequires:  libtool >= 1.4
63 %{?with_mysql:BuildRequires:    mysql-devel}
64 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
65 BuildRequires:  openssl-devel >= 0.9.7d
66 %{?with_opie:BuildRequires:     opie-devel}
67 BuildRequires:  pam-devel
68 %{?with_pgsql:BuildRequires:    postgresql-devel}
69 BuildRequires:  rpmbuild(macros) >= 1.268
70 %{?with_sqlite:BuildRequires:   sqlite-devel}
71 Requires:       pam >= 0.79.0
72 Requires:       %{name}-libs = %{version}-%{release}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     /etc/sasl
76
77 %define         specflags       -fno-strict-aliasing
78
79 %description
80 This is an implementation of the SASL API, useful for adding
81 authentication, authorization, and security to network protocols. The
82 SASL protocol itself is documented in rfc2222; the API standard is a
83 work in progress.
84
85 Note: remember to install appropriate plugins, or you won't have any
86 authentication mechanisms available.
87
88 %description -l pl.UTF-8
89 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
90 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
91 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
92 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
93 RFC 2222; standaryzacja API jest w toku.
94
95 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
96 doinstalować odpowiednie wtyczki.
97
98 %description -l pt_BR.UTF-8
99 Esta é uma implementação da API SASL, útil para acrescentar
100 autenticação, autorização e seguança (criptografia) para protocolos de
101 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
102 ainda está em desenvolvimento.
103
104 %description -l ru.UTF-8
105 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
106 Authentication and Security Layer, метод для добавления поддержки
107 аутентикации к протоколам, основанным на соединениях.
108
109 %description -l uk.UTF-8
110 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
111 Authentication and Security Layer, метод для додання підтримки
112 аутентикації до протоколів, базованих на з'єднаннях.
113
114 %package libs
115 Summary:        cyrus-sasl library itself
116 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
117 Group:          Libraries
118 Requires(post,postun):  /sbin/ldconfig
119
120 %description libs
121 cyrus-sasl library itself.
122
123 %description libs -l pl.UTF-8
124 Sama biblioteka cyrus-sasl.
125
126 %package devel
127 Summary:        Header files and documentation for cyrus-sasl
128 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
129 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
130 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
131 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
132 Group:          Development/Libraries
133 Requires:       %{name} = %{version}-%{release}
134
135 %description devel
136 This includes the header files and documentation needed to develop
137 applications which use SASL.
138
139 %description devel -l pl.UTF-8
140 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
141
142 %description devel -l pt_BR.UTF-8
143 Este pacote inclui os arquivos de cabeçalho e documentação necessários
144 para desenvolver aplicativos que usem SASL.
145
146 %description devel -l ru.UTF-8
147 Хедеры и библиотеки, необходимые для разработки приложений,
148 использующих Cyrus SASL.
149
150 %description devel -l uk.UTF-8
151 Хедери та бібліотеки, необхідні для розробки програм, що
152 використовують Cyrus SASL.
153
154 %package static
155 Summary:        Static cyrus-sasl libraries
156 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
157 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
158 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
159 Group:          Development/Libraries
160 Requires:       %{name}-devel = %{version}-%{release}
161
162 %description static
163 Static cyrus-sasl libraries.
164
165 %description static -l pl.UTF-8
166 Statyczne biblioteki cyrus-sasl.
167
168 %description static -l ru.UTF-8
169 Статические библиотеки, необходимые для разработки приложений,
170 использующих Cyrus SASL.
171
172 %description static -l uk.UTF-8
173 Статичні бібліотеки, необхідні для розробки програм, що використовують
174 Cyrus SASL.
175
176 %package cram-md5
177 Summary:        Cram-MD5 Cyrus SASL plugin
178 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
179 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
180 Group:          Libraries
181 Requires:       %{name} = %{version}-%{release}
182
183 %description cram-md5
184 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
185 mandatory-to-implement authentication mechanism for a number of
186 protocols; it uses MD5 with a challenge/response system to
187 authenticate the user.
188
189 %description cram-md5 -l pl.UTF-8
190 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
191 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
192 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
193 systemem challenge/response.
194
195 %description cram-md5 -l pt_BR.UTF-8
196 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
197 mecanismo de autenticação obrigatório de ser implementado para vários
198 protocolos: ele usa MD5 com um sistema de desafio/resposta para
199 autenticar o usuário.
200
201 %package digest-md5
202 Summary:        Digest-MD5 Cyrus SASL plugin
203 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
204 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
205 Group:          Libraries
206 Requires:       %{name} = %{version}-%{release}
207
208 %description digest-md5
209 This plugin implements the latest draft of the SASL DIGEST-MD5
210 mechanism. Although not yet finalized, this is likely to become the
211 new mandatory-to-implement authentication system in all new protocols.
212 It's based on the digest md5 authentication system designed for HTTP.
213
214 %description digest-md5 -l pl.UTF-8
215 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
216 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
217 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
218 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
219 Digest-MD5 zaprojektowanym dla HTTP.
220
221 %description digest-md5 -l pt_BR.UTF-8
222 Este plugin implementa a última versão da especificação do mecanismo
223 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
224 provavelmente será o novo sistema de autenticação obrigatório para
225 protocolos novos. Ele é baseado na autenticação md5 digest
226 desenvolvida para HTTP.
227
228 %package plain
229 Summary:        Plain Cyrus SASL plugin
230 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
231 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
232 Group:          Libraries
233 Requires:       %{name} = %{version}-%{release}
234
235 %description plain
236 This plugin implements the SASL PLAIN mechanism. Although insecure,
237 PLAIN is useful for transitioning to new security mechanisms, as this
238 is the only mechanism which gives the server a copy of the user's
239 password.
240
241 %description plain -l pl.UTF-8
242 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
243 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
244 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
245 który udostępnia serwerowi kopię hasła użytkownika.
246
247 %description plain -l pt_BR.UTF-8
248 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
249 mecanismo é útil durante transições para novos mecanismos de
250 segurança, pois é o único esquema que fornece uma cópia da senha do
251 usuário para o servidor.
252
253 %package anonymous
254 Summary:        Anonymous Cyrus SASL plugin
255 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
256 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
257 Group:          Libraries
258 Requires:       %{name} = %{version}-%{release}
259
260 %description anonymous
261 This plugin implements the SASL ANONYMOUS mechanism, used for
262 anonymous authentication.
263
264 %description anonymous -l pl.UTF-8
265 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
266 anonimowego uwierzytelniania.
267
268 %description anonymous -l pt_BR.UTF-8
269 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
270 autenticação anônima.
271
272 %package gssapi
273 Summary:        GSSAPI Cyrus SASL plugin
274 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
275 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
276 Group:          Libraries
277 Requires:       %{name} = %{version}-%{release}
278
279 %description gssapi
280 This plugin implements the SASL GSSAPI mechanism, used for
281 GSSAPI/Kerberos5 authentication.
282
283 %description gssapi -l pl.UTF-8
284 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
285 uwierzytelniania z użyciem GSSAPI/Kerberos5.
286
287 %description gssapi -l pt_BR.UTF-8
288 Este plugin implementa o mecanismo SASL GSSAPI, usado para
289 autenticação Kerberos/GSSAPI.
290
291 %package login
292 Summary:        Unsupported Login Cyrus SASL plugin
293 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
294 Group:          Libraries
295 Requires:       %{name} = %{version}-%{release}
296
297 %description login
298 Unsupported LOGIN Cyrus SASL plugin.
299
300 %description login -l pl.UTF-8
301 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
302 SASL.
303
304 %package srp
305 Summary:        SRP Cyrus SASL plugin
306 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
307 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
308 Group:          Libraries
309 Requires:       %{name} = %{version}-%{release}
310
311 %description srp
312 This plugin implements the SASL SRP mechanism, based on the Secure
313 Remote Password protocol. This mechanism performs mutual
314 authentication and can provide a security layer with replay detection,
315 integrity protection and/or condifentiality protection.
316
317 %description srp -l pl.UTF-8
318 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
319 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
320 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
321 powtarzania, zabezpieczeniem integralności i/lub poufności.
322
323 %description srp -l pt_BR.UTF-8
324 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
325 (Secure Remote Password). Este mecanismo oferece autenticação mútua
326 (do cliente e do servidor) e pode prover uma camada de segurança com
327 detecção de ataques de replay, garantia de integridade e/ou
328 confidencialidade.
329
330 %package otp
331 Summary:        OTP Cyrus SASL plugin
332 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
333 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
334 Group:          Libraries
335 Requires:       %{name} = %{version}-%{release}
336
337 %description otp
338 This plugin implements the SASL OTP (One Time Password) mechanism.
339
340 %description otp -l pl.UTF-8
341 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
342 SASL.
343
344 %package opie
345 Summary:        OPIE Cyrus SASL plugin
346 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
347 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
348 Group:          Libraries
349 Requires:       %{name} = %{version}-%{release}
350
351 %description opie
352 This plugin implements the SASL OPIE (One Time Password) mechanism.
353
354 %description opie -l pl.UTF-8
355 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
356 SASL.
357
358 %package x509
359 Summary:        x509 Cyrus SASL plugin
360 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
361 Group:          Libraries
362 Requires:       %{name} = %{version}-%{release}
363
364 %description x509
365 x509 Cyrus SASL plugin.
366
367 %description x509 -l pl.UTF-8
368 Wtyczka x509 do Cyrus SASL.
369
370 %package saslauthd
371 Summary:        Cyrus SASL authd
372 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
373 Group:          Daemons
374 Requires(post,preun):   /sbin/chkconfig
375 Requires:       %{name} = %{version}-%{release}
376 Requires:       /sbin/chkconfig
377 Requires:       rc-scripts
378
379 %description saslauthd
380 Cyrus SASL authd.
381
382 %description saslauthd -l pl.UTF-8
383 Demon authd do Cyrus SASL.
384
385 %package pwcheck
386 Summary:        Cyrus SASL pwcheck helper
387 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
388 Group:          Libraries
389 Requires:       %{name} = %{version}-%{release}
390
391 %description pwcheck
392 Cyrus SASL pwcheck helper.
393
394 %description pwcheck -l pl.UTF-8
395 Program pomocniczy pwcheck do Cyrus SASL.
396
397 %package sasldb
398 Summary:        Cyrus SASL sasldb plugin
399 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
400 Group:          Libraries
401 Requires:       %{name} = %{version}-%{release}
402
403 %description sasldb
404 Cyrus SASL sasldb plugin.
405
406 %description sasldb -l pl.UTF-8
407 Wtyczka sasldb do Cyrus SASL.
408
409 %package mysql
410 Summary:        Cyrus SASL MySQL plugin
411 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
412 Group:          Libraries
413 Requires:       %{name} = %{version}-%{release}
414
415 %description mysql
416 Cyrus SASL MySQL plugin.
417
418 %description mysql -l pl.UTF-8
419 Wtyczka MySQL do Cyrus SASL.
420
421 %package pgsql
422 Summary:        Cyrus SASL PostgreSQL plugin
423 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
424 Group:          Libraries
425 Requires:       %{name} = %{version}-%{release}
426
427 %description pgsql
428 Cyrus SASL PostgreSQL plugin.
429
430 %description pgsql -l pl.UTF-8
431 Wtyczka PostgreSQL do Cyrus SASL.
432
433 %package sqlite
434 Summary:        Cyrus SQLite PostgreSQL plugin
435 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
436 Group:          Libraries
437 Requires:       %{name} = %{version}-%{release}
438
439 %description sqlite
440 Cyrus SASL SQLite plugin.
441
442 %description sqlite -l pl.UTF-8
443 Wtyczka SQLite do Cyrus SASL.
444
445 %package -n nagios-plugin-check_saslauthd
446 Summary:        Nagios plugin to check health of saslauthd
447 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
448 Group:          Networking
449 Requires:       nagios-core
450
451 %description -n nagios-plugin-check_saslauthd
452 Nagios plugin to check health of saslauthd.
453
454 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
455 Wtyczka Nagiosa do sprawdzania działania saslauthd.
456
457 %prep
458 %setup -q
459 %patch0 -p1
460 %patch1 -p1
461 %patch2 -p1
462 %patch3 -p1
463 %patch4 -p1
464 %if %{with cryptedpw}
465 %patch5 -p1
466 %patch6 -p1
467 %endif
468 %patch7 -p1
469 %patch8 -p1
470 %patch9 -p2
471 %patch10 -p1
472 %patch11 -p1
473 %patch12 -p1
474 %patch13 -p1
475 %patch14 -p1
476 %patch15 -p0
477
478 cd doc
479 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
480 ls rfc*.txt >> rfc-compliance
481 rm -f rfc*.txt
482 cd ..
483
484 rm -rf autom4te.cache saslauthd/autom4te.cache
485 # acinclude.m4 contains only old libtool.m4
486 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
487
488 # update to our paths
489 sed -i -e '
490         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
491         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
492         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
493         s,/var/state/saslauthd,/var/lib/sasl2,g
494 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
495
496 %build
497 %{__libtoolize}
498 %{__aclocal} -I cmulocal -I config
499 %{__autoheader}
500 %{__automake}
501 %{__autoconf}
502
503 cd saslauthd
504 %{__libtoolize}
505 %{__aclocal} -I ../cmulocal -I ../config -I config
506 %{__autoheader}
507 %{__automake}
508 %{__autoconf}
509 cd ..
510
511 %configure \
512         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
513         --disable-krb4 \
514         %{!?with_gssapi: --disable-gssapi} \
515         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
516         --enable-login \
517         --enable-sample \
518         --enable-httpform \
519         --enable-sql \
520         %{?with_srp: --enable-srp} \
521         --enable-static \
522         --with-plugindir=%{_libdir}/sasl2 \
523         --with-configdir=%{_sysconfdir} \
524         --with-dblib=berkeley \
525         --with-dbpath=/var/lib/sasl2/sasl.db \
526         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
527         %{?with_ldap: --with-ldap=%{_prefix}} \
528         %{?with_mysql: --with-mysql=%{_prefix}} \
529         %{?with_pgsql: --with-pgsql=%{_prefix}} \
530         %{?with_sqlite: --with-sqlite=%{_prefix}} \
531         %{?with_opie: --with-opie=%{_prefix}} \
532         --with-pam \
533         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
534         --with-saslauthd=/var/lib/sasl2
535 %{__make}
536
537 %{__make} -C saslauthd testsaslauthd
538 %{__make} -C saslauthd saslcache
539 %{__make} -C sample sample-client sample-server
540
541 cd doc
542 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
543 for i in $RFCLIST; do
544         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
545         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
546 done
547
548 %install
549 rm -rf $RPM_BUILD_ROOT
550 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
551                 $RPM_BUILD_ROOT%{_mandir}/man8
552
553 %{__make} install \
554         sasldir=%{_libdir}/sasl2 \
555         DESTDIR=$RPM_BUILD_ROOT
556
557 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
558 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
559
560 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
561 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
562
563 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
564
565 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
566
567 # create empty config
568 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
569 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
570 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
571 cp -a %{SOURCE3} cyrus.pam
572
573 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
574
575 # sample programs for testing sasl
576 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
577 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
578
579 # package for ghost
580 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
581
582 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
583 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
584
585 %clean
586 rm -rf $RPM_BUILD_ROOT
587
588 %post   libs -p /sbin/ldconfig
589 %postun libs -p /sbin/ldconfig
590
591 %post saslauthd
592 /sbin/chkconfig --add saslauthd
593 %service saslauthd restart
594
595 %preun saslauthd
596 if [ "$1" = "0" ]; then
597         %service saslauthd stop
598         /sbin/chkconfig --del saslauthd
599 fi
600
601 %files
602 %defattr(644,root,root,755)
603 %doc AUTHORS COPYING ChangeLog NEWS README
604 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
605 %dir %{_sysconfdir}
606 %dir %{_libdir}/sasl2
607 # sample programs to subpackage instead?
608 %attr(755,root,root) %{_bindir}/sasl-sample-client
609 %attr(755,root,root) %{_bindir}/sasl-sample-server
610 %attr(755,root,root) %{_sbindir}/pluginviewer
611 %attr(755,root,root) %{_sbindir}/sasldblistusers2
612 %attr(755,root,root) %{_sbindir}/saslpasswd2
613 %dir /var/lib/sasl2
614 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
615 %{_mandir}/man8/pluginviewer.8*
616 %{_mandir}/man8/sasldblistusers2.8*
617 %{_mandir}/man8/saslpasswd2.8*
618
619 %files libs
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
622 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
623
624 %files devel
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/libsasl2.so
627 %attr(755,root,root) %{_libdir}/libsasl.so
628 %{_libdir}/libsasl2.la
629 %{_includedir}/sasl
630 %{_mandir}/man3/sasl*.3*
631
632 %files static
633 %defattr(644,root,root,755)
634 %{_libdir}/libsasl2.a
635
636 %files anonymous
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
639
640 %if %{with gssapi}
641 %files gssapi
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
644 %endif
645
646 %files cram-md5
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
649
650 %files digest-md5
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
653
654 %files login
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
657
658 %files otp
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
661
662 %if %{with opie}
663 %files opie
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
666 %endif
667
668 %files plain
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
671
672 %files sasldb
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
675
676 %if %{with mysql}
677 %files mysql
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
680 %endif
681
682 %if %{with pgsql}
683 %files pgsql
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
686 %endif
687
688 %if %{with sqlite}
689 %files sqlite
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
692 %endif
693
694 %if %{with srp}
695 %files srp
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
698 %endif
699
700 %if %{with x509}
701 %files x509
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
704 %endif
705
706 %if %{with pwcheck}
707 %files pwcheck
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_sbindir}/pwcheck
710 %endif
711
712 %files saslauthd
713 %defattr(644,root,root,755)
714 %doc cyrus.pam
715 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
716 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
717 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
718 %attr(755,root,root) %{_sbindir}/saslauthd
719 %attr(755,root,root) %{_sbindir}/testsaslauthd
720 %attr(755,root,root) %{_sbindir}/saslcache
721 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
722 %ghost /var/lib/sasl2/cache.flock
723 %ghost /var/lib/sasl2/cache.mmap
724 %ghost /var/lib/sasl2/mux
725 %ghost /var/lib/sasl2/mux.accept
726 %ghost /var/lib/sasl2/saslauthd.pid
727 %{_mandir}/man8/saslauthd.8*
728
729 %files -n nagios-plugin-check_saslauthd
730 %defattr(644,root,root,755)
731 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
732 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.096112 seconds and 4 git commands to generate.